/[packages]/backports/4/bumblebee/current/SPECS/bumblebee.spec
ViewVC logotype

Annotation of /backports/4/bumblebee/current/SPECS/bumblebee.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 587218 - (hide annotations) (download)
Sun Feb 9 15:12:34 2014 UTC (10 years, 2 months ago) by akien
File size: 5183 byte(s)
backport bumblebee 3.2.1
1 akien 585500 # Package should be built first against core, and then against nonfree
2     # The core build produces the bumblebee and bumblebee-nouveau RPMs,
3     # whereas the nonfree build produces the bumblebee-nvidia RPM
4     %if "%{?distro_section}" == "nonfree"
5     %define driver nvidia
6     %else
7     %define driver nouveau
8     %endif
9 shlomif 261203
10 akien 584591 Name: bumblebee
11     Summary: Support for NVIDIA Optimus laptops on Linux
12     Group: System/Kernel and hardware
13     Version: 3.2.1
14 akien 585500 Release: %mkrel 4
15 akien 584591 License: GPLv3+
16     URL: https://github.com/Bumblebee-Project/bumblebee
17 shlomif 261203 # source from git repo git://github.com/Bumblebee-Project/Bumblebee.git
18 akien 584591 Source0: https://github.com/downloads/Bumblebee-Project/Bumblebee/%{name}-%{version}.tar.gz
19     BuildRequires: pkgconfig(x11)
20     BuildRequires: pkgconfig(glib-2.0)
21     BuildRequires: pkgconfig(libbsd)
22     BuildRequires: help2man
23     Requires(pre): rpm-helper
24     Requires(pre): update-alternatives
25     Requires(post): systemd-units
26 shlomif 261203 Requires(preun):systemd-units
27 akien 585500 Requires: %{name}-bin
28     # Default bumblebee bridge for general use (primus is an alternative bridge, designed for gaming performance)
29 akien 584591 Requires: virtualgl
30     Requires: %mklibname virtualgl
31     Requires: kmod(bbswitch)
32 shlomif 261203
33     %description
34 akien 584591 Bumblebee is an effort to make NVIDIA Optimus enabled laptops work in
35     GNU/Linux systems. These laptops are built in such a way that the NVIDIA
36     graphics card can be used on demand so that battery life is improved and
37     temperature is kept low.
38 shlomif 261203
39 akien 584591 It disables the discrete graphics card if no client is detected, and start
40     an X server making use of NVIDIA card if requested then let software GL
41     implementations (such as VirtualGL or primus) copy frames to the visible
42 akien 585512 display that runs on the integrated graphics. The ability to use discrete
43 akien 584591 graphics depends on the driver: open source nouveau and proprietary nvidia.
44    
45 akien 585500 %if "%{?distro_section}" != "nonfree"
46 shlomif 261203 %files
47 akien 565729 %doc README.markdown doc/RELEASE_NOTES_3_2_1
48 shlomif 261203 %{_sysconfdir}/bash_completion.d/bumblebee
49     %dir %{_sysconfdir}/bumblebee/
50     %config(noreplace) %{_sysconfdir}/bumblebee/xorg.conf.nouveau
51     %config(noreplace) %{_sysconfdir}/bumblebee/xorg.conf.nvidia
52 akien 585500 %config(noreplace) %{_sysconfdir}/bumblebee/xorg.conf.d/10-dummy.conf
53 akien 585512 %{_usr}/lib/udev/rules.d/99-bumblebee-nvidia-dev.rules
54 akien 585515 %{_unitdir}/bumblebeed.service
55 shlomif 261203 %{_bindir}/bumblebee-bugreport
56     %{_mandir}/man1/bumblebeed.1.*
57     %{_mandir}/man1/optirun.1.*
58    
59     %pre
60     %_pre_groupadd %{name}
61 shlomif 265738 if [ "$1" -eq "1" ];then
62     users=$(getent passwd | awk -F: '$3 >= 500 && $3 < 60000 {print $1}')
63     for user in $users; do
64 shlomif 261203 gpasswd -a $user bumblebee
65 shlomif 265738 done
66 shlomif 261203 /usr/sbin/update-alternatives --set gl_conf %{_sysconfdir}/ld.so.conf.d/GL/standard.conf
67     fi
68    
69     %post
70     %_post_service bumblebeed
71     # Simple: still needs this since in release 3 services were not set
72     # enabled and seams that still isnt properly handeled in %%_post_service
73 shlomif 265738 if [ "$1" -ge "1" ]; then
74 shlomif 261203 # Enable (but don't start) the unit by default
75     /bin/systemctl enable bumblebeed.service
76     # Start bumblebeed service
77     /bin/systemctl start bumblebeed.service
78     fi
79    
80     %preun
81     %_preun_service bumblebeed
82    
83     %postun
84     # We need this since "%%_postun_groupdel %%{name}" doesnt remove the group if
85     # set to a user
86 shlomif 265738 if [ "$1" -eq "0" ];then
87     /usr/sbin/groupdel bumblebee
88     fi
89 akien 585500 %endif
90 shlomif 261203
91 akien 585500 %package %{driver}
92     Summary: Bumblebee configuration files and binaries for %{driver} driver
93     Group: System/Kernel and hardware
94     Requires: %{name} = %{version}
95     %if "%{?distro_section}" == "nonfree"
96     Requires: nvidia
97 akien 585513 Suggests: primus-nvidia
98 akien 585500 Conflicts: %{name}-nouveau
99     %else
100     Requires: x11-driver-video-nouveau
101 akien 585513 Suggests: primus-nouveau
102 akien 585500 Conflicts: %{name}-nvidia
103     %endif
104 akien 585512 Provides: %{name}-bin = %{version}
105 akien 585500
106     %description %{driver}
107     Bumblebee configuration files and binaries built against
108     the %{driver} driver.
109    
110     %files %{driver}
111     %config(noreplace) %{_sysconfdir}/bumblebee/bumblebee.conf
112     %{_sbindir}/bumblebeed
113     %{_bindir}/optirun
114    
115 shlomif 261203 #--------------------------------------------------------------------
116     %prep
117 akien 565728 %setup -q
118 shlomif 261203
119     %build
120     %configure2_5x \
121 akien 585500 %if "%{?distro_section}" == "nonfree"
122 shlomif 261203 CONF_DRIVER=nvidia \
123 shlomif 265607 CONF_DRIVER_MODULE_NVIDIA=nvidia-current \
124 shlomif 265469 %else
125 shlomif 265607 CONF_DRIVER=nouveau \
126 shlomif 261203 %endif
127     %ifarch x86_64
128 akien 585500 CONF_LDPATH_NVIDIA=%{_libdir}/nvidia-current:%{_usr}/lib/nvidia-current \
129     CONF_MODPATH_NVIDIA=%{_libdir}/nvidia-current/xorg,%{_usr}/lib/nvidia-current/xorg,%{_libdir}/xorg/modules,%{_usr}/lib/xorg/modules,%{_libdir}/xorg/extra-modules,%{_usr}/lib/xorg/extra-modules \
130 akien 585513 CONF_PRIMUS_LD_PATH=%{_libdir}/primus:%{_usr}/lib/primus
131 shlomif 261203 %else
132 akien 584591 CONF_LDPATH_NVIDIA=%{_libdir}/nvidia-current \
133     CONF_MODPATH_NVIDIA=%{_libdir}/nvidia-current/xorg,%{_libdir}/xorg/modules,%{_libdir}/xorg/extra-modules
134 akien 585513 CONF_PRIMUS_LD_PATH=%{_libdir}/primus
135 shlomif 261203 %endif
136    
137 akien 565728 %make CFLAGS="%{optflags}"
138 shlomif 261203
139     %install
140 akien 585500 %if "%{?distro_section}" == "nonfree"
141     install -D -m644 conf/bumblebee.conf %{buildroot}%{_sysconfdir}/bumblebee/bumblebee.conf
142     install -D -m755 bin/bumblebeed %{buildroot}%{_sbindir}/bumblebeed
143     install -D -m755 bin/optirun %{buildroot}%{_bindir}/optirun
144     %else
145 shlomif 261203 %makeinstall_std
146 akien 585512 mv %{buildroot}/lib %{buildroot}%{_usr}/lib
147 akien 585515 install -D -m644 scripts/systemd/bumblebeed.service %{buildroot}%{_unitdir}/bumblebeed.service
148 akien 585500 %endif

  ViewVC Help
Powered by ViewVC 1.1.30