1 |
# Turn off the brp-python-bytecompile script |
2 |
# because of /usr/lib/python2.7/site-packages/noethys/Outils/C866CA3A-32F7-11D2-9602-00C04F8EE628x0x5x0.py |
3 |
%define __brp_python_bytecompile %{nil} |
4 |
|
5 |
%define oname Noethys |
6 |
|
7 |
Name: noethys |
8 |
Version: 1.1.8.6 |
9 |
Release: %mkrel 2 |
10 |
Summary: Software to handle "multi activity" centers |
11 |
License: GPLv2 |
12 |
Group: Archiving/Other |
13 |
URL: http://noethys.com/ |
14 |
Source0: %version.tar.gz |
15 |
Patch0: Noethys-1.1.7.1-disable-update-checking.patch |
16 |
BuildArch: noarch |
17 |
|
18 |
Requires: wxPython |
19 |
Requires: python-pytz |
20 |
Requires: python2-appdirs |
21 |
Requires: python-dateutil |
22 |
Requires: python-numpy |
23 |
Requires: python-pillow |
24 |
Requires: python-mysql |
25 |
Requires: python-sqlalchemy |
26 |
Requires: python-crypto |
27 |
Requires: python-reportlab |
28 |
Requires: python-paramiko |
29 |
Requires: python-psutil |
30 |
|
31 |
Requires: python-gi |
32 |
Requires: python-OpenSSL |
33 |
Requires: python-serial |
34 |
Requires: python-zope-interface |
35 |
Requires: python-twisted |
36 |
|
37 |
%description |
38 |
Software to handle "multi activity" centers |
39 |
|
40 |
%files |
41 |
%_bindir/%name |
42 |
%_datadir/%name |
43 |
|
44 |
#-------------------------------------------------------------------- |
45 |
|
46 |
%prep |
47 |
%setup -q -n %oname-%version |
48 |
%autopatch -p1 |
49 |
|
50 |
%build |
51 |
|
52 |
%install |
53 |
mkdir -p %buildroot%_datadir |
54 |
mkdir -p %buildroot%_bindir |
55 |
cp -fr %name %buildroot%_datadir |
56 |
pushd %buildroot%_bindir |
57 |
ln -s %_datadir/%name/Noethys.py %name |
58 |
chmod +x %buildroot%_datadir/%name/%oname.py |
59 |
popd |