/[packages]/backports/8/php-imagick/current/SPECS/php-imagick.spec
ViewVC logotype

Annotation of /backports/8/php-imagick/current/SPECS/php-imagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1759297 - (hide annotations) (download)
Fri Nov 26 06:26:28 2021 UTC (2 years, 4 months ago) by joequant
Original Path: cauldron/php-imagick/current/SPECS/php-imagick.spec
File size: 2043 byte(s)
fix php-common requires

1 ennael 35613 %define realname Imagick
2     %define modname imagick
3     %define soname %{modname}.so
4     %define inifile 55_%{modname}.ini
5     %define mod_src %{modname}.c
6    
7 zezinho 1177155 %define build_test 1
8 joequant 1759297 %define gittag 3.6.0RC1
9 joequant 1652547 # need to use git version for php8
10    
11 ennael 35613 Summary: Provides a wrapper to the ImageMagick library for PHP
12     Name: php-%{modname}
13 mokraemer 1665455 Epoch: 3
14 joequant 1759297 Version: 3.6.0
15     Release: %mkrel -c 1
16 ennael 35613 Group: Development/PHP
17     License: PHP License
18     URL: http://pecl.php.net/package/imagick
19 joequant 1759297 Source0: https://github.com/Imagick/imagick/archive/refs/tags/%{gittag}.tar.gz
20 mokraemer 1665453 ##Source0: http://pecl.php.net/get/%%{modname}-%%{version}.tgz
21 ennael 35613 BuildRequires: imagemagick-devel >= 6.3.8
22 joequant 1559176 Recommends: imagemagick >= 6.3.8
23 mokraemer 1650242 BuildRequires: php-devel >= 3:8.0.0
24 mokraemer 1665453 BuildRequires: mercurial
25 joequant 1652559 BuildRequires: pkgconfig(libpcre2-posix)
26 mokraemer 1650242 Requires: php >= 3:8.0.0
27 joequant 1759297 Requires: php-common >= 3:8.0
28 ennael 35613
29     %description
30     Imagick is a native php extension to create and modify images using the
31     ImageMagick API.
32    
33     imagick is a native php-extension. See the examples in the
34     %{_docdir}/%{name}/examples directory for some hints on
35     how to use it.
36    
37     %prep
38    
39 joequant 1759297 %autosetup -S hg -n %{modname}-%{gittag}
40 joequant 1652547 #[ "../package.xml" != "/" ] && mv -f ../package.xml .
41    
42 ennael 35613 # lib64 fixes
43     perl -pi -e "s|/lib\b|/%{_lib}|g" config.m4
44    
45     %build
46     %serverbuild
47    
48     phpize
49 wally 1481283 %configure --with-libdir=%{_lib} \
50 ennael 35613 --with-%{modname}=shared,%{_prefix}
51    
52 daviddavid 1047983 %make_build
53 ennael 35613 mv modules/*.so .
54    
55     %install
56     install -d %{buildroot}%{_libdir}/php/extensions
57     install -d %{buildroot}%{_sysconfdir}/php.d
58    
59     install -m0755 %{soname} %{buildroot}%{_libdir}/php/extensions/
60    
61     cat > README.%{modname} <<EOF
62 wally 1070360 The %{name} package contains a dynamic shared object (DSO) for PHP.
63 ennael 35613 To activate it, make sure a file /etc/php.d/%{inifile} is present and
64     contains the line 'extension = %{soname}'.
65     EOF
66    
67     cat > %{buildroot}%{_sysconfdir}/php.d/%{inifile} << EOF
68     extension = %{soname}
69    
70     [imagick]
71     imagick.locale_fix = 0
72     EOF
73    
74 zezinho 1177155
75 wally 1070360 %files
76 oden 979069 %doc examples ChangeLog CREDITS LICENSE
77 ennael 35613 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/php.d/%{inifile}
78     %attr(0755,root,root) %{_libdir}/php/extensions/%{soname}

  ViewVC Help
Powered by ViewVC 1.1.30