1 |
%define realname Imagick |
2 |
%define modname imagick |
3 |
%define soname %{modname}.so |
4 |
%define inifile 55_%{modname}.ini |
5 |
%define mod_src %{modname}.c |
6 |
|
7 |
%define build_test 1 |
8 |
%define gittag 3.6.0RC1 |
9 |
# need to use git version for php8 |
10 |
|
11 |
Summary: Provides a wrapper to the ImageMagick library for PHP |
12 |
Name: php-%{modname} |
13 |
Epoch: 3 |
14 |
Version: 3.6.0 |
15 |
Release: %mkrel 0.4 |
16 |
Group: Development/PHP |
17 |
License: PHP License |
18 |
URL: http://pecl.php.net/package/imagick |
19 |
Source0: https://github.com/Imagick/imagick/archive/refs/tags/%{gittag}.tar.gz |
20 |
##Source0: http://pecl.php.net/get/%%{modname}-%%{version}.tgz |
21 |
BuildRequires: imagemagick-devel >= 6.3.8 |
22 |
Recommends: imagemagick >= 6.3.8 |
23 |
BuildRequires: php-devel >= 3:8.0.0 |
24 |
BuildRequires: mercurial |
25 |
BuildRequires: pkgconfig(libpcre2-posix) |
26 |
Requires: php >= 3:8.1.0 |
27 |
Requires: php-common >= 3:8.1 |
28 |
|
29 |
%description |
30 |
Imagick is a native php extension to create and modify images using the |
31 |
ImageMagick API. |
32 |
|
33 |
imagick is a native php-extension. See the examples in the |
34 |
%{_docdir}/%{name}/examples directory for some hints on |
35 |
how to use it. |
36 |
|
37 |
%prep |
38 |
|
39 |
%autosetup -S hg -n %{modname}-%{gittag} |
40 |
#[ "../package.xml" != "/" ] && mv -f ../package.xml . |
41 |
|
42 |
# lib64 fixes |
43 |
perl -pi -e "s|/lib\b|/%{_lib}|g" config.m4 |
44 |
|
45 |
%build |
46 |
%serverbuild |
47 |
|
48 |
phpize |
49 |
%configure --with-libdir=%{_lib} \ |
50 |
--with-%{modname}=shared,%{_prefix} |
51 |
|
52 |
%make_build |
53 |
mv modules/*.so . |
54 |
|
55 |
%install |
56 |
install -d %{buildroot}%{_libdir}/php/extensions |
57 |
install -d %{buildroot}%{_sysconfdir}/php.d |
58 |
|
59 |
install -m0755 %{soname} %{buildroot}%{_libdir}/php/extensions/ |
60 |
|
61 |
cat > README.%{modname} <<EOF |
62 |
The %{name} package contains a dynamic shared object (DSO) for PHP. |
63 |
To activate it, make sure a file /etc/php.d/%{inifile} is present and |
64 |
contains the line 'extension = %{soname}'. |
65 |
EOF |
66 |
|
67 |
cat > %{buildroot}%{_sysconfdir}/php.d/%{inifile} << EOF |
68 |
extension = %{soname} |
69 |
|
70 |
[imagick] |
71 |
imagick.locale_fix = 0 |
72 |
EOF |
73 |
|
74 |
|
75 |
%files |
76 |
%doc examples ChangeLog CREDITS LICENSE |
77 |
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/php.d/%{inifile} |
78 |
%attr(0755,root,root) %{_libdir}/php/extensions/%{soname} |