/[packages]/cauldron/AfterStep/current/SPECS/AfterStep.spec
ViewVC logotype

Contents of /cauldron/AfterStep/current/SPECS/AfterStep.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 134328 - (show annotations) (download)
Thu Aug 18 15:16:35 2011 UTC (12 years, 8 months ago) by shlomif
File size: 5720 byte(s)
Bumped the mkrel to change the name of the menu to Mageia
1 %define name AfterStep
2 %define version 2.2.11
3 %define release %mkrel 2
4 %define major 0
5 %define libname %mklibname %{name} %{major}
6 %define libname_devel %mklibname %{name} -d
7 %define ltitle AfterStep Window Manager
8
9 Summary: %{ltitle}
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 Epoch: 4
14 License: GPLv2+
15 Group: Graphical desktop/Other
16 URL: http://www.afterstep.org/
17
18 Source: ftp://ftp.afterstep.org/stable/AfterStep-%version.tar.bz2
19 Source1: %{name}-mdkconf.tar.bz2
20 Source3: %{name}.png
21 Source4: %{name}32.png
22 Source5: %{name}48.png
23 Patch2: %{name}-1.8.9-menuname.patch
24 Patch3: %{name}.MenuKey.patch
25 Patch4: afterstep-2.2.9-ldflags.patch
26
27 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
28 Requires: desktop-common-data xli
29 # Requires: %libname = %{epoch}:%{version}-%{release}
30 BuildRequires: libx11-devel
31 BuildRequires: libxext-devel
32 BuildRequires: libxinerama-devel
33 BuildRequires: dbus-devel
34 BuildRequires: freetype2-devel
35 BuildRequires: jpeg-devel
36 BuildRequires: librsvg-devel
37 BuildRequires: png-devel
38 BuildRequires: tiff-devel
39 BuildRequires: gtk2-devel
40
41 %description
42 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
43 look and feel, but which has been significantly altered according to the
44 requests of various users. Many adepts will tell you that NEXTSTEP is not
45 only the most visually pleasant interface, but also one of the most functional
46 and intuitive out there. AfterStep aims to incorporate the advantages of the
47 NEXTSTEP interface, and add additional useful features.
48
49 The developers of AfterStep have also worked very hard to ensure stability and
50 a small program footprint. Without giving up too many features, AfterStep still
51 works nicely in environments where memory is at a premium.
52
53 %package -n %libname
54 Summary: Libraries needed by AfterStep
55 Group: Graphical desktop/Other
56 Provides: lib%name = %version-%release
57
58 %description -n %libname
59 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
60 look and feel, but which has been significantly altered according to the
61 requests of various users. Many adepts will tell you that NEXTSTEP is not
62 only the most visually pleasant interface, but also one of the most functional
63 and intuitive out there. AfterStep aims to incorporate the advantages of the
64 NEXTSTEP interface, and add additional useful features.
65
66 The developers of AfterStep have also worked very hard to ensure stability and
67 a small program footprint. Without giving up too many features, AfterStep still
68 works nicely in environments where memory is at a premium.
69
70 This package contains libraries needed by AfterStep package.
71
72 %package -n %libname_devel
73 Summary: Devel files needed to build applications based on AfterStep
74 Group: Development/C
75 Provides: %name-devel lib%name-devel
76 Requires: %libname = %{epoch}:%version-%release
77 Obsoletes: %mklibname -d %name 0
78
79 %description -n %libname_devel
80 AfterStep is a Window Manager for X which started by emulating the NEXTSTEP
81 look and feel, but which has been significantly altered according to the
82 requests of various users. Many adepts will tell you that NEXTSTEP is not
83 only the most visually pleasant interface, but also one of the most functional
84 and intuitive out there. AfterStep aims to incorporate the advantages of the
85 NEXTSTEP interface, and add additional useful features.
86
87 The developers of AfterStep have also worked very hard to ensure stability and
88 a small program footprint. Without giving up too many features, AfterStep still
89 works nicely in environments where memory is at a premium.
90
91 This package contains devel files needed to build applications based on
92 AfterStep.
93
94 %prep
95 %setup -q
96
97 # LMDK patches
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p0 -b .link
101
102 %build
103 rm -f config.status
104 export CFLAGS="%optflags"
105 export CCFLAGS="%optflags"
106
107 %configure2_5x \
108 --enable-sharedlibs \
109 --with-imageloader="xsetbg" \
110 --with-helpcommand="xterm -fn 9x15 -e man" \
111 --with-desktops=1 \
112 --with-deskgeometry=1x1 \
113 --enable-different-looknfeels \
114 --enable-i18n \
115 --enable-savewindows \
116 --enable-texture \
117 --enable-shade \
118 --enable-virtual \
119 --enable-saveunders \
120 --enable-windowlist \
121 --enable-availability \
122 --enable-shaping \
123 --enable-xinerama \
124 --enable-script \
125 --with-xpm \
126 --with-jpeg \
127 --with-png \
128 --with-ttf \
129 --with-tiff
130
131 %make
132
133 if [ -x /usr/bin/sgml2html ]; then sgml2html doc/afterstep.sgml; fi
134
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 %makeinstall_std LDCONFIG=/bin/true
139
140 # LMDK icons
141 install -m644 %SOURCE4 -D $RPM_BUILD_ROOT%{_iconsdir}/%{name}.png
142 install -m644 %SOURCE3 -D $RPM_BUILD_ROOT%{_miconsdir}/%{name}.png
143 install -m644 %SOURCE5 -D $RPM_BUILD_ROOT%{_liconsdir}/%{name}.png
144
145 # Not needed with Mageia menu
146 rm -fr $RPM_BUILD_ROOT/%{__datadir}/afterstep/start/Applications/
147
148 install -d $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmsession.d
149 cat > $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmsession.d/15%{name} << EOF
150 NAME=%{name}
151 ICON=%{name}.png
152 EXEC=%{_bindir}/afterstep
153 DESC=A NeXt like Window-Manager
154 SCRIPT:
155 exec %{_bindir}/afterstep
156 EOF
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 %make_session
163
164 %postun
165 %make_session
166
167 %files
168 %defattr(-,root,root)
169 %config(noreplace) %{_sysconfdir}/X11/wmsession.d/15%{name}
170 %doc COPYRIGHT ChangeLog NEW README TEAM UPGRADE doc/languages doc/licences
171 %{_iconsdir}/%{name}.png
172 %{_miconsdir}/%{name}.png
173 %{_liconsdir}/%{name}.png
174 %{_bindir}/*
175 %{_mandir}/man1/*
176 %{_mandir}/man3/*
177 %dir %{_datadir}/afterstep
178 %{_datadir}/afterstep/*
179 %_datadir/xsessions/AfterStep.desktop
180
181 %files -n %libname
182 %defattr(-,root,root,-)
183 %{_libdir}/*.so.%major
184 %{_libdir}/*.so.%major.*
185
186 %files -n %libname_devel
187 %defattr(-,root,root,-)
188 %{_libdir}/*.so
189 %{_libdir}/*.a
190 %_includedir/*

  ViewVC Help
Powered by ViewVC 1.1.30