1 |
Name: HikariCP |
2 |
# Latest release use hibernate-core >= 5.0.9.Final and javassist >= 3.20.0-GA |
3 |
Version: 2.4.0 |
4 |
Release: %mkrel 2 |
5 |
Group: Development/Java |
6 |
Summary: JDBC Connection Pool |
7 |
# Source files without license headers https://github.com/brettwooldridge/HikariCP/issues/665 |
8 |
License: ASL 2.0 |
9 |
URL: http://brettwooldridge.github.io/HikariCP/ |
10 |
Source0: https://github.com/brettwooldridge/HikariCP/archive/%{name}-%{version}.tar.gz |
11 |
|
12 |
BuildRequires: maven-local |
13 |
BuildRequires: mvn(io.dropwizard.metrics:metrics-core) |
14 |
BuildRequires: mvn(io.dropwizard.metrics:metrics-healthchecks) |
15 |
BuildRequires: mvn(javax.inject:javax.inject) |
16 |
BuildRequires: mvn(junit:junit) |
17 |
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin) |
18 |
BuildRequires: mvn(org.apache.felix:org.apache.felix.framework) |
19 |
BuildRequires: mvn(org.codehaus.mojo:exec-maven-plugin) |
20 |
BuildRequires: mvn(org.hibernate:hibernate-core) |
21 |
BuildRequires: mvn(org.javassist:javassist) |
22 |
BuildRequires: mvn(org.mockito:mockito-all) |
23 |
BuildRequires: mvn(simple-jndi:simple-jndi) |
24 |
BuildRequires: mvn(org.slf4j:slf4j-api) |
25 |
BuildRequires: mvn(org.slf4j:slf4j-simple) |
26 |
BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:) |
27 |
|
28 |
BuildArch: noarch |
29 |
|
30 |
%description |
31 |
Fast, simple, reliable. HikariCP is a "zero-overhead" production |
32 |
ready JDBC connection pool. |
33 |
|
34 |
%package javadoc |
35 |
Summary: Javadoc for %{name} |
36 |
|
37 |
%description javadoc |
38 |
This package contains javadoc for %{name}. |
39 |
|
40 |
%prep |
41 |
%setup -q -n %{name}-%{name}-%{version} |
42 |
|
43 |
%pom_remove_plugin :jacoco-maven-plugin |
44 |
%pom_remove_plugin :maven-release-plugin |
45 |
%pom_remove_plugin :maven-source-plugin |
46 |
%pom_xpath_remove "pom:plugin[pom:artifactId='maven-javadoc-plugin']/pom:executions" |
47 |
|
48 |
# org.ops4j.pax.exam:pax-exam-container-native:4.5.0 |
49 |
# org.ops4j.pax.exam:pax-exam-junit4:4.5.0 |
50 |
# org.ops4j.pax.exam:pax-exam-link-mvn:4.5.0 |
51 |
%pom_remove_dep org.ops4j.pax.exam: |
52 |
# org.ops4j.pax.url:pax-url-aether:2.4.1 |
53 |
# org.ops4j.pax.url:pax-url-reference:2.4.1 |
54 |
%pom_remove_dep org.ops4j.pax.url: |
55 |
rm -r src/test/java/com/zaxxer/hikari/osgi |
56 |
|
57 |
# package org.junit does not exist |
58 |
%pom_add_dep junit:junit:4.12:test |
59 |
|
60 |
%mvn_file : %{name} |
61 |
%mvn_alias : com.zaxxer:%{name}-java6 |
62 |
|
63 |
%build |
64 |
|
65 |
%mvn_build |
66 |
|
67 |
%install |
68 |
%mvn_install |
69 |
|
70 |
%files -f .mfiles |
71 |
%doc CHANGES README.md TODO.md |
72 |
%license LICENSE |
73 |
|
74 |
%files javadoc -f .mfiles-javadoc |
75 |
%license LICENSE |
76 |
|