/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Annotation of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 203754 - (hide annotations) (download)
Tue Jan 31 23:25:03 2012 UTC (12 years, 2 months ago) by tv
File size: 17060 byte(s)
further adjust file list (SILENT)
1 blino 21531 # (blino) FIXME: switch back to 1 when systemd is installable
2 dmorgan 185005 %define with_systemd 1
3 blino 21273
4     %define lib_major 0
5     %define lib_name %mklibname %{name} %{lib_major}
6 dmorgan 110058 %define libreport %mklibname report %{lib_major}
7     %define libreportgtk %mklibname report-gtk %{lib_major}
8    
9 blino 21273 %define lib_name_devel %mklibname %{name} -d
10 dmorgan 110058 %define lib_report_devel %mklibname report -d
11 blino 21273
12 dmorgan 109812 %define _disable_ld_no_undefined 1
13    
14 blino 21273 Summary: Automatic bug detection and reporting tool
15     Name: abrt
16 dmorgan 197649 Version: 2.0.7
17     Release: %mkrel 1
18 blino 21273 License: GPLv2+
19 dmorgan 134965 Group: System/Libraries
20 blino 21273 URL: https://fedorahosted.org/abrt/
21     Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
22     Source1: abrt.init
23     Source2: 00abrt.sh
24     Source3: 00abrt.csh
25     Source4: abrt-debuginfo-install
26 dmorgan 109812 Source5: abrt-ccpp.init
27     Source6: abrt-oops.init
28 blino 21484 # (fc) disable package signature check
29 blino 21273 Patch2: abrt_disable_gpgcheck.diff
30 blino 21484 # (pt) generate stacktrace twice to get missing -debug packages
31 dmorgan 110097 #Patch5: abrt-1.1.14-debug.patch
32 blino 21484 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
33 dmorgan 109812 Patch7: abrt-2.0.2-nspluginwrapper.patch
34 blino 21484 # (fc) fix for non UTF-8 locale
35 dmorgan 109812 Patch8: abrt-2.0.2-nonutf8-locale.patch
36 fwang 196875 Patch9: abrt-2.0.2-glib-2.32.patch
37 tv 203675 Patch10: abrt-sec.diff
38 blino 21273 # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
39 dmorgan 110097 #Patch12: abrt-1.1.14-disable_oops_scanner.patch
40 dmorgan 110077
41     # Fedora patches
42 ahmad 109606 BuildRequires: dbus-devel libdbus-glib-devel
43 blino 21273 BuildRequires: gtk2-devel
44     BuildRequires: curl-devel
45 blino 21532 BuildRequires: rpm-devel
46 blino 21273 BuildRequires: sqlite-devel > 3.0
47     BuildRequires: desktop-file-utils
48     #BuildRequires: nss-devel
49     BuildRequires: libnotify-devel
50     BuildRequires: xmlrpc-c-devel
51     BuildRequires: xmlrpc-c
52     BuildRequires: file-devel
53     BuildRequires: python-devel
54     BuildRequires: gettext
55     BuildRequires: polkit-1-devel
56     BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
57     BuildRequires: intltool
58     BuildRequires: gnome-common
59     BuildRequires: bison
60 dmorgan 109812 BuildRequires: asciidoc
61 tv 203677 BuildRequires: docbook-style-xsl docbook5-style-xsl
62 dmorgan 109812 BuildRequires: xmlto
63 dmorgan 110103 BuildRequires: libgnome-keyring-devel
64 dmorgan 196753 BuildRequires: gettext-devel
65 blino 21273 %if %{?with_systemd}
66     BuildRequires: systemd-units
67     %endif
68 dmorgan 197649 BuildRequires: btparser-devel
69     BuildRequires: libreport-devel
70 tv 203549 BuildRequires: pkgconfig(libreport-gtk)
71 blino 21273 Requires: %{lib_name} >= %{version}-%{release}
72     Requires(pre): rpm-helper
73     Requires(post): rpm-helper
74     Requires(preun): rpm-helper
75     Requires(postun): rpm-helper
76 dmorgan 109812 Obsoletes: abrt-plugin-catcut < 1.1.13
77     Obsoletes: abrt-plugin-sqlite3 < 1.1.18
78     # required for transition from 1.1.13, can be removed after some time
79     Obsoletes: abrt-plugin-runapp < 1.1.18
80     Obsoletes: abrt-plugin-filetransfer < 1.1.18
81     Obsoletes: abrt-plugin-sosreport < 1.1.18
82 blino 21273
83     %description
84     %{name} is a tool to help users to detect defects in applications and
85     to create a bug report with all informations needed by maintainer to fix it.
86     It uses plugin system to extend its functionality.
87    
88 dmorgan 109812 %pre
89     %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
90     %_pre_groupadd %{name} %{name}
91    
92     %post
93     %_post_service %{name}d
94     %if %{?with_systemd}
95     # Enable (but don't start) the units by default
96     /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
97     %endif
98    
99     %posttrans
100     service abrtd condrestart >/dev/null 2>&1 || :
101    
102     %preun
103     %_preun_service %{name}d
104     %if %{?with_systemd}
105     if [ "$1" -eq "0" ] ; then
106     /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
107     /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
108     fi
109     %endif
110    
111     %postun
112     %_postun_userdel %{name}
113     %_postun_groupdel %{name} %{name}
114     %if %{?with_systemd}
115     if [ $1 -ge 1 ] ; then
116     # On upgrade, reload init system configuration if we changed unit files
117     /bin/systemctl daemon-reload >/dev/null 2>&1 || :
118     fi
119     %endif
120    
121     %files -f %{name}.lang
122     %defattr(-,root,root,-)
123     %doc README COPYING
124     #systemd
125     %if %{?with_systemd}
126     %endif
127     %{_sbindir}/%{name}d
128     %{_sbindir}/%{name}-server
129     %{_bindir}/%{name}-debuginfo-install
130     %{_bindir}/%{name}-handle-upload
131     %{_bindir}/%{name}-action-save-package-data
132     %{_bindir}/%{name}-retrace-client
133     %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
134     %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
135     %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
136     %ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
137     %ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}d.pid
138     %{_initrddir}/%{name}d
139     #%dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
140     %dir /var/run/%{name}
141     %dir %{_sysconfdir}/%{name}
142     %dir %{_sysconfdir}/%{name}/plugins
143     %{_mandir}/man8/%{name}d.8.*
144     %{_mandir}/man5/%{name}.conf.5.*
145     %{_datadir}/dbus-1/system-services/com.redhat.%{name}.service
146    
147     #--------------------------------------------------------------------
148    
149 blino 21273 %package -n %{lib_name}
150     Summary: Libraries for %{name}
151     Group: System/Libraries
152    
153     %description -n %{lib_name}
154     Libraries for %{name}.
155    
156 dmorgan 109812 %files -n %{lib_name}
157     %defattr(-,root,root,-)
158     %{_libdir}/libabrt*.so.*
159    
160     #--------------------------------------------------------------------
161    
162 blino 21273 %package -n %{lib_name_devel}
163     Summary: Development libraries for %{name}
164     Group: Development/C
165     Requires: %{lib_name} = %{version}-%{release}
166     Requires: abrt = %{version}-%{release}
167     Obsoletes: %{_lib}abrt0-devel
168    
169     %description -n %{lib_name_devel}
170     Development libraries and headers for %{name}.
171    
172 dmorgan 109812 %files -n %{lib_name_devel}
173     %defattr(-,root,root,-)
174     %{_includedir}/abrt/*
175     %{_libdir}/libabrt*.so
176     #FIXME: this should go to libreportgtk-devel package
177     %{_libdir}/pkgconfig/%{name}.pc
178    
179     #--------------------------------------------------------------------
180    
181 blino 21273 %package gui
182     Summary: %{name}'s gui
183     Group: Graphical desktop/Other
184     Requires: %{name} = %{version}-%{release}
185     Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
186     Requires: python-gobject
187     Requires: gnome-python-desktop
188    
189     %description gui
190     GTK+ wizard for convenient bug reporting.
191    
192 dmorgan 109812 %files gui
193     %defattr(-,root,root,-)
194     %{_bindir}/%{name}-gui
195     %{_datadir}/%{name}
196     %{_datadir}/applications/%{name}.desktop
197     %{_datadir}/icons/hicolor/*/*/*.png
198     %{_bindir}/%{name}-applet
199     %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
200    
201     #--------------------------------------------------------------------
202    
203 blino 21273 %package addon-ccpp
204     Summary: %{name}'s C/C++ addon
205     Group: System/Libraries
206     Requires: elfutils
207     Requires: %{name} = %{version}-%{release}
208    
209     %description addon-ccpp
210     This package contains hook for C/C++ crashed programs and %{name}'s C/C++
211     analyzer plugin.
212    
213 dmorgan 109812 %post addon-ccpp
214     chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
215     #if [ $1 -eq 1 ]; then
216     /sbin/chkconfig --add abrt-ccpp
217     #fi
218    
219     %if %{?with_systemd}
220     if [ "$1" -eq "0" ] ; then
221     /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
222     /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
223     fi
224     %endif
225    
226     %posttrans addon-ccpp
227     service abrt-ccpp condrestart >/dev/null 2>&1 || :
228    
229     %preun addon-ccpp
230     if [ "$1" -eq "0" ] ; then
231     service abrt-ccpp stop >/dev/null 2>&1
232     /sbin/chkconfig --del abrt-ccpp
233     fi
234    
235     #systemd (not tested):
236     %if %{?with_systemd}
237     if [ "$1" -eq "0" ] ; then
238     /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
239     /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
240     fi
241     %endif
242    
243     %files addon-ccpp
244     %defattr(-,root,root,-)
245     %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
246     %dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
247     %{_initrddir}/abrt-ccpp
248 dmorgan 134959 %{_libdir}/abrt-hook-ccpp
249 dmorgan 109812 %{_sysconfdir}/profile.d/00abrt.*
250     %{_bindir}/abrt-action-analyze-c
251     %{_bindir}/abrt-action-trim-files
252     %attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
253     %{_bindir}/abrt-action-generate-backtrace
254     %{_bindir}/abrt-action-analyze-backtrace
255     %{_mandir}/man*/abrt-action-trim-files.*
256     %{_mandir}/man*/abrt-action-generate-backtrace.*
257     %{_mandir}/man*/abrt-action-analyze-backtrace.*
258    
259     #--------------------------------------------------------------------
260    
261 blino 21273 %package addon-kerneloops
262     Summary: %{name}'s kerneloops addon
263     Group: System/Libraries
264     Requires: curl
265     Requires: %{name} = %{version}-%{release}
266     #Obsoletes: kerneloops
267    
268     %description addon-kerneloops
269     This package contains plugin for collecting kernel crash information
270     and reporter plugin which sends this information to specified server,
271     usually to kerneloops.org.
272    
273 dmorgan 109812 %post addon-kerneloops
274     if [ $1 -eq 1 ]; then
275     /sbin/chkconfig --add abrt-oops
276     fi
277    
278     %posttrans addon-kerneloops
279     service abrt-oops condrestart >/dev/null 2>&1 || :
280    
281     %preun addon-kerneloops
282     if [ "$1" -eq "0" ] ; then
283     service abrt-oops stop >/dev/null 2>&1
284     /sbin/chkconfig --del abrt-oops
285     fi
286     #systemd (not tested):
287     %if %{?with_systemd}
288     if [ "$1" -eq "0" ] ; then
289     /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
290     /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
291     fi
292     %endif
293    
294     %files addon-kerneloops
295     %defattr(-,root,root,-)
296     %{_initrddir}/abrt-oops
297     %{_bindir}/abrt-dump-oops
298     %{_bindir}/abrt-action-analyze-oops
299    
300     #--------------------------------------------------------------------
301    
302 blino 21273 %package plugin-bugzilla
303     Summary: %{name}'s bugzilla plugin
304     Group: System/Libraries
305     Requires: %{name} = %{version}-%{release}
306    
307     %description plugin-bugzilla
308     Plugin to report bugs into the bugzilla.
309    
310 dmorgan 109812 %files plugin-bugzilla
311     %defattr(-,root,root,-)
312     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Bugzilla.conf
313     %{_sysconfdir}/%{name}/events/report_Bugzilla.xml
314     %config(noreplace) %{_sysconfdir}/%{name}/events/report_Bugzilla.conf
315     # FIXME: remove with the old gui
316     %{_mandir}/man7/abrt-Bugzilla.7.*
317     %{_bindir}/abrt-action-bugzilla
318 blino 21273
319 dmorgan 109812 #--------------------------------------------------------------------
320 blino 21273
321     %package plugin-reportuploader
322     Summary: %{name}'s ticketuploader plugin
323     Group: System/Libraries
324     Requires: %{name} = %{version}-%{release}
325     Obsoletes: plugin-ticketuploader < 1.1.13
326     Provides: plugin-ticketuploader = %{version}-%{release}
327    
328     %description plugin-reportuploader
329     Plugin to report bugs into anonymous FTP site associated with ticketing system.
330    
331 dmorgan 109812 %files plugin-reportuploader
332     %defattr(-,root,root,-)
333     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Upload.conf
334     %{_mandir}/man7/abrt-Upload.7.*
335     %{_bindir}/abrt-action-upload
336 blino 21273
337 dmorgan 109812 #--------------------------------------------------------------------
338 blino 21273
339     %package addon-python
340     Summary: %{name}'s addon for catching and analyzing Python exceptions
341     Group: System/Libraries
342     Requires: %{name} = %{version}-%{release}
343    
344     %description addon-python
345     This package contains python hook and python analyzer plugin for handling
346     uncaught exception in python programs.
347    
348 dmorgan 109812 %files addon-python
349     %defattr(-,root,root,-)
350     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
351     %{_bindir}/abrt-action-analyze-python
352     %{py_puresitedir}/abrt*.py*
353     %{py_puresitedir}/*.pth
354    
355     #--------------------------------------------------------------------
356    
357 blino 21273 %package cli
358     Summary: %{name}'s command line interface
359     Group: Graphical desktop/Other
360     Requires: %{name} = %{version}-%{release}
361     Requires: %{name}-addon-kerneloops
362     Requires: %{name}-addon-ccpp, %{name}-addon-python
363 dmorgan 111340 Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger
364 blino 21273
365     %description cli
366     This package contains simple command line client for controlling abrt
367     daemon over the sockets.
368    
369 dmorgan 109812 %files cli
370     %defattr(-,root,root,-)
371     %{_bindir}/abrt-cli
372     %{_mandir}/man1/abrt-cli.1.*
373     %{_sysconfdir}/bash_completion.d/abrt-cli.bash
374    
375     #--------------------------------------------------------------------
376    
377 blino 21273 %package desktop
378     Summary: Virtual package to install all necessary packages for usage from desktop environment
379     Group: Graphical desktop/Other
380     # This package gets installed when anything requests bug-buddy -
381     # happens when users upgrade Fn to Fn+1;
382     # or if user just wants "typical desktop installation".
383     # Installing abrt-desktop should result in the abrt which works without
384     # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
385     Requires: %{name} = %{version}-%{release}
386     Requires: %{name}-addon-kerneloops
387     Requires: %{name}-addon-ccpp, %{name}-addon-python
388     # Default config of addon-ccpp requires gdb
389     Requires: gdb >= 7.0-3
390     Requires: %{name}-gui
391 dmorgan 111387 Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla
392 blino 21273 #Obsoletes: bug-buddy
393     #Provides: bug-buddy
394    
395     %description desktop
396     Virtual package to make easy default installation on desktop environments.
397    
398 dmorgan 109812 %files desktop
399     %defattr(-,root,root,-)
400    
401     #--------------------------------------------------------------------
402    
403 dmorgan 110088 %package -n %libreport
404 dmorgan 110410 Summary: Libraries for reporting crashes to different targets
405 dmorgan 134965 Group: System/Libraries
406 dmorgan 109812
407 dmorgan 110088 %description -n %libreport
408 dmorgan 109812 Libraries providing API for reporting different problems in applications
409     to different bug targets like bugzilla, ftp, trac, etc...
410    
411 dmorgan 110088 %files -n %libreport
412 dmorgan 109812 %defattr(-,root,root,-)
413 dmorgan 110058 %{_libdir}/libreport.so.%{lib_major}*
414 dmorgan 109812
415     #--------------------------------------------------------------------
416    
417 dmorgan 110088 %package -n %lib_report_devel
418 dmorgan 110410 Summary: Development libraries and headers for libreport
419 dmorgan 134965 Group: System/Libraries
420 dmorgan 109812
421 dmorgan 110088 %description -n %lib_report_devel
422 dmorgan 109812 Development libraries and headers for libreport.
423    
424 dmorgan 110088 %files -n %lib_report_devel
425 dmorgan 109812 %defattr(-,root,root,-)
426     %{_includedir}/report/*
427     %{_libdir}/libreport.so
428    
429     #--------------------------------------------------------------------
430 dmorgan 110077 #
431     #%package -n libreport-python
432     #%Summary: Python bindings for report-libs.
433     #%Group: System/Libraries
434     #
435     #%description -n libreport-python
436     #Python bindings for report-libs.
437     #
438     #%files -n libreport-python
439     #%defattr(-,root,root,-)
440     #%{python_sitearch}/report/*
441     #
442 dmorgan 109812 #--------------------------------------------------------------------
443    
444 dmorgan 110088 %package -n %libreportgtk
445 dmorgan 109812 Summary: GTK frontend for libreport
446     Group: System/Libraries
447    
448 dmorgan 110088 %description -n %libreportgtk
449 dmorgan 109812 Applications for reporting bugs using libreport backend.
450    
451 dmorgan 110088 %files -n %libreportgtk
452 dmorgan 109812 %defattr(-,root,root,-)
453 dmorgan 110058 %{_libdir}/libreportgtk.so.%{lib_major}*
454 dmorgan 109812
455     #--------------------------------------------------------------------
456    
457     %package retrace-server
458     Summary: %{name}'s retrace server using HTTP protocol
459     Group: Graphical desktop/Other
460     Requires: abrt-addon-ccpp
461     Requires: gdb >= 7.0-3
462 dmorgan 138499 Requires: apache-mod_wsgi, apache-mod_ssl, python-webob
463 dmorgan 109812 Requires: mock, xz, elfutils, createrepo
464     Requires(preun): /sbin/install-info
465     Requires(post): /sbin/install-info
466    
467     %post retrace-server
468     /sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
469     /usr/sbin/usermod -G mock apache 2> /dev/null || :
470    
471     %preun retrace-server
472     if [ "$1" = 0 ]; then
473     /sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
474     fi
475    
476     %description retrace-server
477     The retrace server provides a coredump analysis and backtrace
478     generation service over a network using HTTP protocol.
479    
480     %files retrace-server
481     %defattr(-,root,root,-)
482     %config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
483     %config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
484     %config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
485     %dir %attr(0775, apache, abrt) %{_localstatedir}/spool/abrt-retrace
486     %dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/abrt-retrace
487     %dir %attr(0755, abrt, abrt) %{_localstatedir}/log/abrt-retrace
488     %caps(cap_setuid=ep) %{_bindir}/abrt-retrace-worker
489     %{_bindir}/abrt-retrace-cleanup
490     %{_bindir}/abrt-retrace-reposync
491     %{_bindir}/coredump2packages
492     %{py_puresitedir}/retrace.py*
493     %{_datadir}/abrt-retrace/*.py*
494     %{_datadir}/abrt-retrace/*.wsgi
495     %{_datadir}/abrt-retrace/plugins/*.py*
496     %{_infodir}/abrt-retrace-server*
497    
498     #--------------------------------------------------------------------
499    
500 blino 21273 %prep
501     %setup -q
502 dmorgan 110097 %apply_patches
503 tv 203550 # (tv)) disable -Werror:
504 tv 203551 perl -pi -e 's!-Werror!-Wno-deprecated!' configure{.ac,} */*/Makefile*
505 blino 21273
506     %build
507     NOCONFIGURE=yes gnome-autogen.sh
508 dmorgan 61093 %configure2_5x \
509     %if !%{with_systemd}
510     --without-systemdsystemunitdir \
511     %endif
512     --disable-rpath
513 blino 21273 %make
514    
515     %install
516     rm -rf %{buildroot}
517     %makeinstall_std
518     %find_lang %{name}
519    
520     # remove all .la and .a files
521     find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
522     mkdir -p %{buildroot}/%{_initrddir}
523 dmorgan 109812 install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/%{name}d
524     install -m 755 %SOURCE5 %{buildroot}/%{_initrddir}/%{name}-ccpp
525     install -m 755 %SOURCE6 %{buildroot}/%{_initrddir}/%{name}-oops
526 blino 21273 mkdir -p %{buildroot}/var/cache/%{name}-di
527     mkdir -p %{buildroot}/var/run/%{name}
528 dmorgan 109812 mkdir -p %{buildroot}/var/spool/%{name}
529     mkdir -p %{buildroot}/var/spool/%{name}-retrace
530     mkdir -p %{buildroot}/var/cache/%{name}-retrace
531     mkdir -p %{buildroot}/var/log/%{name}-retrace
532     mkdir -p %{buildroot}/var/spool/%{name}-upload
533    
534 dmorgan 134959 sed -i 's!@libexec@!%_libdir!' %{buildroot}/%{_initrddir}/%{name}-ccpp
535    
536 blino 21273 # remove fedora gpg key
537     rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
538     touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
539    
540     # install ulimit disabler
541     mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
542     install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
543    
544     desktop-file-install \
545     --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
546 dmorgan 109812 src/applet/%{name}-applet.desktop
547 blino 21273
548     # replace with our own version
549     cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
550    
551     #remove RH specific plugins
552     rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
553     rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
554 dmorgan 109812 rm -f %{buildroot}%{_sysconfdir}/%{name}/events.d/rhtsupport_events.conf
555     rm -f %{buildroot}%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
556     rm -f %{buildroot}%{_bindir}/%{name}-action-rhtsupport
557 blino 21273
558 dmorgan 109812 # After everything is installed, remove info dir
559     rm -f %{buildroot}%{_infodir}/dir

  ViewVC Help
Powered by ViewVC 1.1.30