/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Annotation of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 61093 - (hide annotations) (download)
Sun Feb 27 00:17:37 2011 UTC (13 years, 1 month ago) by dmorgan
File size: 13924 byte(s)
Fix build without systemd
Fix URL of the page where to create an account ( use identity instead of bugzilla )

1 blino 21531 # (blino) FIXME: switch back to 1 when systemd is installable
2     %define with_systemd 0
3 blino 21273
4     %define lib_major 0
5     %define lib_name %mklibname %{name} %{lib_major}
6     %define lib_name_devel %mklibname %{name} -d
7    
8     Summary: Automatic bug detection and reporting tool
9     Name: abrt
10     Version: 1.1.14
11 tmb 61084 Release: %mkrel 10
12 blino 21273 License: GPLv2+
13     Group: System/Base
14     URL: https://fedorahosted.org/abrt/
15     Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
16     Source1: abrt.init
17     Source2: 00abrt.sh
18     Source3: 00abrt.csh
19     Source4: abrt-debuginfo-install
20 blino 21484 # (fc) fix format security error
21 blino 21273 # (misc) sent upstream https://fedorahosted.org/abrt/attachment/ticket/120
22     Patch0: abrt-1.1.14-format_security.patch
23 blino 21484 # (fc) fix build with rpm 4.6
24 blino 21273 Patch1: abrt-1.0.8-rpm46.patch
25 blino 21484 # (fc) disable package signature check
26 blino 21273 Patch2: abrt_disable_gpgcheck.diff
27 blino 21492 # (blino) use Mageia bugzilla (adapted from Mandriva patch from fcrozat)
28     # FIXME: check the query is still correct when bugzilla is deployed
29     Patch3: abrt-mageiabugzilla.patch
30 blino 21484 # (pt) generate stacktrace twice to get missing -debug packages
31 blino 21273 Patch5: abrt-1.1.14-debug.patch
32 blino 21530 # (blino) parse /etc/release (adapted from Mandriva patch from fcrozat)
33     # FIXME: check the parsing is ok
34     Patch6: abrt-1.1.13-mageia-release.patch
35 blino 21484 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
36 blino 21273 Patch7: abrt-1.1.13-nspluginwrapper.patch
37 blino 21484 # (fc) fix for non UTF-8 locale
38 blino 21273 Patch8: abrt-1.1.1-nonutf8-locale.patch
39     Patch10: abrt-1.1.14-link.patch
40     # (proyvind): port to rpm5 api
41     Patch11: abrt-1.1.14-rpm5.patch
42     # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
43     Patch12: abrt-1.1.14-disable_oops_scanner.patch
44     BuildRequires: dbus-devel
45     BuildRequires: gtk2-devel
46     BuildRequires: curl-devel
47 blino 21532 BuildRequires: rpm-devel
48 blino 21273 BuildRequires: sqlite-devel > 3.0
49     BuildRequires: desktop-file-utils
50     #BuildRequires: nss-devel
51     BuildRequires: libnotify-devel
52     BuildRequires: xmlrpc-c-devel
53     BuildRequires: xmlrpc-c
54     BuildRequires: file-devel
55     BuildRequires: python-devel
56     BuildRequires: gettext
57     BuildRequires: polkit-1-devel
58     BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
59     BuildRequires: intltool
60     BuildRequires: gnome-common
61     BuildRequires: bison
62     %if %{?with_systemd}
63     BuildRequires: systemd-units
64     %endif
65     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
66     Requires: %{lib_name} >= %{version}-%{release}
67     Requires(pre): rpm-helper
68     Requires(post): rpm-helper
69     Requires(preun): rpm-helper
70     Requires(postun): rpm-helper
71     Obsoletes: plugin-catcut < 1.1.13
72    
73     %description
74     %{name} is a tool to help users to detect defects in applications and
75     to create a bug report with all informations needed by maintainer to fix it.
76     It uses plugin system to extend its functionality.
77    
78     %package -n %{lib_name}
79     Summary: Libraries for %{name}
80     Group: System/Libraries
81    
82     %description -n %{lib_name}
83     Libraries for %{name}.
84    
85     %package -n %{lib_name_devel}
86     Summary: Development libraries for %{name}
87     Group: Development/C
88     Requires: %{lib_name} = %{version}-%{release}
89     Requires: abrt = %{version}-%{release}
90     Obsoletes: %{_lib}abrt0-devel
91    
92     %description -n %{lib_name_devel}
93     Development libraries and headers for %{name}.
94    
95     %package gui
96     Summary: %{name}'s gui
97     Group: Graphical desktop/Other
98     Requires: %{name} = %{version}-%{release}
99     Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
100     Requires: python-gobject
101     Requires: gnome-python-desktop
102    
103     %description gui
104     GTK+ wizard for convenient bug reporting.
105    
106     %package addon-ccpp
107     Summary: %{name}'s C/C++ addon
108     Group: System/Libraries
109     Requires: elfutils
110     Requires: %{name} = %{version}-%{release}
111    
112     %description addon-ccpp
113     This package contains hook for C/C++ crashed programs and %{name}'s C/C++
114     analyzer plugin.
115    
116     %package addon-kerneloops
117     Summary: %{name}'s kerneloops addon
118     Group: System/Libraries
119     Requires: curl
120     Requires: %{name} = %{version}-%{release}
121     #Obsoletes: kerneloops
122    
123     %description addon-kerneloops
124     This package contains plugin for collecting kernel crash information
125     and reporter plugin which sends this information to specified server,
126     usually to kerneloops.org.
127    
128     %package plugin-logger
129     Summary: %{name}'s logger reporter plugin
130     Group: System/Libraries
131     Requires: %{name} = %{version}-%{release}
132    
133     %description plugin-logger
134     The simple reporter plugin which writes a report to a specified file.
135    
136     %package plugin-mailx
137     Summary: %{name}'s mailx reporter plugin
138     Group: System/Libraries
139     Requires: %{name} = %{version}-%{release}
140     Requires: mailx
141    
142     %description plugin-mailx
143     The simple reporter plugin which sends a report via mailx to a specified
144     email address.
145    
146     %package plugin-runapp
147     Summary: %{name}'s runapp plugin
148     Group: System/Libraries
149     Requires: %{name} = %{version}-%{release}
150    
151     %description plugin-runapp
152     Plugin to run external programs.
153    
154     %package plugin-sosreport
155     Summary: %{name}'s sosreport plugin
156     Group: System/Libraries
157     Requires: sos
158     Requires: %{name} = %{version}-%{release}
159    
160     %description plugin-sosreport
161     Plugin to include an sosreport in an abrt report.
162    
163     %package plugin-bugzilla
164     Summary: %{name}'s bugzilla plugin
165     Group: System/Libraries
166     Requires: %{name} = %{version}-%{release}
167    
168     %description plugin-bugzilla
169     Plugin to report bugs into the bugzilla.
170    
171     ##%package plugin-catcut
172     #Summary: %{name}'s catcut plugin
173     #Group: System/Libraries
174     #Requires: %{name} = %{version}-%{release}
175    
176     ##%description plugin-catcut
177     #Plugin to report bugs into the catcut.
178    
179     %package plugin-reportuploader
180     Summary: %{name}'s ticketuploader plugin
181     Group: System/Libraries
182     Requires: %{name} = %{version}-%{release}
183     Obsoletes: plugin-ticketuploader < 1.1.13
184     Provides: plugin-ticketuploader = %{version}-%{release}
185    
186     %description plugin-reportuploader
187     Plugin to report bugs into anonymous FTP site associated with ticketing system.
188    
189     %package plugin-filetransfer
190     Summary: %{name}'s File Transfer plugin
191     Group: System/Libraries
192     Requires: %{name} = %{version}-%{release}
193    
194     %description plugin-filetransfer
195     Plugin to uploading files to a server.
196    
197     %package addon-python
198     Summary: %{name}'s addon for catching and analyzing Python exceptions
199     Group: System/Libraries
200     Requires: %{name} = %{version}-%{release}
201    
202     %description addon-python
203     This package contains python hook and python analyzer plugin for handling
204     uncaught exception in python programs.
205    
206     %package cli
207     Summary: %{name}'s command line interface
208     Group: Graphical desktop/Other
209     Requires: %{name} = %{version}-%{release}
210     Requires: %{name}-addon-kerneloops
211     Requires: %{name}-addon-ccpp, %{name}-addon-python
212     Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger, %{name}-plugin-runapp
213    
214     %description cli
215     This package contains simple command line client for controlling abrt
216     daemon over the sockets.
217    
218     %package desktop
219     Summary: Virtual package to install all necessary packages for usage from desktop environment
220     Group: Graphical desktop/Other
221     # This package gets installed when anything requests bug-buddy -
222     # happens when users upgrade Fn to Fn+1;
223     # or if user just wants "typical desktop installation".
224     # Installing abrt-desktop should result in the abrt which works without
225     # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
226     Requires: %{name} = %{version}-%{release}
227     Requires: %{name}-addon-kerneloops
228     Requires: %{name}-addon-ccpp, %{name}-addon-python
229     # Default config of addon-ccpp requires gdb
230     Requires: gdb >= 7.0-3
231     Requires: %{name}-gui
232     Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla, %{name}-plugin-runapp
233     #Obsoletes: bug-buddy
234     #Provides: bug-buddy
235    
236     %description desktop
237     Virtual package to make easy default installation on desktop environments.
238    
239     %prep
240     %setup -q
241     %patch0 -p1 -b .format_security
242 dmorgan 61093 # Remove when we will use rpm 4.8.1
243 blino 21273 %patch1 -p1 -b .rpm46
244     %patch2 -p1 -b .disable_signature_check
245 blino 21492 %patch3 -p0 -b .mgabugzilla
246 blino 21273 %patch5 -p0 -b .debug
247 blino 21530 %patch6 -p0 -b .mageia-release
248 blino 21273 %patch7 -p0 -b .nspluginwrapper
249     %patch8 -p1 -b .nonutf8-locale
250     %patch10 -p0 -b .link
251 blino 21532 #patch11 -p1 -b .rpm5~
252 blino 21273 %patch12 -p1 -b .disable_oops_scanner
253    
254     %build
255     NOCONFIGURE=yes gnome-autogen.sh
256 dmorgan 61093 %configure2_5x \
257     %if !%{with_systemd}
258     --without-systemdsystemunitdir \
259     %endif
260     --disable-rpath
261 blino 21273 %make
262    
263     %install
264     rm -rf %{buildroot}
265     %makeinstall_std
266     %find_lang %{name}
267    
268     #rm -rf %{buildroot}/%{_libdir}/lib*.la
269     #rm -rf %{buildroot}/%{_libdir}/%{name}/lib*.la
270     # remove all .la and .a files
271     find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
272     mkdir -p %{buildroot}/%{_initrddir}
273     install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/abrtd
274     mkdir -p %{buildroot}/var/cache/%{name}
275     mkdir -p %{buildroot}/var/cache/%{name}-di
276     mkdir -p %{buildroot}/var/run/%{name}
277     # remove fedora gpg key
278     rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
279     touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
280    
281     # install ulimit disabler
282     mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
283     install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
284    
285     desktop-file-install \
286     --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
287     src/Applet/%{name}-applet.desktop
288    
289     # replace with our own version
290     cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
291    
292     #remove RH specific plugins
293     rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
294     rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
295    
296    
297     %clean
298     rm -rf %{buildroot}
299    
300     %pre
301     %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
302     %_pre_groupadd %{name} %{name}
303    
304     %post
305     %_post_service %{name}d
306     %if %{?with_systemd}
307     # Enable (but don't start) the units by default
308     /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
309     %endif
310    
311    
312     %preun
313     %_preun_service %{name}d
314     %if %{?with_systemd}
315     if [ "$1" -eq "0" ] ; then
316     /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
317     /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
318     fi
319     %endif
320    
321    
322     %postun
323     %_postun_userdel %{name}
324     %_postun_groupdel %{name} %{name}
325     %if %{?with_systemd}
326     if [ $1 -ge 1 ] ; then
327     # On upgrade, reload init system configuration if we changed unit files
328     /bin/systemctl daemon-reload >/dev/null 2>&1 || :
329     fi
330     %endif
331    
332    
333     %files -f %{name}.lang
334     %defattr(-,root,root,-)
335     %doc README COPYING
336     #systemd
337     %if %{?with_systemd}
338     /lib/systemd/system/%{name}d.service
339     %endif
340     %{_sbindir}/%{name}d
341     %{_bindir}/%{name}-debuginfo-install
342     %{_bindir}/%{name}-backtrace
343     %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
344     %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
345     %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
346     %{_initrddir}/%{name}d
347     %dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
348     %dir /var/run/%{name}
349     %dir %{_sysconfdir}/%{name}
350     %dir %{_sysconfdir}/%{name}/plugins
351     %dir %{_libdir}/%{name}
352     %{_mandir}/man1/%{name}-backtrace.1.*
353     %{_mandir}/man8/abrtd.8.*
354     %{_mandir}/man5/%{name}.conf.5.*
355     #%{_mandir}/man5/pyhook.conf.5.*
356     %{_mandir}/man7/%{name}-plugins.7.*
357     %{_datadir}/polkit-1/actions/org.fedoraproject.abrt.policy
358     %{_datadir}/dbus-1/system-services/com.redhat.abrt.service
359     %config(noreplace) %{_sysconfdir}/%{name}/plugins/SQLite3.conf
360     %{_libdir}/%{name}/libSQLite3.so*
361     %{_mandir}/man7/%{name}-SQLite3.7.*
362    
363     %files -n %{lib_name}
364     %defattr(-,root,root,-)
365     %{_libdir}/lib*.so.*
366    
367     %files -n %{lib_name_devel}
368     %defattr(-,root,root,-)
369     %{_libdir}/lib*.so
370     %{_includedir}/%{name}/*.h
371     %{_libdir}/pkgconfig/%{name}.pc
372    
373     %files gui
374     %defattr(-,root,root,-)
375     %{_bindir}/%{name}-gui
376     %{_datadir}/%{name}
377     %{_datadir}/applications/%{name}.desktop
378     %{_datadir}/icons/hicolor/*/*/*.png
379     %{_bindir}/%{name}-applet
380     %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
381    
382     %files addon-ccpp
383     %defattr(-,root,root,-)
384     %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
385     %dir %{_localstatedir}/cache/%{name}-di
386     %{_libdir}/%{name}/libCCpp.so*
387     %{_libexecdir}/abrt-hook-ccpp
388     %{_sysconfdir}/profile.d/00abrt.*
389    
390     %files addon-kerneloops
391     %defattr(-,root,root,-)
392     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
393     %{_bindir}/dumpoops
394     %{_libdir}/%{name}/libKerneloops.so*
395     %{_libdir}/%{name}/libKerneloopsScanner.so*
396     %{_mandir}/man7/%{name}-KerneloopsScanner.7.*
397     %{_libdir}/%{name}/libKerneloopsReporter.so*
398     %{_libdir}/%{name}/KerneloopsReporter.glade
399     %{_mandir}/man7/%{name}-KerneloopsReporter.7.*
400    
401     %files plugin-logger
402     %defattr(-,root,root,-)
403     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Logger.conf
404     %{_libdir}/%{name}/libLogger.so*
405     %{_libdir}/%{name}/Logger.glade
406     %{_mandir}/man7/%{name}-Logger.7.*
407    
408     %files plugin-mailx
409     %defattr(-,root,root,-)
410     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Mailx.conf
411     %{_libdir}/%{name}/libMailx.so*
412     %{_libdir}/%{name}/Mailx.glade
413     %{_mandir}/man7/%{name}-Mailx.7.*
414    
415     %files plugin-runapp
416     %defattr(-,root,root,-)
417     %{_libdir}/%{name}/libRunApp.so*
418     %{_mandir}/man7/%{name}-RunApp.7.*
419    
420     %files plugin-sosreport
421     %defattr(-,root,root,-)
422     %config(noreplace) %{_sysconfdir}/%{name}/plugins/SOSreport.conf
423     %{_libdir}/%{name}/libSOSreport.so*
424    
425    
426     %files plugin-bugzilla
427     %defattr(-,root,root,-)
428     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Bugzilla.conf
429     %{_libdir}/%{name}/libBugzilla.so*
430     %{_libdir}/%{name}/Bugzilla.glade
431     %{_mandir}/man7/%{name}-Bugzilla.7.*
432    
433     ##%files plugin-catcut
434     #%defattr(-,root,root,-)
435     #%config(noreplace) %{_sysconfdir}/%{name}/plugins/Catcut.conf
436     #%{_libdir}/%{name}/libCatcut.so*
437     #%{_libdir}/%{name}/Catcut.GTKBuilder
438     #%{_mandir}/man7/%{name}-Catcut.7.*
439    
440     %files plugin-reportuploader
441     %defattr(-,root,root,-)
442     %config(noreplace) %{_sysconfdir}/%{name}/plugins/ReportUploader.conf
443     %{_bindir}/%{name}-handle-upload
444     %{_libdir}/%{name}/libReportUploader.so*
445     %{_libdir}/%{name}/ReportUploader.glade
446     %{_mandir}/man7/%{name}-ReportUploader.7.*
447    
448     %files plugin-filetransfer
449     %defattr(-,root,root,-)
450     %config(noreplace) %{_sysconfdir}/%{name}/plugins/FileTransfer.conf
451     %{_libdir}/%{name}/libFileTransfer.so*
452     %{_mandir}/man7/%{name}-FileTransfer.7.*
453    
454     %files addon-python
455     %defattr(-,root,root,-)
456     %config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
457     #%attr(4755, abrt, abrt) %{_libexecdir}/abrt-hook-python
458     %{_libdir}/%{name}/libPython.so*
459     %{py_puresitedir}/*.py*
460     %{py_puresitedir}/*.pth
461    
462    
463     %files cli
464     %defattr(-,root,root,-)
465     %{_bindir}/abrt-cli
466     %{_mandir}/man1/abrt-cli.1.*
467     %{_sysconfdir}/bash_completion.d/abrt-cli.bash
468    
469     %files desktop
470     %defattr(-,root,root,-)
471    
472    
473    

  ViewVC Help
Powered by ViewVC 1.1.30