/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Contents of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 203726 - (show annotations) (download)
Tue Jan 31 22:38:40 2012 UTC (12 years, 2 months ago) by tv
File size: 18889 byte(s)
adjust file list
1 # (blino) FIXME: switch back to 1 when systemd is installable
2 %define with_systemd 1
3
4 %define lib_major 0
5 %define lib_name %mklibname %{name} %{lib_major}
6 %define libreport %mklibname report %{lib_major}
7 %define libreportgtk %mklibname report-gtk %{lib_major}
8
9 %define lib_name_devel %mklibname %{name} -d
10 %define lib_report_devel %mklibname report -d
11
12 %define _disable_ld_no_undefined 1
13
14 Summary: Automatic bug detection and reporting tool
15 Name: abrt
16 Version: 2.0.7
17 Release: %mkrel 1
18 License: GPLv2+
19 Group: System/Libraries
20 URL: https://fedorahosted.org/abrt/
21 Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
22 Source1: abrt.init
23 Source2: 00abrt.sh
24 Source3: 00abrt.csh
25 Source4: abrt-debuginfo-install
26 Source5: abrt-ccpp.init
27 Source6: abrt-oops.init
28 # (fc) disable package signature check
29 Patch2: abrt_disable_gpgcheck.diff
30 # (pt) generate stacktrace twice to get missing -debug packages
31 #Patch5: abrt-1.1.14-debug.patch
32 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
33 Patch7: abrt-2.0.2-nspluginwrapper.patch
34 # (fc) fix for non UTF-8 locale
35 Patch8: abrt-2.0.2-nonutf8-locale.patch
36 Patch9: abrt-2.0.2-glib-2.32.patch
37 Patch10: abrt-sec.diff
38 # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
39 #Patch12: abrt-1.1.14-disable_oops_scanner.patch
40
41 # Fedora patches
42 BuildRequires: dbus-devel libdbus-glib-devel
43 BuildRequires: gtk2-devel
44 BuildRequires: curl-devel
45 BuildRequires: rpm-devel
46 BuildRequires: sqlite-devel > 3.0
47 BuildRequires: desktop-file-utils
48 #BuildRequires: nss-devel
49 BuildRequires: libnotify-devel
50 BuildRequires: xmlrpc-c-devel
51 BuildRequires: xmlrpc-c
52 BuildRequires: file-devel
53 BuildRequires: python-devel
54 BuildRequires: gettext
55 BuildRequires: polkit-1-devel
56 BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
57 BuildRequires: intltool
58 BuildRequires: gnome-common
59 BuildRequires: bison
60 BuildRequires: asciidoc
61 BuildRequires: docbook-style-xsl docbook5-style-xsl
62 BuildRequires: xmlto
63 BuildRequires: libgnome-keyring-devel
64 BuildRequires: gettext-devel
65 %if %{?with_systemd}
66 BuildRequires: systemd-units
67 %endif
68 BuildRequires: btparser-devel
69 BuildRequires: libreport-devel
70 BuildRequires: pkgconfig(libreport-gtk)
71 Requires: %{lib_name} >= %{version}-%{release}
72 Requires(pre): rpm-helper
73 Requires(post): rpm-helper
74 Requires(preun): rpm-helper
75 Requires(postun): rpm-helper
76 Obsoletes: abrt-plugin-catcut < 1.1.13
77 Obsoletes: abrt-plugin-sqlite3 < 1.1.18
78 # required for transition from 1.1.13, can be removed after some time
79 Obsoletes: abrt-plugin-runapp < 1.1.18
80 Obsoletes: abrt-plugin-filetransfer < 1.1.18
81 Obsoletes: abrt-plugin-sosreport < 1.1.18
82
83 %description
84 %{name} is a tool to help users to detect defects in applications and
85 to create a bug report with all informations needed by maintainer to fix it.
86 It uses plugin system to extend its functionality.
87
88 %pre
89 %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
90 %_pre_groupadd %{name} %{name}
91
92 %post
93 %_post_service %{name}d
94 %if %{?with_systemd}
95 # Enable (but don't start) the units by default
96 /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
97 %endif
98
99 %posttrans
100 service abrtd condrestart >/dev/null 2>&1 || :
101
102 %preun
103 %_preun_service %{name}d
104 %if %{?with_systemd}
105 if [ "$1" -eq "0" ] ; then
106 /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
107 /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
108 fi
109 %endif
110
111 %postun
112 %_postun_userdel %{name}
113 %_postun_groupdel %{name} %{name}
114 %if %{?with_systemd}
115 if [ $1 -ge 1 ] ; then
116 # On upgrade, reload init system configuration if we changed unit files
117 /bin/systemctl daemon-reload >/dev/null 2>&1 || :
118 fi
119 %endif
120
121 %files -f %{name}.lang
122 %defattr(-,root,root,-)
123 %doc README COPYING
124 #systemd
125 %if %{?with_systemd}
126 %endif
127 %{_sbindir}/%{name}d
128 %{_sbindir}/%{name}-server
129 %{_bindir}/%{name}-debuginfo-install
130 %{_bindir}/%{name}-handle-upload
131 %{_bindir}/%{name}-action-save-package-data
132 %{_bindir}/%{name}-retrace-client
133 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
134 %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
135 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
136 %ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
137 %ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}d.pid
138 %{_initrddir}/%{name}d
139 #%dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
140 %dir /var/run/%{name}
141 %dir %{_sysconfdir}/%{name}
142 %dir %{_sysconfdir}/%{name}/plugins
143 %{_mandir}/man8/%{name}d.8.*
144 %{_mandir}/man5/%{name}.conf.5.*
145 %{_datadir}/dbus-1/system-services/com.redhat.%{name}.service
146
147 #--------------------------------------------------------------------
148
149 %package -n %{lib_name}
150 Summary: Libraries for %{name}
151 Group: System/Libraries
152
153 %description -n %{lib_name}
154 Libraries for %{name}.
155
156 %files -n %{lib_name}
157 %defattr(-,root,root,-)
158 %{_libdir}/libabrt*.so.*
159 %{_libdir}/libbtparser.so.*
160
161 #--------------------------------------------------------------------
162
163 %package -n %{lib_name_devel}
164 Summary: Development libraries for %{name}
165 Group: Development/C
166 Requires: %{lib_name} = %{version}-%{release}
167 Requires: abrt = %{version}-%{release}
168 Obsoletes: %{_lib}abrt0-devel
169
170 %description -n %{lib_name_devel}
171 Development libraries and headers for %{name}.
172
173 %files -n %{lib_name_devel}
174 %defattr(-,root,root,-)
175 %{_includedir}/abrt/*
176 %{_includedir}/btparser/*
177 %{_libdir}/libabrt*.so
178 %{_libdir}/libbtparser.so
179 #FIXME: this should go to libreportgtk-devel package
180 %{_libdir}/libreportgtk.so
181 %{_libdir}/pkgconfig/%{name}.pc
182 %{_libdir}/pkgconfig/btparser.pc
183
184 #--------------------------------------------------------------------
185
186 %package gui
187 Summary: %{name}'s gui
188 Group: Graphical desktop/Other
189 Requires: %{name} = %{version}-%{release}
190 Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
191 Requires: python-gobject
192 Requires: gnome-python-desktop
193
194 %description gui
195 GTK+ wizard for convenient bug reporting.
196
197 %files gui
198 %defattr(-,root,root,-)
199 %{_bindir}/%{name}-gui
200 %{_datadir}/%{name}
201 %{_datadir}/applications/%{name}.desktop
202 %{_datadir}/icons/hicolor/*/*/*.png
203 %{_bindir}/%{name}-applet
204 %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
205
206 #--------------------------------------------------------------------
207
208 %package addon-ccpp
209 Summary: %{name}'s C/C++ addon
210 Group: System/Libraries
211 Requires: elfutils
212 Requires: %{name} = %{version}-%{release}
213
214 %description addon-ccpp
215 This package contains hook for C/C++ crashed programs and %{name}'s C/C++
216 analyzer plugin.
217
218 %post addon-ccpp
219 chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
220 #if [ $1 -eq 1 ]; then
221 /sbin/chkconfig --add abrt-ccpp
222 #fi
223
224 %if %{?with_systemd}
225 if [ "$1" -eq "0" ] ; then
226 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
227 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
228 fi
229 %endif
230
231 %posttrans addon-ccpp
232 service abrt-ccpp condrestart >/dev/null 2>&1 || :
233
234 %preun addon-ccpp
235 if [ "$1" -eq "0" ] ; then
236 service abrt-ccpp stop >/dev/null 2>&1
237 /sbin/chkconfig --del abrt-ccpp
238 fi
239
240 #systemd (not tested):
241 %if %{?with_systemd}
242 if [ "$1" -eq "0" ] ; then
243 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
244 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
245 fi
246 %endif
247
248 %files addon-ccpp
249 %defattr(-,root,root,-)
250 %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
251 %dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
252 %{_initrddir}/abrt-ccpp
253 %{_libdir}/abrt-hook-ccpp
254 %{_sysconfdir}/profile.d/00abrt.*
255 %{_bindir}/abrt-action-analyze-c
256 %{_bindir}/abrt-action-trim-files
257 %attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
258 %{_bindir}/abrt-action-install-debuginfo.py*
259 %{_bindir}/abrt-action-generate-backtrace
260 %{_bindir}/abrt-action-analyze-backtrace
261 %{_bindir}/abrt-action-list-dsos.py*
262 %{_sysconfdir}/%{name}/events.d/ccpp_events.conf
263 %{_sysconfdir}/%{name}/events/analyze_LocalGDB.xml
264 %{_sysconfdir}/%{name}/events/reanalyze_LocalGDB.xml
265 %{_sysconfdir}/%{name}/events/analyze_RetraceServer.xml
266 %{_sysconfdir}/%{name}/events/reanalyze_RetraceServer.xml
267 %{_mandir}/man*/abrt-action-trim-files.*
268 %{_mandir}/man*/abrt-action-generate-backtrace.*
269 %{_mandir}/man*/abrt-action-analyze-backtrace.*
270
271 #--------------------------------------------------------------------
272
273 %package addon-kerneloops
274 Summary: %{name}'s kerneloops addon
275 Group: System/Libraries
276 Requires: curl
277 Requires: %{name} = %{version}-%{release}
278 #Obsoletes: kerneloops
279
280 %description addon-kerneloops
281 This package contains plugin for collecting kernel crash information
282 and reporter plugin which sends this information to specified server,
283 usually to kerneloops.org.
284
285 %post addon-kerneloops
286 if [ $1 -eq 1 ]; then
287 /sbin/chkconfig --add abrt-oops
288 fi
289
290 %posttrans addon-kerneloops
291 service abrt-oops condrestart >/dev/null 2>&1 || :
292
293 %preun addon-kerneloops
294 if [ "$1" -eq "0" ] ; then
295 service abrt-oops stop >/dev/null 2>&1
296 /sbin/chkconfig --del abrt-oops
297 fi
298 #systemd (not tested):
299 %if %{?with_systemd}
300 if [ "$1" -eq "0" ] ; then
301 /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
302 /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
303 fi
304 %endif
305
306 %files addon-kerneloops
307 %defattr(-,root,root,-)
308 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
309 %config(noreplace) %{_sysconfdir}/%{name}/events.d/koops_events.conf
310 %{_sysconfdir}/%{name}/events/report_Kerneloops.xml
311 %{_initrddir}/abrt-oops
312 %{_mandir}/man7/abrt-KerneloopsReporter.7.*
313 %{_bindir}/abrt-dump-oops
314 %{_bindir}/abrt-action-analyze-oops
315 %{_bindir}/abrt-action-kerneloops
316
317 #--------------------------------------------------------------------
318
319 %package plugin-logger
320 Summary: %{name}'s logger reporter plugin
321 Group: System/Libraries
322 Requires: %{name} = %{version}-%{release}
323
324 %description plugin-logger
325 The simple reporter plugin which writes a report to a specified file.
326
327 %files plugin-logger
328 %defattr(-,root,root,-)
329 %{_sysconfdir}/%{name}/events/report_Logger.conf
330 %{_bindir}/abrt-action-print
331 %{_mandir}/man7/%{name}-Logger.7.*
332 %{_mandir}/man*/%{name}-action-print.*
333
334 #--------------------------------------------------------------------
335
336 %package plugin-mailx
337 Summary: %{name}'s mailx reporter plugin
338 Group: System/Libraries
339 Requires: %{name} = %{version}-%{release}
340 Requires: mailx
341
342 %description plugin-mailx
343 The simple reporter plugin which sends a report via mailx to a specified
344 email address.
345
346 %files plugin-mailx
347 %defattr(-,root,root,-)
348 %{_sysconfdir}/%{name}/events/report_Mailx.xml
349 %{_sysconfdir}/%{name}/events.d/mailx_events.conf
350 %{_bindir}/abrt-action-mailx
351 %{_mandir}/man7/%{name}-Mailx.7.*
352 %{_mandir}/man*/%{name}-action-mailx.*
353
354 #--------------------------------------------------------------------
355
356 %package plugin-bugzilla
357 Summary: %{name}'s bugzilla plugin
358 Group: System/Libraries
359 Requires: %{name} = %{version}-%{release}
360
361 %description plugin-bugzilla
362 Plugin to report bugs into the bugzilla.
363
364 %files plugin-bugzilla
365 %defattr(-,root,root,-)
366 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Bugzilla.conf
367 %{_sysconfdir}/%{name}/events/report_Bugzilla.xml
368 %config(noreplace) %{_sysconfdir}/%{name}/events/report_Bugzilla.conf
369 # FIXME: remove with the old gui
370 %{_mandir}/man7/abrt-Bugzilla.7.*
371 %{_bindir}/abrt-action-bugzilla
372
373 #--------------------------------------------------------------------
374
375 %package plugin-reportuploader
376 Summary: %{name}'s ticketuploader plugin
377 Group: System/Libraries
378 Requires: %{name} = %{version}-%{release}
379 Obsoletes: plugin-ticketuploader < 1.1.13
380 Provides: plugin-ticketuploader = %{version}-%{release}
381
382 %description plugin-reportuploader
383 Plugin to report bugs into anonymous FTP site associated with ticketing system.
384
385 %files plugin-reportuploader
386 %defattr(-,root,root,-)
387 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Upload.conf
388 %{_mandir}/man7/abrt-Upload.7.*
389 %{_bindir}/abrt-action-upload
390
391 #--------------------------------------------------------------------
392
393 %package addon-python
394 Summary: %{name}'s addon for catching and analyzing Python exceptions
395 Group: System/Libraries
396 Requires: %{name} = %{version}-%{release}
397
398 %description addon-python
399 This package contains python hook and python analyzer plugin for handling
400 uncaught exception in python programs.
401
402 %files addon-python
403 %defattr(-,root,root,-)
404 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
405 %{_bindir}/abrt-action-analyze-python
406 %{py_puresitedir}/abrt*.py*
407 %{py_puresitedir}/*.pth
408
409 #--------------------------------------------------------------------
410
411 %package cli
412 Summary: %{name}'s command line interface
413 Group: Graphical desktop/Other
414 Requires: %{name} = %{version}-%{release}
415 Requires: %{name}-addon-kerneloops
416 Requires: %{name}-addon-ccpp, %{name}-addon-python
417 Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger
418
419 %description cli
420 This package contains simple command line client for controlling abrt
421 daemon over the sockets.
422
423 %files cli
424 %defattr(-,root,root,-)
425 %{_bindir}/abrt-cli
426 %{_mandir}/man1/abrt-cli.1.*
427 %{_sysconfdir}/bash_completion.d/abrt-cli.bash
428
429 #--------------------------------------------------------------------
430
431 %package desktop
432 Summary: Virtual package to install all necessary packages for usage from desktop environment
433 Group: Graphical desktop/Other
434 # This package gets installed when anything requests bug-buddy -
435 # happens when users upgrade Fn to Fn+1;
436 # or if user just wants "typical desktop installation".
437 # Installing abrt-desktop should result in the abrt which works without
438 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
439 Requires: %{name} = %{version}-%{release}
440 Requires: %{name}-addon-kerneloops
441 Requires: %{name}-addon-ccpp, %{name}-addon-python
442 # Default config of addon-ccpp requires gdb
443 Requires: gdb >= 7.0-3
444 Requires: %{name}-gui
445 Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla
446 #Obsoletes: bug-buddy
447 #Provides: bug-buddy
448
449 %description desktop
450 Virtual package to make easy default installation on desktop environments.
451
452 %files desktop
453 %defattr(-,root,root,-)
454
455 #--------------------------------------------------------------------
456
457 %package -n %libreport
458 Summary: Libraries for reporting crashes to different targets
459 Group: System/Libraries
460
461 %description -n %libreport
462 Libraries providing API for reporting different problems in applications
463 to different bug targets like bugzilla, ftp, trac, etc...
464
465 %files -n %libreport
466 %defattr(-,root,root,-)
467 %{_libdir}/libreport.so.%{lib_major}*
468
469 #--------------------------------------------------------------------
470
471 %package -n %lib_report_devel
472 Summary: Development libraries and headers for libreport
473 Group: System/Libraries
474
475 %description -n %lib_report_devel
476 Development libraries and headers for libreport.
477
478 %files -n %lib_report_devel
479 %defattr(-,root,root,-)
480 %{_includedir}/report/*
481 %{_libdir}/libreport.so
482
483 #--------------------------------------------------------------------
484 #
485 #%package -n libreport-python
486 #%Summary: Python bindings for report-libs.
487 #%Group: System/Libraries
488 #
489 #%description -n libreport-python
490 #Python bindings for report-libs.
491 #
492 #%files -n libreport-python
493 #%defattr(-,root,root,-)
494 #%{python_sitearch}/report/*
495 #
496 #--------------------------------------------------------------------
497
498 %package -n %libreportgtk
499 Summary: GTK frontend for libreport
500 Group: System/Libraries
501
502 %description -n %libreportgtk
503 Applications for reporting bugs using libreport backend.
504
505 %files -n %libreportgtk
506 %defattr(-,root,root,-)
507 %{_libdir}/libreportgtk.so.%{lib_major}*
508
509 #--------------------------------------------------------------------
510
511 %package retrace-server
512 Summary: %{name}'s retrace server using HTTP protocol
513 Group: Graphical desktop/Other
514 Requires: abrt-addon-ccpp
515 Requires: gdb >= 7.0-3
516 Requires: apache-mod_wsgi, apache-mod_ssl, python-webob
517 Requires: mock, xz, elfutils, createrepo
518 Requires(preun): /sbin/install-info
519 Requires(post): /sbin/install-info
520
521 %post retrace-server
522 /sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
523 /usr/sbin/usermod -G mock apache 2> /dev/null || :
524
525 %preun retrace-server
526 if [ "$1" = 0 ]; then
527 /sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
528 fi
529
530 %description retrace-server
531 The retrace server provides a coredump analysis and backtrace
532 generation service over a network using HTTP protocol.
533
534 %files retrace-server
535 %defattr(-,root,root,-)
536 %config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
537 %config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
538 %config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
539 %dir %attr(0775, apache, abrt) %{_localstatedir}/spool/abrt-retrace
540 %dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/abrt-retrace
541 %dir %attr(0755, abrt, abrt) %{_localstatedir}/log/abrt-retrace
542 %caps(cap_setuid=ep) %{_bindir}/abrt-retrace-worker
543 %{_bindir}/abrt-retrace-cleanup
544 %{_bindir}/abrt-retrace-reposync
545 %{_bindir}/coredump2packages
546 %{py_puresitedir}/retrace.py*
547 %{_datadir}/abrt-retrace/*.py*
548 %{_datadir}/abrt-retrace/*.wsgi
549 %{_datadir}/abrt-retrace/plugins/*.py*
550 %{_infodir}/abrt-retrace-server*
551
552 #--------------------------------------------------------------------
553
554 %prep
555 %setup -q
556 %apply_patches
557 # (tv)) disable -Werror:
558 perl -pi -e 's!-Werror!-Wno-deprecated!' configure{.ac,} */*/Makefile*
559
560 %build
561 NOCONFIGURE=yes gnome-autogen.sh
562 %configure2_5x \
563 %if !%{with_systemd}
564 --without-systemdsystemunitdir \
565 %endif
566 --disable-rpath
567 %make
568
569 %install
570 rm -rf %{buildroot}
571 %makeinstall_std
572 %find_lang %{name}
573
574 # remove all .la and .a files
575 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
576 mkdir -p %{buildroot}/%{_initrddir}
577 install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/%{name}d
578 install -m 755 %SOURCE5 %{buildroot}/%{_initrddir}/%{name}-ccpp
579 install -m 755 %SOURCE6 %{buildroot}/%{_initrddir}/%{name}-oops
580 mkdir -p %{buildroot}/var/cache/%{name}-di
581 mkdir -p %{buildroot}/var/run/%{name}
582 mkdir -p %{buildroot}/var/spool/%{name}
583 mkdir -p %{buildroot}/var/spool/%{name}-retrace
584 mkdir -p %{buildroot}/var/cache/%{name}-retrace
585 mkdir -p %{buildroot}/var/log/%{name}-retrace
586 mkdir -p %{buildroot}/var/spool/%{name}-upload
587
588 sed -i 's!@libexec@!%_libdir!' %{buildroot}/%{_initrddir}/%{name}-ccpp
589
590 # remove fedora gpg key
591 rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
592 touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
593
594 # install ulimit disabler
595 mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
596 install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
597
598 desktop-file-install \
599 --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
600 src/applet/%{name}-applet.desktop
601
602 # replace with our own version
603 cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
604
605 #remove RH specific plugins
606 rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
607 rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
608 rm -f %{buildroot}%{_sysconfdir}/%{name}/events.d/rhtsupport_events.conf
609 rm -f %{buildroot}%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
610 rm -f %{buildroot}%{_bindir}/%{name}-action-rhtsupport
611
612 # After everything is installed, remove info dir
613 rm -f %{buildroot}%{_infodir}/dir

  ViewVC Help
Powered by ViewVC 1.1.30