/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Contents of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 203733 - (show annotations) (download)
Tue Jan 31 22:55:49 2012 UTC (12 years, 1 month ago) by tv
File size: 18835 byte(s)
further adjust file list (SILENT)
1 # (blino) FIXME: switch back to 1 when systemd is installable
2 %define with_systemd 1
3
4 %define lib_major 0
5 %define lib_name %mklibname %{name} %{lib_major}
6 %define libreport %mklibname report %{lib_major}
7 %define libreportgtk %mklibname report-gtk %{lib_major}
8
9 %define lib_name_devel %mklibname %{name} -d
10 %define lib_report_devel %mklibname report -d
11
12 %define _disable_ld_no_undefined 1
13
14 Summary: Automatic bug detection and reporting tool
15 Name: abrt
16 Version: 2.0.7
17 Release: %mkrel 1
18 License: GPLv2+
19 Group: System/Libraries
20 URL: https://fedorahosted.org/abrt/
21 Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
22 Source1: abrt.init
23 Source2: 00abrt.sh
24 Source3: 00abrt.csh
25 Source4: abrt-debuginfo-install
26 Source5: abrt-ccpp.init
27 Source6: abrt-oops.init
28 # (fc) disable package signature check
29 Patch2: abrt_disable_gpgcheck.diff
30 # (pt) generate stacktrace twice to get missing -debug packages
31 #Patch5: abrt-1.1.14-debug.patch
32 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
33 Patch7: abrt-2.0.2-nspluginwrapper.patch
34 # (fc) fix for non UTF-8 locale
35 Patch8: abrt-2.0.2-nonutf8-locale.patch
36 Patch9: abrt-2.0.2-glib-2.32.patch
37 Patch10: abrt-sec.diff
38 # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
39 #Patch12: abrt-1.1.14-disable_oops_scanner.patch
40
41 # Fedora patches
42 BuildRequires: dbus-devel libdbus-glib-devel
43 BuildRequires: gtk2-devel
44 BuildRequires: curl-devel
45 BuildRequires: rpm-devel
46 BuildRequires: sqlite-devel > 3.0
47 BuildRequires: desktop-file-utils
48 #BuildRequires: nss-devel
49 BuildRequires: libnotify-devel
50 BuildRequires: xmlrpc-c-devel
51 BuildRequires: xmlrpc-c
52 BuildRequires: file-devel
53 BuildRequires: python-devel
54 BuildRequires: gettext
55 BuildRequires: polkit-1-devel
56 BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
57 BuildRequires: intltool
58 BuildRequires: gnome-common
59 BuildRequires: bison
60 BuildRequires: asciidoc
61 BuildRequires: docbook-style-xsl docbook5-style-xsl
62 BuildRequires: xmlto
63 BuildRequires: libgnome-keyring-devel
64 BuildRequires: gettext-devel
65 %if %{?with_systemd}
66 BuildRequires: systemd-units
67 %endif
68 BuildRequires: btparser-devel
69 BuildRequires: libreport-devel
70 BuildRequires: pkgconfig(libreport-gtk)
71 Requires: %{lib_name} >= %{version}-%{release}
72 Requires(pre): rpm-helper
73 Requires(post): rpm-helper
74 Requires(preun): rpm-helper
75 Requires(postun): rpm-helper
76 Obsoletes: abrt-plugin-catcut < 1.1.13
77 Obsoletes: abrt-plugin-sqlite3 < 1.1.18
78 # required for transition from 1.1.13, can be removed after some time
79 Obsoletes: abrt-plugin-runapp < 1.1.18
80 Obsoletes: abrt-plugin-filetransfer < 1.1.18
81 Obsoletes: abrt-plugin-sosreport < 1.1.18
82
83 %description
84 %{name} is a tool to help users to detect defects in applications and
85 to create a bug report with all informations needed by maintainer to fix it.
86 It uses plugin system to extend its functionality.
87
88 %pre
89 %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
90 %_pre_groupadd %{name} %{name}
91
92 %post
93 %_post_service %{name}d
94 %if %{?with_systemd}
95 # Enable (but don't start) the units by default
96 /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
97 %endif
98
99 %posttrans
100 service abrtd condrestart >/dev/null 2>&1 || :
101
102 %preun
103 %_preun_service %{name}d
104 %if %{?with_systemd}
105 if [ "$1" -eq "0" ] ; then
106 /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
107 /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
108 fi
109 %endif
110
111 %postun
112 %_postun_userdel %{name}
113 %_postun_groupdel %{name} %{name}
114 %if %{?with_systemd}
115 if [ $1 -ge 1 ] ; then
116 # On upgrade, reload init system configuration if we changed unit files
117 /bin/systemctl daemon-reload >/dev/null 2>&1 || :
118 fi
119 %endif
120
121 %files -f %{name}.lang
122 %defattr(-,root,root,-)
123 %doc README COPYING
124 #systemd
125 %if %{?with_systemd}
126 %endif
127 %{_sbindir}/%{name}d
128 %{_sbindir}/%{name}-server
129 %{_bindir}/%{name}-debuginfo-install
130 %{_bindir}/%{name}-handle-upload
131 %{_bindir}/%{name}-action-save-package-data
132 %{_bindir}/%{name}-retrace-client
133 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
134 %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
135 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
136 %ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
137 %ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}d.pid
138 %{_initrddir}/%{name}d
139 #%dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
140 %dir /var/run/%{name}
141 %dir %{_sysconfdir}/%{name}
142 %dir %{_sysconfdir}/%{name}/plugins
143 %{_mandir}/man8/%{name}d.8.*
144 %{_mandir}/man5/%{name}.conf.5.*
145 %{_datadir}/dbus-1/system-services/com.redhat.%{name}.service
146
147 #--------------------------------------------------------------------
148
149 %package -n %{lib_name}
150 Summary: Libraries for %{name}
151 Group: System/Libraries
152
153 %description -n %{lib_name}
154 Libraries for %{name}.
155
156 %files -n %{lib_name}
157 %defattr(-,root,root,-)
158 %{_libdir}/libabrt*.so.*
159
160 #--------------------------------------------------------------------
161
162 %package -n %{lib_name_devel}
163 Summary: Development libraries for %{name}
164 Group: Development/C
165 Requires: %{lib_name} = %{version}-%{release}
166 Requires: abrt = %{version}-%{release}
167 Obsoletes: %{_lib}abrt0-devel
168
169 %description -n %{lib_name_devel}
170 Development libraries and headers for %{name}.
171
172 %files -n %{lib_name_devel}
173 %defattr(-,root,root,-)
174 %{_includedir}/abrt/*
175 %{_includedir}/btparser/*
176 %{_libdir}/libabrt*.so
177 #FIXME: this should go to libreportgtk-devel package
178 %{_libdir}/libreportgtk.so
179 %{_libdir}/pkgconfig/%{name}.pc
180 %{_libdir}/pkgconfig/btparser.pc
181
182 #--------------------------------------------------------------------
183
184 %package gui
185 Summary: %{name}'s gui
186 Group: Graphical desktop/Other
187 Requires: %{name} = %{version}-%{release}
188 Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
189 Requires: python-gobject
190 Requires: gnome-python-desktop
191
192 %description gui
193 GTK+ wizard for convenient bug reporting.
194
195 %files gui
196 %defattr(-,root,root,-)
197 %{_bindir}/%{name}-gui
198 %{_datadir}/%{name}
199 %{_datadir}/applications/%{name}.desktop
200 %{_datadir}/icons/hicolor/*/*/*.png
201 %{_bindir}/%{name}-applet
202 %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
203
204 #--------------------------------------------------------------------
205
206 %package addon-ccpp
207 Summary: %{name}'s C/C++ addon
208 Group: System/Libraries
209 Requires: elfutils
210 Requires: %{name} = %{version}-%{release}
211
212 %description addon-ccpp
213 This package contains hook for C/C++ crashed programs and %{name}'s C/C++
214 analyzer plugin.
215
216 %post addon-ccpp
217 chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
218 #if [ $1 -eq 1 ]; then
219 /sbin/chkconfig --add abrt-ccpp
220 #fi
221
222 %if %{?with_systemd}
223 if [ "$1" -eq "0" ] ; then
224 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
225 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
226 fi
227 %endif
228
229 %posttrans addon-ccpp
230 service abrt-ccpp condrestart >/dev/null 2>&1 || :
231
232 %preun addon-ccpp
233 if [ "$1" -eq "0" ] ; then
234 service abrt-ccpp stop >/dev/null 2>&1
235 /sbin/chkconfig --del abrt-ccpp
236 fi
237
238 #systemd (not tested):
239 %if %{?with_systemd}
240 if [ "$1" -eq "0" ] ; then
241 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
242 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
243 fi
244 %endif
245
246 %files addon-ccpp
247 %defattr(-,root,root,-)
248 %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
249 %dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
250 %{_initrddir}/abrt-ccpp
251 %{_libdir}/abrt-hook-ccpp
252 %{_sysconfdir}/profile.d/00abrt.*
253 %{_bindir}/abrt-action-analyze-c
254 %{_bindir}/abrt-action-trim-files
255 %attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
256 %{_bindir}/abrt-action-install-debuginfo.py*
257 %{_bindir}/abrt-action-generate-backtrace
258 %{_bindir}/abrt-action-analyze-backtrace
259 %{_bindir}/abrt-action-list-dsos.py*
260 %{_sysconfdir}/%{name}/events.d/ccpp_events.conf
261 %{_sysconfdir}/%{name}/events/analyze_LocalGDB.xml
262 %{_sysconfdir}/%{name}/events/reanalyze_LocalGDB.xml
263 %{_sysconfdir}/%{name}/events/analyze_RetraceServer.xml
264 %{_sysconfdir}/%{name}/events/reanalyze_RetraceServer.xml
265 %{_mandir}/man*/abrt-action-trim-files.*
266 %{_mandir}/man*/abrt-action-generate-backtrace.*
267 %{_mandir}/man*/abrt-action-analyze-backtrace.*
268
269 #--------------------------------------------------------------------
270
271 %package addon-kerneloops
272 Summary: %{name}'s kerneloops addon
273 Group: System/Libraries
274 Requires: curl
275 Requires: %{name} = %{version}-%{release}
276 #Obsoletes: kerneloops
277
278 %description addon-kerneloops
279 This package contains plugin for collecting kernel crash information
280 and reporter plugin which sends this information to specified server,
281 usually to kerneloops.org.
282
283 %post addon-kerneloops
284 if [ $1 -eq 1 ]; then
285 /sbin/chkconfig --add abrt-oops
286 fi
287
288 %posttrans addon-kerneloops
289 service abrt-oops condrestart >/dev/null 2>&1 || :
290
291 %preun addon-kerneloops
292 if [ "$1" -eq "0" ] ; then
293 service abrt-oops stop >/dev/null 2>&1
294 /sbin/chkconfig --del abrt-oops
295 fi
296 #systemd (not tested):
297 %if %{?with_systemd}
298 if [ "$1" -eq "0" ] ; then
299 /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
300 /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
301 fi
302 %endif
303
304 %files addon-kerneloops
305 %defattr(-,root,root,-)
306 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
307 %config(noreplace) %{_sysconfdir}/%{name}/events.d/koops_events.conf
308 %{_sysconfdir}/%{name}/events/report_Kerneloops.xml
309 %{_initrddir}/abrt-oops
310 %{_mandir}/man7/abrt-KerneloopsReporter.7.*
311 %{_bindir}/abrt-dump-oops
312 %{_bindir}/abrt-action-analyze-oops
313 %{_bindir}/abrt-action-kerneloops
314
315 #--------------------------------------------------------------------
316
317 %package plugin-logger
318 Summary: %{name}'s logger reporter plugin
319 Group: System/Libraries
320 Requires: %{name} = %{version}-%{release}
321
322 %description plugin-logger
323 The simple reporter plugin which writes a report to a specified file.
324
325 %files plugin-logger
326 %defattr(-,root,root,-)
327 %{_sysconfdir}/%{name}/events/report_Logger.conf
328 %{_bindir}/abrt-action-print
329 %{_mandir}/man7/%{name}-Logger.7.*
330 %{_mandir}/man*/%{name}-action-print.*
331
332 #--------------------------------------------------------------------
333
334 %package plugin-mailx
335 Summary: %{name}'s mailx reporter plugin
336 Group: System/Libraries
337 Requires: %{name} = %{version}-%{release}
338 Requires: mailx
339
340 %description plugin-mailx
341 The simple reporter plugin which sends a report via mailx to a specified
342 email address.
343
344 %files plugin-mailx
345 %defattr(-,root,root,-)
346 %{_sysconfdir}/%{name}/events/report_Mailx.xml
347 %{_sysconfdir}/%{name}/events.d/mailx_events.conf
348 %{_bindir}/abrt-action-mailx
349 %{_mandir}/man7/%{name}-Mailx.7.*
350 %{_mandir}/man*/%{name}-action-mailx.*
351
352 #--------------------------------------------------------------------
353
354 %package plugin-bugzilla
355 Summary: %{name}'s bugzilla plugin
356 Group: System/Libraries
357 Requires: %{name} = %{version}-%{release}
358
359 %description plugin-bugzilla
360 Plugin to report bugs into the bugzilla.
361
362 %files plugin-bugzilla
363 %defattr(-,root,root,-)
364 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Bugzilla.conf
365 %{_sysconfdir}/%{name}/events/report_Bugzilla.xml
366 %config(noreplace) %{_sysconfdir}/%{name}/events/report_Bugzilla.conf
367 # FIXME: remove with the old gui
368 %{_mandir}/man7/abrt-Bugzilla.7.*
369 %{_bindir}/abrt-action-bugzilla
370
371 #--------------------------------------------------------------------
372
373 %package plugin-reportuploader
374 Summary: %{name}'s ticketuploader plugin
375 Group: System/Libraries
376 Requires: %{name} = %{version}-%{release}
377 Obsoletes: plugin-ticketuploader < 1.1.13
378 Provides: plugin-ticketuploader = %{version}-%{release}
379
380 %description plugin-reportuploader
381 Plugin to report bugs into anonymous FTP site associated with ticketing system.
382
383 %files plugin-reportuploader
384 %defattr(-,root,root,-)
385 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Upload.conf
386 %{_mandir}/man7/abrt-Upload.7.*
387 %{_bindir}/abrt-action-upload
388
389 #--------------------------------------------------------------------
390
391 %package addon-python
392 Summary: %{name}'s addon for catching and analyzing Python exceptions
393 Group: System/Libraries
394 Requires: %{name} = %{version}-%{release}
395
396 %description addon-python
397 This package contains python hook and python analyzer plugin for handling
398 uncaught exception in python programs.
399
400 %files addon-python
401 %defattr(-,root,root,-)
402 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
403 %{_bindir}/abrt-action-analyze-python
404 %{py_puresitedir}/abrt*.py*
405 %{py_puresitedir}/*.pth
406
407 #--------------------------------------------------------------------
408
409 %package cli
410 Summary: %{name}'s command line interface
411 Group: Graphical desktop/Other
412 Requires: %{name} = %{version}-%{release}
413 Requires: %{name}-addon-kerneloops
414 Requires: %{name}-addon-ccpp, %{name}-addon-python
415 Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger
416
417 %description cli
418 This package contains simple command line client for controlling abrt
419 daemon over the sockets.
420
421 %files cli
422 %defattr(-,root,root,-)
423 %{_bindir}/abrt-cli
424 %{_mandir}/man1/abrt-cli.1.*
425 %{_sysconfdir}/bash_completion.d/abrt-cli.bash
426
427 #--------------------------------------------------------------------
428
429 %package desktop
430 Summary: Virtual package to install all necessary packages for usage from desktop environment
431 Group: Graphical desktop/Other
432 # This package gets installed when anything requests bug-buddy -
433 # happens when users upgrade Fn to Fn+1;
434 # or if user just wants "typical desktop installation".
435 # Installing abrt-desktop should result in the abrt which works without
436 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
437 Requires: %{name} = %{version}-%{release}
438 Requires: %{name}-addon-kerneloops
439 Requires: %{name}-addon-ccpp, %{name}-addon-python
440 # Default config of addon-ccpp requires gdb
441 Requires: gdb >= 7.0-3
442 Requires: %{name}-gui
443 Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla
444 #Obsoletes: bug-buddy
445 #Provides: bug-buddy
446
447 %description desktop
448 Virtual package to make easy default installation on desktop environments.
449
450 %files desktop
451 %defattr(-,root,root,-)
452
453 #--------------------------------------------------------------------
454
455 %package -n %libreport
456 Summary: Libraries for reporting crashes to different targets
457 Group: System/Libraries
458
459 %description -n %libreport
460 Libraries providing API for reporting different problems in applications
461 to different bug targets like bugzilla, ftp, trac, etc...
462
463 %files -n %libreport
464 %defattr(-,root,root,-)
465 %{_libdir}/libreport.so.%{lib_major}*
466
467 #--------------------------------------------------------------------
468
469 %package -n %lib_report_devel
470 Summary: Development libraries and headers for libreport
471 Group: System/Libraries
472
473 %description -n %lib_report_devel
474 Development libraries and headers for libreport.
475
476 %files -n %lib_report_devel
477 %defattr(-,root,root,-)
478 %{_includedir}/report/*
479 %{_libdir}/libreport.so
480
481 #--------------------------------------------------------------------
482 #
483 #%package -n libreport-python
484 #%Summary: Python bindings for report-libs.
485 #%Group: System/Libraries
486 #
487 #%description -n libreport-python
488 #Python bindings for report-libs.
489 #
490 #%files -n libreport-python
491 #%defattr(-,root,root,-)
492 #%{python_sitearch}/report/*
493 #
494 #--------------------------------------------------------------------
495
496 %package -n %libreportgtk
497 Summary: GTK frontend for libreport
498 Group: System/Libraries
499
500 %description -n %libreportgtk
501 Applications for reporting bugs using libreport backend.
502
503 %files -n %libreportgtk
504 %defattr(-,root,root,-)
505 %{_libdir}/libreportgtk.so.%{lib_major}*
506
507 #--------------------------------------------------------------------
508
509 %package retrace-server
510 Summary: %{name}'s retrace server using HTTP protocol
511 Group: Graphical desktop/Other
512 Requires: abrt-addon-ccpp
513 Requires: gdb >= 7.0-3
514 Requires: apache-mod_wsgi, apache-mod_ssl, python-webob
515 Requires: mock, xz, elfutils, createrepo
516 Requires(preun): /sbin/install-info
517 Requires(post): /sbin/install-info
518
519 %post retrace-server
520 /sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
521 /usr/sbin/usermod -G mock apache 2> /dev/null || :
522
523 %preun retrace-server
524 if [ "$1" = 0 ]; then
525 /sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
526 fi
527
528 %description retrace-server
529 The retrace server provides a coredump analysis and backtrace
530 generation service over a network using HTTP protocol.
531
532 %files retrace-server
533 %defattr(-,root,root,-)
534 %config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
535 %config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
536 %config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
537 %dir %attr(0775, apache, abrt) %{_localstatedir}/spool/abrt-retrace
538 %dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/abrt-retrace
539 %dir %attr(0755, abrt, abrt) %{_localstatedir}/log/abrt-retrace
540 %caps(cap_setuid=ep) %{_bindir}/abrt-retrace-worker
541 %{_bindir}/abrt-retrace-cleanup
542 %{_bindir}/abrt-retrace-reposync
543 %{_bindir}/coredump2packages
544 %{py_puresitedir}/retrace.py*
545 %{_datadir}/abrt-retrace/*.py*
546 %{_datadir}/abrt-retrace/*.wsgi
547 %{_datadir}/abrt-retrace/plugins/*.py*
548 %{_infodir}/abrt-retrace-server*
549
550 #--------------------------------------------------------------------
551
552 %prep
553 %setup -q
554 %apply_patches
555 # (tv)) disable -Werror:
556 perl -pi -e 's!-Werror!-Wno-deprecated!' configure{.ac,} */*/Makefile*
557
558 %build
559 NOCONFIGURE=yes gnome-autogen.sh
560 %configure2_5x \
561 %if !%{with_systemd}
562 --without-systemdsystemunitdir \
563 %endif
564 --disable-rpath
565 %make
566
567 %install
568 rm -rf %{buildroot}
569 %makeinstall_std
570 %find_lang %{name}
571
572 # remove all .la and .a files
573 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
574 mkdir -p %{buildroot}/%{_initrddir}
575 install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/%{name}d
576 install -m 755 %SOURCE5 %{buildroot}/%{_initrddir}/%{name}-ccpp
577 install -m 755 %SOURCE6 %{buildroot}/%{_initrddir}/%{name}-oops
578 mkdir -p %{buildroot}/var/cache/%{name}-di
579 mkdir -p %{buildroot}/var/run/%{name}
580 mkdir -p %{buildroot}/var/spool/%{name}
581 mkdir -p %{buildroot}/var/spool/%{name}-retrace
582 mkdir -p %{buildroot}/var/cache/%{name}-retrace
583 mkdir -p %{buildroot}/var/log/%{name}-retrace
584 mkdir -p %{buildroot}/var/spool/%{name}-upload
585
586 sed -i 's!@libexec@!%_libdir!' %{buildroot}/%{_initrddir}/%{name}-ccpp
587
588 # remove fedora gpg key
589 rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
590 touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
591
592 # install ulimit disabler
593 mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
594 install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
595
596 desktop-file-install \
597 --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
598 src/applet/%{name}-applet.desktop
599
600 # replace with our own version
601 cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
602
603 #remove RH specific plugins
604 rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
605 rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
606 rm -f %{buildroot}%{_sysconfdir}/%{name}/events.d/rhtsupport_events.conf
607 rm -f %{buildroot}%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
608 rm -f %{buildroot}%{_bindir}/%{name}-action-rhtsupport
609
610 # After everything is installed, remove info dir
611 rm -f %{buildroot}%{_infodir}/dir

  ViewVC Help
Powered by ViewVC 1.1.30