/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Contents of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 203755 - (show annotations) (download)
Tue Jan 31 23:33:26 2012 UTC (12 years, 1 month ago) by tv
File size: 15858 byte(s)
further adjust file list (SILENT)
1 # (blino) FIXME: switch back to 1 when systemd is installable
2 %define with_systemd 1
3
4 %define lib_major 0
5 %define lib_name %mklibname %{name} %{lib_major}
6 %define libreport %mklibname report %{lib_major}
7 %define libreportgtk %mklibname report-gtk %{lib_major}
8
9 %define lib_name_devel %mklibname %{name} -d
10 %define lib_report_devel %mklibname report -d
11
12 %define _disable_ld_no_undefined 1
13
14 Summary: Automatic bug detection and reporting tool
15 Name: abrt
16 Version: 2.0.7
17 Release: %mkrel 1
18 License: GPLv2+
19 Group: System/Libraries
20 URL: https://fedorahosted.org/abrt/
21 Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
22 Source1: abrt.init
23 Source2: 00abrt.sh
24 Source3: 00abrt.csh
25 Source4: abrt-debuginfo-install
26 Source5: abrt-ccpp.init
27 Source6: abrt-oops.init
28 # (fc) disable package signature check
29 Patch2: abrt_disable_gpgcheck.diff
30 # (pt) generate stacktrace twice to get missing -debug packages
31 #Patch5: abrt-1.1.14-debug.patch
32 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
33 Patch7: abrt-2.0.2-nspluginwrapper.patch
34 # (fc) fix for non UTF-8 locale
35 Patch8: abrt-2.0.2-nonutf8-locale.patch
36 Patch9: abrt-2.0.2-glib-2.32.patch
37 Patch10: abrt-sec.diff
38 # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
39 #Patch12: abrt-1.1.14-disable_oops_scanner.patch
40
41 # Fedora patches
42 BuildRequires: dbus-devel libdbus-glib-devel
43 BuildRequires: gtk2-devel
44 BuildRequires: curl-devel
45 BuildRequires: rpm-devel
46 BuildRequires: sqlite-devel > 3.0
47 BuildRequires: desktop-file-utils
48 #BuildRequires: nss-devel
49 BuildRequires: libnotify-devel
50 BuildRequires: xmlrpc-c-devel
51 BuildRequires: xmlrpc-c
52 BuildRequires: file-devel
53 BuildRequires: python-devel
54 BuildRequires: gettext
55 BuildRequires: polkit-1-devel
56 BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
57 BuildRequires: intltool
58 BuildRequires: gnome-common
59 BuildRequires: bison
60 BuildRequires: asciidoc
61 BuildRequires: docbook-style-xsl docbook5-style-xsl
62 BuildRequires: xmlto
63 BuildRequires: libgnome-keyring-devel
64 BuildRequires: gettext-devel
65 %if %{?with_systemd}
66 BuildRequires: systemd-units
67 %endif
68 BuildRequires: btparser-devel
69 BuildRequires: libreport-devel
70 BuildRequires: pkgconfig(libreport-gtk)
71 Requires: %{lib_name} >= %{version}-%{release}
72 Requires(pre): rpm-helper
73 Requires(post): rpm-helper
74 Requires(preun): rpm-helper
75 Requires(postun): rpm-helper
76 Obsoletes: abrt-plugin-catcut < 1.1.13
77 Obsoletes: abrt-plugin-sqlite3 < 1.1.18
78 # required for transition from 1.1.13, can be removed after some time
79 Obsoletes: abrt-plugin-runapp < 1.1.18
80 Obsoletes: abrt-plugin-filetransfer < 1.1.18
81 Obsoletes: abrt-plugin-sosreport < 1.1.18
82
83 %description
84 %{name} is a tool to help users to detect defects in applications and
85 to create a bug report with all informations needed by maintainer to fix it.
86 It uses plugin system to extend its functionality.
87
88 %pre
89 %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
90 %_pre_groupadd %{name} %{name}
91
92 %post
93 %_post_service %{name}d
94 %if %{?with_systemd}
95 # Enable (but don't start) the units by default
96 /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
97 %endif
98
99 %posttrans
100 service abrtd condrestart >/dev/null 2>&1 || :
101
102 %preun
103 %_preun_service %{name}d
104 %if %{?with_systemd}
105 if [ "$1" -eq "0" ] ; then
106 /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
107 /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
108 fi
109 %endif
110
111 %postun
112 %_postun_userdel %{name}
113 %_postun_groupdel %{name} %{name}
114 %if %{?with_systemd}
115 if [ $1 -ge 1 ] ; then
116 # On upgrade, reload init system configuration if we changed unit files
117 /bin/systemctl daemon-reload >/dev/null 2>&1 || :
118 fi
119 %endif
120
121 %files -f %{name}.lang
122 %defattr(-,root,root,-)
123 %doc README COPYING
124 #systemd
125 %if %{?with_systemd}
126 %endif
127 %{_sbindir}/%{name}d
128 %{_sbindir}/%{name}-server
129 %{_bindir}/%{name}-debuginfo-install
130 %{_bindir}/%{name}-handle-upload
131 %{_bindir}/%{name}-action-save-package-data
132 %{_bindir}/%{name}-retrace-client
133 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
134 %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
135 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-%{name}.conf
136 %ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
137 %ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}d.pid
138 %{_initrddir}/%{name}d
139 #%dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
140 %dir /var/run/%{name}
141 %dir %{_sysconfdir}/%{name}
142 %dir %{_sysconfdir}/%{name}/plugins
143 %{_mandir}/man8/%{name}d.8.*
144 %{_mandir}/man5/%{name}.conf.5.*
145 %{_datadir}/dbus-1/system-services/com.redhat.%{name}.service
146
147 #--------------------------------------------------------------------
148
149 %package -n %{lib_name}
150 Summary: Libraries for %{name}
151 Group: System/Libraries
152
153 %description -n %{lib_name}
154 Libraries for %{name}.
155
156 %files -n %{lib_name}
157 %defattr(-,root,root,-)
158 %{_libdir}/libabrt*.so.*
159
160 #--------------------------------------------------------------------
161
162 %package -n %{lib_name_devel}
163 Summary: Development libraries for %{name}
164 Group: Development/C
165 Requires: %{lib_name} = %{version}-%{release}
166 Requires: abrt = %{version}-%{release}
167 Obsoletes: %{_lib}abrt0-devel
168
169 %description -n %{lib_name_devel}
170 Development libraries and headers for %{name}.
171
172 %files -n %{lib_name_devel}
173 %defattr(-,root,root,-)
174 %{_includedir}/abrt/*
175 %{_libdir}/libabrt*.so
176 #FIXME: this should go to libreportgtk-devel package
177 %{_libdir}/pkgconfig/%{name}.pc
178
179 #--------------------------------------------------------------------
180
181 %package gui
182 Summary: %{name}'s gui
183 Group: Graphical desktop/Other
184 Requires: %{name} = %{version}-%{release}
185 Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
186 Requires: python-gobject
187 Requires: gnome-python-desktop
188
189 %description gui
190 GTK+ wizard for convenient bug reporting.
191
192 %files gui
193 %defattr(-,root,root,-)
194 %{_bindir}/%{name}-gui
195 %{_datadir}/%{name}
196 %{_datadir}/applications/%{name}.desktop
197 %{_datadir}/icons/hicolor/*/*/*.png
198 %{_bindir}/%{name}-applet
199 %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
200
201 #--------------------------------------------------------------------
202
203 %package addon-ccpp
204 Summary: %{name}'s C/C++ addon
205 Group: System/Libraries
206 Requires: elfutils
207 Requires: %{name} = %{version}-%{release}
208
209 %description addon-ccpp
210 This package contains hook for C/C++ crashed programs and %{name}'s C/C++
211 analyzer plugin.
212
213 %post addon-ccpp
214 chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
215 #if [ $1 -eq 1 ]; then
216 /sbin/chkconfig --add abrt-ccpp
217 #fi
218
219 %if %{?with_systemd}
220 if [ "$1" -eq "0" ] ; then
221 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
222 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
223 fi
224 %endif
225
226 %posttrans addon-ccpp
227 service abrt-ccpp condrestart >/dev/null 2>&1 || :
228
229 %preun addon-ccpp
230 if [ "$1" -eq "0" ] ; then
231 service abrt-ccpp stop >/dev/null 2>&1
232 /sbin/chkconfig --del abrt-ccpp
233 fi
234
235 #systemd (not tested):
236 %if %{?with_systemd}
237 if [ "$1" -eq "0" ] ; then
238 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
239 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
240 fi
241 %endif
242
243 %files addon-ccpp
244 %defattr(-,root,root,-)
245 %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
246 %dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
247 %{_initrddir}/abrt-ccpp
248 %{_libdir}/abrt-hook-ccpp
249 %{_sysconfdir}/profile.d/00abrt.*
250 %{_bindir}/abrt-action-analyze-c
251 %{_bindir}/abrt-action-trim-files
252 %attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
253 %{_bindir}/abrt-action-generate-backtrace
254 %{_bindir}/abrt-action-analyze-backtrace
255 %{_mandir}/man*/abrt-action-trim-files.*
256 %{_mandir}/man*/abrt-action-generate-backtrace.*
257 %{_mandir}/man*/abrt-action-analyze-backtrace.*
258
259 #--------------------------------------------------------------------
260
261 %package addon-kerneloops
262 Summary: %{name}'s kerneloops addon
263 Group: System/Libraries
264 Requires: curl
265 Requires: %{name} = %{version}-%{release}
266 #Obsoletes: kerneloops
267
268 %description addon-kerneloops
269 This package contains plugin for collecting kernel crash information
270 and reporter plugin which sends this information to specified server,
271 usually to kerneloops.org.
272
273 %post addon-kerneloops
274 if [ $1 -eq 1 ]; then
275 /sbin/chkconfig --add abrt-oops
276 fi
277
278 %posttrans addon-kerneloops
279 service abrt-oops condrestart >/dev/null 2>&1 || :
280
281 %preun addon-kerneloops
282 if [ "$1" -eq "0" ] ; then
283 service abrt-oops stop >/dev/null 2>&1
284 /sbin/chkconfig --del abrt-oops
285 fi
286 #systemd (not tested):
287 %if %{?with_systemd}
288 if [ "$1" -eq "0" ] ; then
289 /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
290 /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
291 fi
292 %endif
293
294 %files addon-kerneloops
295 %defattr(-,root,root,-)
296 %{_initrddir}/abrt-oops
297 %{_bindir}/abrt-dump-oops
298 %{_bindir}/abrt-action-analyze-oops
299
300 #--------------------------------------------------------------------
301
302 %package addon-python
303 Summary: %{name}'s addon for catching and analyzing Python exceptions
304 Group: System/Libraries
305 Requires: %{name} = %{version}-%{release}
306
307 %description addon-python
308 This package contains python hook and python analyzer plugin for handling
309 uncaught exception in python programs.
310
311 %files addon-python
312 %defattr(-,root,root,-)
313 %config(noreplace) %{_sysconfdir}/%{name}/plugins/Python.conf
314 %{_bindir}/abrt-action-analyze-python
315 %{py_puresitedir}/abrt*.py*
316 %{py_puresitedir}/*.pth
317
318 #--------------------------------------------------------------------
319
320 %package cli
321 Summary: %{name}'s command line interface
322 Group: Graphical desktop/Other
323 Requires: %{name} = %{version}-%{release}
324 Requires: %{name}-addon-kerneloops
325 Requires: %{name}-addon-ccpp, %{name}-addon-python
326 Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger
327
328 %description cli
329 This package contains simple command line client for controlling abrt
330 daemon over the sockets.
331
332 %files cli
333 %defattr(-,root,root,-)
334 %{_bindir}/abrt-cli
335 %{_mandir}/man1/abrt-cli.1.*
336 %{_sysconfdir}/bash_completion.d/abrt-cli.bash
337
338 #--------------------------------------------------------------------
339
340 %package desktop
341 Summary: Virtual package to install all necessary packages for usage from desktop environment
342 Group: Graphical desktop/Other
343 # This package gets installed when anything requests bug-buddy -
344 # happens when users upgrade Fn to Fn+1;
345 # or if user just wants "typical desktop installation".
346 # Installing abrt-desktop should result in the abrt which works without
347 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
348 Requires: %{name} = %{version}-%{release}
349 Requires: %{name}-addon-kerneloops
350 Requires: %{name}-addon-ccpp, %{name}-addon-python
351 # Default config of addon-ccpp requires gdb
352 Requires: gdb >= 7.0-3
353 Requires: %{name}-gui
354 Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla
355 #Obsoletes: bug-buddy
356 #Provides: bug-buddy
357
358 %description desktop
359 Virtual package to make easy default installation on desktop environments.
360
361 %files desktop
362 %defattr(-,root,root,-)
363
364 #--------------------------------------------------------------------
365
366 %package -n %libreport
367 Summary: Libraries for reporting crashes to different targets
368 Group: System/Libraries
369
370 %description -n %libreport
371 Libraries providing API for reporting different problems in applications
372 to different bug targets like bugzilla, ftp, trac, etc...
373
374 %files -n %libreport
375 %defattr(-,root,root,-)
376 %{_libdir}/libreport.so.%{lib_major}*
377
378 #--------------------------------------------------------------------
379
380 %package -n %lib_report_devel
381 Summary: Development libraries and headers for libreport
382 Group: System/Libraries
383
384 %description -n %lib_report_devel
385 Development libraries and headers for libreport.
386
387 %files -n %lib_report_devel
388 %defattr(-,root,root,-)
389 %{_includedir}/report/*
390 %{_libdir}/libreport.so
391
392 #--------------------------------------------------------------------
393 #
394 #%package -n libreport-python
395 #%Summary: Python bindings for report-libs.
396 #%Group: System/Libraries
397 #
398 #%description -n libreport-python
399 #Python bindings for report-libs.
400 #
401 #%files -n libreport-python
402 #%defattr(-,root,root,-)
403 #%{python_sitearch}/report/*
404 #
405 #--------------------------------------------------------------------
406
407 %package -n %libreportgtk
408 Summary: GTK frontend for libreport
409 Group: System/Libraries
410
411 %description -n %libreportgtk
412 Applications for reporting bugs using libreport backend.
413
414 %files -n %libreportgtk
415 %defattr(-,root,root,-)
416 %{_libdir}/libreportgtk.so.%{lib_major}*
417
418 #--------------------------------------------------------------------
419
420 %package retrace-server
421 Summary: %{name}'s retrace server using HTTP protocol
422 Group: Graphical desktop/Other
423 Requires: abrt-addon-ccpp
424 Requires: gdb >= 7.0-3
425 Requires: apache-mod_wsgi, apache-mod_ssl, python-webob
426 Requires: mock, xz, elfutils, createrepo
427 Requires(preun): /sbin/install-info
428 Requires(post): /sbin/install-info
429
430 %post retrace-server
431 /sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
432 /usr/sbin/usermod -G mock apache 2> /dev/null || :
433
434 %preun retrace-server
435 if [ "$1" = 0 ]; then
436 /sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
437 fi
438
439 %description retrace-server
440 The retrace server provides a coredump analysis and backtrace
441 generation service over a network using HTTP protocol.
442
443 %files retrace-server
444 %defattr(-,root,root,-)
445 %config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
446 %config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
447 %config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
448 %dir %attr(0775, apache, abrt) %{_localstatedir}/spool/abrt-retrace
449 %dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/abrt-retrace
450 %dir %attr(0755, abrt, abrt) %{_localstatedir}/log/abrt-retrace
451 %caps(cap_setuid=ep) %{_bindir}/abrt-retrace-worker
452 %{_bindir}/abrt-retrace-cleanup
453 %{_bindir}/abrt-retrace-reposync
454 %{_bindir}/coredump2packages
455 %{py_puresitedir}/retrace.py*
456 %{_datadir}/abrt-retrace/*.py*
457 %{_datadir}/abrt-retrace/*.wsgi
458 %{_datadir}/abrt-retrace/plugins/*.py*
459 %{_infodir}/abrt-retrace-server*
460
461 #--------------------------------------------------------------------
462
463 %prep
464 %setup -q
465 %apply_patches
466 # (tv)) disable -Werror:
467 perl -pi -e 's!-Werror!-Wno-deprecated!' configure{.ac,} */*/Makefile*
468
469 %build
470 NOCONFIGURE=yes gnome-autogen.sh
471 %configure2_5x \
472 %if !%{with_systemd}
473 --without-systemdsystemunitdir \
474 %endif
475 --disable-rpath
476 %make
477
478 %install
479 rm -rf %{buildroot}
480 %makeinstall_std
481 %find_lang %{name}
482
483 # remove all .la and .a files
484 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
485 mkdir -p %{buildroot}/%{_initrddir}
486 install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/%{name}d
487 install -m 755 %SOURCE5 %{buildroot}/%{_initrddir}/%{name}-ccpp
488 install -m 755 %SOURCE6 %{buildroot}/%{_initrddir}/%{name}-oops
489 mkdir -p %{buildroot}/var/cache/%{name}-di
490 mkdir -p %{buildroot}/var/run/%{name}
491 mkdir -p %{buildroot}/var/spool/%{name}
492 mkdir -p %{buildroot}/var/spool/%{name}-retrace
493 mkdir -p %{buildroot}/var/cache/%{name}-retrace
494 mkdir -p %{buildroot}/var/log/%{name}-retrace
495 mkdir -p %{buildroot}/var/spool/%{name}-upload
496
497 sed -i 's!@libexec@!%_libdir!' %{buildroot}/%{_initrddir}/%{name}-ccpp
498
499 # remove fedora gpg key
500 rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
501 touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
502
503 # install ulimit disabler
504 mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
505 install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
506
507 desktop-file-install \
508 --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
509 src/applet/%{name}-applet.desktop
510
511 # replace with our own version
512 cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
513
514 #remove RH specific plugins
515 rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
516 rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
517 rm -f %{buildroot}%{_sysconfdir}/%{name}/events.d/rhtsupport_events.conf
518 rm -f %{buildroot}%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
519 rm -f %{buildroot}%{_bindir}/%{name}-action-rhtsupport
520
521 # After everything is installed, remove info dir
522 rm -f %{buildroot}%{_infodir}/dir

  ViewVC Help
Powered by ViewVC 1.1.30