/[packages]/cauldron/abrt/current/SPECS/abrt.spec
ViewVC logotype

Contents of /cauldron/abrt/current/SPECS/abrt.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 203819 - (show annotations) (download)
Wed Feb 1 03:38:15 2012 UTC (12 years, 2 months ago) by fwang
File size: 17067 byte(s)
update file list
1 # (blino) FIXME: switch back to 1 when systemd is installable
2 %define with_systemd 1
3
4 %define lib_major 0
5 %define lib_name %mklibname %{name} %{lib_major}
6
7 %define lib_name_devel %mklibname %{name} -d
8 %define lib_report_devel %mklibname report -d
9
10 Summary: Automatic bug detection and reporting tool
11 Name: abrt
12 Version: 2.0.7
13 Release: %mkrel 1
14 License: GPLv2+
15 Group: System/Libraries
16 URL: https://fedorahosted.org/abrt/
17 Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
18 Source1: abrt.init
19 Source2: 00abrt.sh
20 Source3: 00abrt.csh
21 Source4: abrt-debuginfo-install
22 Source5: abrt-ccpp.init
23 Source6: abrt-oops.init
24 Patch0: abrt-2.0.7-link.patch
25 # (fc) disable package signature check
26 Patch2: abrt_disable_gpgcheck.diff
27 # (pt) generate stacktrace twice to get missing -debug packages
28 #Patch5: abrt-1.1.14-debug.patch
29 # (fc) disable nspluginwrapper-i386 (Mdv bug #59237)
30 Patch7: abrt-2.0.2-nspluginwrapper.patch
31 # (fc) fix for non UTF-8 locale
32 Patch8: abrt-2.0.2-nonutf8-locale.patch
33 Patch9: abrt-2.0.2-glib-2.32.patch
34 Patch10: abrt-sec.diff
35 # (eugeni): disable kernel oops cron plugin by default (mdv #61986)
36 #Patch12: abrt-1.1.14-disable_oops_scanner.patch
37
38 # Fedora patches
39 BuildRequires: dbus-devel libdbus-glib-devel
40 BuildRequires: gtk2-devel
41 BuildRequires: curl-devel
42 BuildRequires: rpm-devel
43 BuildRequires: sqlite-devel > 3.0
44 BuildRequires: desktop-file-utils
45 #BuildRequires: nss-devel
46 BuildRequires: libnotify-devel
47 BuildRequires: xmlrpc-c-devel
48 BuildRequires: xmlrpc-c
49 BuildRequires: file-devel
50 BuildRequires: python-devel
51 BuildRequires: gettext
52 BuildRequires: polkit-1-devel
53 BuildRequires: libzip-devel, libtar-devel, bzip2-devel, zlib-devel
54 BuildRequires: intltool
55 BuildRequires: gnome-common
56 BuildRequires: bison
57 BuildRequires: asciidoc
58 BuildRequires: docbook-style-xsl docbook5-style-xsl
59 BuildRequires: xmlto
60 BuildRequires: libgnome-keyring-devel
61 BuildRequires: gettext-devel
62 %if %{?with_systemd}
63 BuildRequires: systemd-units
64 %endif
65 BuildRequires: btparser-devel
66 BuildRequires: libreport-devel
67 BuildRequires: pkgconfig(libreport-gtk)
68 Requires: %{lib_name} >= %{version}-%{release}
69 Requires(pre): rpm-helper
70 Requires(post): rpm-helper
71 Requires(preun): rpm-helper
72 Requires(postun): rpm-helper
73 Obsoletes: abrt-plugin-catcut < 1.1.13
74 Obsoletes: abrt-plugin-sqlite3 < 1.1.18
75 # required for transition from 1.1.13, can be removed after some time
76 Obsoletes: abrt-plugin-runapp < 1.1.18
77 Obsoletes: abrt-plugin-filetransfer < 1.1.18
78 Obsoletes: abrt-plugin-sosreport < 1.1.18
79
80 %description
81 %{name} is a tool to help users to detect defects in applications and
82 to create a bug report with all informations needed by maintainer to fix it.
83 It uses plugin system to extend its functionality.
84
85 %pre
86 %_pre_useradd %{name} %{_sysconfdir}/%{name} /bin/nologin
87 %_pre_groupadd %{name} %{name}
88
89 %post
90 %_post_service %{name}d
91 %if %{?with_systemd}
92 # Enable (but don't start) the units by default
93 /bin/systemctl enable %{name}d.service >/dev/null 2>&1 || :
94 %endif
95
96 %posttrans
97 service abrtd condrestart >/dev/null 2>&1 || :
98
99 %preun
100 %_preun_service %{name}d
101 %if %{?with_systemd}
102 if [ "$1" -eq "0" ] ; then
103 /bin/systemctl stop %{name}d.service >/dev/null 2>&1 || :
104 /bin/systemctl disable %{name}d.service >/dev/null 2>&1 || :
105 fi
106 %endif
107
108 %postun
109 %_postun_userdel %{name}
110 %_postun_groupdel %{name} %{name}
111 %if %{?with_systemd}
112 if [ $1 -ge 1 ] ; then
113 # On upgrade, reload init system configuration if we changed unit files
114 /bin/systemctl daemon-reload >/dev/null 2>&1 || :
115 fi
116 %endif
117
118 %files -f %{name}.lang
119 %defattr(-,root,root,-)
120 %doc README COPYING
121 #systemd
122 %if %{?with_systemd}
123 %endif
124 %{_sbindir}/%{name}d
125 %{_sbindir}/%{name}-server
126 %{_sbindir}/abrt-dbus
127 %{_bindir}/%{name}-debuginfo-install
128 %{_bindir}/%{name}-handle-upload
129 %{_bindir}/%{name}-action-save-package-data
130 %{_bindir}/%{name}-retrace-client
131 %{_libexecdir}/abrt-handle-event
132 %config(noreplace) %{_sysconfdir}/%{name}/abrt.conf
133 %config(noreplace) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
134 %config(noreplace) %{_sysconfdir}/%{name}/gpg_keys
135 %config(noreplace) %{_sysconfdir}/libreport/events.d/abrt_event.conf
136 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/dbus-abrt.conf
137 %config(noreplace) %{_sysconfdir}/libreport/events.d/smart_event.conf
138 %config(noreplace) %{_sysconfdir}/libreport/events.d/smolt_event.conf
139 %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
140 %{_sysconfdir}/libreport/events/analyze_RetraceServer.xml
141 %ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
142 %ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}d.pid
143 %{_initrddir}/%{name}d
144 #%dir %attr(0755, %{name}, %{name}) %{_localstatedir}/cache/%{name}
145 %dir /var/run/%{name}
146 %dir %{_sysconfdir}/%{name}
147 %dir %{_sysconfdir}/%{name}/plugins
148 %{_mandir}/man1/abrt-handle-upload.1.*
149 %{_mandir}/man1/abrt-server.1.*
150 %{_mandir}/man1/abrt-action-save-package-data.1.*
151 %{_mandir}/man1/abrt-retrace-client.1.*
152 %{_mandir}/man8/abrtd.8.*
153 %{_mandir}/man8/abrt-dbus.8.*
154 %{_mandir}/man5/abrt.conf.5.*
155 %{_mandir}/man5/abrt-action-save-package-data.conf.5.*
156 %{_datadir}/dbus-1/system-services/com.redhat.%{name}.service
157
158 #--------------------------------------------------------------------
159
160 %package -n %{lib_name}
161 Summary: Libraries for %{name}
162 Group: System/Libraries
163
164 %description -n %{lib_name}
165 Libraries for %{name}.
166
167 %files -n %{lib_name}
168 %defattr(-,root,root,-)
169 %{_libdir}/libabrt*.so.*
170
171 #--------------------------------------------------------------------
172
173 %package -n %{lib_name_devel}
174 Summary: Development libraries for %{name}
175 Group: Development/C
176 Requires: %{lib_name} = %{version}-%{release}
177 Requires: abrt = %{version}-%{release}
178 Obsoletes: %{_lib}abrt0-devel
179
180 %description -n %{lib_name_devel}
181 Development libraries and headers for %{name}.
182
183 %files -n %{lib_name_devel}
184 %defattr(-,root,root,-)
185 %{_includedir}/abrt/*
186 %{_libdir}/libabrt*.so
187 #FIXME: this should go to libreportgtk-devel package
188 %{_libdir}/pkgconfig/%{name}.pc
189
190 #--------------------------------------------------------------------
191
192 %package gui
193 Summary: %{name}'s gui
194 Group: Graphical desktop/Other
195 Requires: %{name} = %{version}-%{release}
196 Requires: dbus-python, pygtk2.0, pygtk2.0-libglade
197 Requires: python-gobject
198 Requires: gnome-python-desktop
199
200 %description gui
201 GTK+ wizard for convenient bug reporting.
202
203 %files gui
204 %defattr(-,root,root,-)
205 %{_bindir}/%{name}-gui
206 %{_datadir}/%{name}
207 %{_datadir}/applications/%{name}.desktop
208 %{_datadir}/icons/hicolor/*/*/*.png
209 %{_bindir}/%{name}-applet
210 %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
211
212 #--------------------------------------------------------------------
213
214 %package addon-ccpp
215 Summary: %{name}'s C/C++ addon
216 Group: System/Libraries
217 Requires: elfutils
218 Requires: %{name} = %{version}-%{release}
219
220 %description addon-ccpp
221 This package contains hook for C/C++ crashed programs and %{name}'s C/C++
222 analyzer plugin.
223
224 %post addon-ccpp
225 chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
226 #if [ $1 -eq 1 ]; then
227 /sbin/chkconfig --add abrt-ccpp
228 #fi
229
230 %if %{?with_systemd}
231 if [ "$1" -eq "0" ] ; then
232 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
233 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
234 fi
235 %endif
236
237 %posttrans addon-ccpp
238 service abrt-ccpp condrestart >/dev/null 2>&1 || :
239
240 %preun addon-ccpp
241 if [ "$1" -eq "0" ] ; then
242 service abrt-ccpp stop >/dev/null 2>&1
243 /sbin/chkconfig --del abrt-ccpp
244 fi
245
246 #systemd (not tested):
247 %if %{?with_systemd}
248 if [ "$1" -eq "0" ] ; then
249 /bin/systemctl stop abrt-ccpp.service >/dev/null 2>&1 || :
250 /bin/systemctl disable abrt-ccpp.service >/dev/null 2>&1 || :
251 fi
252 %endif
253
254 %files addon-ccpp
255 %defattr(-,root,root,-)
256 %config(noreplace) %{_sysconfdir}/%{name}/plugins/CCpp.conf
257 %{_sysconfdir}/libreport/events.d/ccpp_event.conf
258 %{_sysconfdir}/libreport/events.d/gconf_event.conf
259 %{_sysconfdir}/libreport/events.d/vimrc_event.conf
260 %{_sysconfdir}/libreport/events/analyze_LocalGDB.xml
261 %{_sysconfdir}/libreport/events/collect_xsession_errors.xml
262 %{_sysconfdir}/libreport/events/collect_Smolt.xml
263 %{_sysconfdir}/libreport/events/collect_GConf.xml
264 %{_sysconfdir}/libreport/events/collect_vimrc_user.xml
265 %{_sysconfdir}/libreport/events/collect_vimrc_system.xml
266 %dir %attr(0775, abrt, abrt) %{_localstatedir}/cache/abrt-di
267 %{_initrddir}/abrt-ccpp
268 %{_libdir}/abrt-hook-ccpp
269 %{_sysconfdir}/profile.d/00abrt.*
270 %{_bindir}/abrt-action-analyze-c
271 %{_bindir}/abrt-action-trim-files
272 %{_bindir}/abrt-action-analyze-core
273 %{_bindir}/abrt-action-list-dsos
274 %attr(2755, abrt, abrt) %{_bindir}/abrt-action-install-debuginfo
275 %attr(4755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
276 %{_bindir}/abrt-action-generate-backtrace
277 %{_bindir}/abrt-action-analyze-backtrace
278 %{_sbindir}/abrt-install-ccpp-hook
279 %{_mandir}/man*/abrt-action-analyze-c.*
280 %{_mandir}/man*/abrt-action-trim-files.*
281 %{_mandir}/man*/abrt-action-generate-backtrace.*
282 %{_mandir}/man*/abrt-action-analyze-backtrace.*
283 %{_mandir}/man*/abrt-action-list-dsos.*
284 %{_mandir}/man1/abrt-install-ccpp-hook.*
285
286 #--------------------------------------------------------------------
287
288 %package addon-kerneloops
289 Summary: %{name}'s kerneloops addon
290 Group: System/Libraries
291 Requires: curl
292 Requires: %{name} = %{version}-%{release}
293 #Obsoletes: kerneloops
294
295 %description addon-kerneloops
296 This package contains plugin for collecting kernel crash information
297 and reporter plugin which sends this information to specified server,
298 usually to kerneloops.org.
299
300 %post addon-kerneloops
301 if [ $1 -eq 1 ]; then
302 /sbin/chkconfig --add abrt-oops
303 fi
304
305 %posttrans addon-kerneloops
306 service abrt-oops condrestart >/dev/null 2>&1 || :
307
308 %preun addon-kerneloops
309 if [ "$1" -eq "0" ] ; then
310 service abrt-oops stop >/dev/null 2>&1
311 /sbin/chkconfig --del abrt-oops
312 fi
313 #systemd (not tested):
314 %if %{?with_systemd}
315 if [ "$1" -eq "0" ] ; then
316 /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
317 /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
318 fi
319 %endif
320
321 %files addon-kerneloops
322 %defattr(-,root,root,-)
323 %config(noreplace) %{_sysconfdir}/libreport/events.d/koops_event.conf
324 %{_initrddir}/abrt-oops
325 %{_bindir}/abrt-dump-oops
326 %{_bindir}/abrt-action-analyze-oops
327 %{_mandir}/man1/abrt-action-analyze-oops.1*
328
329 #--------------------------------------------------------------------
330
331 %package addon-vmcore
332 Summary: %{name}'s vmcore addon
333 Group: System/Libraries
334 Requires: %{name} = %{version}-%{release}
335 Requires: abrt-addon-kerneloops
336
337 %description addon-vmcore
338 This package contains plugin for collecting kernel crash information from vmcore files.
339
340 %post addon-vmcore
341 if [ $1 -eq 1 ]; then
342 /sbin/chkconfig --add abrt-oops
343 fi
344
345 %posttrans addon-vmcore
346 service abrt-oops condrestart >/dev/null 2>&1 || :
347
348 %preun addon-vmcore
349 if [ "$1" -eq "0" ] ; then
350 service abrt-oops stop >/dev/null 2>&1
351 /sbin/chkconfig --del abrt-oops
352 fi
353 #systemd (not tested):
354 %if %{?with_systemd}
355 if [ "$1" -eq "0" ] ; then
356 /bin/systemctl stop abrt-oops.service >/dev/null 2>&1 || :
357 /bin/systemctl disable abrt-oops.service >/dev/null 2>&1 || :
358 fi
359 %endif
360
361 %files addon-vmcore
362 %config(noreplace) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
363 %{_sysconfdir}/libreport/events/analyze_VMcore.xml
364 %if %{with systemd}
365 /lib/systemd/system/abrt-vmcore.service
366 %else
367 %{_initrddir}/abrt-vmcore
368 %endif
369 %{_sbindir}/abrt-harvest-vmcore
370 %{_bindir}/abrt-action-analyze-vmcore
371
372 #--------------------------------------------------------------------
373
374 %package addon-python
375 Summary: %{name}'s addon for catching and analyzing Python exceptions
376 Group: System/Libraries
377 Requires: %{name} = %{version}-%{release}
378
379 %description addon-python
380 This package contains python hook and python analyzer plugin for handling
381 uncaught exception in python programs.
382
383 %files addon-python
384 %defattr(-,root,root,-)
385 %config(noreplace) %{_sysconfdir}/%{name}/plugins/python.conf
386 %{_sysconfdir}/libreport/events.d/python_event.conf
387 %{_bindir}/abrt-action-analyze-python
388 %{_mandir}/man1/abrt-action-analyze-python.1*
389 %{py_puresitedir}/abrt*.py*
390 %{py_puresitedir}/*.pth
391
392 #--------------------------------------------------------------------
393
394 %package cli
395 Summary: %{name}'s command line interface
396 Group: Graphical desktop/Other
397 Requires: %{name} = %{version}-%{release}
398 Requires: %{name}-addon-kerneloops
399 Requires: %{name}-addon-ccpp, %{name}-addon-python
400 Requires: %{name}-plugin-bugzilla, %{name}-plugin-logger
401
402 %description cli
403 This package contains simple command line client for controlling abrt
404 daemon over the sockets.
405
406 %files cli
407 %defattr(-,root,root,-)
408 %{_bindir}/abrt-cli
409
410 #--------------------------------------------------------------------
411
412 %package desktop
413 Summary: Virtual package to install all necessary packages for usage from desktop environment
414 Group: Graphical desktop/Other
415 # This package gets installed when anything requests bug-buddy -
416 # happens when users upgrade Fn to Fn+1;
417 # or if user just wants "typical desktop installation".
418 # Installing abrt-desktop should result in the abrt which works without
419 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
420 Requires: %{name} = %{version}-%{release}
421 Requires: %{name}-addon-kerneloops
422 Requires: %{name}-addon-vmcore
423 Requires: %{name}-addon-ccpp, %{name}-addon-python
424 # Default config of addon-ccpp requires gdb
425 Requires: gdb >= 7.0-3
426 Requires: %{name}-gui
427 Requires: %{name}-plugin-logger, %{name}-plugin-bugzilla
428 #Obsoletes: bug-buddy
429 #Provides: bug-buddy
430
431 %description desktop
432 Virtual package to make easy default installation on desktop environments.
433
434 %files desktop
435 %defattr(-,root,root,-)
436
437 #--------------------------------------------------------------------
438 %if 0
439 %package retrace-server
440 Summary: %{name}'s retrace server using HTTP protocol
441 Group: Graphical desktop/Other
442 Requires: abrt-addon-ccpp
443 Requires: gdb >= 7.0-3
444 Requires: apache-mod_wsgi, apache-mod_ssl, python-webob
445 Requires: mock, xz, elfutils, createrepo
446 Requires(preun): /sbin/install-info
447 Requires(post): /sbin/install-info
448
449 %post retrace-server
450 /sbin/install-info %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
451 /usr/sbin/usermod -G mock apache 2> /dev/null || :
452
453 %preun retrace-server
454 if [ "$1" = 0 ]; then
455 /sbin/install-info --delete %{_infodir}/abrt-retrace-server %{_infodir}/dir 2> /dev/null || :
456 fi
457
458 %description retrace-server
459 The retrace server provides a coredump analysis and backtrace
460 generation service over a network using HTTP protocol.
461
462 %files retrace-server
463 %defattr(-,root,root,-)
464 %config(noreplace) %{_sysconfdir}/%{name}/retrace.conf
465 %config(noreplace) %{_sysconfdir}/httpd/conf.d/retrace_httpd.conf
466 %config(noreplace) %{_sysconfdir}/yum.repos.d/retrace.repo
467 %dir %attr(0775, apache, abrt) %{_localstatedir}/spool/abrt-retrace
468 %dir %attr(0755, abrt, abrt) %{_localstatedir}/cache/abrt-retrace
469 %dir %attr(0755, abrt, abrt) %{_localstatedir}/log/abrt-retrace
470 %caps(cap_setuid=ep) %{_bindir}/abrt-retrace-worker
471 %{_bindir}/abrt-retrace-cleanup
472 %{_bindir}/abrt-retrace-reposync
473 %{_bindir}/coredump2packages
474 %{py_puresitedir}/retrace.py*
475 %{_datadir}/abrt-retrace/*.py*
476 %{_datadir}/abrt-retrace/*.wsgi
477 %{_datadir}/abrt-retrace/plugins/*.py*
478 %{_infodir}/abrt-retrace-server*
479 %endif
480 #--------------------------------------------------------------------
481
482 %prep
483 %setup -q
484 %apply_patches
485 # (tv)) disable -Werror:
486 perl -pi -e 's!-Werror!-Wno-deprecated!' configure{.ac,} */*/Makefile*
487
488 %build
489 NOCONFIGURE=yes gnome-autogen.sh
490 %configure2_5x \
491 %if !%{with_systemd}
492 --without-systemdsystemunitdir \
493 %endif
494 --disable-rpath
495 %make
496
497 %install
498 %makeinstall_std
499 %find_lang %{name}
500
501 # remove all .la and .a files
502 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
503 mkdir -p %{buildroot}/%{_initrddir}
504 install -m 755 %SOURCE1 %{buildroot}/%{_initrddir}/%{name}d
505 install -m 755 %SOURCE5 %{buildroot}/%{_initrddir}/%{name}-ccpp
506 install -m 755 %SOURCE6 %{buildroot}/%{_initrddir}/%{name}-oops
507 mkdir -p %{buildroot}/var/cache/%{name}-di
508 mkdir -p %{buildroot}/var/run/%{name}
509 mkdir -p %{buildroot}/var/spool/%{name}
510 mkdir -p %{buildroot}/var/spool/%{name}-retrace
511 mkdir -p %{buildroot}/var/cache/%{name}-retrace
512 mkdir -p %{buildroot}/var/log/%{name}-retrace
513 mkdir -p %{buildroot}/var/spool/%{name}-upload
514
515 sed -i 's!@libexec@!%_libdir!' %{buildroot}/%{_initrddir}/%{name}-ccpp
516
517 # remove fedora gpg key
518 rm -f %{buildroot}%{_sysconfdir}/abrt/gpg_keys
519 touch %{buildroot}%{_sysconfdir}/abrt/gpg_keys
520
521 # install ulimit disabler
522 mkdir -p %{buildroot}%{_sysconfdir}/profile.d/
523 install -m755 %SOURCE2 %SOURCE3 %{buildroot}%{_sysconfdir}/profile.d/
524
525 desktop-file-install \
526 --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
527 src/applet/%{name}-applet.desktop
528
529 # replace with our own version
530 cat %{SOURCE4} > %{buildroot}/usr/bin/%{name}-debuginfo-install
531
532 #remove RH specific plugins
533 rm -f %{buildroot}%{_libdir}/%{name}/{RHTSupport.glade,libRHTSupport.so}
534 rm -f %{buildroot}%{_sysconfdir}/%{name}/plugins/RHTSupport.conf
535 rm -f %{buildroot}%{_sysconfdir}/%{name}/events.d/rhtsupport_events.conf
536 rm -f %{buildroot}%{_sysconfdir}/%{name}/events/report_RHTSupport.xml
537 rm -f %{buildroot}%{_bindir}/%{name}-action-rhtsupport
538
539 # After everything is installed, remove info dir
540 rm -f %{buildroot}%{_infodir}/dir

  ViewVC Help
Powered by ViewVC 1.1.30