/[packages]/cauldron/acme/current/SPECS/acme.spec
ViewVC logotype

Contents of /cauldron/acme/current/SPECS/acme.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1155515 - (show annotations) (download)
Tue Sep 19 12:02:27 2017 UTC (6 years, 6 months ago) by rapsys
File size: 1690 byte(s)
Version 1.0
Fix issue with pending challenge

1 # Avoid problem without man and info
2 %define dont_compress 1
3
4 Name: acme
5 Version: 1.0
6 Release: %mkrel 1
7 Summary: Letsencrypt perl client
8 License: GPLv3+
9 Group: Development/Perl
10 Url: https://git.rapsys.eu/?p=%{name}
11 Source0: %{name}-%{version}.tar.xz
12 BuildArch: noarch
13 Requires: php-json perl(LWP::Protocol::https)
14 Provides: perl(Acme)
15
16 %description
17 This program allow you to configure, generate and automate
18 letsencrypt certificate generation.
19
20 %prep
21 %setup -q -n %{name}
22
23 %install
24 # Install directories
25 install -d %{buildroot}%{_datadir}/%{name}
26 install -d %{buildroot}%{perl_vendorlib}
27 install -d %{buildroot}%{_bindir}
28 install -d %{buildroot}%{_sysconfdir}/%{name}
29 install -d %{buildroot}/%{_mandir}/man1
30
31 # Install php script
32 install -m644 www/acme-challenge.php %{buildroot}%{_datadir}/%{name}/
33
34 # Install perl library
35 install -m644 Acme.pm %{buildroot}%{perl_vendorlib}/Acme.pm
36
37 # Install binaries
38 install -m755 acmecert %{buildroot}%{_bindir}/
39 install -m755 acmeconf %{buildroot}%{_bindir}/
40 install -m755 acmecron %{buildroot}%{_bindir}/
41
42 # Touch fake man to avoid error with man and info compression
43 install -m644 acmecert.1 %{buildroot}/%{_mandir}/man1/
44 install -m644 acmeconf.1 %{buildroot}/%{_mandir}/man1/
45 install -m644 acmecron.1 %{buildroot}/%{_mandir}/man1/
46
47 # Touch thumbprint file
48 touch %{buildroot}/%{_sysconfdir}/%{name}/thumbprint
49
50 %files
51 # Apache configuration files
52 %doc www/example.com.conf www/acme.conf
53 %config %{_sysconfdir}/%{name}/thumbprint
54 %{_datadir}/%{name}/acme-challenge.php
55 %{perl_vendorlib}/Acme.pm
56 %{_bindir}/acmecert
57 %{_bindir}/acmeconf
58 %{_bindir}/acmecron
59 %{_mandir}/man1/acmecert.1
60 %{_mandir}/man1/acmeconf.1
61 %{_mandir}/man1/acmecron.1

  ViewVC Help
Powered by ViewVC 1.1.30