/[packages]/cauldron/afflib/current/SPECS/afflib.spec
ViewVC logotype

Contents of /cauldron/afflib/current/SPECS/afflib.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1370449 - (show annotations) (download)
Thu Feb 28 06:25:56 2019 UTC (5 years, 1 month ago) by daviddavid
File size: 3907 byte(s)
SILENT: remove merged upstream patch

1 %define major 0
2 %define libname %mklibname afflib %{major}
3 %define develname %mklibname afflib -d
4
5 %define py3support 1
6
7 Summary: A set of programs for creating and manipulating AFF files
8 Name: afflib
9 Version: 3.7.18
10 Release: %mkrel 1
11 Group: System/Libraries
12 License: BSD
13 URL: https://github.com/sshock/AFFLIBv3
14 Source0: https://github.com/sshock/AFFLIBv3/archive/v%{version}/%{name}-%{version}.tar.gz
15
16 BuildRequires: pkgconfig(libcurl)
17 # GPLv2 FOSS incompatible with BSD with advertising
18 #BuildRequires: pkgconfig(fuse)
19 BuildRequires: pkgconfig(libewf)
20 BuildRequires: pkgconfig(liblzma)
21 BuildRequires: pkgconfig(expat)
22 BuildRequires: pkgconfig(ncurses)
23 BuildRequires: pkgconfig(openssl)
24
25 %if %py3support
26 BuildRequires: pkgconfig(python3)
27 BuildRequires: pythonegg(3)(cython)
28 %else
29 BuildRequires: pkgconfig(python2)
30 BuildRequires: pythonegg(2)(cython)
31 %endif
32 # GPLv2 FOSS incompatible with BSD with advertising
33 #BuildRequires: readline-devel
34 BuildRequires: pkgconfig(zlib)
35
36
37 %description
38 AFFLIB is an open source library developed by Simson Garfinkel and Basis
39 Technology that implements the AFF standard. AFFLIB is distributed under
40 4-clause Berkeley License and may be freely incorporated into both Open
41 Source and Proprietary software.
42
43 In addition to the library, AFFLIB also comes with the AFF Tools, a set of
44 programs for creating and manipulating AFF files.
45
46 %package -n %{libname}
47 Summary: A shared library that implements the AFF standard
48 Group: System/Libraries
49
50 %description -n %{libname}
51 AFFLIB is an open source library developed by Simson Garfinkel and Basis
52 Technology that implements the AFF standard. AFFLIB is distributed under
53 4-clause Berkeley License and may be freely incorporated into both Open
54 Source and Proprietary software.
55
56 This package contains a shared library that implements the AFF standard.
57
58 %package -n %{develname}
59 Summary: Static library and header files for the afflib library
60 Group: Development/C
61 Provides: %{name}-devel = %{version}
62 Requires: %{libname} = %{version}
63
64 %description -n %{develname}
65 AFFLIB is an open source library developed by Simson Garfinkel and Basis
66 Technology that implements the AFF standard. AFFLIB is distributed under
67 4-clause Berkeley License and may be freely incorporated into both Open
68 Source and Proprietary software.
69
70 This package contains the static afflib library and its header files.
71
72 %prep
73 %autosetup -p1 -n AFFLIBv3-%{version}
74
75 #fix spurious permissions with lzma443
76 find lzma443 -type f -exec chmod 0644 {} ';'
77 chmod 0644 lib/base64.{h,cpp}
78
79 %build
80
81 sh bootstrap.sh
82
83 %configure2_5x \
84 --disable-static \
85 --enable-shared \
86 --enable-s3=yes \
87 --enable-fuse=no \
88 --enable-python=yes \
89 --enable-qemu=no \
90 --with-curl=%{_prefix} \
91 %if %py3support
92 PYTHON=%{__python3}
93 %endif
94
95 %make_build
96
97 %install
98
99 %make_install
100
101 # install headers as well
102 install -d %{buildroot}%{_includedir}/afflib
103 install -m0644 lib/*.h %{buildroot}%{_includedir}/afflib/
104
105 # we don't want these
106 find %{buildroot} -name '*.la' -delete
107
108 %files
109 %{_bindir}/affcat
110 %{_bindir}/affcompare
111 %{_bindir}/affconvert
112 %{_bindir}/affcopy
113 %{_bindir}/affcrypto
114 %{_bindir}/affdiskprint
115 %{_bindir}/affix
116 %{_bindir}/affuse
117 %{_bindir}/affinfo
118 %{_bindir}/affrecover
119 %{_bindir}/affsegment
120 %{_bindir}/affsign
121 %{_bindir}/affstats
122 %{_bindir}/affverify
123 %{_bindir}/affxml
124 %{_mandir}/man1/*
125 %if %py3support
126 %{python3_sitearch}/pyaff*.so
127 %{python3_sitearch}/PyAFF-*-py%{python3_version}.egg-info/
128 %else
129 %{python2_sitearch}/*
130 %endif
131
132 %files -n %{libname}
133 %doc AUTHORS BUGLIST.txt COPYING ChangeLog NEWS README* doc/*
134 %{_libdir}/*.so.%{major}{,.*}
135
136 %files -n %{develname}
137 %dir %{_includedir}/afflib
138 %{_includedir}/afflib/*.h
139 %{_libdir}/*.so
140 %{_libdir}/pkgconfig/*.pc

  ViewVC Help
Powered by ViewVC 1.1.30