/[packages]/cauldron/alienarena/current/SPECS/alienarena.spec
ViewVC logotype

Contents of /cauldron/alienarena/current/SPECS/alienarena.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2048836 - (show annotations) (download)
Sat Mar 9 06:53:00 2024 UTC (5 weeks, 6 days ago) by daviddavid
File size: 3555 byte(s)
SILENT: fix tarball name

1 %define svn 5771
2
3 Name: alienarena
4 Summary: Multiplayer retro sci-fi deathmatch game
5 Version: 7.71.6
6 Release: %mkrel 1
7 License: GPLv2+
8 Group: Games/Shooter
9 URL: http://red.planetarena.org/
10 # Been so long since a release, we need to use the svn code
11 # svn export svn://svn.icculus.org/alienarena/trunk alienarena-7.71.6
12 # svn co svn://svn.icculus.org/alienarena/tags/7.71.6 alienarena-7.71.6
13 # cd alienarena-7.71.6
14 # # remove useless files to gain xz compressed 60MB
15 # rm -rf Tools/ *.dll *.exe vs2010/ lib_zipfiles/
16 # cd ..
17 # tar --exclude-vcs -cJf alienarena-7.71.6-svn5771.tar.xz alienarena-7.71.6
18 Source0: alienarena-%{version}-svn%{svn}.tar.xz
19 Source1: alien-arena.desktop
20 Source2: GPL.acebot.txt
21 Patch3: alienarena-7.66-no-qglBlitFramebufferEXT.patch
22 BuildRequires: pkgconfig(xext)
23 BuildRequires: pkgconfig(xxf86vm)
24 BuildRequires: pkgconfig(libjpeg)
25 BuildRequires: pkgconfig(gl)
26 BuildRequires: pkgconfig(glu)
27 BuildRequires: pkgconfig(libcurl)
28 BuildRequires: pkgconfig(libpng)
29 BuildRequires: pkgconfig(vorbis)
30 BuildRequires: pkgconfig(openal)
31 BuildRequires: pkgconfig(freetype2)
32 BuildRequires: desktop-file-utils
33 Requires: %{name}-data = 1:%{version}
34 Requires: desktop-file-utils >= 0.9
35 Requires: glxinfo
36 Requires: openal
37 Requires: opengl-games-utils
38
39 %description
40 Alien Arena : Mercury Edition is an online deathmatch game with over 30
41 levels, seven modes of play, loads of mutators, built-in bots, multiple
42 player characters and weapons (with alt-fire modes).
43
44 %package server
45 Group: Games/Shooter
46 Summary: Dedicated server for alienarena, the FPS game
47 Requires: %{name}-data = 1:%{version}
48
49 %description server
50 Alien Arena : Mercury Edition is an online deathmatch game with over 30
51 levels, seven modes of play, loads of mutators, built-in bots, multiple
52 player characters and weapons (with alt-fire modes).
53
54 This is the dedicated server.
55
56 %package data
57 Group: Games/Shooter
58 Summary: Data files for Alien Arena 2011
59 Epoch: 1
60 BuildArch: noarch
61
62 %description data
63 This is the game data (audio, maps, etc) for Alien Arena.
64
65 %prep
66 %autosetup -p1 -n %{name}-%{version}
67
68 # Copy license clarification for acebot
69 cp -p %{SOURCE2} .
70
71 # clean up end-line encoding
72 [[ -e docs/README.txt ]] && %{__sed} -i 's/\r//' docs/README.txt
73
74 # So, AlienArena now "uses" openal by dlopening the library, which is hardcoded to
75 # "libopenal.so". That file only lives in openal-devel, so we need to adjust the hardcoding.
76 LIBOPENAL=`ls %{_libdir}/libopenal.so.? | cut -d "/" -f 4`
77 sed -i "s|\"libopenal.so\"|\"$LIBOPENAL\"|g" source/unix/qal_unix.c
78
79 %build
80 autoreconf -vfi
81 export PTHREAD_LIBS="-lpthread"
82 export PTHREAD_CFLAGS="-pthread"
83 %configure
84 %make_build
85
86 %install
87 %make_install
88
89 mkdir -p %{buildroot}%{_datadir}/applications
90 desktop-file-install --vendor "" \
91 --dir %{buildroot}%{_datadir}/applications \
92 %{SOURCE1}
93
94 mkdir -p %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/
95 mv %{buildroot}%{_datadir}/icons/%{name}/alien-arena.png \
96 %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/alien-arena.png
97
98 # Fedora's little opengl checker
99 ln -s opengl-game-wrapper.sh %{buildroot}%{_bindir}/%{name}-wrapper
100 ln -s %{name}-ded %{buildroot}%{_bindir}/%{name}-server
101
102 rm -f %{buildroot}%{_docdir}/%{name}/{INSTALL,alien-arena.desktop}
103
104 %files
105 %doc GPL.acebot.txt README docs/README.txt docs/license.txt COPYING GPLv2 NEWS
106 %{_bindir}/%{name}
107 %{_bindir}/%{name}-wrapper
108 %{_datadir}/applications/alien-arena.desktop
109 %{_datadir}/icons/hicolor/*/apps/alien-arena.png
110
111 %files server
112 %{_bindir}/%{name}-ded
113 %{_bindir}/%{name}-server
114
115 %files data
116 %{_datadir}/%{name}/

  ViewVC Help
Powered by ViewVC 1.1.30