/[packages]/cauldron/allegro4/current/SPECS/allegro4.spec
ViewVC logotype

Contents of /cauldron/allegro4/current/SPECS/allegro4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1379294 - (show annotations) (download)
Wed Mar 20 20:56:17 2019 UTC (5 years, 1 month ago) by zezinho
File size: 5402 byte(s)
SILENT hopefully really fix paths for this bugfix version
1 %define uname allegro
2 %define major 4.4
3 %define libname %mklibname %{uname} %{major}
4 %define devname %mklibname %{uname}4 -d
5 %define testlib %mklibname %{uname}-testing %{major}
6
7 Name: allegro4
8 Version: 4.4.3.1
9 Release: %mkrel 1
10 Summary: Game programming library
11 Group: System/Libraries
12 License: Public Domain
13 URL: http://liballeg.org/
14 Source0: https://github.com/liballeg/allegro5/releases/download/%{version}/%{uname}-%{version}.tar.gz
15 Patch1: allegro-4.0.3-cfg.patch
16 Patch2: allegro-4.0.3-libdir.patch
17 Patch3: allegro-4.4.2-doc-install.patch
18 Patch4: allegro-4.4.2-buildsys-fix.patch
19 # gnome-shell starts apps while gnome-shell has the keyb grabbed...
20 Patch5: allegro-4.4.2-keybgrab-fix.patch
21 # 4.4.3 has dropped the fadd/fsub etc aliases, but some apps need them
22 Patch6: allegro-4.4.2-compat-fix-aliases.patch
23
24 BuildRequires: cmake
25 BuildRequires: pkgconfig(alsa)
26 BuildRequires: pkgconfig(audiofile)
27 BuildRequires: pkgconfig(glu)
28 BuildRequires: pkgconfig(jack)
29 BuildRequires: pkgconfig(libjpeg)
30 BuildRequires: pkgconfig(libpng)
31 BuildRequires: pkgconfig(vorbis)
32 BuildRequires: pkgconfig(x11)
33 BuildRequires: pkgconfig(xcursor)
34 BuildRequires: pkgconfig(xext)
35 BuildRequires: pkgconfig(xpm)
36 BuildRequires: pkgconfig(xxf86dga)
37 BuildRequires: pkgconfig(xxf86vm)
38 BuildRequires: texinfo
39 %ifarch %ix86
40 BuildRequires: svgalib-devel
41 %endif
42 Obsoletes: allegro-testing < 4.4.2-9
43 Provides: allegro-testing = %{version}-%{release}
44 Obsoletes: allegro-arts-plugin < 4.4.2-9
45 # Renamed to allegro4 during mga6 dev
46 Obsoletes: allegro < 4.4.2-9
47 Provides: allegro = %{version}-%{release}
48
49 %description
50 Allegro is a library of functions for use in computer games.
51
52 %package -n %{libname}
53 Summary: Game programming library
54 Group: System/Libraries
55 Provides: lib%{uname} = %{version}-%{release}
56 Provides: %{testlib} = %{version}-%{release}
57 Obsoletes: %{testlib} < 4.4.2-9
58 Recommends: %{name} >= %{version}
59
60 %description -n %{libname}
61 Allegro is a library of functions for use in computer games.
62
63 %package -n %{devname}
64 Summary: Game programming library
65 Group: Development/C++
66 Requires: %{libname} = %{version}
67 Provides: lib%{uname}-devel = %{version}-%{release}
68 Provides: %{uname}-devel = %{version}-%{release}
69 Provides: %{uname}4-devel = %{version}-%{release}
70 Provides: %{testlib}-devel = %{version}-%{release}
71 Obsoletes: allegro-devel < 4.4.2-9
72 Obsoletes: %{testlib}-devel < 4.4.2-9
73 Obsoletes: %{_lib}allegro4.2-devel < 4.4.2-9
74
75 %description -n %{devname}
76 Allegro is a library of functions for use in computer games.
77 This package contains files needed to build programs using Allegro.
78
79 %package jack-plugin
80 Summary: Allegro JACK (Jack Audio Connection Kit) plugin
81 Group: System/Libraries
82 Requires: %{name} = %{version}-%{release}
83 # Renamed to allegro4 during mga6 dev
84 Obsoletes: allegro-jack-plugin < 4.4.2-9
85 Provides: allegro-jack-plugin = %{version}-%{release}
86
87 %description jack-plugin
88 This package contains a plugin for Allegro which enables Allegro to playback
89 sound through JACK (Jack Audio Connection Kit).
90
91 %prep
92 %autosetup -p1 -n %{uname}-%{version}
93
94 iconv -f iso-8859-1 -t utf-8 docs/src/allegro._tx > docs/src/allegro._tx.tmp
95 mv docs/src/allegro._tx.tmp docs/src/allegro._tx
96
97 %build
98 %ifnarch %{ix86}
99 export CFLAGS="%{optflags} -fPIC"
100 %endif
101
102 %cmake
103 %make_build
104
105 find demos examples setup -type f -perm +111 -print | xargs rm -rf
106
107 %install
108 %make_install -C build
109
110 # (from fedora) installation of these is broken, because they use a cmake GLOB, but
111 # that gets "resolved" when runnning cmake, and at that time the files
112 # to install aren't generated yet ...
113 install -d -m 755 %{buildroot}%{_mandir}/man3
114 install -D -m 644 build/docs/man/*3* %{buildroot}%{_mandir}/man3
115 install -d -m 755 %{buildroot}%{_infodir}
116 install -D -m 644 allegro.cfg %{buildroot}%{_sysconfdir}/allegrorc
117 install -p -m 755 tools/x11/xfixicon.sh %{buildroot}%{_bindir}
118 install -d -m 755 %{buildroot}%{_datadir}/allegro
119 install -D -m 644 keyboard.dat language.dat %{buildroot}%{_datadir}/allegro
120 install -D -m 644 misc/allegro.m4 %{buildroot}%{_datadir}/aclocal/allegro.m4
121
122 rm -rf %{buildroot}%{_prefix}/doc
123
124 %post -n %{devname}
125 %_install_info %{name}.info
126
127 %preun -n %{devname}
128 %_remove_install_info %{name}.info
129
130 %files
131 %doc %{_docdir}/%{uname}-4.4.3/*
132 %{_bindir}/colormap
133 %{_bindir}/dat
134 %{_bindir}/dat2c
135 %{_bindir}/dat2s
136 %{_bindir}/exedat
137 %{_bindir}/grabber
138 %{_bindir}/pack
139 %{_bindir}/pat2dat
140 %{_bindir}/rgbmap
141 %{_bindir}/textconv
142 %{_bindir}/xfixicon.sh
143 %{_datadir}/%{uname}/
144 %{_libdir}/%{uname}/
145 %exclude %{_libdir}/%{uname}/%{version}/alleg-jack.so
146 %config(noreplace) %{_sysconfdir}/allegrorc
147
148 %files -n %{libname}
149 %{_libdir}/lib*.so.%{major}{,.*}
150
151 %files -n %{devname}
152 %doc *.txt AUTHORS CHANGES THANKS
153 %doc docs/txt/abi.txt docs/txt/ahack.txt docs/txt/allegro.txt
154 %doc docs/txt/const.txt docs/txt/faq.txt docs/txt/help.txt
155 %doc docs/html
156 %doc demos examples setup
157 %{_bindir}/%{uname}-config
158 %{_libdir}/lib*.so
159 %{_libdir}/pkgconfig/*.pc
160 %{_includedir}/*.h
161 %{_includedir}/%{uname}/
162 %{_includedir}/%{uname}gl/
163 %{_datadir}/aclocal/%{uname}.m4
164 %{_mandir}/man3/*.3*
165 %{_infodir}/%{uname}.info*
166
167 %files jack-plugin
168 %{_libdir}/%{uname}/4.4.3/alleg-jack.so

  ViewVC Help
Powered by ViewVC 1.1.30