/[packages]/cauldron/apache-rat/current/SPECS/apache-rat.spec
ViewVC logotype

Contents of /cauldron/apache-rat/current/SPECS/apache-rat.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 129952 - (show annotations) (download)
Wed Jul 27 16:05:43 2011 UTC (12 years, 9 months ago) by dmorgan
File size: 5142 byte(s)
Clean spec file
1 %define rel_date 20100707
2 Name: apache-rat
3 Version: 0.8
4 Release: %mkrel 1
5 Summary: Apache Release Audit Tool (RAT)
6 License: Apache Software License Version 2.0
7 Group: Development/Java
8 URL: http://www.apache.org/dist/incubator/rat/
9 # svn export -r 990212 http://svn.apache.org/repos/asf/incubator/rat/main/trunk apache-rat-0.8-20100707
10 # tar czf apache-rat-0.8-20100707-src-svn.tar.gz apache-rat-0.8-20100707
11 Source0: apache-rat-%{version}-%{rel_date}-src-svn.tar.gz
12 Patch0: apache-rat-0.8-doxia-1.1.patch
13 Patch1: apache-rat-0.8-test.patch
14 BuildRequires: ant-antunit
15 BuildRequires: ant-testutil
16 BuildRequires: apache-commons-compress
17 BuildRequires: java-devel
18 BuildRequires: jpackage-utils
19
20 BuildRequires: maven
21 BuildRequires: maven-antrun-plugin
22 BuildRequires: maven-compiler-plugin
23 BuildRequires: maven-dependency-plugin
24 BuildRequires: maven-install-plugin
25 BuildRequires: maven-jar-plugin
26 BuildRequires: maven-javadoc-plugin
27 BuildRequires: maven-plugin-plugin
28 BuildRequires: maven-resources-plugin
29 BuildRequires: maven-site-plugin
30 BuildRequires: maven-source-plugin
31 BuildRequires: maven-surefire-plugin
32 BuildRequires: maven-doxia
33 BuildRequires: maven-doxia-sitetools
34 BuildRequires: maven-wagon
35 Requires: java
36 Requires: jpackage-utils
37 BuildArch: noarch
38
39 %description
40 Release Audit Tool (RAT) is a tool to improve accuracy and efficiency when
41 checking releases. It is heuristic in nature: making guesses about possible
42 problems. It will produce false positives and cannot find every possible
43 issue with a release. It's reports require interpretation.
44
45 RAT was developed in response to a need felt in the Apache Incubator to be
46 able to review releases for the most common faults less labor intensively.
47 It is therefore highly tuned to the Apache style of releases.
48
49 This package just contains meta-data, you will want either apache-rat-tasks,
50 or apache-rat-plugin.
51
52 %package core
53 Summary: Core functionality for %{name}
54 Group: Development/Java
55 Requires: %{name} = %{version}-%{release}
56 Requires: apache-commons-cli
57 Requires: apache-commons-collections
58 Requires: apache-commons-compress
59 Requires: apache-commons-lang
60 Requires: apache-commons-io
61 Requires: junit
62 Requires: jpackage-utils
63
64 %description core
65 Apache Release Audit Tool (RAT).
66
67 This package contains the core functionality of RAT,
68 shared by the Ant tasks, and the Maven plugin.
69
70 %package plugin
71 Summary: Maven 2 plugin for %{name}
72 Group: Development/Java
73 Requires: %{name}-core = %{version}-%{release}
74 Requires: jpackage-utils
75
76 %description plugin
77 Apache Release Audit Tool (RAT).
78
79 This package contains Maven 2 plugin for running RAT.
80
81 %package tasks
82 Summary: Ant tasks for %{name}
83 Group: Development/Java
84 Requires: %{name}-core = %{version}-%{release}
85 Requires: jpackage-utils
86
87 %description tasks
88 Apache Release Audit Tool (RAT).
89
90 This package contains Ant tasks for running RAT.
91
92 %package javadoc
93 Group: Development/Java
94 Summary: Javadoc for %{name}
95
96 %description javadoc
97 Apache Release Audit Tool (RAT).
98
99 This package contains javadoc for %{name}.
100
101 %prep
102 %setup -q -n apache-rat-%{version}-%{rel_date}
103
104 %patch0 -p0
105 %patch1 -p0
106
107 %build
108
109 export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
110 mkdir -p $MAVEN_REPO_LOCAL
111
112 mvn-jpp \
113 -e \
114 -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
115 -Dmaven.test.failure.ignore=true \
116 install javadoc:aggregate
117
118 %install
119 [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
120
121 mkdir -p %{buildroot}%{_javadir}/apache-rat
122 mkdir -p %{buildroot}%{_mavenpomdir}
123
124 install -pm 0644 pom.xml %{buildroot}%{_mavenpomdir}/JPP.apache-rat-apache-rat.pom
125 %add_to_maven_depmap org.apache.rat apache-rat-project %{version} JPP/apache-rat apache-rat
126
127 for jarname in apache-rat{-core,-plugin,-tasks} ; do
128 jarfile=$jarname/target/${jarname}-%{version}-SNAPSHOT.jar
129 install -pm 0644 $jarfile %{buildroot}%{_javadir}/apache-rat/${jarname}.jar
130 install -pm 0644 ${jarname}/pom.xml %{buildroot}%{_mavenpomdir}/JPP.apache-rat-${jarname}.pom
131 %add_to_maven_depmap org.apache.rat ${jarname} %{version}-SNAPSHOT JPP/apache-rat ${jarname}
132 done
133
134 mkdir -p %{buildroot}%{_javadocdir}/apache-rat
135 cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/apache-rat/
136
137 mkdir -p %{buildroot}%{_sysconfdir}/ant.d
138 echo "apache-rat/rat-core apache-rat/rat-tasks" > %{buildroot}%{_sysconfdir}/ant.d/apache-rat
139
140 %post
141 %update_maven_depmap
142
143 %postun
144 %update_maven_depmap
145
146 %files
147 %dir %{_javadir}/apache-rat
148 %{_mavenpomdir}/JPP.apache-rat-apache-rat.pom
149 %{_mavendepmapfragdir}
150 %doc DISCLAIMER.txt LICENSE NOTICE README.txt RELEASE_NOTES.txt
151
152 %files core
153 %{_javadir}/apache-rat/apache-rat-core.jar
154 %{_mavenpomdir}/JPP.apache-rat-apache-rat-core.pom
155
156 %files plugin
157 %{_javadir}/apache-rat/apache-rat-plugin.jar
158 %{_mavenpomdir}/JPP.apache-rat-apache-rat-plugin.pom
159
160 %files tasks
161 %{_sysconfdir}/ant.d/apache-rat
162 %{_javadir}/apache-rat/apache-rat-tasks.jar
163 %{_mavenpomdir}/JPP.apache-rat-apache-rat-tasks.pom
164
165 %files javadoc
166 %{_javadocdir}/apache-rat
167

  ViewVC Help
Powered by ViewVC 1.1.30