/[packages]/cauldron/bind/current/SPECS/bind.spec
ViewVC logotype

Annotation of /cauldron/bind/current/SPECS/bind.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 136519 - (hide annotations) (download)
Tue Aug 30 10:48:41 2011 UTC (12 years, 7 months ago) by guillomovitch
File size: 20008 byte(s)
renumerate patches to match fedora ones
1 ennael 36772 # default options
2     %define sdb_ldap 1
3     %define sdb_mysql 0
4     %define geoip 0
5     %define gssapi 1
6    
7     %{?_with_sdb_ldap: %{expand: %%global sdb_ldap 1}}
8     %{?_without_sdb_ldap: %{expand: %%global sdb_ldap 0}}
9     %{?_with_sdb_mysql: %{expand: %%global sdb_mysql 1}}
10     %{?_without_sdb_mysql: %{expand: %%global sdb_mysql 0}}
11     %{?_with_geoip: %{expand: %%global geoip 1}}
12     %{?_without_geoip: %{expand: %%global geoip 0}}
13     %{?_with_gssapi: %{expand: %%global gssapi 1}}
14     %{?_without_gssapi: %{expand: %%global gssapi 0}}
15    
16     %if %{sdb_mysql}
17     %define sdb_ldap 0
18     %endif
19    
20     %if %{sdb_ldap}
21     %define sdb_mysql 0
22     %endif
23    
24     %if %{geoip}
25     %define geoip 1
26     %endif
27    
28     %if %{gssapi}
29     %define gssapi 1
30     %endif
31    
32 guillomovitch 136446 %define patchver P4
33 pterjan 95469 %define dashpatch %{?patchver:-%patchver}%nil
34     %define dotpatch %{?patchver:.%patchver}%nil
35    
36 ennael 36772 Summary: A DNS (Domain Name System) server
37     Name: bind
38 misc 87095 Version: 9.8.0
39 guillomovitch 136446 Release: %mkrel 1%dotpatch
40 pterjan 95469 License: ISC
41 ennael 36772 Group: System/Servers
42     URL: http://www.isc.org/products/BIND/
43 pterjan 95469 Source0: ftp://ftp.isc.org/isc/%{name}9/%{version}%{dashpatch}/%{name}-%{version}%{dashpatch}.tar.gz
44     Source1: ftp://ftp.isc.org/isc/%{name}9/%{version}%{dashpatch}/%{name}-%{version}%{dashpatch}.tar.gz.asc
45 ennael 36772 Source2: bind-manpages.tar.bz2
46     Source3: bind-dhcp-dynamic-dns-examples.tar.bz2
47     Source4: bind-named.init
48     Source6: bind-named.sysconfig
49     Source7: bind-keygen.c
50     Source11: ftp://ftp.internic.net/domain/named.cache
51     # (oe) http://mysql-bind.sourceforge.net/
52     Source12: mysql-bind-0.1.tar.bz2
53     # (oe) http://bind9-ldap.bayour.com/bind-sdb-ldap-1.0.tar.gz
54     Source13: bind-sdb-ldap-1.0.tar.bz2
55     # (oe) http://www.blue-giraffe.com/zone2ldap/zone2ldap-0.4.tar.gz
56     Source14: zone2ldap-0.4.tar.bz2
57     # (oe) http://www.venaas.no/dns/ldap2zone/
58     Source15: ldap2zone.tar.bz2
59     # caching-nameserver files (S100-S112)
60     Source100: bogon_acl.conf
61     Source101: hosts
62     Source102: localdomain.zone
63     Source103: localhost.zone
64     Source104: logging.conf
65     Source105: named.broadcast
66     Source106: named.conf
67     Source107: named.ip6.local
68     Source108: named.local
69     Source109: named.zero
70     Source110: rndc.conf
71     Source111: rndc.key
72     Source112: trusted_networks_acl.conf
73 guillomovitch 136519
74     # fedora patches
75     Patch71: bind-9.5-overflow.patch
76     Patch72: bind-9.5-dlz-64bit.patch
77     Patch87: bind-9.5-parallel-build.patch
78     Patch99: bind-96-libtool2.patch
79     Patch102: bind-95-rh452060.patch
80     Patch106: bind93-rh490837.patch
81     Patch104: bind-96-dyndb.patch
82    
83     # IDN patches
84     Patch73: bind-9.5-libidn.patch
85     Patch83: bind-9.5-libidn2.patch
86     Patch85: bind-9.5-libidn3.patch
87     Patch94: bind95-rh461409.patch
88    
89     # other patches
90 misc 87096 # make dig go to the 2nd server by default
91     # likely deprecated, to be looked at
92 guillomovitch 136519 Patch200: bind-fallback-to-second-server.diff
93     Patch201: bind-queryperf_fix.diff
94     Patch202: bind-9.2.3-sdb_ldap.patch
95     Patch203: bind-9.3.1-zone2ldap_fixes.diff
96     Patch204: bind-9.3.0rc2-sdb_mysql.patch
97     Patch205: zone2ldap-0.4-ldapv3.patch
98     Patch206: bind-9.2.0rc3-varrun.patch
99     Patch207: bind-9.4.0rc1-ppc-asm.patch
100     Patch208: bind-9.3.2-prctl_set_dumpable.patch
101 ennael 36772 # (oe) rediffed patch originates from http://www.caraytech.com/geodns/
102     Patch300: bind-9.4.0-geoip.diff
103     Requires(pre): rpm-helper
104     Requires(postun): rpm-helper
105     Requires: bind-utils >= %{version}-%{release}
106     BuildRequires: openssl-devel
107     BuildRequires: autoconf2.5
108     BuildRequires: automake
109     BuildRequires: file
110     %if %{sdb_mysql}
111     BuildRequires: mysql-devel
112     %endif
113     %if %{sdb_ldap}
114     BuildRequires: openldap-devel
115     %endif
116     Obsoletes: libdns0
117     Provides: libdns0
118     BuildRequires: multiarch-utils >= 1.0.3
119     %if %{geoip}
120     BuildRequires: libgeoip-devel
121     %endif
122     BuildRequires: libidn-devel
123     BuildRequires: postgresql-devel
124     BuildRequires: mysql-devel
125     BuildRequires: libcap-devel >= 2.10
126     %if %{gssapi}
127     BuildRequires: krb5-devel
128     %endif
129     BuildRequires: libxml2-devel
130    
131     %description
132     BIND (Berkeley Internet Name Domain) is an implementation of the DNS
133     (domain Name System) protocols. BIND includes a DNS server (named),
134     which resolves host names to IP addresses, and a resolver library
135     (routines for applications to use when interfacing with DNS). A DNS
136     server allows clients to name resources or objects and share the
137     information with other network machines. The named DNS server can be
138     used on workstations as a caching name server, but is generally only
139     needed on one machine for an entire network. Note that the
140     configuration files for making BIND act as a simple caching nameserver
141     are included in the caching-nameserver package.
142    
143     Install the bind package if you need a DNS server for your network. If
144     you want bind to act a caching name server, you will also need to install
145     the caching-nameserver package.
146    
147     Many BIND 8 features previously unimplemented in BIND 9, including
148     domain-specific forwarding, the \$GENERATE master file directive, and
149     the "blackhole", "dialup", and "sortlist" options Forwarding of dynamic
150     update requests; this is enabled by the "allow-update-forwarding" option
151     A new, simplified database interface and a number of sample drivers based
152     on it; see doc/dev/sdb for details
153     Support for building single-threaded servers for environments that do not
154     supply POSIX threads
155     New configuration options: "min-refresh-time", "max-refresh-time",
156     "min-retry-time", "max-retry-time", "additional-from-auth",
157     "additional-from-cache", "notify explicit"
158     Faster lookups, particularly in large zones.
159    
160     Build Options:
161     --without sdb_ldap Build without ldap simple database support (enabled
162     per default)
163     --with sdb_mysql Build with MySQL database support (disables ldap
164     support, it's either way.)
165     --with geoip Build with GeoIP support (disabled per default)
166    
167     %package utils
168     Summary: Utilities for querying DNS name servers
169     Group: Networking/Other
170    
171     %description utils
172     Bind-utils contains a collection of utilities for querying DNS (Domain
173     Name Service) name servers to find out information about Internet hosts.
174     These tools will provide you with the IP addresses for given host names,
175     as well as other information about registered domains and network
176     addresses.
177    
178     You should install bind-utils if you need to get information from DNS name
179     servers.
180    
181     %package devel
182     Summary: Include files and libraries needed for bind DNS development
183     Group: Development/C
184    
185     %description devel
186     The bind-devel package contains all the include files and the
187     library required for DNS (Domain Name Service) development for
188     BIND versions 9.x.x.
189    
190     %package doc
191     Summary: Documentation for BIND
192     Group: Books/Other
193    
194     %description doc
195     The bind-devel package contains the documentation for BIND.
196    
197     %prep
198    
199 pterjan 95469 %setup -q -n %{name}-%{version}%{dashpatch} -a2 -a3 -a12 -a13 -a14 -a15
200 ennael 36772
201 guillomovitch 136519 %patch200 -p1 -b .fallback-to-second-server.droplet
202     %patch201 -p0 -b .queryperf_fix.droplet
203 ennael 36772
204     %if %{sdb_ldap}
205     %__cp bind-sdb-ldap-*/ldapdb.c bin/named/
206     %__cp bind-sdb-ldap-*/ldapdb.h bin/named/include/
207 guillomovitch 136519 %patch202 -p1 -b .ldap_sdb.droplet
208     %patch203 -p0 -b .zone2ldap_fixes.droplet
209     %patch205 -p0 -b .ldapv3.droplet
210 ennael 36772 %endif
211    
212     %if %{sdb_mysql}
213     mv mysql-bind-0.1 contrib/sdb/mysql
214     %__cp contrib/sdb/mysql/mysqldb.c bin/named
215     %__cp contrib/sdb/mysql/mysqldb.h bin/named/include
216 guillomovitch 136519 %patch204 -p1 -b .sdb_mysql.droplet
217 ennael 36772 %endif
218    
219 guillomovitch 136519 %patch206 -p0 -b .varrun.droplet
220     %patch207 -p0 -b .no-register-names.droplet
221     %patch208 -p0 -b .prctl_set_dumpable.droplet
222     %patch71 -p1 -b .overflow.droplet
223     %patch72 -p0 -b .64bit
224 ennael 36772
225 guillomovitch 136519 %patch73 -p1 -b .libidn
226     %patch83 -p1 -b .libidn2
227     %patch85 -p1 -b .libidn3
228     %patch94 -p1 -b .rh461409
229 ennael 36772 mkdir -p m4
230 guillomovitch 136519 %patch99 -p1 -b .libtool2
231     %patch102 -p0 -b .rh452060
232     %patch106 -p0 -b .rh490837
233     %patch104 -p1 -b .dyndb
234     %patch87 -p1 -b .parallel
235 ennael 36772
236     %if %{geoip}
237     %patch300 -p1 -b .geoip
238     %endif
239    
240 cjw 94107 sed -e "s#@BUILD_ARCH@#%{_target_cpu}#" %{SOURCE4} >named.init
241 ennael 36772 cp %{SOURCE6} named.sysconfig
242     cp %{SOURCE7} keygen.c
243     cp %{SOURCE11} named.cache
244    
245     mkdir -p caching-nameserver
246     cp %{SOURCE100} caching-nameserver/bogon_acl.conf
247     cp %{SOURCE101} caching-nameserver/hosts
248     cp %{SOURCE102} caching-nameserver/localdomain.zone
249     cp %{SOURCE103} caching-nameserver/localhost.zone
250     cp %{SOURCE104} caching-nameserver/logging.conf
251     cp %{SOURCE105} caching-nameserver/named.broadcast
252     cp %{SOURCE106} caching-nameserver/named.conf
253     cp %{SOURCE107} caching-nameserver/named.ip6.local
254     cp %{SOURCE108} caching-nameserver/named.local
255     cp %{SOURCE109} caching-nameserver/named.zero
256     cp %{SOURCE110} caching-nameserver/rndc.conf
257     cp %{SOURCE111} caching-nameserver/rndc.key
258     cp %{SOURCE112} caching-nameserver/trusted_networks_acl.conf
259    
260     %build
261     %serverbuild
262    
263     export CPPFLAGS="$CPPFLAGS -DDIG_SIGCHASE"
264     export STD_CDEFINES="$CPPFLAGS"
265    
266 guillomovitch 136264 libtoolize --copy --force
267     aclocal -I m4 --force
268     autoheader --force
269     autoconf --force
270 ennael 36772
271     # (oe) make queryperf from the contrib _before_ bind..., makes it
272     # easier to determine if it builds or not, it saves time...
273     pushd contrib/queryperf
274     rm -f configure
275     autoconf
276     %configure2_5x
277     %make CFLAGS="$CFLAGS"
278     popd
279    
280     pushd contrib/query-loc-*
281     perl -pi -e "s|-lnsl|-lnsl -lresolv|g" configure*
282     rm -f configure
283     autoconf
284     %configure2_5x
285     %make CFLAGS="$CFLAGS"
286     popd
287    
288     export CFLAGS="$CFLAGS -DLDAP_DEPRECATED"
289    
290     %if %{geoip}
291     export CFLAGS="$CFLAGS -DLDAP_DEPRECATED -DGEOIP"
292     export LDFLAGS="$LDFLAGS -lGeoIP"
293     %endif
294    
295 guillomovitch 136293 %configure2_5x \
296 ennael 36772 --localstatedir=/var \
297     --disable-openssl-version-check \
298 guillomovitch 136263 --enable-exportlib \
299     --with-export-libdir=%{_libdir} \
300     --with-export-includedir=%{_includedir} \
301 ennael 36772 --enable-threads \
302     --enable-largefile \
303     --enable-ipv6 \
304     --enable-filter-aaaa \
305     --enable-epoll \
306     --with-openssl=%{_prefix} \
307     %if %{gssapi}
308     --with-gssapi=%{_prefix} --disable-isc-spnego \
309     %endif
310     --with-randomdev=/dev/urandom \
311     --with-libxml2=yes \
312     --with-dlz-postgres=yes \
313     --with-dlz-mysql=yes \
314     --with-dlz-bdb=no \
315     --with-dlz-filesystem=yes \
316     --with-dlz-ldap=yes \
317     --with-dlz-odbc=no \
318     --with-dlz-stub=yes
319    
320     # pkcs11 support requires a working backend, otherwise bind won't start
321     # http://blogs.sun.com/janp/
322     # http://sourceforge.net/projects/opencryptoki
323     #--with-pkcs11 \
324    
325 guillomovitch 136299 %make
326 ennael 36772
327     %if %{sdb_ldap}
328     pushd zone2ldap
329     # fix references to zone2ldap
330     perl -pi -e "s|zone2ldap|zonetoldap|g" *
331     gcc $CFLAGS -I../lib/dns/include -I../lib/dns/sec/dst/include \
332     -I../lib/isc/include -I../lib/isc/unix/include -I../lib/isc/pthreads/include -c zone2ldap.c
333     gcc $CFLAGS -o zone2ldap zone2ldap.o ../lib/dns/libdns.a -lcrypto -lpthread \
334     ../lib/isc/libisc.a -lldap -llber -lresolv %{?gssapi:-lgssapi_krb5} -lxml2 $LDFLAGS
335     popd
336    
337     pushd ldap2zone
338     gcc $CFLAGS -I../lib/dns/include -I../lib/dns/sec/dst/include \
339     -I../lib/isc/include -I../lib/isc/unix/include -I../lib/isc/pthreads/include -c ldap2zone.c
340     gcc $CFLAGS -o ldap2zone ldap2zone.o ../lib/dns/libdns.a -lcrypto -lpthread \
341     ../lib/isc/libisc.a -lldap -llber -lresolv %{?_with_gssapi:-lgssapi_krb5} -lxml2 $LDFLAGS
342     popd
343     %endif
344    
345     %if %{sdb_mysql}
346     pushd contrib/sdb/mysql
347     gcc $CFLAGS -I%{_includedir}/mysql -I../../../lib/dns/include -I../../../lib/dns/sec/dst/include \
348     -I../../../lib/isc/include -I../../../lib/isc/unix/include -I../../../lib/isc/pthreads/include \
349     -c zonetodb.c
350     gcc $CFLAGS -o zonetodb zonetodb.o \
351     ../../../lib/dns/libdns.a -lcrypto -lpthread ../../../lib/isc/libisc.a \
352     -lmysqlclient -lresolv %{?_with_gssapi:-lgssapi_krb5} -lxml2 $LDFLAGS
353     popd
354     %endif
355    
356     gcc $CFLAGS -o dns-keygen keygen.c
357    
358     #%%check
359     ## run the test suite
360     #make check
361    
362     %install
363     rm -rf %{buildroot}
364    
365     pushd doc
366     rm -rf html
367     popd
368    
369     # make some directories
370     install -d %{buildroot}%{_initrddir}
371     install -d %{buildroot}%{_sysconfdir}/sysconfig
372     install -d %{buildroot}/var/run/named
373    
374     %makeinstall_std
375    
376     ln -snf named %{buildroot}%{_sbindir}/lwresd
377    
378     install -m0755 contrib/named-bootconf/named-bootconf.sh %{buildroot}%{_sbindir}/named-bootconf
379     install -m0755 contrib/queryperf/queryperf %{buildroot}%{_bindir}/
380     cp contrib/queryperf/README README.queryperf
381    
382     install -m0755 contrib/query-loc-*/query-loc %{buildroot}%{_bindir}/
383     install -m0644 contrib/query-loc-*/query-loc.1 %{buildroot}%{_mandir}/man1/
384     cp contrib/query-loc-*/ADDRESSES ADDRESSES.query-loc
385     cp contrib/query-loc-*/ALGO ALGO.query-loc
386     cp contrib/query-loc-*/README README.query-loc
387     cp contrib/query-loc-*/USAGE USAGE.query-loc
388    
389    
390     install -m0755 named.init %{buildroot}%{_initrddir}/named
391     install -m0644 named.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/named
392    
393     %if %{sdb_ldap}
394     install -m0755 zone2ldap/zone2ldap %{buildroot}%{_bindir}/zonetoldap
395     install -m0644 zone2ldap/zone2ldap.1 %{buildroot}%{_mandir}/man1/zonetoldap.1
396     install -m0755 ldap2zone/ldap2zone %{buildroot}%{_bindir}/ldap2zone
397     %endif
398    
399     %if %{sdb_mysql}
400     install -m0755 contrib/sdb/mysql/zonetodb %{buildroot}%{_bindir}/
401     cp contrib/sdb/mysql/ChangeLog contrib/sdb/mysql/ChangeLog.mysql
402     cp contrib/sdb/mysql/README contrib/sdb/mysql/README.mysql
403     %endif
404    
405     install -m0755 dns-keygen %{buildroot}%{_sbindir}/dns-keygen
406    
407     # make the chroot
408     install -d %{buildroot}/var/lib/named/{dev,etc}
409     install -d %{buildroot}/var/lib/named/var/{log,run,tmp}
410     install -d %{buildroot}/var/lib/named/var/named/{master,slaves,reverse}
411    
412     install -m 644 \
413     caching-nameserver/named.conf \
414     caching-nameserver/logging.conf \
415     caching-nameserver/trusted_networks_acl.conf \
416     caching-nameserver/hosts \
417     caching-nameserver/bogon_acl.conf \
418     %{buildroot}/var/lib/named/etc
419     install -m 640 \
420     caching-nameserver/rndc.conf\
421     caching-nameserver/rndc.key \
422     %{buildroot}/var/lib/named/etc
423     install -m 644 \
424     caching-nameserver/localdomain.zone \
425     caching-nameserver/localhost.zone \
426     %{buildroot}/var/lib/named/var/named/master
427     install -m 644 \
428     caching-nameserver/named.broadcast \
429     caching-nameserver/named.ip6.local \
430     caching-nameserver/named.local \
431     caching-nameserver/named.zero \
432     %{buildroot}/var/lib/named/var/named/reverse
433    
434     # fix some compat symlinks
435     ln -s /var/lib/named/etc/named.conf %{buildroot}%{_sysconfdir}/named.conf
436     ln -s /var/lib/named/etc/rndc.conf %{buildroot}%{_sysconfdir}/rndc.conf
437     ln -s /var/lib/named/etc/rndc.key %{buildroot}%{_sysconfdir}/rndc.key
438     mv %{buildroot}%{_sysconfdir}/bind.keys %{buildroot}/var/lib/named/etc/
439     ln -s /var/lib/named/etc/bind.keys %{buildroot}%{_sysconfdir}/bind.keys
440    
441     echo "; Use \"dig @A.ROOT-SERVERS.NET . ns\" to update this file if it's outdated." > named.cache.tmp
442     cat named.cache >> named.cache.tmp
443     install -m0644 named.cache.tmp %{buildroot}/var/lib/named/var/named/named.ca
444    
445     # fix man pages
446     install -m0644 man5/resolver.5 %{buildroot}%{_mandir}/man5/
447     ln -s resolver.5 %{buildroot}%{_mandir}/man5/resolv.5
448    
449     # the following 3 lines is needed to make it short-circuit compliant.
450     pushd doc
451     rm -rf html
452     popd
453    
454     install -d doc/html
455     cp -f `find . -type f |grep html |sed -e 's#\/%{name}-%{version}##'|grep -v contrib` doc/html
456    
457     %multiarch_binaries %{buildroot}%{_bindir}/isc-config.sh
458    
459     cat > README.urpmi << EOF
460     The most significant changes starting from the bind-9.3.2-5mdk package:
461    
462     o Installs in a chroot environment per default (/var/lib/named) for
463     security measures.
464    
465     o Acts as a caching only resolver per default, ip addresses that should be
466     allowed to use recursive lookups must be defined in the
467     /var/lib/named/etc/trusted_networks_acl.conf file.
468     EOF
469    
470     %pre
471     %_pre_useradd named /var/lib/named /bin/false
472    
473     # check if bind is chrooted and try to restore it
474     if [ -x %{_sbindir}/bind-chroot.sh ]; then
475     ROOTDIR="/var/lib/named-chroot"
476     [ -f /etc/sysconfig/named ] && . /etc/sysconfig/named
477     if [ -d $ROOTDIR -a ! -d /var/lib/named ]; then
478     echo "old chroot found at $ROOTDIR, copying to /var/lib/named"
479     cp -rp $ROOTDIR /var/lib/named
480     chown -R named:named /var/lib/named
481     fi
482     if grep -q "$ROOTDIR" /etc/sysconfig/syslog; then
483     if [ -f /var/lock/subsys/named ]; then
484     service named stop > /dev/null 2>/dev/null || :
485     fi
486     %{_sbindir}/bind-chroot.sh --unchroot > /dev/null 2>/dev/null || :
487     fi
488     if [ -f /var/lock/subsys/syslog ]; then
489     service syslog restart > /dev/null 2>/dev/null || :
490     fi
491     fi
492    
493     DATE=`date +%%Y%%m%%d%%j%%S`
494     for f in named.conf rndc.conf rndc.key; do
495     # move away files to prepare for softlinks
496     if [ -f /etc/$f -a ! -h /etc/$f ]; then mv -vf /etc/$f /etc/$f.$DATE; fi
497     if [ -f /etc/$f -a ! -h /etc/$f ]; then mv -vf /etc/$f /etc/$f.$DATE; fi
498     if [ -f /etc/$f -a ! -h /etc/$f ]; then mv -vf /etc/$f /etc/$f.$DATE; fi
499     done
500    
501     %post
502     if grep -q "_MY_KEY_" /var/lib/named/etc/rndc.conf /var/lib/named/etc/rndc.key; then
503     MYKEY="`%{_sbindir}/dns-keygen`"
504     perl -pi -e "s|_MY_KEY_|$MYKEY|g" /var/lib/named/etc/rndc.conf /var/lib/named/etc/rndc.key
505     fi
506    
507     %_post_service named
508    
509     %preun
510     %_preun_service named
511    
512     %postun
513     %_postun_userdel named
514    
515     %files
516     %doc CHANGES README FAQ COPYRIGHT README.urpmi
517     %if %{sdb_ldap}
518     %doc contrib/sdb/ldap/README.ldap contrib/sdb/ldap/INSTALL.ldap
519     %endif
520     %if %{sdb_mysql}
521     %doc contrib/sdb/mysql/ChangeLog.mysql contrib/sdb/mysql/README.mysql
522     %endif
523     %if %{geoip}
524     %doc geodns.INSTALL geodns.named.conf-sample
525     %endif
526     %config(noreplace) %{_sysconfdir}/sysconfig/named
527     %{_initrddir}/named
528     %{_sbindir}/arpaname
529     %{_sbindir}/ddns-confgen
530     %{_sbindir}/dns-keygen
531     %{_sbindir}/dnssec-dsfromkey
532     %{_sbindir}/dnssec-keyfromlabel
533     %{_sbindir}/dnssec-keygen
534     %{_sbindir}/dnssec-revoke
535     %{_sbindir}/dnssec-settime
536     %{_sbindir}/dnssec-signzone
537     %{_sbindir}/genrandom
538     %{_sbindir}/isc-hmac-fixup
539     %{_sbindir}/lwresd
540     %{_sbindir}/named
541     %{_sbindir}/named-bootconf
542     %{_sbindir}/named-checkconf
543     %{_sbindir}/named-checkzone
544     %{_sbindir}/named-compilezone
545     %{_sbindir}/named-journalprint
546     %{_sbindir}/nsec3hash
547     %{_sbindir}/rndc
548     %{_sbindir}/rndc-confgen
549     %{_mandir}/man1/arpaname.1.*
550     %{_mandir}/man5/named.conf.5*
551     %{_mandir}/man5/rndc.conf.5*
552     %{_mandir}/man8/ddns-confgen.8.*
553     %{_mandir}/man8/dnssec-*.8*
554     %{_mandir}/man8/genrandom.8.*
555     %{_mandir}/man8/isc-hmac-fixup.8.*
556     %{_mandir}/man8/lwresd.8*
557     %{_mandir}/man8/named-*.8*
558     %{_mandir}/man8/named.8*
559     %{_mandir}/man8/nsec3hash.8.*
560     %{_mandir}/man8/rndc.8*
561     %{_mandir}/man8/rndc-confgen.8*
562     # the chroot
563     %dir /var/lib/named
564     %dir /var/lib/named/dev
565     %dir /var/lib/named/etc
566     %dir /var/lib/named/var
567     %dir /var/lib/named/var/named
568     %attr(-,named,named) %dir /var/lib/named/var/log
569     %attr(-,named,named) %dir /var/lib/named/var/run
570     %attr(-,named,named) %dir /var/lib/named/var/tmp
571     %attr(-,named,named) %dir /var/lib/named/var/named/master
572     %attr(-,named,named) %dir /var/lib/named/var/named/slaves
573     %attr(-,named,named) %dir /var/lib/named/var/named/reverse
574     %config(noreplace) /var/lib/named/etc/named.conf
575     %attr(-,root,named) %config(noreplace) /var/lib/named/etc/bind.keys
576     %attr(-,root,named) %config(noreplace) /var/lib/named/etc/rndc.conf
577     %attr(-,root,named) %config(noreplace) /var/lib/named/etc/rndc.key
578     %{_sysconfdir}/bind.keys
579     %{_sysconfdir}/named.conf
580     %{_sysconfdir}/rndc.conf
581     %{_sysconfdir}/rndc.key
582     %config(noreplace) /var/lib/named/etc/bogon_acl.conf
583     %config(noreplace) /var/lib/named/etc/logging.conf
584     %config(noreplace) /var/lib/named/etc/trusted_networks_acl.conf
585     %config(noreplace) /var/lib/named/etc/hosts
586     %config(noreplace) /var/lib/named/var/named/master/localdomain.zone
587     %config(noreplace) /var/lib/named/var/named/master/localhost.zone
588     %config(noreplace) /var/lib/named/var/named/reverse/named.broadcast
589     %config(noreplace) /var/lib/named/var/named/reverse/named.ip6.local
590     %config(noreplace) /var/lib/named/var/named/reverse/named.local
591     %config(noreplace) /var/lib/named/var/named/reverse/named.zero
592     %config(noreplace) /var/lib/named/var/named/named.ca
593    
594     %files devel
595     %doc CHANGES README
596     %multiarch %{multiarch_bindir}/isc-config.sh
597     %{_bindir}/isc-config.sh
598     %{_includedir}/*
599     %{_libdir}/*.a
600     %{_mandir}/man1/isc-config.sh.1*
601     %{_mandir}/man3/lwres*.3*
602    
603     %files utils
604     %doc README COPYRIGHT *.query-loc *.queryperf
605     %{_bindir}/dig
606     %{_bindir}/host
607     %{_bindir}/nslookup
608     %{_bindir}/nsupdate
609     %{_bindir}/queryperf
610     %{_bindir}/query-loc
611     %{_mandir}/man1/host.1*
612     %{_mandir}/man1/dig.1*
613     %{_mandir}/man1/nslookup.1*
614     %{_mandir}/man1/nsupdate.1*
615     %{_mandir}/man1/query-loc.1*
616     %if %{sdb_ldap}
617     %doc zone2ldap/zone2ldap.README ldap2zone/README.ldap2zone ldap2zone/dnszone-schema.txt
618     %{_bindir}/zonetoldap
619     %{_bindir}/ldap2zone
620     %{_mandir}/man1/zonetoldap.1*
621     %endif
622     %{_mandir}/man5/resolver.5*
623     %{_mandir}/man5/resolv.5*
624    
625     %files doc
626     %doc doc/draft doc/html doc/rfc doc/misc/
627     %doc doc/dhcp-dynamic-dns-examples doc/chroot doc/trustix
628    

  ViewVC Help
Powered by ViewVC 1.1.30