/[packages]/cauldron/black-hole-solver/current/SPECS/black-hole-solver.spec
ViewVC logotype

Contents of /cauldron/black-hole-solver/current/SPECS/black-hole-solver.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1395137 - (show annotations) (download)
Wed Apr 24 11:34:10 2019 UTC (5 years ago) by shlomif
File size: 3580 byte(s)
- remove unused BRs
1 %define basen black-hole-solver
2 %define libname_orig lib%{basen}
3 %define major 1
4 %define libname %mklibname %{basen} %{major}
5 %define develname %mklibname %{basen} -d
6 %define staticname %mklibname %{basen} -d -s
7
8 Name: %{basen}
9 Version: 0.20.0
10 Release: %mkrel 3
11 License: MIT
12 Group: Games/Cards
13 Source0: https://fc-solve.shlomifish.org/downloads/fc-solve/%{basen}-%{version}.tar.xz
14 URL: https://www.shlomifish.org/open-source/projects/black-hole-solitaire-solver/
15 Requires: %{libname} = %version-%release
16 Summary: The Black Hole Solitaire Solver Executable
17 BuildRequires: cmake
18 BuildRequires: perl(Carp)
19 BuildRequires: perl(Cwd)
20 BuildRequires: perl(Data::Dumper)
21 BuildRequires: perl(Dir::Manifest)
22 BuildRequires: perl(Env::Path)
23 BuildRequires: perl(File::Path)
24 BuildRequires: perl(File::Spec)
25 BuildRequires: perl(Inline)
26 BuildRequires: perl(Inline::C)
27 BuildRequires: perl(List::MoreUtils)
28 BuildRequires: perl(Path::Tiny)
29 BuildRequires: perl(Test::Differences)
30 BuildRequires: perl(Test::More)
31 BuildRequires: perl(Test::RunValgrind)
32 BuildRequires: perl(Test::Trap)
33 BuildRequires: perl(base)
34 BuildRequires: perl(lib)
35 BuildRequires: perl(strict)
36 BuildRequires: perl(warnings)
37 BuildRequires: perl-devel
38 BuildRequires: python3
39 BuildRequires: valgrind
40
41 %description
42 This is a solver, written in C, to solve the Solitaire variants “Golf”,
43 “Black Hole” and “All in a Row”. It provides a portable C library, and
44 a command line application that after being fed with a layout will emit the
45 cards to move.
46
47 %files
48 %doc COPYING NEWS README.md TODO.quicktask
49 %_bindir/black-hole-solve
50 %{_mandir}/*/*
51
52 #--------------------------------------------------------------------
53
54 %package -n %{libname}
55 Summary: The Black Hole Solver dynamic libraries
56 Group: Games/Cards
57
58 %description -n %{libname}
59 Contains the Black Hole Solver libraries that are used by some programs.
60
61 This package is mandatory for the Black Hole Solver executable too.
62
63 %files -n %{libname}
64 %{_libdir}/libblack_hole_solver.so.%{major}{,.*}
65 %{_libdir}/libblack_hole_solver.so.%{major}
66
67 #--------------------------------------------------------------------
68
69 %package -n %{develname}
70 Summary: The Black Hole Solitaire development tools
71 Group: Games/Cards
72 Requires: %{libname} = %version-%release
73 Provides: %{name}-devel = %{version}-%{release}
74
75 %description -n %{develname}
76 Development tools for the Black Hole Solitaire Solver.
77
78 %files -n %{develname}
79 %_includedir/black-hole-solver/*.h
80 %{_libdir}/pkgconfig/*.pc
81 %{_libdir}/libblack_hole_solver.so
82
83 #--------------------------------------------------------------------
84
85 %package -n %{staticname}
86 Summary: The Freecell Solver static libraries
87 Group: Games/Cards
88 Requires: %{develname} = %version-%release
89
90 %description -n %{staticname}
91 Black Hole Solitaire Solver is a library for automatically solving boards of
92 Golf, Black Hole, and All in a Row solitaires. This package contains the static
93 libraries.
94
95 It is not generally required.
96
97 %files -n %{staticname}
98 %{_libdir}/libblack_hole_solver.a
99
100 #--------------------------------------------------------------------
101
102 %prep
103 %setup -q
104 %autopatch -p1
105
106 %build
107 # The game limit flags are recommended by the PySolFC README.
108 %cmake -DLOCALE_INSTALL_DIR=%{_datadir}/locale -DLIB_INSTALL_DIR=%{_libdir}
109 %make_build
110
111 %check
112 %ifarch %arm
113 # valgrind suppression not working without glibc-debuginfo breaks it
114 rm -f t/valgrind.t
115 %endif
116 rm -f t/clang-format.t
117 rm -f t/perltidy.t
118 # fails due to build containing binaries
119 rm -f t/style-trailing-space.t
120 cd build
121 # %%make_build test
122 %__perl ../run-tests.pl
123
124 %install
125 %{make_install} -C build

  ViewVC Help
Powered by ViewVC 1.1.30