/[packages]/cauldron/cheese/current/SPECS/cheese.spec
ViewVC logotype

Annotation of /cauldron/cheese/current/SPECS/cheese.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 140137 - (hide annotations) (download)
Tue Sep 6 23:11:08 2011 UTC (12 years, 7 months ago) by tv
File size: 4610 byte(s)
library majors got bumped
1 tv 140137 %define major 20
2     %define cheesemajor 2
3 ennael 60054
4 wally 118520 %define libname %mklibname %{name}-gtk %{major}
5     %define develname %mklibname -d %{name}-gtk
6    
7     %define girmajor 3.0
8     %define girname %mklibname %{name}-gtk-gir %{girmajor}
9    
10 ennael 60054 Name: cheese
11 tv 140110 Version: 3.1.91.1
12 fwang 139374 Release: %mkrel 1
13 ennael 60054 Summary: A GNOME application for taking pictures and videos from a webcam
14     License: GPLv2+
15     Group: Video
16     URL: http://www.gnome.org/projects/cheese/
17 tv 139390 Source: ftp://ftp.gnome.org/pub/GNOME/sources/cheese/3.1/%{name}-%{version}.tar.xz
18 wally 118520 BuildRequires: glib2-devel >= 2.28.0
19     BuildRequires: libgdk_pixbuf2.0-devel
20     BuildRequires: libgudev-devel
21     BuildRequires: libgstreamer-devel >= 0.10.32
22     BuildRequires: libgstreamer0.10-plugins-base-devel >= 0.10.32
23     BuildRequires: cairo-devel >= 1.10.0
24     BuildRequires: pango-devel >= 1.28.0
25     BuildRequires: clutter-devel >= 1.6.1
26     BuildRequires: clutter-gst-devel >= 0.91.8
27     BuildRequires: libmx-devel
28     BuildRequires: gobject-introspection-devel >= 0.6.7
29     BuildRequires: gtk-doc >= 1.14
30     BuildRequires: gnome-doc-utils >= 0.20
31     BuildRequires: gtk+3-devel >= 0.91.8
32     BuildRequires: gnome-desktop3-devel >= 2.91.6
33     BuildRequires: librsvg2-devel >= 2.32.0
34     BuildRequires: clutter-gtk-devel >= 0.91.8
35     BuildRequires: libgee-devel >= 0.6.0
36     BuildRequires: libcanberra-gtk-devel >= 0.26
37     BuildRequires: gnome-video-effects
38     BuildRequires: dbus-glib-devel
39     BuildRequires: libcanberra-devel
40     BuildRequires: libxxf86vm-devel
41 fwang 139380 BuildRequires: libxtst-devel
42 wally 118520 BuildRequires: desktop-file-utils
43     BuildRequires: intltool
44     BuildRequires: gnome-common
45     Requires: gnome-video-effects
46    
47 ennael 60054 # TODO update features once added upstream
48     %description
49     Cheese is a Photobooth-inspired GNOME application for taking pictures and
50     videos from a webcam. It also includes fancy graphical effects based on
51     the gstreamer-backend.
52    
53 wally 118520 %package -n %{libname}
54     Group: System/Libraries
55     Summary: Shared library part of %{name}
56 ennael 60054
57 wally 118520 %description -n %{libname}
58 ennael 60054 Cheese is a Photobooth-inspired GNOME application for taking pictures and
59     videos from a webcam. It also includes fancy graphical effects based on
60     the gstreamer-backend.
61    
62 wally 118520 %package -n %{develname}
63     Group: Development/C
64     Summary: Developent files for %{name}
65     Requires: %{libname} = %{version}-%{release}
66     Provides: lib%{name}-gtk-devel = %{version}-%{release}
67     Provides: lib%{name}-devel = %{version}-%{release}
68     Provides: %{name}-devel = %{version}-%{release}
69 ennael 60054
70 wally 118520 %description -n %{develname}
71 ennael 60054 Cheese is a Photobooth-inspired GNOME application for taking pictures and
72     videos from a webcam. It also includes fancy graphical effects based on
73     the gstreamer-backend.
74    
75 wally 118520 %package -n %{girname}
76     Summary: GObject Introspection interface description for %{name}
77     Group: System/Libraries
78 wally 118524 Provides: %{mklibname %{name}-gir %{girmajor}} = %{version}-%{release}
79 wally 118520 Requires: %{libname} = %{version}-%{release}
80    
81     %description -n %{girname}
82     GObject Introspection interface description for %{name}.
83    
84 ennael 60054 %prep
85     %setup -q
86    
87     %build
88 wally 118520 autoreconf -vf
89     %configure2_5x --disable-static
90 ennael 60054 %make
91    
92     %install
93 wally 118520 rm -rf %{buildroot}
94 ennael 60054 %makeinstall_std
95    
96 wally 118520 #we don't want these
97     find %{buildroot} -name '*.la' -exec rm -f {} ';'
98    
99 ennael 60054 %find_lang %{name} --with-gnome --all-name
100    
101     %define launchers %{_sysconfdir}/dynamic/launchers/webcam
102 wally 118520
103 ennael 60054 # dynamic support
104 wally 118520 mkdir -p %{buildroot}%{launchers}
105     cat > %{buildroot}%{launchers}/%name.desktop << EOF
106 ennael 60054 [Desktop Entry]
107     Name=Webcam Photobooth
108     Comment=Cheese Webcam Photobooth using \$devicename
109 wally 118520 TryExec=cheese
110     Exec=cheese
111 ennael 60054 Terminal=false
112     Icon=cheese
113     Type=Application
114     StartupNotify=true
115     EOF
116    
117     %clean
118     rm -rf %{buildroot}
119    
120     %post
121 wally 118520 update-alternatives --install %{launchers}/kde.desktop webcam.kde.dynamic %{launchers}/%name.desktop 60
122     update-alternatives --install %{launchers}/gnome.desktop webcam.gnome.dynamic %{launchers}/%name.desktop 60
123 ennael 60054
124     %postun
125     if [ "$1" = "0" ]; then
126 wally 118520 update-alternatives --remove webcam.kde.dynamic %{launchers}/%name.desktop
127     update-alternatives --remove webcam.gnome.dynamic %{launchers}/%name.desktop
128 ennael 60054 fi
129    
130     %files -f %{name}.lang
131     %defattr(-,root,root)
132 wally 118520 %config(noreplace) %{launchers}/*.desktop
133 ennael 60054 %{_bindir}/*
134     %{_datadir}/%{name}
135     %{_datadir}/icons/hicolor/*/apps/*
136     %{_datadir}/applications/*
137 wally 118520 %{_datadir}/glib-2.0/schemas/org.gnome.Cheese.gschema.xml
138 ennael 60054
139 wally 118520 %files -n %{libname}
140 ennael 60054 %defattr(-,root,root)
141 wally 118520 %{_libdir}/lib%{name}-gtk.so.%{major}*
142     %{_libdir}/lib%{name}.so.%{cheesemajor}*
143 ennael 60054
144 wally 118520 %files -n %{girname}
145 ennael 60054 %defattr(-,root,root)
146 wally 118520 %{_libdir}/girepository-1.0/Cheese-%{girmajor}.typelib
147 ennael 60054
148 wally 118520 %files -n %{develname}
149     %defattr(-,root,root)
150     %{_includedir}/%{name}
151     %{_libdir}/lib%{name}-gtk.so
152     %{_libdir}/lib%{name}.so
153     %{_libdir}/pkgconfig/%{name}.pc
154     %{_libdir}/pkgconfig/%{name}-gtk.pc
155     %{_datadir}/gtk-doc/html/%{name}/
156     %{_datadir}/gir-1.0/Cheese-%{girmajor}.gir

  ViewVC Help
Powered by ViewVC 1.1.30