1 |
Name: chirp |
2 |
Version: 20230130 |
3 |
Release: %mkrel 1 |
4 |
Summary: A tool for programming radio equipment |
5 |
Group: Communications/Radio |
6 |
License: GPLv3+ |
7 |
URL: https://chirp.danplanet.com/projects/chirp/wiki/Download |
8 |
Source0: https://trac.%{name}.danplanet.com/%{name}_next/next-%{version}/%{name}-%{version}.tar.gz |
9 |
|
10 |
BuildArch: noarch |
11 |
|
12 |
BuildRequires: desktop-file-utils |
13 |
BuildRequires: libxml2-python3 |
14 |
BuildRequires: python3-serial |
15 |
BuildRequires: python3-six |
16 |
BuildRequires: python3-future |
17 |
|
18 |
Requires: libxml2-python3 |
19 |
Requires: python3-future |
20 |
Requires: python3-requests |
21 |
Requires: python3-serial |
22 |
Requires: python3-suds |
23 |
Requires: python3-wxpython4 |
24 |
Requires: python3-yattag |
25 |
|
26 |
%description |
27 |
CHIRP is an open-source tool for programming radio transceivers. |
28 |
It supports a large number of manufacturers and models, as well as providing |
29 |
a way to interface with multiple data sources and formats. |
30 |
|
31 |
This version is built from the chirp-next sources. |
32 |
|
33 |
%prep |
34 |
%autosetup -p1 -n %{name}-%{version} |
35 |
|
36 |
sed -i 's/chirpw/chirp/g' chirp/share/chirpw.1 |
37 |
|
38 |
%build |
39 |
%py3_build |
40 |
|
41 |
%install |
42 |
%py3_install |
43 |
|
44 |
# Desktop file |
45 |
install -d -m 755 %{buildroot}%{_datadir}/applications |
46 |
install -m 755 chirp/share/chirp.desktop %{buildroot}%{_datadir}/applications/%{name}.desktop |
47 |
|
48 |
desktop-file-install \ |
49 |
--dir=%{buildroot}%{_datadir}/applications \ |
50 |
%{buildroot}%{_datadir}/applications/%{name}.desktop |
51 |
|
52 |
# Icon |
53 |
install -d -m 755 %{buildroot}/%{_iconsdir} |
54 |
install -m 644 chirp/share/chirp.png %{buildroot}/%{_iconsdir}/chirp.png |
55 |
|
56 |
# man page |
57 |
mkdir -p %{buildroot}/%{_mandir}/man1 |
58 |
install -m 644 chirp/share/chirpw.1 %{buildroot}/%{_mandir}/man1/chirp.1 |
59 |
|
60 |
%files |
61 |
%doc COPYING |
62 |
%{_bindir}/* |
63 |
%{python3_sitelib}/%{name}/ |
64 |
%{python3_sitelib}/%{name}-* |
65 |
%{_datadir}/applications/%{name}.desktop |
66 |
%{_iconsdir}/chirp.png |
67 |
%{_mandir}/man1/chirp.1* |