/[packages]/cauldron/clutter/current/SPECS/clutter.spec
ViewVC logotype

Annotation of /cauldron/clutter/current/SPECS/clutter.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 133669 - (hide annotations) (download)
Tue Aug 16 10:41:38 2011 UTC (12 years, 7 months ago) by wally
File size: 4961 byte(s)
- try with plain make (SILENT)
1 wally 118267 %define name clutter
2 wally 133662 %define version 1.7.10
3 wally 118267 %define git 0
4 wally 129761 %define rel 1
5 wally 118267
6 pterjan 35451 %if ! %git
7 wally 118267 %define release %mkrel %{rel}
8 pterjan 35451 %else
9 wally 118267 %define release %mkrel -c %{git} %{rel}
10 pterjan 35451 %endif
11    
12 wally 118267 %define api 1.0
13     %define major 0
14     %define girmajor 1.0
15 pterjan 35451
16 wally 118699 %define libname %mklibname %{name}-glx %{api} %{major}
17     %define libnamedevel %mklibname -d %{name}-glx %{api}
18 wally 119846 %define girname %mklibname %{name}-glx-gir %{girmajor}
19 wally 118267
20     Summary: Software library for fast, visually rich GUIs
21     Name: %{name}
22     Version: %{version}
23     Release: %{release}
24 pterjan 35451 %if %git
25 wally 118267 Source0: %{name}-%{git}.tar.bz2
26 pterjan 35451 %else
27 wally 118267 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/clutter/1.7/%{name}-%{version}.tar.xz
28 pterjan 35451 %endif
29 wally 118267 License: LGPLv2+
30     Group: Graphics
31     Url: http://clutter-project.org/
32     BuildRequires: libx11-devel
33     BuildRequires: libxext-devel
34     BuildRequires: libxcomposite-devel >= 0.4
35     BuildRequires: libxdamage-devel
36     BuildRequires: libxfixes-devel >= 3
37     BuildRequires: GL-devel
38     BuildRequires: atk-devel >= 1.17
39     BuildRequires: pango-devel >= 1.20
40     BuildRequires: glib2-devel >= 2.26.0
41     BuildRequires: libgdk_pixbuf2.0-devel >= 2.0
42     BuildRequires: libjson-glib-devel >= 0.12.0
43     BuildRequires: gobject-introspection-devel >= 0.9.5
44     BuildRequires: x11-server-xvfb
45     BuildRequires: cogl-devel
46 pterjan 35451
47     %description
48     Clutter is an open source software library for creating fast, visually rich
49     graphical user interfaces. The most obvious example of potential usage is in
50     media center type applications. We hope however it can be used for a lot more.
51    
52     Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but with an
53     API which hides the underlying GL complexity from the developer. The Clutter
54     API is intended to be easy to use, efficient and flexible.
55    
56 dmorgan 118843 #--------------------------------------------------------------------
57 pterjan 35451
58     %package i18n
59 wally 118267 Summary: Translations for %{name}
60     Group: System/Internationalization
61 pterjan 35451
62     %description i18n
63 wally 118267 This contains the translation data for %{name}.
64 pterjan 35451
65 dmorgan 118843 %files i18n -f %{name}-%{api}.lang
66    
67     #--------------------------------------------------------------------
68    
69 wally 118267 %package -n %{libname}
70     Summary: Software library for fast, visually rich GUIs
71     Group: System/Libraries
72     Requires: %{name}-i18n >= %{version}-%{release}
73 dmorgan 118843 Requires: %{girname}
74 wally 118699 Provides: %{mklibname %{name} %{api} %{major}} = %{version}-%{release}
75     Obsoletes: %{mklibname %{name} %{api} %{major}} < 1.7.4
76 pterjan 35451
77 wally 118267 %description -n %{libname}
78 pterjan 35451 Clutter is an open source software library for creating fast, visually rich
79     graphical user interfaces. The most obvious example of potential usage is in
80     media center type applications. We hope however it can be used for a lot more.
81    
82     Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but with an
83     API which hides the underlying GL complexity from the developer. The Clutter
84     API is intended to be easy to use, efficient and flexible.
85    
86 dmorgan 118843 %files -n %{libname}
87     %{_libdir}/lib%{name}-glx-%{api}.so.%{major}*
88 pterjan 35451
89 dmorgan 118843 #--------------------------------------------------------------------
90    
91 wally 118267 %package -n %{libnamedevel}
92     Summary: Development headers/libraries for %{name}
93     Group: Development/X11
94     Provides: %{name}-devel = %{version}-%{release}
95 wally 118699 Provides: %{name}-glx-devel = %{version}-%{release}
96     Provides: %{mklibname -d %{name} %{api}} = %{version}-%{release}
97     Obsoletes: %{mklibname -d %{name} %{api}} < 1.7.4
98 wally 118267 Requires: %{libname} = %{version}-%{release}
99 pterjan 35451
100 wally 118267 %description -n %{libnamedevel}
101     Development headers/libraries for %{name} (see %{libname} package)
102 pterjan 35451
103 dmorgan 118843 %files -n %{libnamedevel}
104     %{_libdir}/pkgconfig/cally-%{api}.pc
105     %{_libdir}/pkgconfig/%{name}-%{api}.pc
106     %{_libdir}/pkgconfig/%{name}-glx-%{api}.pc
107     %{_libdir}/pkgconfig/%{name}-cogl-%{api}.pc
108     %{_libdir}/pkgconfig/%{name}-x11-%{api}.pc
109     %{_libdir}/lib%{name}-glx-%{api}.so
110     %dir %{_includedir}/%{name}-%{api}
111     %{_includedir}/%{name}-%{api}/cally
112     %{_includedir}/%{name}-%{api}/%{name}
113     %{_datadir}/gir-1.0/Cally-%{girmajor}.gir
114     %{_datadir}/gir-1.0/Clutter-%{girmajor}.gir
115     %{_datadir}/gir-1.0/ClutterX11-%{girmajor}.gir
116     %{_datadir}/gtk-doc/html/cally
117     %{_datadir}/gtk-doc/html/%{name}
118 pterjan 35451
119 dmorgan 118843 #--------------------------------------------------------------------
120    
121 wally 118267 %package -n %{girname}
122     Summary: GObject Introspection interface description for %{name}
123     Group: System/Libraries
124     Requires: %{libname} = %{version}-%{release}
125 wally 119846 Conflicts: %{mklibname %{name}-glx1.0-gir 1.0} < 1.7.4-3
126 wally 118267
127     %description -n %{girname}
128     GObject Introspection interface description for %{name}.
129    
130 dmorgan 118843 %files -n %{girname}
131     %{_libdir}/girepository-1.0/Cally-%{girmajor}.typelib
132     %{_libdir}/girepository-1.0/Clutter-%{girmajor}.typelib
133     %{_libdir}/girepository-1.0/ClutterX11-%{girmajor}.typelib
134 wally 118267
135 dmorgan 118843
136     #--------------------------------------------------------------------
137    
138 pterjan 35451 %prep
139 wally 118267 %if %{git}
140     %setup -q -n %{name}
141 pterjan 35451 ./autogen.sh -V
142     %else
143     %setup -q
144     %endif
145     %apply_patches
146     #autoreconf -fi
147    
148     %build
149 wally 129761 %configure2_5x
150 wally 118267
151 pterjan 35451 #git from 20090602 does not work with parallel make
152 wally 133669 xvfb-run make V=1
153 pterjan 35451
154     %install
155 wally 118267 rm -rf %{buildroot}
156 pterjan 35451
157     %makeinstall_std
158 wally 118267 %find_lang %{name}-%{api}
159 pterjan 35451
160 wally 118267 # we don't want these
161 dmorgan 102534 find %{buildroot} -name '*.la' -exec rm -f {} ';'
162    

  ViewVC Help
Powered by ViewVC 1.1.30