/[packages]/cauldron/clutter/current/SPECS/clutter.spec
ViewVC logotype

Contents of /cauldron/clutter/current/SPECS/clutter.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 693631 - (show annotations) (download)
Thu Sep 18 00:27:22 2014 UTC (9 years, 7 months ago) by umeabot
File size: 5685 byte(s)
Rebuild to fix library dependencies
1 %define api 1.0
2 %define major 0
3 %define girmajor 1.0
4
5 %define libname %mklibname %{name} %{api} %{major}
6 %define libnamedevel %mklibname -d %{name} %{api}
7 %define girname %mklibname %{name}-gir %{girmajor}
8
9 %define url_ver %(echo %{version}|cut -d. -f1,2)
10
11 Summary: Software library for fast, visually rich GUIs
12 Name: clutter
13 Version: 1.19.8
14 Release: %mkrel 4
15 Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz
16 License: LGPLv2+
17 Group: System/Libraries
18 Url: http://clutter-project.org/
19 BuildRequires: pkgconfig(atk) >= 2.1.5
20 BuildRequires: pkgconfig(cairo-gobject) >= 1.10
21 BuildRequires: pkgconfig(cogl-1.0) >= 1.17.5
22 BuildRequires: pkgconfig(cogl-pango-1.0)
23 BuildRequires: pkgconfig(gl)
24 BuildRequires: pkgconfig(glib-2.0) >= 2.26.0
25 BuildRequires: pkgconfig(gdk-3.0)
26 BuildRequires: pkgconfig(json-glib-1.0) >= 0.12.0
27 BuildRequires: pkgconfig(pangocairo) >= 1.20
28 BuildRequires: pkgconfig(pangoft2)
29 BuildRequires: pkgconfig(x11)
30 BuildRequires: pkgconfig(xcomposite) >= 0.4
31 BuildRequires: pkgconfig(xdamage)
32 BuildRequires: pkgconfig(xext)
33 BuildRequires: pkgconfig(xfixes) >= 3
34 BuildRequires: pkgconfig(xi)
35 BuildRequires: pkgconfig(gobject-introspection-1.0) >= 0.9.5
36 # ovitters: Wayland support (evdev also needed)
37 BuildRequires: pkgconfig(wayland-client)
38 BuildRequires: pkgconfig(wayland-cursor)
39 BuildRequires: pkgconfig(wayland-server)
40 BuildRequires: pkgconfig(xkbcommon)
41 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
42 BuildRequires: pkgconfig(gudev-1.0)
43 BuildRequires: pkgconfig(libevdev)
44 BuildRequires: pkgconfig(libinput) >= 0.4.0
45
46 %description
47 Clutter is an open source software library for creating fast, visually rich
48 graphical user interfaces. The most obvious example of potential usage is in
49 media center type applications. We hope however it can be used for a lot more.
50
51 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but with an
52 API which hides the underlying GL complexity from the developer. The Clutter
53 API is intended to be easy to use, efficient and flexible.
54
55 #--------------------------------------------------------------------
56
57 %package i18n
58 Summary: Translations for %{name}
59 Group: System/Internationalization
60 BuildArch: noarch
61
62 %description i18n
63 This contains the translation data for %{name}.
64
65 %files i18n -f %{name}-%{api}.lang
66
67 #--------------------------------------------------------------------
68
69 %package -n %{libname}
70 Summary: Software library for fast, visually rich GUIs
71 Group: System/Libraries
72 Requires: %{name}-i18n >= %{version}-%{release}
73 Obsoletes: %{mklibname %{name}-glx 1.0 0} < 1.9.2
74
75 %description -n %{libname}
76 Clutter is an open source software library for creating fast, visually rich
77 graphical user interfaces. The most obvious example of potential usage is in
78 media center type applications. We hope however it can be used for a lot more.
79
80 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but with an
81 API which hides the underlying GL complexity from the developer. The Clutter
82 API is intended to be easy to use, efficient and flexible.
83
84 %files -n %{libname}
85 %{_libdir}/lib%{name}-%{api}.so.%{major}*
86 %{_libdir}/lib%{name}-glx-%{api}.so.%{major}*
87
88 #--------------------------------------------------------------------
89
90 %package -n %{libnamedevel}
91 Summary: Development headers/libraries for %{name}
92 Group: Development/X11
93 Provides: %{name}-devel = %{version}-%{release}
94 Provides: %{name}-glx-devel = %{version}-%{release}
95 Obsoletes: %{mklibname -d %{name}-glx 1.0} < 1.9.2
96 Requires: %{libname} = %{version}-%{release}
97
98 %description -n %{libnamedevel}
99 Development headers/libraries for %{name} (see %{libname} package)
100
101 %files -n %{libnamedevel}
102 %doc %{_datadir}/gtk-doc/html/cally
103 %doc %{_datadir}/gtk-doc/html/%{name}
104 %{_libdir}/pkgconfig/cally-%{api}.pc
105 %{_libdir}/pkgconfig/%{name}-%{api}.pc
106 %{_libdir}/pkgconfig/%{name}-gdk-%{api}.pc
107 %{_libdir}/pkgconfig/%{name}-glx-%{api}.pc
108 %{_libdir}/pkgconfig/%{name}-cogl-%{api}.pc
109 %{_libdir}/pkgconfig/%{name}-x11-%{api}.pc
110 %{_libdir}/pkgconfig/%{name}-wayland-%{api}.pc
111 %{_libdir}/pkgconfig/%{name}-wayland-compositor-%{api}.pc
112 %{_libdir}/pkgconfig/%{name}-egl-%{api}.pc
113 %{_libdir}/lib%{name}-%{api}.so
114 %{_libdir}/lib%{name}-glx-%{api}.so
115 %dir %{_includedir}/%{name}-%{api}
116 %{_includedir}/%{name}-%{api}/cally
117 %{_includedir}/%{name}-%{api}/%{name}
118 %{_datadir}/gir-1.0/Cally-%{girmajor}.gir
119 %{_datadir}/gir-1.0/ClutterGdk-%{girmajor}.gir
120 %{_datadir}/gir-1.0/Clutter-%{girmajor}.gir
121 %{_datadir}/gir-1.0/ClutterX11-%{girmajor}.gir
122
123 #--------------------------------------------------------------------
124
125 %package -n %{girname}
126 Summary: GObject Introspection interface description for %{name}
127 Group: System/Libraries
128 Requires: %{libname} = %{version}-%{release}
129 Obsoletes: %{mklibname %{name}-glx1.0-gir 1.0} < 1.7.4-3
130 Obsoletes: %{mklibname %{name}-glx-gir 1.0} < 1.9.2
131
132 %description -n %{girname}
133 GObject Introspection interface description for %{name}.
134
135 %files -n %{girname}
136 %{_libdir}/girepository-1.0/Cally-%{girmajor}.typelib
137 %{_libdir}/girepository-1.0/Clutter-%{girmajor}.typelib
138 %{_libdir}/girepository-1.0/ClutterX11-%{girmajor}.typelib
139 %{_libdir}/girepository-1.0/ClutterGdk-%{girmajor}.typelib
140
141 #--------------------------------------------------------------------
142
143 %prep
144 %setup -q
145 %apply_patches
146
147 %build
148 %configure2_5x \
149 --disable-static \
150 --disable-rpath \
151 --enable-introspection=yes \
152 --enable-gdk-backend=yes \
153 --enable-x11-backend=yes \
154 --enable-wayland-backend=yes \
155 --enable-wayland-compositor=yes \
156 --enable-evdev-input=yes \
157 --enable-egl-backend=yes
158 %make
159
160 %install
161 %makeinstall_std
162 %find_lang %{name}-%{api}
163
164 # we don't want these
165 find %{buildroot} -name '*.la' -delete

  ViewVC Help
Powered by ViewVC 1.1.30