/[packages]/cauldron/createrepo_c/current/SPECS/createrepo_c.spec
ViewVC logotype

Contents of /cauldron/createrepo_c/current/SPECS/createrepo_c.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1397908 - (show annotations) (download)
Wed May 15 23:32:14 2019 UTC (4 years, 10 months ago) by ngompa
File size: 3504 byte(s)
Update to 0.14.0
1 %define major 0
2 %define libname %mklibname %name %major
3 %define libname_devel %mklibname -d %name
4
5 Name: createrepo_c
6 Summary: Creates a common metadata repository
7 Group: System/Packaging
8 Version: 0.14.0
9 Release: %mkrel 1
10 License: GPLv2
11 URL: https://github.com/rpm-software-management/createrepo_c
12 Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
13
14
15 BuildRequires: bzip2-devel
16 BuildRequires: cmake
17 BuildRequires: doxygen
18 BuildRequires: pkgconfig(expat)
19 BuildRequires: file-devel
20 BuildRequires: glib2-devel >= 2.22.0
21 BuildRequires: pkgconfig(libcurl)
22 BuildRequires: pkgconfig(libxml-2.0)
23 BuildRequires: pkgconfig(openssl)
24 BuildRequires: rpm-devel >= 4.9.0
25 BuildRequires: pkgconfig(sqlite3)
26 BuildRequires: pkgconfig(liblzma)
27 BuildRequires: pkgconfig(zlib)
28 BuildRequires: bash-completion
29 BuildRequires: pkgconfig(drpm) >= 0.1.3
30 BuildRequires: pkgconfig(modulemd-2.0) >= 2.3.0
31 BuildRequires: pkgconfig(zck) >= 0.9.11
32 BuildRequires: zchunk
33
34 BuildRequires: python3-devel
35 BuildRequires: python3-nose
36 BuildRequires: python3-sphinx
37
38 Requires: %{libname}%{?_isa} = %{version}-%{release}
39
40 # prevent provides from nonstandard paths:
41 %define __provides_exclude_from ^(%{python3_sitearch}/.*\\.so)$
42
43 %description
44 C implementation of Createrepo.
45 A set of utilities (createrepo_c, mergerepo_c, modifyrepo_c)
46 for generating a common metadata repository from a directory of
47 rpm packages and maintaining it.
48
49 %package -n %{libname}
50 Summary: Library for repodata manipulation
51 Group: System/Libraries
52 # The function to create DeltaRPMs calls /usr/bin/makedeltarpm,
53 # which is part of the 'deltarpm' package
54 Requires: deltarpm
55
56 %description -n %{libname}
57 Libraries for applications using the createrepo_c library
58 for easy manipulation with a repodata.
59
60 %package -n %{libname_devel}
61 Summary: Library for repodata manipulation
62 Group: Development/C
63 Provides: %{name}-devel = %{version}-%{release}
64 Requires: pkgconfig
65 Requires: %{libname}%{?_isa} = %{version}-%{release}
66
67 %description -n %{libname_devel}
68 This package contains the createrepo_c C library and header files.
69 These development files are for easy manipulation with a repodata.
70
71 %package -n python3-%{name}
72 Summary: Python 3 bindings for the createrepo_c library
73 Group: Development/Python
74 %{?python_provide:%python_provide python3-%{name}}
75 Requires: %{libname}%{?_isa} = %{version}-%{release}
76 # Python 2 subpackage is being dropped
77 Obsoletes: python2-createrepo_c < 0.12.1
78
79 %description -n python3-createrepo_c
80 Python 3 bindings for the createrepo_c library.
81
82
83 %prep
84 %autosetup -p1
85
86 %build
87 %cmake -DPYTHON_DESIRED:FILEPATH=%{__python3}
88 %make_build
89 make doc-c
90
91 %check
92 pushd ./build
93 make tests
94 make ARGS="-V" test
95 popd
96
97 %install
98 pushd ./build
99 %make_install
100 popd
101
102
103 %files
104 %doc README.md
105 %license COPYING
106 %{_mandir}/man8/createrepo_c.8.*
107 %{_mandir}/man8/mergerepo_c.8.*
108 %{_mandir}/man8/modifyrepo_c.8.*
109 %{_mandir}/man8/sqliterepo_c.8.*
110 %{_datadir}/bash-completion/completions/
111 %{_bindir}/createrepo_c
112 %{_bindir}/mergerepo_c
113 %{_bindir}/modifyrepo_c
114 %{_bindir}/sqliterepo_c
115
116 %files -n %{libname}
117 %license COPYING
118 %{_libdir}/libcreaterepo_c.so.%{major}
119 %{_libdir}/libcreaterepo_c.so.%{major}.*
120
121 %files -n %{libname_devel}
122 %{_libdir}/libcreaterepo_c.so
123 %{_libdir}/pkgconfig/createrepo_c.pc
124 %{_includedir}/createrepo_c/
125 %license COPYING
126 %doc build/doc/html
127
128 %files -n python3-createrepo_c
129 %license COPYING
130 %{python3_sitearch}/createrepo_c/

  ViewVC Help
Powered by ViewVC 1.1.30