/[packages]/cauldron/db48/current/SPECS/db48.spec
ViewVC logotype

Contents of /cauldron/db48/current/SPECS/db48.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 273158 - (show annotations) (download)
Sat Jul 21 17:42:31 2012 UTC (11 years, 8 months ago) by colin
File size: 18520 byte(s)
Update for usrmove
1 # compatibility with legacy rpm
2 %{!?_lib:%define _lib lib}
3
4 %define __soversion 4.8
5 %define _libdb_a libdb-%{__soversion}.a
6 %define _libcxx_a libdb_cxx-%{__soversion}.a
7
8 %define libname_orig %mklibname db
9 %define libname %{libname_orig}%{__soversion}
10 %define libnamedev %{libname}-devel
11 %define libnamestatic %{libname}-static-devel
12
13 %define libdbcxx %{libname_orig}cxx%{__soversion}
14 %define libdbtcl %{libname_orig}tcl%{__soversion}
15 %define libdbjava db%{__soversion}
16
17 %define libdbnss %{libname_orig}nss%{__soversion}
18 %define libdbnssdev %{libdbnss}-devel
19
20 %ifnarch %mips %arm
21 %bcond_without java
22 %define gcj_support 1
23 %endif
24
25 # Define to build a stripped down version to use for nss libraries
26 %define build_nss 1
27
28 # Allow --with[out] nss rpm command line build
29 %{?_with_nss: %{expand: %%define build_nss 1}}
30 %{?_without_nss: %{expand: %%define build_nss 0}}
31
32 # Define to rename utilities and allow parallel installation
33 %define build_parallel 0
34
35 # Allow --with[out] parallel rpm command line build
36 %{?_with_parallel: %{expand: %%define build_parallel 1}}
37 %{?_without_parallel: %{expand: %%define build_parallel 0}}
38
39 # mutexes defaults to POSIX/pthreads/library
40 %define build_asmmutex 0
41
42 %{?_with_asmmutex: %global build_asmmutex 1}
43 %{?_without_asmmutex: %global build_asmmutex 0}
44
45 Summary: The Berkeley DB database library for C
46 Name: db48
47 Version: 4.8.30
48 Release: %mkrel 9
49 Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
50 # statically link db1 library
51 Patch0: db-4.2.52-db185.patch
52 Patch1: db-4.7.25-fix-format-errors.patch
53 Patch2: db-4.8.30-tcl-link.patch
54 # fedora patches
55 Patch101: db-4.7.25-jni-include-dir.patch
56 URL: http://www.oracle.com/technology/software/products/berkeley-db/
57 License: BSD
58 Group: System/Libraries
59 BuildRequires: %{!?_without_tcl:tcl-devel} %{!?_without_db1:db1-devel} ed libtool
60 %if %with java
61 BuildRequires: java-rpmbuild
62 BuildRequires: sharutils
63 %if %{gcj_support}
64 BuildRequires: java-gcj-compat-devel
65 %endif
66 %endif
67 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
68
69 %description
70 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
71 embedded database support for both traditional and client/server applications.
72 Berkeley DB is used by many applications, including Python and Perl, so this
73 should be installed on all systems.
74
75 %package -n %{libname}
76 Summary: The Berkeley DB database library for C
77 Group: System/Libraries
78 Requires(pre): filesystem >= 2.1.9-18
79
80 %description -n %{libname}
81 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
82 embedded database support for both traditional and client/server applications.
83 Berkeley DB is used by many applications, including Python and Perl, so this
84 should be installed on all systems.
85
86 %package -n %{libdbcxx}
87 Summary: The Berkeley DB database library for C++
88 Group: System/Libraries
89
90 %description -n %{libdbcxx}
91 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
92 embedded database support for both traditional and client/server applications.
93 Berkeley DB is used by many applications, including Python and Perl, so this
94 should be installed on all systems.
95
96 This package contains the files needed to build C++ programs which use
97 Berkeley DB.
98
99 %if %with java
100 %package -n %{libdbjava}
101 Summary: The Berkeley DB database library for C++
102 Group: System/Libraries
103
104 %description -n %{libdbjava}
105 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
106 embedded database support for both traditional and client/server applications.
107 Berkeley DB is used by many applications, including Python and Perl, so this
108 should be installed on all systems.
109
110 This package contains the files needed to build Java programs which use
111 Berkeley DB.
112
113 %package -n %{libdbjava}-javadoc
114 Summary: Javadoc for %{name}
115 Group: Development/Java
116
117 %description -n %{libdbjava}-javadoc
118 Javadoc for %{name}.
119 %endif
120
121 %if %{!?_without_tcl:1}%{?_without_tcl:0}
122 %package -n %{libdbtcl}
123 Summary: The Berkeley DB database library for TCL
124 Group: System/Libraries
125
126 %description -n %{libdbtcl}
127 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
128 embedded database support for both traditional and client/server applications.
129 Berkeley DB is used by many applications, including Python and Perl, so this
130 should be installed on all systems.
131
132 This package contains the header files, libraries, and documentation for
133 building tcl programs which use Berkeley DB.
134 %endif
135
136 %package utils
137 Summary: Command line tools for managing Berkeley DB databases
138 Group: Databases
139 %if !%{build_parallel}
140 Conflicts: db3-utils
141 Conflicts: db46-utils
142 Conflicts: db47-utils
143 %endif
144 Provides: db4-utils = %{version}-%{release}
145
146 %description utils
147 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
148 embedded database support for both traditional and client/server applications.
149 Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
150 record access methods, transactions, locking, logging, shared memory caching
151 and database recovery. DB supports C, C++, Java and Perl APIs.
152
153 This package contains command line tools for managing Berkeley DB databases.
154
155 %package -n %{libnamedev}
156 Summary: Development libraries/header files for the Berkeley DB library
157 Group: Development/Databases
158 Requires(pre): filesystem >= 2.1.9-18
159 Requires: %{libname} = %{version}-%{release}
160 %if %{!?_without_tcl:1}%{?_without_tcl:0}
161 Requires: %{libdbtcl} = %{version}-%{release}
162 %endif
163 Requires: %{libdbcxx} = %{version}-%{release}
164 %if %with java
165 Requires: %{libdbjava} = %{version}
166 %endif
167 Provides: db%{__soversion}-devel = %{version}-%{release}
168 Provides: libdb%{__soversion}-devel = %{version}-%{release}
169 Conflicts: %{libname_orig}3.3-devel %{libname_orig}4.0-devel
170 Conflicts: %{libname_orig}4.1-devel %{libname_orig}4.2-devel
171 Conflicts: %{libname_orig}4.3-devel %{libname_orig}4.4-devel
172 Conflicts: %{libname_orig}4.5-devel
173 Conflicts: %{libname_orig}4.6-devel
174 Conflicts: %{libname_orig}4.7-devel
175 Provides: db-devel = %{version}-%{release}
176 Provides: db4-devel = %{version}-%{release}
177
178 %description -n %{libnamedev}
179 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
180 embedded database support for both traditional and client/server applications.
181 Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
182 record access methods, transactions, locking, logging, shared memory caching
183 and database recovery. DB supports C, C++, Java and Perl APIs.
184
185 This package contains the header files, libraries, and documentation for
186 building programs which use Berkeley DB.
187
188 %package -n %{libnamestatic}
189 Summary: Development static libraries files for the Berkeley DB library
190 Group: Development/Databases
191 Requires: db%{__soversion}-devel = %{version}-%{release}
192 Provides: db%{__soversion}-static-devel = %{version}-%{release}
193 Provides: libdb%{__soversion}-static-devel = %{version}-%{release}
194 Conflicts: %{libname_orig}3.3-static-devel %{libname_orig}4.0-static-devel
195 Conflicts: %{libname_orig}4.1-static-devel %{libname_orig}4.2-static-devel
196 Conflicts: %{libname_orig}4.3-static-devel %{libname_orig}4.4-static-devel
197 Conflicts: %{libname_orig}4.5-static-devel
198 Conflicts: %{libname_orig}4.6-static-devel
199 Conflicts: %{libname_orig}4.7static-devel
200 Provides: db-static-devel = %{version}-%{release}
201 Provides: db4-static-devel = %{version}-%{release}
202
203 %description -n %{libnamestatic}
204 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
205 embedded database support for both traditional and client/server applications.
206 Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
207 record access methods, transactions, locking, logging, shared memory caching
208 and database recovery. DB supports C, C++, Java and Perl APIs.
209
210 This package contains the static libraries for building programs which
211 use Berkeley DB.
212
213 %if %{build_nss}
214 %package -n %{libdbnss}
215 Summary: The Berkeley DB database library for NSS modules
216 Group: System/Libraries
217
218 %description -n %{libdbnss}
219 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
220 embedded database support for both traditional and client/server applications.
221 Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
222 record access methods, transactions, locking, logging, shared memory caching
223 and database recovery. DB supports C, C++, Java and Perl APIs.
224
225 This package contains the shared library required by some nss modules
226 that use Berkeley DB.
227
228 %package -n %{libdbnssdev}
229 Summary: Development libraries/header files for building nss modules with Berkeley DB
230 Group: Development/Databases
231 Requires: %{libdbnss} = %{version}-%{release}
232 Provides: libdbnss-devel = %{version}-%{release}
233 Provides: %{_lib}dbnss-devel = %{version}-%{release}
234 Provides: db_nss-devel = %{version}-%{release}
235 Provides: libdb_nss-devel = %{version}-%{release}
236 Conflicts: %{libname_orig}nss4.2-devel
237 Conflicts: %{libname_orig}nss4.6-devel
238 Conflicts: %{libname_orig}nss4.7devel
239
240 %description -n %{libdbnssdev}
241 The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
242 embedded database support for both traditional and client/server applications.
243 Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
244 record access methods, transactions, locking, logging, shared memory caching
245 and database recovery. DB supports C, C++, Java and Perl APIs.
246
247 This package contains the header files and libraries for building nss
248 modules which use Berkeley DB.
249 %endif
250
251 %prep
252
253 %setup -q -n db-%{version}
254
255 # fix strange attribs
256 find . -type f -perm 0444 -exec chmod 644 {} \;
257
258 %{__rm} -r docs/java
259 %patch0 -p1 -b .db185
260 %patch1 -p1 -b .format
261 %patch2 -p0 -b .tcl
262
263 # fedora patches
264 %patch101 -p1 -b .jni
265
266 pushd dist
267 libtoolize --copy --force
268 cat %{_datadir}/aclocal/libtool.m4 >> aclocal.m4
269 popd
270
271 # Remove tags files which we don't need.
272 find . -name tags | xargs rm -f
273 # Define a shell function for fixing HREF references in the docs, which
274 # would otherwise break when we split the docs up into subpackages.
275 fixup_href() {
276 for doc in $@ ; do
277 chmod u+w ${doc}
278 sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
279 -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
280 -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
281 -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
282 -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
283 -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
284 -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
285 -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
286 -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
287 -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
288 -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
289 -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
290 -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
291 -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
292 -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
293 -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
294 -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
295 -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
296 touch -r ${doc} ${doc}.new
297 cat ${doc}.new > ${doc}
298 touch -r ${doc}.new ${doc}
299 rm -f ${doc}.new
300 done
301 }
302
303 set +x # XXX painful to watch
304 # Fix all of the HTML files.
305 fixup_href `find . -name "*.html"`
306 set -x # XXX painful to watch
307
308 cd dist
309 ./s_config
310
311 %build
312 CFLAGS="$RPM_OPT_FLAGS"
313 %ifarch ppc
314 CFLAGS="$CFLAGS -D_GNU_SOURCE -D_REENTRANT"
315 %endif
316 export CFLAGS
317
318 %if %with java
319 export CLASSPATH=
320 export JAVAC=%{javac}
321 export JAR=%{jar}
322 export JAVA=%{java}
323 export JAVACFLAGS="-nowarn"
324 JAVA_MAKE="JAR=%{jar} JAVAC=%{javac} JAVACFLAGS="-nowarn" JAVA=%{java}"
325 %endif
326
327 pushd build_unix
328 CONFIGURE_TOP="../dist" %configure2_5x \
329 --enable-shared --enable-static \
330 %if %{?!_without_db1:1}%{?_without_db1:0}
331 --enable-compat185 --enable-dump185 \
332 %endif
333 %if %{?!_without_tcl:1}%{?_without_tcl:0}
334 --enable-tcl --with-tcl=%{_libdir} --enable-test \
335 %endif
336 --enable-cxx \
337 %if %with java
338 --enable-java \
339 %endif
340 %if %{build_asmmutex}
341 %ifarch %{ix86}
342 --disable-posixmutexes --with-mutex=x86/gcc-assembly
343 %endif
344 %ifarch x86_64
345 --disable-posixmutexes --with-mutex=x86_64/gcc-assembly
346 %endif
347 %ifarch alpha
348 --disable-posixmutexes --with-mutex=ALPHA/gcc-assembly
349 %endif
350 %ifarch ia64
351 --disable-posixmutexes --with-mutex=ia64/gcc-assembly
352 %endif
353 %ifarch ppc
354 --disable-posixmutexes --with-mutex=PPC/gcc-assembly
355 %endif
356 %ifarch %{sunsparc}
357 --disable-posixmutexes --with-mutex=Sparc/gcc-assembly
358 %endif
359 %ifarch %mips
360 --disable-posixmutexes --with-mutex=MIPS/gcc-assembly
361 %endif
362 %ifarch %arm
363 --disable-posixmutexes --with-mutex=ARM/gcc-assembly
364 %endif
365 %else
366 --with-mutex=POSIX/pthreads/library
367 %endif
368
369 %make $JAVA_MAKE
370 %if %with java
371 pushd ../java
372 %{javadoc} -d ../docs/java `%{_bindir}/find . -name '*.java'`
373 popd
374 %endif
375 popd
376 %if %{build_nss}
377 mkdir build_nss
378 pushd build_nss
379 CONFIGURE_TOP="../dist" %configure2_5x \
380 --enable-shared --disable-static \
381 --disable-tcl --disable-cxx --disable-java \
382 --with-uniquename=_nss \
383 --enable-compat185 \
384 --disable-cryptography --disable-queue \
385 --disable-replication --disable-verify \
386 %ifarch %{ix86}
387 --disable-posixmutexes --with-mutex=x86/gcc-assembly
388 %endif
389 %ifarch x86_64
390 --disable-posixmutexes --with-mutex=x86_64/gcc-assembly
391 %endif
392 %ifarch alpha
393 --disable-posixmutexes --with-mutex=ALPHA/gcc-assembly
394 %endif
395 %ifarch ia64
396 --disable-posixmutexes --with-mutex=ia64/gcc-assembly
397 %endif
398 %ifarch ppc
399 --disable-posixmutexes --with-mutex=PPC/gcc-assembly
400 %endif
401 %ifarch %{sunsparc}
402 --disable-posixmutexes --with-mutex=Sparc/gcc-assembly
403 %endif
404 %ifarch %mips
405 --disable-posixmutexes --with-mutex=MIPS/gcc-assembly
406 %endif
407 %ifarch %arm
408 --disable-posixmutexes --with-mutex=ARM/gcc-assembly
409 %endif
410
411 %make libdb_base=libdb_nss libso_target=libdb_nss-%{__soversion}.la libdir=%{_libdir}
412 popd
413 %endif
414
415 %install
416 rm -rf %{buildroot}
417
418 make -C build_unix install_setup install_include install_lib install_utilities \
419 DESTDIR=%{buildroot} includedir=%{_includedir}/db4 \
420 emode=755
421
422 %if %{build_nss}
423 make -C build_nss install_include install_lib libdb_base=libdb_nss \
424 DESTDIR=%{buildroot} includedir=%{_includedir}/db_nss \
425 LIB_INSTALL_FILE_LIST=""
426 %endif
427
428 ln -sf db4/db.h %{buildroot}%{_includedir}/db.h
429
430 # XXX This is needed for parallel install with db4.2
431 %if %{build_parallel}
432 for F in %{buildroot}%{_bindir}/*db_* ; do
433 mv $F `echo $F | sed -e 's,db_,%{name}_,'`
434 done
435 %endif
436
437 # Move db.jar file to the correct place, and version it
438 %if %with java
439 mkdir -p %{buildroot}%{_datadir}/java
440 mv %{buildroot}%{_libdir}/db.jar %{buildroot}%{_datadir}/java/db%{__soversion}-%{version}.jar
441 (cd %{buildroot}%{_datadir}/java && for jar in *-%{version}*; do %{__ln_s} ${jar} ${jar/-%{version}/}; done)
442
443 %{__mkdir_p} %{buildroot}%{_javadocdir}/db%{__soversion}-%{version}
444 %{__cp} -a docs/java/* %{buildroot}%{_javadocdir}/db%{__soversion}-%{version}
445 %{__ln_s} db%{__soversion}-%{version} %{buildroot}%{_javadocdir}/db%{__soversion}
446
447 %if %{gcj_support}
448 %{_bindir}/aot-compile-rpm
449 %endif
450 %endif
451
452 #symlink the short libdb???.a name
453 ln -sf %{_libdb_a} %{buildroot}%{_libdir}/libdb.a
454 ln -sf %{_libcxx_a} %{buildroot}%{_libdir}/libdb_cxx.a
455 ln -sf libdb_tcl-%{__soversion}.a %{buildroot}%{_libdir}/libdb_tcl.a
456 ln -sf %{_libdb_a} %{buildroot}%{_libdir}/libdb-4.a
457 ln -sf %{_libcxx_a} %{buildroot}%{_libdir}/libdb_cxx-4.a
458 ln -sf libdb_tcl-%{__soversion}.a %{buildroot}%{_libdir}/libdb_tcl-4.a
459 %if %with java
460 ln -sf libdb_java-%{__soversion}.a %{buildroot}%{_libdir}/libdb_java.a
461 ln -sf libdb_java-%{__soversion}.a %{buildroot}%{_libdir}/libdb_java-4.a
462 %endif
463 rm -fr %{buildroot}%{_includedir}/db_nss/db_cxx.h
464
465 %clean
466 rm -rf %{buildroot}
467
468 %if %with java
469 %post -n %{libdbjava}
470 %{update_gcjdb}
471
472 %postun -n %{libdbjava}
473 %{clean_gcjdb}
474 %endif
475
476 %files -n %{libname}
477 %defattr(644,root,root,755)
478 %doc LICENSE README
479 %attr(755,root,root) %{_libdir}/libdb-%{__soversion}.so
480
481 %files -n %{libdbcxx}
482 %defattr(755,root,root)
483 %{_libdir}/libdb_cxx-%{__soversion}.so
484
485 %if %with java
486 %files -n %{libdbjava}
487 %defattr(644,root,root,755)
488 %doc docs/java
489 %doc examples_java
490 %attr(755,root,root) %{_libdir}/libdb_java-%{__soversion}.so
491 %attr(755,root,root) %{_libdir}/libdb_java-%{__soversion}_g.so
492 %{_datadir}/java/db%{__soversion}.jar
493 %{_datadir}/java/db%{__soversion}-%{version}.jar
494 %if %{gcj_support}
495 %dir %{_libdir}/gcj/%{name}
496 %{_libdir}/gcj/%{name}/*
497 %endif
498
499 %files -n %{libdbjava}-javadoc
500 %defattr(0644,root,root,0755)
501 %doc %{_javadocdir}/db%{__soversion}-%{version}
502 %doc %dir %{_javadocdir}/db%{__soversion}
503 %endif
504
505 %if %{?!_without_tcl:1}%{?_without_tcl:0}
506 %files -n %{libdbtcl}
507 %defattr(755,root,root)
508 %{_libdir}/libdb_tcl-%{__soversion}.so
509 %endif
510
511 %files utils
512 %defattr(-,root,root)
513 %{_bindir}/db*_archive
514 %{_bindir}/db*_checkpoint
515 %{_bindir}/db*_deadlock
516 %{_bindir}/db*_dump*
517 %{_bindir}/db*_hotbackup
518 %{_bindir}/db*_load
519 %{_bindir}/db*_printlog
520 %{_bindir}/db*_recover
521 %{_bindir}/db*_sql
522 %{_bindir}/db*_stat
523 %{_bindir}/db*_upgrade
524 %{_bindir}/db*_verify
525
526 %files -n %{libnamedev}
527 %defattr(644,root,root,755)
528 %doc docs/api_reference
529 %dir %{_includedir}/db4
530 %{_includedir}/db4/db.h
531 %if %{?!_without_db1:1}%{?_without_db1:0}
532 %{_includedir}/db4/db_185.h
533 %endif
534 %{_includedir}/db4/db_cxx.h
535 %{_includedir}/db.h
536 %{_libdir}/libdb.so
537 %{_libdir}/libdb-4.so
538 %{_libdir}/libdb-%{__soversion}.la
539 %{_libdir}/libdb_cxx.so
540 %{_libdir}/libdb_cxx-4.so
541 %{_libdir}/libdb_cxx-%{__soversion}.la
542 %if %{?!_without_tcl:1}%{?_without_tcl:0}
543 %{_libdir}/libdb_tcl.so
544 %{_libdir}/libdb_tcl-4.so
545 %{_libdir}/libdb_tcl-%{__soversion}.la
546 %endif
547 %if %with java
548 %{_libdir}/libdb_java.so
549 %{_libdir}/libdb_java-4.so
550 %{_libdir}/libdb_java-%{__soversion}.la
551 %endif
552
553 %files -n %{libnamestatic}
554 %defattr(644,root,root,755)
555 %{_libdir}/*.a
556
557 %if %{build_nss}
558 %files -n %{libdbnss}
559 %defattr(755,root,root)
560 %{_libdir}/libdb_nss-%{__soversion}.so
561
562 %files -n %{libdbnssdev}
563 %defattr(644,root,root,755)
564 %dir %{_includedir}/db_nss
565 %{_includedir}/db_nss/db.h
566 %if %{?!_without_db1:1}%{?_without_db1:0}
567 %{_includedir}/db_nss/db_185.h
568 %endif
569 %{_libdir}/libdb_nss.so
570 %{_libdir}/libdb_nss-4.so
571 %{_libdir}/libdb_nss-%{__soversion}.la
572 %endif
573
574
575

  ViewVC Help
Powered by ViewVC 1.1.30