/[packages]/cauldron/dssi/current/SPECS/dssi.spec
ViewVC logotype

Contents of /cauldron/dssi/current/SPECS/dssi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 197820 - (show annotations) (download)
Wed Jan 18 12:03:59 2012 UTC (12 years, 2 months ago) by mikala
File size: 3096 byte(s)
- Remove BuildRoot tag
- Remove %clean & %defattr()
- Fix LDFLAGS 

1 Summary: Disposable Soft Synth Interface examples and utilities
2 Name: dssi
3 Version: 1.1.0
4 Release: %mkrel 2
5 License: LGPLv2+
6 Group: Sound
7 URL: http://dssi.sourceforge.net/
8 Source0: http://prdownloads.sourceforge.net/dssi/%{name}-%{version}.tar.gz
9 Source1: dssi.sh.bz2
10 Source2: dssi.csh.bz2
11 BuildRequires: ladspa-devel
12 BuildRequires: liblo-devel
13 BuildRequires: libalsa-devel
14 BuildRequires: jackit-devel
15 BuildRequires: libsamplerate-devel
16 BuildRequires: libsndfile-devel
17 BuildRequires: qt4-devel
18
19 %description
20 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
21 application for software synthesis plugins with native user
22 interfaces. DSSI is an open specification developed for use in Linux
23 audio applications, although portable to other platforms. It may be
24 thought of as LADSPA-for-instruments, or something comparable to VSTi.
25
26 This package contains examples and utilities.
27
28 %package devel
29 Summary: Disposable Soft Synth Interface API
30 Group: Development/C
31 Requires: %{name} = %{version}
32 Requires: ladspa-devel
33 Requires: libalsa-devel
34
35 %description devel
36 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
37 application for software synthesis plugins with native user
38 interfaces. DSSI is an open specification developed for use in Linux
39 audio applications, although portable to other platforms. It may be
40 thought of as LADSPA-for-instruments, or something comparable to VSTi.
41
42 DSSI consists of a C language API for use by plugins and hosts, based
43 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
44 interface to host communications. The DSSI specification consists of
45 an RFC which describes the background for the proposal and defines the
46 OSC part of the specification, and a documented header file which
47 defines the C API.
48
49 %prep
50 %setup -q
51
52 %build
53 #perl -pi -e 's/\$QTDIR\/lib/\$QTDIR\/%{_lib}/g' configure.ac
54 #perl -pi -e 's/\${QTDIR}\/lib/\${QTDIR}\/%{_lib}/g' configure.ac
55 #autoreconf
56 export LDFLAGS="$LDFLAGS -lm -ldl"
57 %configure2_5x
58 %make
59
60 %install
61 rm -rf %{buildroot}
62 %makeinstall_std
63
64 install -d -m 755 %{buildroot}%{_sysconfdir}/profile.d
65 bzcat %{SOURCE1} > %{buildroot}%{_sysconfdir}/profile.d/dssi.sh
66 bzcat %{SOURCE2} > %{buildroot}%{_sysconfdir}/profile.d/dssi.csh
67 perl -pi -e "s!__LIBDIR__!%{_libdir}!" %{buildroot}%{_sysconfdir}/profile.d/dssi*sh
68
69 %files
70 %doc ChangeLog README
71 %{_bindir}/jack-dssi-host
72 %{_bindir}/dssi_analyse_plugin
73 %{_bindir}/dssi_list_plugins
74 %{_bindir}/dssi_osc_send
75 %{_bindir}/dssi_osc_update
76 %{_bindir}/karplong
77 %{_bindir}/less_trivial_synth
78 %{_bindir}/trivial_sampler
79 %{_bindir}/trivial_synth
80 %dir %{_libdir}/dssi
81 %{_libdir}/dssi/*.so
82 %{_libdir}/dssi/*.la
83 %{_libdir}/dssi/less_trivial_synth/LTS_*
84 %{_libdir}/dssi/trivial_sampler/trivial_sampler_*
85 %{_mandir}/man1/dssi_osc_send.1*
86 %{_mandir}/man1/dssi_osc_update.1*
87 %{_mandir}/man1/jack-dssi-host.1*
88 %{_mandir}/man1/dssi_analyse_plugin.1*
89 %{_mandir}/man1/dssi_list_plugins.1*
90 %config(noreplace) %attr(755,root,root) %{_sysconfdir}/profile.d/dssi*sh
91
92 %files devel
93 %doc doc/TODO doc/*.txt doc/*.html
94 %{_includedir}/dssi.h
95 %{_libdir}/pkgconfig/dssi.pc

  ViewVC Help
Powered by ViewVC 1.1.30