1 |
%define url_ver %{lua: ver = rpm.expand("%{version}"); majmin, count1 = string.gsub(ver, "^([0123456789]+%.[0123456789]+).*", "%1", 1); if count1 == 0 then print(ver); return; end; maj, count2 = string.gsub(majmin, "^([0123456789]+).*", "%1", 1); if count2 == 0 then print(majmin) elseif tonumber(majmin) < 40 then print(majmin) else print(maj) end} |
2 |
|
3 |
# don't provides plugin .sos |
4 |
%global __provides_exclude_from %{_libdir}/(nautilus|caja|nemo)/extensions-.\\.0/.*\\.so |
5 |
|
6 |
Summary: Configurable context menu for Nautilus, Caja and Nemo |
7 |
Name: filemanager-actions |
8 |
Version: 3.4 |
9 |
Release: %mkrel 5 |
10 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
11 |
License: GPLv2+ |
12 |
Group: Graphical desktop/GNOME |
13 |
Url: http://www.nautilus-actions.org/ |
14 |
BuildRequires: intltool |
15 |
BuildRequires: xsltproc |
16 |
BuildRequires: pkgconfig(gtk+-3.0) |
17 |
BuildRequires: pkgconfig(gconf-2.0) |
18 |
BuildRequires: pkgconfig(libgtop-2.0) |
19 |
BuildRequires: pkgconfig(xml2po) |
20 |
BuildRequires: pkgconfig(libcaja-extension) |
21 |
BuildRequires: pkgconfig(libnautilus-extension) |
22 |
BuildRequires: pkgconfig(libnemo-extension) |
23 |
#needed to get correct deps for na-gconf2key.sh |
24 |
BuildRequires: pdksh |
25 |
BuildRequires: scrollkeeper |
26 |
|
27 |
%description |
28 |
An extension for Nautilus, Caja and Nemo file managers which allows the user |
29 |
to add arbitrary program to be launched through the file manager popup menu |
30 |
of selected files. |
31 |
|
32 |
%package nautilus |
33 |
Summary: Configurable context menu for Nautilus |
34 |
Group: Graphical desktop/MATE |
35 |
Requires: %{name} = %{version}-%{release} |
36 |
Provides: nautilus-actions = %{version}-%{release} |
37 |
Obsoletes: nautilus-actions < 3.4 |
38 |
|
39 |
%description nautilus |
40 |
An extension for Nautilus. It allow to configure program to be launch on |
41 |
files selected into Nautilus interface. |
42 |
|
43 |
%package caja |
44 |
Summary: Configurable context menu for Caja |
45 |
Group: Graphical desktop/MATE |
46 |
Requires: %{name} = %{version}-%{release} |
47 |
|
48 |
%description caja |
49 |
An extension for Caja. It allow to configure program to be launch on |
50 |
files selected into Caja interface. |
51 |
|
52 |
%package nemo |
53 |
Summary: Configurable context menu for Nemo |
54 |
Group: Graphical desktop/Cinnamon |
55 |
Requires: %{name} = %{version}-%{release} |
56 |
|
57 |
%description nemo |
58 |
An extension for Nemo. It allow to configure program to be launch on |
59 |
files selected into Nemo interface. |
60 |
|
61 |
%package devel |
62 |
Group: Development/C |
63 |
Summary: Development files of %name |
64 |
Requires: %{name} = %{version}-%{release} |
65 |
Obsoletes: nautilus-actions-devel < 3.4 |
66 |
|
67 |
%description devel |
68 |
Install this if you want to build extensions for %{name}. |
69 |
|
70 |
%prep |
71 |
%setup -q |
72 |
|
73 |
%build |
74 |
%configure \ |
75 |
--enable-gconf \ |
76 |
--disable-schemas-install \ |
77 |
--with-nautilus \ |
78 |
--with-caja \ |
79 |
--with-nemo |
80 |
%make_build |
81 |
|
82 |
%install |
83 |
%make_install |
84 |
|
85 |
#we don't want these |
86 |
find %{buildroot} -name "*.la" -delete |
87 |
|
88 |
#let files section handle docs |
89 |
rm -rf %{buildroot}%{_defaultdocdir} |
90 |
|
91 |
%find_lang %{name} --all-name --with-gnome |
92 |
|
93 |
#more lang files |
94 |
for omf in %{buildroot}%{_datadir}/omf/*/*-??*.omf;do |
95 |
echo "%lang($(basename $omf|sed -e s/.*-// -e s/.omf//)) $(echo $omf|sed -e s!%{buildroot}!!)" >> %{name}.lang |
96 |
done |
97 |
|
98 |
%files -f %{name}.lang |
99 |
%doc AUTHORS README TODO NEWS MAINTAINERS |
100 |
%doc docs/objects-hierarchy.odg |
101 |
%{_bindir}/* |
102 |
%{_libdir}/%{name}/ |
103 |
%{_libexecdir}/%{name}/ |
104 |
%{_datadir}/%{name}/ |
105 |
%{_datadir}/icons/hicolor/*/apps/%{name}.* |
106 |
%{_datadir}/applications/fma-config-tool.desktop |
107 |
%{_datadir}/fma-config-tool/ |
108 |
|
109 |
%files nautilus |
110 |
%{_libdir}/nautilus/extensions-3.0/libfma-nautilus-*.so |
111 |
|
112 |
%files caja |
113 |
%{_libdir}/caja/extensions-2.0/libfma-caja-*.so |
114 |
|
115 |
%files nemo |
116 |
%{_libdir}/nemo/extensions-3.0/libfma-nemo-*.so |
117 |
|
118 |
%files devel |
119 |
%doc %{_datadir}/gtk-doc/html/filemanager-actions-3/ |
120 |
%{_includedir}/%{name}/ |