/[packages]/cauldron/firefox/current/SPECS/firefox.spec
ViewVC logotype

Annotation of /cauldron/firefox/current/SPECS/firefox.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 134676 - (hide annotations) (download)
Sat Aug 20 23:15:27 2011 UTC (12 years, 8 months ago) by dmorgan
File size: 14543 byte(s)
Fux nspr minimum required version
1 blino 20612 #
2     # WARNING, READ FIRST:
3     #
4     # PLEASE svn cp SOURCES FROM xulrunner SOURCES INSTEAD
5     # OF COMMITING AGAIN THE TARBALL
6     #
7     # This is a special package that needs special treatment. Due to the amount of
8     # security updates it needs, it's common to ship new upstream versions instead of patching.
9     # That means this package MUST be BUILDABLE for stable official releases.
10     # This also means only STABLE upstream releases, NO betas.
11     # This is a discussed topic. Please, do not flame it again.
12    
13 tv 133084 %define major 6.0
14 blino 20612 %define ff_epoch 0
15     # (tpg) set version HERE !!!
16 tv 133087 %define realver %{major}
17 lmenut 130942 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
18 dmorgan 127856
19 blino 20612 # (tpg) MOZILLA_FIVE_HOME
20 tv 67799 %define mozillalibdir %{_libdir}/%{name}-%{realver}
21 blino 20612 %define pluginsdir %{_libdir}/mozilla/plugins
22    
23     # libxul.so is provided by libxulrunnner2.0.
24     %define _requires_exceptions libxul.so
25    
26     # this seems fragile, so require the exact version or later (#58754)
27     %define sqlite3_version %(pkg-config --modversion sqlite3 &>/dev/null && pkg-config --modversion sqlite3 2>/dev/null || echo 0)
28 lmenut 130942 %define nss_version %(pkg-config --modversion nss &>/dev/null && pkg-config --modversion nss 2>/dev/null || echo 0)
29     %define nspr_version %(pkg-config --modversion nspr &>/dev/null && pkg-config --modversion nspr 2>/dev/null || echo 0)
30 blino 20612
31     %define _use_syshunspell 1
32    
33 ahmad 75375 #define prel 0
34     %if 0%{?prel}
35 dmorgan 74764 %define release %mkrel -c %prel 1
36 ahmad 75375 %else
37 fwang 133345 %define release %mkrel 4
38 ahmad 75375 %endif
39 blino 20612
40     Summary: Next generation web browser
41     Name: firefox
42     Version: %{realver}
43     Epoch: %{ff_epoch}
44     Release: %{release}
45     License: MPLv1+
46     Group: Networking/WWW
47 tv 45608 Url: http://www.mozilla.com/firefox/
48 ahmad 75375 %if 0%{?prel}
49 blino 20612 Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}%prel.source.tar.bz2
50 ahmad 75100 Source1: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}%prel.source.tar.bz2.asc
51 ahmad 75375 %else
52     Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}.source.tar.bz2
53     Source1: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}.source.tar.bz2.asc
54     %endif
55 blino 20612 Source4: %{name}.desktop
56     Source9: kde.js
57 dmorgan 127856
58 fwang 133091 Patch1: firefox-6.0-lang.patch
59 dmorgan 127856 Patch2: firefox-vendor.patch
60 blino 20612 Patch3: mozilla-firefox-1.5.0.6-systemproxy.patch
61     # (OpenSuse) add patch to make firefox always use /usr/bin/firefox when "make firefox
62     # the default web browser" is used fix mdv bug#58784
63 fwang 133095 Patch5: firefox-6.0-appname.patch
64 dmorgan 127856 Patch7: mozilla-firefox-run-mozilla.patch
65     Patch8: firefox-disable-check-default-browser.patch
66     Patch10: firefox-3.5.3-default-mail-handler.patch
67     # Patches for kde integration of FF
68     Patch11: firefox-kde.patch
69     Patch12: mozilla-kde.patch
70 rtp 79029
71     # patch from https://bugzilla.mozilla.org/show_bug.cgi?id=551138
72     # we'll have to use system libffi on arm because moz folks are using
73     # vfp asm which doesn't exist on non-cortex platforms
74     # src/arm/sysv.S: Assembler messages:
75     # src/arm/sysv.S:266: Error: selected processor does not support ARM mode `flddle d0,[ip]'
76     # src/arm/sysv.S:267: Error: selected processor does not support ARM mode `fldmiadgt ip,{d0-d7}'
77     # src/arm/sysv.S:307: Error: selected processor does not support ARM mode `fstseq s0,[r2]'
78     # src/arm/sysv.S:311: Error: selected processor does not support ARM mode `fstdeq d0,[r2]'
79     # src/arm/sysv.S:316: Error: selected processor does not support ARM mode `fstmiadeq r2,{d0-d3}'
80     # src/arm/sysv.S:400: Error: selected processor does not support ARM mode `fstmfdd sp!,{d0-d7}'
81     # src/arm/sysv.S:438: Error: selected processor does not support ARM mode `flds s0,[sp]'
82     # src/arm/sysv.S:441: Error: selected processor does not support ARM mode `fldd d0,[sp]'
83     # src/arm/sysv.S:450: Error: selected processor does not support ARM mode `fldmiad sp,{d0-d1}'
84     # src/arm/sysv.S:453: Error: selected processor does not support ARM mode `fldmiad sp,{d0-d3}'
85     Patch32: xulrunner_allow_to_use_system_libffi.patch
86     Patch33: xulrunner_configure_neon_check.patch
87     Patch34: xulrunner_nojit.patch
88 fwang 128523 Patch35: firefox-5.0-asciidel.patch
89 lmenut 130942
90 blino 20612 BuildRequires: gtk+2-devel
91     BuildRequires: unzip
92     BuildRequires: zip
93 fwang 133282 BuildRequires: libxinerama-devel
94 blino 20612 BuildRequires: libjpeg-devel
95     BuildRequires: zlib-devel
96     BuildRequires: glib2-devel
97     BuildRequires: libIDL2-devel
98     BuildRequires: makedepend
99 dmorgan 51554 BuildRequires: nss-devel >= 2:3.12.8
100 dmorgan 127866 BuildRequires: nss-static-devel
101 dmorgan 134676 BuildRequires: nspr-devel >= 2:4.8.9
102 blino 20612 BuildRequires: startup-notification-devel
103     BuildRequires: dbus-glib-devel
104     BuildRequires: python
105     BuildRequires: libsqlite3-devel >= 3.7.0.1-2
106 rtp 79029 %ifnarch %arm %mips
107 blino 20612 BuildRequires: valgrind
108 rtp 79029 BuildRequires: java-rpmbuild
109 dmorgan 114215 BuildRequires: yasm >= 1.0.1
110 rtp 79029 %endif
111     %ifarch %arm
112     BuildRequires: libffi-devel
113     %endif
114 blino 20612 BuildRequires: rootcerts
115     BuildRequires: libxt-devel
116     %if %_use_syshunspell
117     BuildRequires: hunspell-devel
118     %endif
119     BuildRequires: doxygen
120 ahmad 130766 # BuildRequires: xulrunner-devel >= %xulrunner_version%{?prel:-0.%prel}
121     BuildRequires: pkgconfig(libproxy-1.0)
122     BuildRequires: pkgconfig(alsa)
123 blino 20612 BuildRequires: wget
124     BuildRequires: libnotify-devel
125 ahmad 48246 BuildRequires: cairo-devel >= 1.10
126 blino 20612 BuildRequires: mesagl-devel
127 ahmad 75100 BuildRequires: libvpx-devel
128 rtp 79029 BuildRequires: autoconf2.1
129 dmorgan 127865 BuildRequires: libiw-devel
130 lmenut 130942
131 ahmad 75375 %if 0%{?prel}
132 blino 20612 Provides: %{name} = %{epoch}:%{realver}-0.%{prel}
133 ahmad 75375 %else
134     Provides: %{name} = %{epoch}:%{realver}
135 blino 20612 %endif
136 lmenut 130942 Provides: mozilla-firefox = %{epoch}:%{version}-%{release}
137 blino 20612 Provides: webclient
138 lmenut 130942
139     Requires: %{mklibname sqlite3_ 0} >= %{sqlite3_version}
140     Requires: %{mklibname nss 3} >= 2:%{nss_version}
141     Requires: %{mklibname nspr 4} >= 2:%{nspr_version}
142 blino 20612 Requires: indexhtml
143     Requires: xdg-utils
144 lmenut 130942 # fixes bug #42096
145     Requires: mailcap
146 ahmad 117223 Suggests: myspell-en_US
147     %ifarch x86_64
148     Suggests: nspluginwrapper
149     %endif
150 lmenut 130942
151 ahmad 75375 Obsoletes: firefox-ext-weave-sync
152 blino 20612
153     %description
154     The award-winning Web browser is now faster, more secure, and fully customizable
155 tv 45609 to your online life. With Firefox(R), we've added powerful new features that
156 blino 20612 make your online experience even better. It is an 'open source' product which is
157     freely available, and is acquiring a growing proportion of international web
158     browser usage.
159    
160     Firefox claims to offer a more secure web browsing experience than other products,
161     with better protection against spyware and other Internet-based security threats.
162     It includes all the standard features of a modern web browser, like Internet
163     searching, tracking recently visited sites, setting up shortcuts to favourite
164     sites, customising the software behaviour and so on. Firefox also includes
165     features like 'tabbed browsing' (opening several web sites as sections within the
166     same window) and methods for controlling pop-up windows, cookies and downloaded
167     files.
168    
169     %package devel
170     Summary: Development files for %{name}
171     Group: Development/Other
172    
173     %description devel
174     Files and macros mainly for building Firefox extensions.
175    
176     %prep
177 tv 110649 %setup -qn mozilla-release
178 dmorgan 116916 %patch1 -p1 -b .lang
179 dmorgan 127856 %patch2 -p1 -b .vendor
180 lmenut 130942 #patch3 -p1 -b .systemproxy
181     %patch5 -p1 -b .appname
182 blino 20612 # It was disabled because firefox3 hangs when using soundwrapper
183 dmorgan 127856 #patch7 -p1
184     %patch8 -p1 -b .disable-software-update
185     %patch10 -p1 -b .default-mail-handler
186 blino 20612 ## KDE INTEGRATION
187     # copy current files and patch them later to keep them in sync
188 dmorgan 127856 %patch11 -p1 -b .kde
189     %patch12 -p1 -b .kdemoz
190 blino 20612 # install kde.js
191 dmorgan 74498 install -m 644 %{SOURCE9} browser/app/profile/kde.js
192 blino 20612
193 rtp 79029 %patch32 -p1
194 fwang 133104 #patch33 -p1
195 rtp 79029 %ifarch %arm
196     %if "%{_target_cpu}" != "armv7l"
197     %patch34 -p1
198     %endif
199     %endif
200 fwang 128523 %patch35 -p1
201 rtp 79029 pushd js/src
202     autoconf-2.13
203     popd
204     autoconf-2.13
205    
206 dmorgan 127856 # needed to regenerate certdata.c
207     pushd security/nss/lib/ckfw/builtins
208     perl ./certdata.perl < /etc/pki/tls/mozilla/certdata.txt
209     popd
210    
211 blino 20612 %build
212 dmorgan 127856 export MOZCONFIG=./mozconfig
213     cat << EOF > $MOZCONFIG
214     mk_add_options MOZILLA_OFFICIAL=1
215     mk_add_options BUILD_OFFICIAL=1
216     mk_add_options MOZ_MAKE_FLAGS="%{_smp_mflags}"
217     mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
218 fwang 132978 ac_add_options --host=%{_host}
219     ac_add_options --target=%{_target_platform}
220 fwang 131970 ac_add_options --enable-optimize="%{optflags}"
221 dmorgan 127856 ac_add_options --prefix="%{_prefix}"
222     ac_add_options --libdir="%{_libdir}"
223     ac_add_options --sysconfdir="%{_sysconfdir}"
224     ac_add_options --mandir="%{_mandir}"
225     ac_add_options --includedir="%{_includedir}"
226     ac_add_options --datadir="%{_datadir}"
227     ac_add_options --with-system-nspr
228     ac_add_options --with-system-nss
229     ac_add_options --with-system-zlib
230 fwang 133280 ac_add_options --with-system-libvpx
231     ac_add_options --enable-webm
232 lmenut 130942 ac_add_options --enable-gio
233     ac_add_options --disable-gnomevfs
234 dmorgan 127856 ac_add_options --disable-installer
235     ac_add_options --disable-updater
236     ac_add_options --disable-tests
237     ac_add_options --disable-debug
238     #ac_add_options --enable-chrome-format=jar
239     #ac_add_options --enable-update-channel=beta
240     ac_add_options --enable-official-branding
241     ac_add_options --enable-libproxy
242     ac_add_options --without-system-png
243     ac_add_options --with-system-jpeg
244     ac_add_options --enable-system-cairo
245     ac_add_options --enable-system-sqlite
246 lmenut 130942 ac_add_options --enable-startup-notification
247 fwang 133282 ac_add_options --enable-xinerama
248 dmorgan 127856 ac_add_options --with-distribution-id=org.mageia
249     ac_add_options --disable-crashreporter
250 rtp 79029 %ifarch %arm
251     %if "%{_target_cpu}" != "armv7l"
252 dmorgan 127856 ac_add_options --disable-methodjit
253     ac_add_options --disable-tracejit
254 rtp 79029 %endif
255 dmorgan 127856 ac_add_options --enable-system-ffi
256 rtp 79029 %endif
257     %ifnarch %arm %mips
258 dmorgan 127856 ac_add_options --with-valgrind
259     ac_add_options --with-java-include-path=%{java_home}/include
260     ac_add_options --with-java-bin-path=%{java_home}/bin
261 rtp 79029 %endif
262 blino 20612
263 dmorgan 127856 EOF
264    
265 blino 20612 %__perl -p -i -e 's|\-0|\-9|g' config/make-jars.pl
266    
267 fwang 133345 export LDFLAGS="%ldflags"
268 dmorgan 127856 make -f client.mk build
269 blino 20612
270     %install
271 ahmad 75100 rm -rf %{buildroot}
272 blino 20612
273 dmorgan 127856 make -C %{_builddir}/obj/browser/installer STRIP=/bin/true
274 blino 20612
275 dmorgan 127856 # Copy files to buildroot
276     %{__mkdir_p} %{buildroot}%{mozillalibdir}
277     cp -rf %{_builddir}/obj/dist/firefox/* %{buildroot}%{mozillalibdir}
278 blino 20612
279 dmorgan 127856 %{__mkdir_p} %{buildroot}%{_bindir}
280     ln -sf %{mozillalibdir}/firefox %{buildroot}%{_bindir}/firefox
281     pushd %{buildroot}%{_bindir}
282     ln -sf firefox mozilla-firefox
283     popd
284 tv 110649
285 lmenut 130942 # Create and own %_libdir/mozilla/plugins & firefox extensions directories
286     %{__mkdir_p} %{buildroot}%{pluginsdir}
287     %{__mkdir_p} %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
288     %{__mkdir_p} %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
289 blino 20612
290     # (tpg) desktop entry
291     %{__mkdir_p} %{buildroot}%{_datadir}/applications
292     install -m 644 %{SOURCE4} %{buildroot}%{_datadir}/applications/%{name}.desktop
293    
294     # (tpg) icons
295 dmorgan 127856 %{__cp} %{buildroot}%{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}/%{mozillalibdir}/icons/
296 colin 130660 for i in 16 22 24 32 48 256; do
297     # (cg) Not all icon sizes are installed with make install, so just redo it here.
298 tv 133105 %{__install} -m 644 browser/branding/official/default$i.png %{buildroot}%{mozillalibdir}/chrome/icons/default/default$i.png
299 blino 20612 %{__mkdir_p} %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps
300 colin 130660 ln -sf %{mozillalibdir}/chrome/icons/default/default$i.png %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps/%{name}.png ;
301 blino 20612 done
302 colin 130660 %{__mkdir_p} %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
303     ln -sf %{mozillalibdir}/chrome/icons/default/default48.png %{buildroot}%{_liconsdir}/%{name}.png
304     ln -sf %{mozillalibdir}/chrome/icons/default/default32.png %{buildroot}%{_iconsdir}/%{name}.png
305 dmorgan 130666 ln -sf %{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}%{_miconsdir}/%{name}.png
306 blino 20612
307 dmorgan 127856 # exclusions
308     rm -f %{buildroot}%{mozillalibdir}/README.txt
309     rm -f %{buildroot}%{mozillalibdir}/removed-files
310     rm -f %{buildroot}%{mozillalibdir}/precomplete
311    
312 blino 20612 install -D -m644 browser/app/profile/prefs.js %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
313     cat << EOF >> %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
314     user_pref("browser.EULA.override", true);
315     user_pref("browser.shell.checkDefaultBrowser", false);
316 rda 76933 user_pref("browser.startup.homepage", "file:///usr/share/indexhtml/index.html");
317 blino 20612 user_pref("app.update.auto", false);
318     user_pref("app.update.enabled", false);
319     user_pref("app.update.autoInstallEnabled", false);
320 lmenut 130942 user_pref("browser.showQuitWarning", true);
321 blino 20612 EOF
322    
323 ahmad 75106 # (ahmad) these ones belonged in prefs.js (see above), remove them until it's
324     # decided what search engines to ship by default
325     #user_pref("browser.search.selectedEngine","Ask.com");
326     #user_pref("browser.search.order.1","Ask.com");
327     #user_pref("browser.search.order.2","Exalead");
328     #user_pref("browser.search.order.3","Google");
329     #user_pref("browser.search.order.4","Yahoo");
330    
331     # (ahmad) don't install these until it's decided what search engines to ship by
332     # default
333 blino 20612 # search engines
334 ahmad 75106 #cp -f %{SOURCE5} %{buildroot}%{mozillalibdir}/searchplugins/jamendo.xml
335     #cp -f %{SOURCE6} %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
336     #cp -f %{SOURCE8} %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
337 blino 20612
338 ahmad 75106 #sed -i 's/@DISTRO_VALUE@/ffx/' %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
339     #sed -i 's/@DISTRO_VALUE@//' %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
340 blino 20612
341 ahmad 130766 # use the system myspell dictionaries
342     rm -fr %{buildroot}%{mozillalibdir}/dictionaries
343     ln -s %{_datadir}/dict/mozilla %{buildroot}%{mozillalibdir}/dictionaries
344    
345 lmenut 130942 # (lm) touch and %ghost bookmarks.html to a proper uninstall
346     touch %{buildroot}%{mozillalibdir}/defaults/profile/bookmarks.html
347    
348 blino 20612 %find_lang %{name}
349    
350     mkdir -p %{buildroot}%{_sys_macros_dir}
351     cat <<FIN >%{buildroot}%{_sys_macros_dir}/%{name}.macros
352     # Macros from %{name} package
353     %%firefox_major %{major}
354     %%firefox_epoch %{ff_epoch}
355     %%firefox_version %{realver}%{?prel:-0.%prel}
356     %%firefox_mozillapath %{mozillalibdir}
357     %%firefox_pluginsdir %{pluginsdir}
358 tv 45614 %%firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
359     %%firefox_extdir %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
360 blino 20612 FIN
361    
362 ahmad 130766 %pre
363     if [ -d %{mozillalibdir}/dictionaries ]; then
364     rm -fr %{mozillalibdir}/dictionaries
365     fi
366 dmorgan 127856
367 blino 20612 %post
368     if [ ! -r /etc/sysconfig/oem ]; then
369     case `grep META_CLASS /etc/sysconfig/system` in
370     *powerpack) bookmark="mozilla-powerpack.html" ;;
371     *desktop) bookmark="mozilla-one.html";;
372     *) bookmark="mozilla-download.html";;
373     esac
374 lmenut 130942 ln -s -f ../../../../share/mga/bookmarks/mozilla/$bookmark %{mozillalibdir}/defaults/profile/bookmarks.html
375 blino 20612 fi
376    
377     %files -f %{name}.lang
378     %{_bindir}/%{name}
379     %{_bindir}/mozilla-firefox
380     %{_iconsdir}/hicolor/*/apps/*.png
381 colin 130660 %{_miconsdir}/%{name}.png
382     %{_iconsdir}/%{name}.png
383     %{_liconsdir}/%{name}.png
384 blino 20612 %{_datadir}/applications/*.desktop
385     %{_libdir}/%{name}-%{realver}*
386 lmenut 130942 %ghost %{mozillalibdir}/defaults/profile/bookmarks.html
387 blino 20612 %dir %{_libdir}/mozilla
388     %dir %{pluginsdir}
389 lmenut 130942 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
390     %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
391 blino 20612
392     %files devel
393     %{_sys_macros_dir}/%{name}.macros

  ViewVC Help
Powered by ViewVC 1.1.30