/[packages]/cauldron/firefox/current/SPECS/firefox.spec
ViewVC logotype

Annotation of /cauldron/firefox/current/SPECS/firefox.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 149306 - (hide annotations) (download)
Tue Sep 27 08:59:02 2011 UTC (12 years, 6 months ago) by fwang
File size: 14413 byte(s)
sync patch from opensuse
1 blino 20612 #
2     # WARNING, READ FIRST:
3     #
4     # PLEASE svn cp SOURCES FROM xulrunner SOURCES INSTEAD
5     # OF COMMITING AGAIN THE TARBALL
6     #
7     # This is a special package that needs special treatment. Due to the amount of
8     # security updates it needs, it's common to ship new upstream versions instead of patching.
9     # That means this package MUST be BUILDABLE for stable official releases.
10     # This also means only STABLE upstream releases, NO betas.
11     # This is a discussed topic. Please, do not flame it again.
12    
13 fwang 149188 %define major 7.0
14 blino 20612 %define ff_epoch 0
15     # (tpg) set version HERE !!!
16 fwang 149188 %define realver %{major}
17 lmenut 130942 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
18 dmorgan 127856
19 blino 20612 # (tpg) MOZILLA_FIVE_HOME
20 tv 67799 %define mozillalibdir %{_libdir}/%{name}-%{realver}
21 blino 20612 %define pluginsdir %{_libdir}/mozilla/plugins
22    
23     # libxul.so is provided by libxulrunnner2.0.
24     %define _requires_exceptions libxul.so
25    
26     # this seems fragile, so require the exact version or later (#58754)
27     %define sqlite3_version %(pkg-config --modversion sqlite3 &>/dev/null && pkg-config --modversion sqlite3 2>/dev/null || echo 0)
28 lmenut 130942 %define nss_version %(pkg-config --modversion nss &>/dev/null && pkg-config --modversion nss 2>/dev/null || echo 0)
29     %define nspr_version %(pkg-config --modversion nspr &>/dev/null && pkg-config --modversion nspr 2>/dev/null || echo 0)
30 blino 20612
31     %define _use_syshunspell 1
32    
33 ahmad 75375 #define prel 0
34     %if 0%{?prel}
35 dmorgan 74764 %define release %mkrel -c %prel 1
36 ahmad 75375 %else
37 fwang 149306 %define release %mkrel 2
38 ahmad 75375 %endif
39 blino 20612
40     Summary: Next generation web browser
41     Name: firefox
42     Version: %{realver}
43     Epoch: %{ff_epoch}
44     Release: %{release}
45     License: MPLv1+
46     Group: Networking/WWW
47 tv 45608 Url: http://www.mozilla.com/firefox/
48 ahmad 75375 %if 0%{?prel}
49 blino 20612 Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}%prel.source.tar.bz2
50 ahmad 75375 %else
51     Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}.source.tar.bz2
52     %endif
53 blino 20612 Source4: %{name}.desktop
54     Source9: kde.js
55 dmorgan 127856
56 fwang 133091 Patch1: firefox-6.0-lang.patch
57 dmorgan 127856 Patch2: firefox-vendor.patch
58 blino 20612 Patch3: mozilla-firefox-1.5.0.6-systemproxy.patch
59     # (OpenSuse) add patch to make firefox always use /usr/bin/firefox when "make firefox
60     # the default web browser" is used fix mdv bug#58784
61 fwang 133095 Patch5: firefox-6.0-appname.patch
62 fwang 149203 Patch6: firefox-7.0-fix-str-fmt.patch
63 dmorgan 127856 Patch7: mozilla-firefox-run-mozilla.patch
64     Patch8: firefox-disable-check-default-browser.patch
65     Patch10: firefox-3.5.3-default-mail-handler.patch
66     # Patches for kde integration of FF
67     Patch11: firefox-kde.patch
68     Patch12: mozilla-kde.patch
69 rtp 79029
70     # patch from https://bugzilla.mozilla.org/show_bug.cgi?id=551138
71     # we'll have to use system libffi on arm because moz folks are using
72     # vfp asm which doesn't exist on non-cortex platforms
73     # src/arm/sysv.S: Assembler messages:
74     # src/arm/sysv.S:266: Error: selected processor does not support ARM mode `flddle d0,[ip]'
75     # src/arm/sysv.S:267: Error: selected processor does not support ARM mode `fldmiadgt ip,{d0-d7}'
76     # src/arm/sysv.S:307: Error: selected processor does not support ARM mode `fstseq s0,[r2]'
77     # src/arm/sysv.S:311: Error: selected processor does not support ARM mode `fstdeq d0,[r2]'
78     # src/arm/sysv.S:316: Error: selected processor does not support ARM mode `fstmiadeq r2,{d0-d3}'
79     # src/arm/sysv.S:400: Error: selected processor does not support ARM mode `fstmfdd sp!,{d0-d7}'
80     # src/arm/sysv.S:438: Error: selected processor does not support ARM mode `flds s0,[sp]'
81     # src/arm/sysv.S:441: Error: selected processor does not support ARM mode `fldd d0,[sp]'
82     # src/arm/sysv.S:450: Error: selected processor does not support ARM mode `fldmiad sp,{d0-d1}'
83     # src/arm/sysv.S:453: Error: selected processor does not support ARM mode `fldmiad sp,{d0-d3}'
84     Patch32: xulrunner_allow_to_use_system_libffi.patch
85     Patch33: xulrunner_configure_neon_check.patch
86     Patch34: xulrunner_nojit.patch
87 fwang 128523 Patch35: firefox-5.0-asciidel.patch
88 lmenut 130942
89 blino 20612 BuildRequires: gtk+2-devel
90     BuildRequires: unzip
91     BuildRequires: zip
92 fwang 133282 BuildRequires: libxinerama-devel
93 blino 20612 BuildRequires: libjpeg-devel
94 fwang 142362 BuildRequires: libpng-devel >= 2:1.4
95 blino 20612 BuildRequires: zlib-devel
96     BuildRequires: glib2-devel
97     BuildRequires: libIDL2-devel
98     BuildRequires: makedepend
99 dmorgan 134679 BuildRequires: nss-devel >= 2:3.12.10
100 dmorgan 127866 BuildRequires: nss-static-devel
101 dmorgan 134676 BuildRequires: nspr-devel >= 2:4.8.9
102 blino 20612 BuildRequires: startup-notification-devel
103     BuildRequires: dbus-glib-devel
104     BuildRequires: python
105     BuildRequires: libsqlite3-devel >= 3.7.0.1-2
106 rtp 79029 %ifnarch %arm %mips
107 blino 20612 BuildRequires: valgrind
108 rtp 79029 BuildRequires: java-rpmbuild
109 dmorgan 114215 BuildRequires: yasm >= 1.0.1
110 rtp 79029 %endif
111     %ifarch %arm
112     BuildRequires: libffi-devel
113     %endif
114 dmorgan 137463 BuildRequires: rootcerts >= 1:20110830.00
115 blino 20612 BuildRequires: libxt-devel
116     %if %_use_syshunspell
117     BuildRequires: hunspell-devel
118     %endif
119     BuildRequires: doxygen
120 ahmad 130766 # BuildRequires: xulrunner-devel >= %xulrunner_version%{?prel:-0.%prel}
121     BuildRequires: pkgconfig(libproxy-1.0)
122     BuildRequires: pkgconfig(alsa)
123 blino 20612 BuildRequires: wget
124     BuildRequires: libnotify-devel
125 ahmad 48246 BuildRequires: cairo-devel >= 1.10
126 blino 20612 BuildRequires: mesagl-devel
127 ahmad 75100 BuildRequires: libvpx-devel
128 rtp 79029 BuildRequires: autoconf2.1
129 dmorgan 127865 BuildRequires: libiw-devel
130 lmenut 130942
131 ahmad 75375 %if 0%{?prel}
132 blino 20612 Provides: %{name} = %{epoch}:%{realver}-0.%{prel}
133 ahmad 75375 %else
134     Provides: %{name} = %{epoch}:%{realver}
135 blino 20612 %endif
136 lmenut 130942 Provides: mozilla-firefox = %{epoch}:%{version}-%{release}
137 blino 20612 Provides: webclient
138 lmenut 130942
139     Requires: %{mklibname sqlite3_ 0} >= %{sqlite3_version}
140     Requires: %{mklibname nss 3} >= 2:%{nss_version}
141     Requires: %{mklibname nspr 4} >= 2:%{nspr_version}
142 blino 20612 Requires: indexhtml
143     Requires: xdg-utils
144 lmenut 130942 # fixes bug #42096
145     Requires: mailcap
146 ahmad 117223 Suggests: myspell-en_US
147     %ifarch x86_64
148     Suggests: nspluginwrapper
149     %endif
150 lmenut 130942
151 ahmad 75375 Obsoletes: firefox-ext-weave-sync
152 blino 20612
153     %description
154     The award-winning Web browser is now faster, more secure, and fully customizable
155 tv 45609 to your online life. With Firefox(R), we've added powerful new features that
156 blino 20612 make your online experience even better. It is an 'open source' product which is
157     freely available, and is acquiring a growing proportion of international web
158     browser usage.
159    
160     Firefox claims to offer a more secure web browsing experience than other products,
161     with better protection against spyware and other Internet-based security threats.
162     It includes all the standard features of a modern web browser, like Internet
163     searching, tracking recently visited sites, setting up shortcuts to favourite
164     sites, customising the software behaviour and so on. Firefox also includes
165     features like 'tabbed browsing' (opening several web sites as sections within the
166     same window) and methods for controlling pop-up windows, cookies and downloaded
167     files.
168    
169     %package devel
170     Summary: Development files for %{name}
171     Group: Development/Other
172    
173     %description devel
174     Files and macros mainly for building Firefox extensions.
175    
176     %prep
177 tv 110649 %setup -qn mozilla-release
178 dmorgan 116916 %patch1 -p1 -b .lang
179 dmorgan 127856 %patch2 -p1 -b .vendor
180 lmenut 130942 #patch3 -p1 -b .systemproxy
181     %patch5 -p1 -b .appname
182 fwang 149203 %patch6 -p0 -b .str
183 blino 20612 # It was disabled because firefox3 hangs when using soundwrapper
184 dmorgan 127856 #patch7 -p1
185     %patch8 -p1 -b .disable-software-update
186     %patch10 -p1 -b .default-mail-handler
187 blino 20612 ## KDE INTEGRATION
188     # copy current files and patch them later to keep them in sync
189 dmorgan 127856 %patch11 -p1 -b .kde
190     %patch12 -p1 -b .kdemoz
191 blino 20612 # install kde.js
192 dmorgan 74498 install -m 644 %{SOURCE9} browser/app/profile/kde.js
193 blino 20612
194 rtp 79029 %patch32 -p1
195 fwang 133104 #patch33 -p1
196 rtp 79029 %ifarch %arm
197     %if "%{_target_cpu}" != "armv7l"
198     %patch34 -p1
199     %endif
200     %endif
201 fwang 128523 %patch35 -p1
202 rtp 79029 pushd js/src
203     autoconf-2.13
204     popd
205     autoconf-2.13
206    
207 dmorgan 127856 # needed to regenerate certdata.c
208     pushd security/nss/lib/ckfw/builtins
209     perl ./certdata.perl < /etc/pki/tls/mozilla/certdata.txt
210     popd
211    
212 blino 20612 %build
213 fwang 149200 export MOZCONFIG=`pwd`/mozconfig
214 dmorgan 127856 cat << EOF > $MOZCONFIG
215     mk_add_options MOZILLA_OFFICIAL=1
216     mk_add_options BUILD_OFFICIAL=1
217     mk_add_options MOZ_MAKE_FLAGS="%{_smp_mflags}"
218     mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
219 fwang 132978 ac_add_options --host=%{_host}
220     ac_add_options --target=%{_target_platform}
221 fwang 131970 ac_add_options --enable-optimize="%{optflags}"
222 dmorgan 127856 ac_add_options --prefix="%{_prefix}"
223     ac_add_options --libdir="%{_libdir}"
224     ac_add_options --sysconfdir="%{_sysconfdir}"
225     ac_add_options --mandir="%{_mandir}"
226     ac_add_options --includedir="%{_includedir}"
227     ac_add_options --datadir="%{_datadir}"
228     ac_add_options --with-system-nspr
229     ac_add_options --with-system-nss
230     ac_add_options --with-system-zlib
231 fwang 133280 ac_add_options --with-system-libvpx
232     ac_add_options --enable-webm
233 lmenut 130942 ac_add_options --enable-gio
234     ac_add_options --disable-gnomevfs
235 dmorgan 127856 ac_add_options --disable-installer
236     ac_add_options --disable-updater
237     ac_add_options --disable-tests
238     ac_add_options --disable-debug
239     #ac_add_options --enable-chrome-format=jar
240     #ac_add_options --enable-update-channel=beta
241     ac_add_options --enable-official-branding
242     ac_add_options --enable-libproxy
243 fwang 142362 ac_add_options --with-system-png
244 dmorgan 127856 ac_add_options --with-system-jpeg
245     ac_add_options --enable-system-cairo
246     ac_add_options --enable-system-sqlite
247 lmenut 130942 ac_add_options --enable-startup-notification
248 fwang 133282 ac_add_options --enable-xinerama
249 dmorgan 127856 ac_add_options --with-distribution-id=org.mageia
250     ac_add_options --disable-crashreporter
251 rtp 79029 %ifarch %arm
252     %if "%{_target_cpu}" != "armv7l"
253 dmorgan 127856 ac_add_options --disable-methodjit
254     ac_add_options --disable-tracejit
255 rtp 79029 %endif
256 dmorgan 127856 ac_add_options --enable-system-ffi
257 rtp 79029 %endif
258     %ifnarch %arm %mips
259 dmorgan 127856 ac_add_options --with-valgrind
260     ac_add_options --with-java-include-path=%{java_home}/include
261     ac_add_options --with-java-bin-path=%{java_home}/bin
262 rtp 79029 %endif
263 blino 20612
264 dmorgan 127856 EOF
265    
266 blino 20612 %__perl -p -i -e 's|\-0|\-9|g' config/make-jars.pl
267    
268 fwang 133345 export LDFLAGS="%ldflags"
269 dmorgan 127856 make -f client.mk build
270 blino 20612
271     %install
272 ahmad 75100 rm -rf %{buildroot}
273 blino 20612
274 dmorgan 127856 make -C %{_builddir}/obj/browser/installer STRIP=/bin/true
275 blino 20612
276 dmorgan 127856 # Copy files to buildroot
277     %{__mkdir_p} %{buildroot}%{mozillalibdir}
278     cp -rf %{_builddir}/obj/dist/firefox/* %{buildroot}%{mozillalibdir}
279 blino 20612
280 dmorgan 127856 %{__mkdir_p} %{buildroot}%{_bindir}
281     ln -sf %{mozillalibdir}/firefox %{buildroot}%{_bindir}/firefox
282     pushd %{buildroot}%{_bindir}
283     ln -sf firefox mozilla-firefox
284     popd
285 tv 110649
286 lmenut 130942 # Create and own %_libdir/mozilla/plugins & firefox extensions directories
287     %{__mkdir_p} %{buildroot}%{pluginsdir}
288     %{__mkdir_p} %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
289     %{__mkdir_p} %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
290 blino 20612
291     # (tpg) desktop entry
292     %{__mkdir_p} %{buildroot}%{_datadir}/applications
293     install -m 644 %{SOURCE4} %{buildroot}%{_datadir}/applications/%{name}.desktop
294    
295     # (tpg) icons
296 dmorgan 127856 %{__cp} %{buildroot}%{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}/%{mozillalibdir}/icons/
297 colin 130660 for i in 16 22 24 32 48 256; do
298     # (cg) Not all icon sizes are installed with make install, so just redo it here.
299 tv 133105 %{__install} -m 644 browser/branding/official/default$i.png %{buildroot}%{mozillalibdir}/chrome/icons/default/default$i.png
300 blino 20612 %{__mkdir_p} %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps
301 colin 130660 ln -sf %{mozillalibdir}/chrome/icons/default/default$i.png %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps/%{name}.png ;
302 blino 20612 done
303 colin 130660 %{__mkdir_p} %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
304     ln -sf %{mozillalibdir}/chrome/icons/default/default48.png %{buildroot}%{_liconsdir}/%{name}.png
305     ln -sf %{mozillalibdir}/chrome/icons/default/default32.png %{buildroot}%{_iconsdir}/%{name}.png
306 dmorgan 130666 ln -sf %{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}%{_miconsdir}/%{name}.png
307 blino 20612
308 dmorgan 127856 # exclusions
309     rm -f %{buildroot}%{mozillalibdir}/README.txt
310     rm -f %{buildroot}%{mozillalibdir}/removed-files
311     rm -f %{buildroot}%{mozillalibdir}/precomplete
312    
313 blino 20612 install -D -m644 browser/app/profile/prefs.js %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
314     cat << EOF >> %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
315     user_pref("browser.EULA.override", true);
316     user_pref("browser.shell.checkDefaultBrowser", false);
317 rda 76933 user_pref("browser.startup.homepage", "file:///usr/share/indexhtml/index.html");
318 blino 20612 user_pref("app.update.auto", false);
319     user_pref("app.update.enabled", false);
320     user_pref("app.update.autoInstallEnabled", false);
321 lmenut 130942 user_pref("browser.showQuitWarning", true);
322 blino 20612 EOF
323    
324 ahmad 75106 # (ahmad) these ones belonged in prefs.js (see above), remove them until it's
325     # decided what search engines to ship by default
326     #user_pref("browser.search.selectedEngine","Ask.com");
327     #user_pref("browser.search.order.1","Ask.com");
328     #user_pref("browser.search.order.2","Exalead");
329     #user_pref("browser.search.order.3","Google");
330     #user_pref("browser.search.order.4","Yahoo");
331    
332     # (ahmad) don't install these until it's decided what search engines to ship by
333     # default
334 blino 20612 # search engines
335 ahmad 75106 #cp -f %{SOURCE5} %{buildroot}%{mozillalibdir}/searchplugins/jamendo.xml
336     #cp -f %{SOURCE6} %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
337     #cp -f %{SOURCE8} %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
338 blino 20612
339 ahmad 75106 #sed -i 's/@DISTRO_VALUE@/ffx/' %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
340     #sed -i 's/@DISTRO_VALUE@//' %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
341 blino 20612
342 ahmad 130766 # use the system myspell dictionaries
343     rm -fr %{buildroot}%{mozillalibdir}/dictionaries
344     ln -s %{_datadir}/dict/mozilla %{buildroot}%{mozillalibdir}/dictionaries
345    
346 lmenut 130942 # (lm) touch and %ghost bookmarks.html to a proper uninstall
347     touch %{buildroot}%{mozillalibdir}/defaults/profile/bookmarks.html
348    
349 blino 20612 %find_lang %{name}
350    
351     mkdir -p %{buildroot}%{_sys_macros_dir}
352     cat <<FIN >%{buildroot}%{_sys_macros_dir}/%{name}.macros
353     # Macros from %{name} package
354     %%firefox_major %{major}
355     %%firefox_epoch %{ff_epoch}
356     %%firefox_version %{realver}%{?prel:-0.%prel}
357     %%firefox_mozillapath %{mozillalibdir}
358     %%firefox_pluginsdir %{pluginsdir}
359 tv 45614 %%firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
360     %%firefox_extdir %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
361 blino 20612 FIN
362    
363 ahmad 130766 %pre
364     if [ -d %{mozillalibdir}/dictionaries ]; then
365     rm -fr %{mozillalibdir}/dictionaries
366     fi
367 dmorgan 127856
368 blino 20612 %post
369     if [ ! -r /etc/sysconfig/oem ]; then
370     case `grep META_CLASS /etc/sysconfig/system` in
371     *powerpack) bookmark="mozilla-powerpack.html" ;;
372     *desktop) bookmark="mozilla-one.html";;
373     *) bookmark="mozilla-download.html";;
374     esac
375 lmenut 130942 ln -s -f ../../../../share/mga/bookmarks/mozilla/$bookmark %{mozillalibdir}/defaults/profile/bookmarks.html
376 blino 20612 fi
377    
378     %files -f %{name}.lang
379     %{_bindir}/%{name}
380     %{_bindir}/mozilla-firefox
381     %{_iconsdir}/hicolor/*/apps/*.png
382 colin 130660 %{_miconsdir}/%{name}.png
383     %{_iconsdir}/%{name}.png
384     %{_liconsdir}/%{name}.png
385 blino 20612 %{_datadir}/applications/*.desktop
386     %{_libdir}/%{name}-%{realver}*
387 lmenut 130942 %ghost %{mozillalibdir}/defaults/profile/bookmarks.html
388 blino 20612 %dir %{_libdir}/mozilla
389     %dir %{pluginsdir}
390 lmenut 130942 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
391     %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
392 blino 20612
393     %files devel
394     %{_sys_macros_dir}/%{name}.macros

  ViewVC Help
Powered by ViewVC 1.1.30