/[packages]/cauldron/firefox/current/SPECS/firefox.spec
ViewVC logotype

Annotation of /cauldron/firefox/current/SPECS/firefox.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 169617 - (hide annotations) (download)
Sun Nov 20 01:11:22 2011 UTC (12 years, 5 months ago) by dmorgan
File size: 13834 byte(s)
Disabled addon check UI (RHBZ #753551)
1 blino 20612 #
2     # WARNING, READ FIRST:
3     #
4     # PLEASE svn cp SOURCES FROM xulrunner SOURCES INSTEAD
5     # OF COMMITING AGAIN THE TARBALL
6     #
7     # This is a special package that needs special treatment. Due to the amount of
8     # security updates it needs, it's common to ship new upstream versions instead of patching.
9     # That means this package MUST be BUILDABLE for stable official releases.
10     # This also means only STABLE upstream releases, NO betas.
11     # This is a discussed topic. Please, do not flame it again.
12    
13 fwang 168118 %define major 8.0.1
14 blino 20612 %define ff_epoch 0
15     # (tpg) set version HERE !!!
16 fwang 164134 %define realver %{major}
17 lmenut 130942 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
18 dmorgan 127856
19 blino 20612 # (tpg) MOZILLA_FIVE_HOME
20 tv 67799 %define mozillalibdir %{_libdir}/%{name}-%{realver}
21 blino 20612 %define pluginsdir %{_libdir}/mozilla/plugins
22    
23     # libxul.so is provided by libxulrunnner2.0.
24     %define _requires_exceptions libxul.so
25    
26     # this seems fragile, so require the exact version or later (#58754)
27     %define sqlite3_version %(pkg-config --modversion sqlite3 &>/dev/null && pkg-config --modversion sqlite3 2>/dev/null || echo 0)
28 lmenut 130942 %define nss_version %(pkg-config --modversion nss &>/dev/null && pkg-config --modversion nss 2>/dev/null || echo 0)
29     %define nspr_version %(pkg-config --modversion nspr &>/dev/null && pkg-config --modversion nspr 2>/dev/null || echo 0)
30 blino 20612
31     %define _use_syshunspell 1
32    
33 ahmad 75375 #define prel 0
34     %if 0%{?prel}
35 dmorgan 74764 %define release %mkrel -c %prel 1
36 ahmad 75375 %else
37 doktor5000 168152 %define release %mkrel 2
38 ahmad 75375 %endif
39 blino 20612
40     Summary: Next generation web browser
41     Name: firefox
42     Version: %{realver}
43     Epoch: %{ff_epoch}
44     Release: %{release}
45     License: MPLv1+
46     Group: Networking/WWW
47 tv 45608 Url: http://www.mozilla.com/firefox/
48 ahmad 75375 %if 0%{?prel}
49 blino 20612 Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}%prel.source.tar.bz2
50 ahmad 75375 %else
51     Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}.source.tar.bz2
52     %endif
53 blino 20612 Source4: %{name}.desktop
54     Source9: kde.js
55 dmorgan 127856
56 fwang 133091 Patch1: firefox-6.0-lang.patch
57 dmorgan 127856 Patch2: firefox-vendor.patch
58 blino 20612 Patch3: mozilla-firefox-1.5.0.6-systemproxy.patch
59     # (OpenSuse) add patch to make firefox always use /usr/bin/firefox when "make firefox
60     # the default web browser" is used fix mdv bug#58784
61 fwang 133095 Patch5: firefox-6.0-appname.patch
62 fwang 149203 Patch6: firefox-7.0-fix-str-fmt.patch
63 dmorgan 127856 Patch7: mozilla-firefox-run-mozilla.patch
64     Patch8: firefox-disable-check-default-browser.patch
65     Patch10: firefox-3.5.3-default-mail-handler.patch
66     # Patches for kde integration of FF
67     Patch11: firefox-kde.patch
68     Patch12: mozilla-kde.patch
69 rtp 79029 Patch34: xulrunner_nojit.patch
70 fwang 128523 Patch35: firefox-5.0-asciidel.patch
71 dmorgan 169617 Patch36: firefox-8.0-enable-addons.patch
72 blino 20612 BuildRequires: gtk+2-devel
73     BuildRequires: unzip
74     BuildRequires: zip
75 fwang 133282 BuildRequires: libxinerama-devel
76 fwang 164134 BuildRequires: libxscrnsaver-devel
77 blino 20612 BuildRequires: libjpeg-devel
78 fwang 142362 BuildRequires: libpng-devel >= 2:1.4
79 blino 20612 BuildRequires: zlib-devel
80     BuildRequires: glib2-devel
81     BuildRequires: libIDL2-devel
82     BuildRequires: makedepend
83 dmorgan 134679 BuildRequires: nss-devel >= 2:3.12.10
84 dmorgan 127866 BuildRequires: nss-static-devel
85 dmorgan 134676 BuildRequires: nspr-devel >= 2:4.8.9
86 blino 20612 BuildRequires: startup-notification-devel
87     BuildRequires: dbus-glib-devel
88     BuildRequires: python
89     BuildRequires: libsqlite3-devel >= 3.7.0.1-2
90 rtp 79029 %ifnarch %arm %mips
91 blino 20612 BuildRequires: valgrind
92 rtp 79029 BuildRequires: java-rpmbuild
93 dmorgan 114215 BuildRequires: yasm >= 1.0.1
94 rtp 79029 %endif
95     %ifarch %arm
96     BuildRequires: libffi-devel
97     %endif
98 dmorgan 137463 BuildRequires: rootcerts >= 1:20110830.00
99 blino 20612 BuildRequires: libxt-devel
100     %if %_use_syshunspell
101     BuildRequires: hunspell-devel
102     %endif
103     BuildRequires: doxygen
104 ahmad 130766 # BuildRequires: xulrunner-devel >= %xulrunner_version%{?prel:-0.%prel}
105     BuildRequires: pkgconfig(libproxy-1.0)
106     BuildRequires: pkgconfig(alsa)
107 blino 20612 BuildRequires: wget
108     BuildRequires: libnotify-devel
109 ahmad 48246 BuildRequires: cairo-devel >= 1.10
110 blino 20612 BuildRequires: mesagl-devel
111 ahmad 75100 BuildRequires: libvpx-devel
112 rtp 79029 BuildRequires: autoconf2.1
113 dmorgan 127865 BuildRequires: libiw-devel
114 lmenut 130942
115 ahmad 75375 %if 0%{?prel}
116 blino 20612 Provides: %{name} = %{epoch}:%{realver}-0.%{prel}
117 ahmad 75375 %else
118     Provides: %{name} = %{epoch}:%{realver}
119 blino 20612 %endif
120 lmenut 130942 Provides: mozilla-firefox = %{epoch}:%{version}-%{release}
121 blino 20612 Provides: webclient
122 lmenut 130942
123     Requires: %{mklibname sqlite3_ 0} >= %{sqlite3_version}
124     Requires: %{mklibname nss 3} >= 2:%{nss_version}
125     Requires: %{mklibname nspr 4} >= 2:%{nspr_version}
126 blino 20612 Requires: indexhtml
127     Requires: xdg-utils
128 lmenut 130942 # fixes bug #42096
129     Requires: mailcap
130 ahmad 117223 Suggests: myspell-en_US
131     %ifarch x86_64
132     Suggests: nspluginwrapper
133     %endif
134 lmenut 130942
135 ahmad 75375 Obsoletes: firefox-ext-weave-sync
136 blino 20612
137     %description
138     The award-winning Web browser is now faster, more secure, and fully customizable
139 tv 45609 to your online life. With Firefox(R), we've added powerful new features that
140 blino 20612 make your online experience even better. It is an 'open source' product which is
141     freely available, and is acquiring a growing proportion of international web
142     browser usage.
143    
144     Firefox claims to offer a more secure web browsing experience than other products,
145     with better protection against spyware and other Internet-based security threats.
146     It includes all the standard features of a modern web browser, like Internet
147     searching, tracking recently visited sites, setting up shortcuts to favourite
148     sites, customising the software behaviour and so on. Firefox also includes
149     features like 'tabbed browsing' (opening several web sites as sections within the
150     same window) and methods for controlling pop-up windows, cookies and downloaded
151     files.
152    
153     %package devel
154     Summary: Development files for %{name}
155     Group: Development/Other
156    
157     %description devel
158     Files and macros mainly for building Firefox extensions.
159    
160     %prep
161 tv 110649 %setup -qn mozilla-release
162 dmorgan 116916 %patch1 -p1 -b .lang
163 dmorgan 127856 %patch2 -p1 -b .vendor
164 lmenut 130942 #patch3 -p1 -b .systemproxy
165     %patch5 -p1 -b .appname
166 fwang 149203 %patch6 -p0 -b .str
167 blino 20612 # It was disabled because firefox3 hangs when using soundwrapper
168 dmorgan 127856 #patch7 -p1
169     %patch8 -p1 -b .disable-software-update
170     %patch10 -p1 -b .default-mail-handler
171 blino 20612 ## KDE INTEGRATION
172     # copy current files and patch them later to keep them in sync
173 dmorgan 127856 %patch11 -p1 -b .kde
174     %patch12 -p1 -b .kdemoz
175 blino 20612 # install kde.js
176 dmorgan 74498 install -m 644 %{SOURCE9} browser/app/profile/kde.js
177 blino 20612
178 rtp 79029 %ifarch %arm
179     %if "%{_target_cpu}" != "armv7l"
180     %patch34 -p1
181     %endif
182     %endif
183 fwang 128523 %patch35 -p1
184 dmorgan 169617 %patch36 -p2 -b .addons
185 rtp 79029 pushd js/src
186     autoconf-2.13
187     popd
188     autoconf-2.13
189    
190 dmorgan 127856 # needed to regenerate certdata.c
191     pushd security/nss/lib/ckfw/builtins
192     perl ./certdata.perl < /etc/pki/tls/mozilla/certdata.txt
193     popd
194    
195 blino 20612 %build
196 fwang 149200 export MOZCONFIG=`pwd`/mozconfig
197 dmorgan 127856 cat << EOF > $MOZCONFIG
198     mk_add_options MOZILLA_OFFICIAL=1
199     mk_add_options BUILD_OFFICIAL=1
200     mk_add_options MOZ_MAKE_FLAGS="%{_smp_mflags}"
201     mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
202 fwang 132978 ac_add_options --host=%{_host}
203     ac_add_options --target=%{_target_platform}
204 fwang 131970 ac_add_options --enable-optimize="%{optflags}"
205 dmorgan 127856 ac_add_options --prefix="%{_prefix}"
206     ac_add_options --libdir="%{_libdir}"
207     ac_add_options --sysconfdir="%{_sysconfdir}"
208     ac_add_options --mandir="%{_mandir}"
209     ac_add_options --includedir="%{_includedir}"
210     ac_add_options --datadir="%{_datadir}"
211     ac_add_options --with-system-nspr
212     ac_add_options --with-system-nss
213     ac_add_options --with-system-zlib
214 fwang 133280 ac_add_options --with-system-libvpx
215     ac_add_options --enable-webm
216 lmenut 130942 ac_add_options --enable-gio
217     ac_add_options --disable-gnomevfs
218 dmorgan 127856 ac_add_options --disable-installer
219     ac_add_options --disable-updater
220     ac_add_options --disable-tests
221     ac_add_options --disable-debug
222     #ac_add_options --enable-chrome-format=jar
223     #ac_add_options --enable-update-channel=beta
224     ac_add_options --enable-official-branding
225     ac_add_options --enable-libproxy
226 fwang 142362 ac_add_options --with-system-png
227 dmorgan 127856 ac_add_options --with-system-jpeg
228     ac_add_options --enable-system-cairo
229     ac_add_options --enable-system-sqlite
230 lmenut 130942 ac_add_options --enable-startup-notification
231 fwang 133282 ac_add_options --enable-xinerama
232 dmorgan 127856 ac_add_options --with-distribution-id=org.mageia
233     ac_add_options --disable-crashreporter
234 rtp 79029 %ifarch %arm
235     %if "%{_target_cpu}" != "armv7l"
236 dmorgan 127856 ac_add_options --disable-methodjit
237     ac_add_options --disable-tracejit
238 rtp 79029 %endif
239 dmorgan 127856 ac_add_options --enable-system-ffi
240 rtp 79029 %endif
241     %ifnarch %arm %mips
242 dmorgan 127856 ac_add_options --with-valgrind
243     ac_add_options --with-java-include-path=%{java_home}/include
244     ac_add_options --with-java-bin-path=%{java_home}/bin
245 rtp 79029 %endif
246 blino 20612
247 dmorgan 127856 EOF
248    
249 blino 20612 %__perl -p -i -e 's|\-0|\-9|g' config/make-jars.pl
250    
251 fwang 133345 export LDFLAGS="%ldflags"
252 dmorgan 127856 make -f client.mk build
253 blino 20612
254     %install
255 ahmad 75100 rm -rf %{buildroot}
256 blino 20612
257 dmorgan 127856 make -C %{_builddir}/obj/browser/installer STRIP=/bin/true
258 blino 20612
259 dmorgan 127856 # Copy files to buildroot
260     %{__mkdir_p} %{buildroot}%{mozillalibdir}
261     cp -rf %{_builddir}/obj/dist/firefox/* %{buildroot}%{mozillalibdir}
262 blino 20612
263 dmorgan 127856 %{__mkdir_p} %{buildroot}%{_bindir}
264     ln -sf %{mozillalibdir}/firefox %{buildroot}%{_bindir}/firefox
265     pushd %{buildroot}%{_bindir}
266     ln -sf firefox mozilla-firefox
267     popd
268 tv 110649
269 lmenut 130942 # Create and own %_libdir/mozilla/plugins & firefox extensions directories
270     %{__mkdir_p} %{buildroot}%{pluginsdir}
271     %{__mkdir_p} %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
272     %{__mkdir_p} %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
273 blino 20612
274     # (tpg) desktop entry
275     %{__mkdir_p} %{buildroot}%{_datadir}/applications
276     install -m 644 %{SOURCE4} %{buildroot}%{_datadir}/applications/%{name}.desktop
277    
278     # (tpg) icons
279 dmorgan 127856 %{__cp} %{buildroot}%{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}/%{mozillalibdir}/icons/
280 colin 130660 for i in 16 22 24 32 48 256; do
281     # (cg) Not all icon sizes are installed with make install, so just redo it here.
282 tv 133105 %{__install} -m 644 browser/branding/official/default$i.png %{buildroot}%{mozillalibdir}/chrome/icons/default/default$i.png
283 blino 20612 %{__mkdir_p} %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps
284 colin 130660 ln -sf %{mozillalibdir}/chrome/icons/default/default$i.png %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps/%{name}.png ;
285 blino 20612 done
286 colin 130660 %{__mkdir_p} %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
287     ln -sf %{mozillalibdir}/chrome/icons/default/default48.png %{buildroot}%{_liconsdir}/%{name}.png
288     ln -sf %{mozillalibdir}/chrome/icons/default/default32.png %{buildroot}%{_iconsdir}/%{name}.png
289 dmorgan 130666 ln -sf %{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}%{_miconsdir}/%{name}.png
290 blino 20612
291 dmorgan 127856 # exclusions
292     rm -f %{buildroot}%{mozillalibdir}/README.txt
293     rm -f %{buildroot}%{mozillalibdir}/removed-files
294     rm -f %{buildroot}%{mozillalibdir}/precomplete
295    
296 doktor5000 168152 # extensions.autoDisableScopes is a new preference added in firefox 8
297     # it defines "scopes" where newly installed addons are disabled by default
298     # this is an additive bit field, and the value defaults to 15 (1+2+4+8)
299     # we need to remove system scope (8) from it so language packs and other addons
300     # which are installed systemwide won't get marked as 3rd party and disabled
301     # documentation: http://kb.mozillazine.org/About:config_entries#Extensions.
302     # or in toolkit/mozapps/extensions/AddonManager.jsm
303 blino 20612 install -D -m644 browser/app/profile/prefs.js %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
304     cat << EOF >> %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
305     user_pref("browser.EULA.override", true);
306     user_pref("browser.shell.checkDefaultBrowser", false);
307 rda 76933 user_pref("browser.startup.homepage", "file:///usr/share/indexhtml/index.html");
308 blino 20612 user_pref("app.update.auto", false);
309     user_pref("app.update.enabled", false);
310     user_pref("app.update.autoInstallEnabled", false);
311 lmenut 130942 user_pref("browser.showQuitWarning", true);
312 dmorgan 169617 user_pref("extensions.shownSelectionUI", true);
313     user_pref("extensions.autoDisableScopes", 0);
314 blino 20612 EOF
315    
316 ahmad 75106 # (ahmad) these ones belonged in prefs.js (see above), remove them until it's
317     # decided what search engines to ship by default
318     #user_pref("browser.search.selectedEngine","Ask.com");
319     #user_pref("browser.search.order.1","Ask.com");
320     #user_pref("browser.search.order.2","Exalead");
321     #user_pref("browser.search.order.3","Google");
322     #user_pref("browser.search.order.4","Yahoo");
323    
324     # (ahmad) don't install these until it's decided what search engines to ship by
325     # default
326 blino 20612 # search engines
327 ahmad 75106 #cp -f %{SOURCE5} %{buildroot}%{mozillalibdir}/searchplugins/jamendo.xml
328     #cp -f %{SOURCE6} %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
329     #cp -f %{SOURCE8} %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
330 blino 20612
331 ahmad 75106 #sed -i 's/@DISTRO_VALUE@/ffx/' %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
332     #sed -i 's/@DISTRO_VALUE@//' %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
333 blino 20612
334 ahmad 130766 # use the system myspell dictionaries
335     rm -fr %{buildroot}%{mozillalibdir}/dictionaries
336     ln -s %{_datadir}/dict/mozilla %{buildroot}%{mozillalibdir}/dictionaries
337    
338 lmenut 130942 # (lm) touch and %ghost bookmarks.html to a proper uninstall
339     touch %{buildroot}%{mozillalibdir}/defaults/profile/bookmarks.html
340    
341 blino 20612 %find_lang %{name}
342    
343     mkdir -p %{buildroot}%{_sys_macros_dir}
344     cat <<FIN >%{buildroot}%{_sys_macros_dir}/%{name}.macros
345     # Macros from %{name} package
346     %%firefox_major %{major}
347     %%firefox_epoch %{ff_epoch}
348     %%firefox_version %{realver}%{?prel:-0.%prel}
349     %%firefox_mozillapath %{mozillalibdir}
350     %%firefox_pluginsdir %{pluginsdir}
351 tv 45614 %%firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
352     %%firefox_extdir %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
353 blino 20612 FIN
354    
355 ahmad 130766 %pre
356     if [ -d %{mozillalibdir}/dictionaries ]; then
357     rm -fr %{mozillalibdir}/dictionaries
358     fi
359 dmorgan 127856
360 blino 20612 %post
361     if [ ! -r /etc/sysconfig/oem ]; then
362     case `grep META_CLASS /etc/sysconfig/system` in
363     *powerpack) bookmark="mozilla-powerpack.html" ;;
364     *desktop) bookmark="mozilla-one.html";;
365     *) bookmark="mozilla-download.html";;
366     esac
367 lmenut 130942 ln -s -f ../../../../share/mga/bookmarks/mozilla/$bookmark %{mozillalibdir}/defaults/profile/bookmarks.html
368 blino 20612 fi
369    
370     %files -f %{name}.lang
371     %{_bindir}/%{name}
372     %{_bindir}/mozilla-firefox
373     %{_iconsdir}/hicolor/*/apps/*.png
374 colin 130660 %{_miconsdir}/%{name}.png
375     %{_iconsdir}/%{name}.png
376     %{_liconsdir}/%{name}.png
377 blino 20612 %{_datadir}/applications/*.desktop
378     %{_libdir}/%{name}-%{realver}*
379 lmenut 130942 %ghost %{mozillalibdir}/defaults/profile/bookmarks.html
380 blino 20612 %dir %{_libdir}/mozilla
381     %dir %{pluginsdir}
382 lmenut 130942 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
383     %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
384 blino 20612
385     %files devel
386     %{_sys_macros_dir}/%{name}.macros

  ViewVC Help
Powered by ViewVC 1.1.30