/[packages]/cauldron/firefox/current/SPECS/firefox.spec
ViewVC logotype

Annotation of /cauldron/firefox/current/SPECS/firefox.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 206849 - (hide annotations) (download)
Fri Feb 10 12:45:06 2012 UTC (12 years, 2 months ago) by fwang
File size: 14005 byte(s)
update file list
1 blino 20612 #
2     # WARNING, READ FIRST:
3     #
4     # PLEASE svn cp SOURCES FROM xulrunner SOURCES INSTEAD
5     # OF COMMITING AGAIN THE TARBALL
6     #
7     # This is a special package that needs special treatment. Due to the amount of
8     # security updates it needs, it's common to ship new upstream versions instead of patching.
9     # That means this package MUST be BUILDABLE for stable official releases.
10     # This also means only STABLE upstream releases, NO betas.
11     # This is a discussed topic. Please, do not flame it again.
12    
13 fwang 206843 %define major 10.0.1
14 blino 20612 %define ff_epoch 0
15     # (tpg) set version HERE !!!
16 fwang 206843 %define realver %{major}esr
17 lmenut 130942 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
18 dmorgan 127856
19 blino 20612 # (tpg) MOZILLA_FIVE_HOME
20 fwang 206843 %define mozillalibdir %{_libdir}/%{name}-%{major}
21 blino 20612 %define pluginsdir %{_libdir}/mozilla/plugins
22    
23     # libxul.so is provided by libxulrunnner2.0.
24     %define _requires_exceptions libxul.so
25    
26     # this seems fragile, so require the exact version or later (#58754)
27     %define sqlite3_version %(pkg-config --modversion sqlite3 &>/dev/null && pkg-config --modversion sqlite3 2>/dev/null || echo 0)
28 lmenut 130942 %define nss_version %(pkg-config --modversion nss &>/dev/null && pkg-config --modversion nss 2>/dev/null || echo 0)
29     %define nspr_version %(pkg-config --modversion nspr &>/dev/null && pkg-config --modversion nspr 2>/dev/null || echo 0)
30 blino 20612
31     %define _use_syshunspell 1
32    
33 ahmad 75375 #define prel 0
34     %if 0%{?prel}
35 dmorgan 74764 %define release %mkrel -c %prel 1
36 ahmad 75375 %else
37 fwang 206849 %define release %mkrel 1
38 ahmad 75375 %endif
39 blino 20612
40     Summary: Next generation web browser
41     Name: firefox
42 fwang 206843 Version: %{major}
43 blino 20612 Epoch: %{ff_epoch}
44     Release: %{release}
45     License: MPLv1+
46     Group: Networking/WWW
47 tv 45608 Url: http://www.mozilla.com/firefox/
48 ahmad 75375 %if 0%{?prel}
49 blino 20612 Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}%prel.source.tar.bz2
50 ahmad 75375 %else
51     Source0: ftp://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{realver}/source/%{name}-%{realver}.source.tar.bz2
52     %endif
53 blino 20612 Source4: %{name}.desktop
54     Source9: kde.js
55 fwang 133091 Patch1: firefox-6.0-lang.patch
56 dmorgan 127856 Patch2: firefox-vendor.patch
57 blino 20612 Patch3: mozilla-firefox-1.5.0.6-systemproxy.patch
58     # (OpenSuse) add patch to make firefox always use /usr/bin/firefox when "make firefox
59     # the default web browser" is used fix mdv bug#58784
60 fwang 133095 Patch5: firefox-6.0-appname.patch
61 fwang 149203 Patch6: firefox-7.0-fix-str-fmt.patch
62 dmorgan 127856 Patch7: mozilla-firefox-run-mozilla.patch
63     Patch8: firefox-disable-check-default-browser.patch
64     Patch10: firefox-3.5.3-default-mail-handler.patch
65     # Patches for kde integration of FF
66     Patch11: firefox-kde.patch
67     Patch12: mozilla-kde.patch
68 rtp 79029 Patch34: xulrunner_nojit.patch
69 fwang 128523 Patch35: firefox-5.0-asciidel.patch
70 blino 20612 BuildRequires: gtk+2-devel
71     BuildRequires: unzip
72     BuildRequires: zip
73 fwang 133282 BuildRequires: libxinerama-devel
74 fwang 164134 BuildRequires: libxscrnsaver-devel
75 blino 20612 BuildRequires: libjpeg-devel
76 fwang 142362 BuildRequires: libpng-devel >= 2:1.4
77 blino 20612 BuildRequires: zlib-devel
78     BuildRequires: glib2-devel
79     BuildRequires: libIDL2-devel
80     BuildRequires: makedepend
81 dmorgan 134679 BuildRequires: nss-devel >= 2:3.12.10
82 dmorgan 127866 BuildRequires: nss-static-devel
83 dmorgan 134676 BuildRequires: nspr-devel >= 2:4.8.9
84 blino 20612 BuildRequires: startup-notification-devel
85     BuildRequires: dbus-glib-devel
86     BuildRequires: python
87 fwang 184892 BuildRequires: sqlite3-devel >= 3.7.7.1
88 rtp 79029 %ifnarch %arm %mips
89 blino 20612 BuildRequires: valgrind
90 rtp 79029 BuildRequires: java-rpmbuild
91 dmorgan 114215 BuildRequires: yasm >= 1.0.1
92 rtp 79029 %endif
93     %ifarch %arm
94     BuildRequires: libffi-devel
95     %endif
96 dmorgan 137463 BuildRequires: rootcerts >= 1:20110830.00
97 blino 20612 BuildRequires: libxt-devel
98     %if %_use_syshunspell
99     BuildRequires: hunspell-devel
100     %endif
101     BuildRequires: doxygen
102 ahmad 130766 # BuildRequires: xulrunner-devel >= %xulrunner_version%{?prel:-0.%prel}
103     BuildRequires: pkgconfig(libproxy-1.0)
104     BuildRequires: pkgconfig(alsa)
105 blino 20612 BuildRequires: wget
106     BuildRequires: libnotify-devel
107 ahmad 48246 BuildRequires: cairo-devel >= 1.10
108 blino 20612 BuildRequires: mesagl-devel
109 ahmad 75100 BuildRequires: libvpx-devel
110 rtp 79029 BuildRequires: autoconf2.1
111 dmorgan 127865 BuildRequires: libiw-devel
112 lmenut 130942
113 ahmad 75375 %if 0%{?prel}
114 blino 20612 Provides: %{name} = %{epoch}:%{realver}-0.%{prel}
115 ahmad 75375 %else
116     Provides: %{name} = %{epoch}:%{realver}
117 blino 20612 %endif
118 lmenut 130942 Provides: mozilla-firefox = %{epoch}:%{version}-%{release}
119 blino 20612 Provides: webclient
120 lmenut 130942
121     Requires: %{mklibname sqlite3_ 0} >= %{sqlite3_version}
122     Requires: %{mklibname nss 3} >= 2:%{nss_version}
123     Requires: %{mklibname nspr 4} >= 2:%{nspr_version}
124 blino 20612 Requires: indexhtml
125     Requires: xdg-utils
126 lmenut 130942 # fixes bug #42096
127     Requires: mailcap
128 ahmad 117223 Suggests: myspell-en_US
129 fwang 205048 Suggests: %{_lib}canberra0
130     Suggests: %{_lib}cups2
131 ahmad 75375 Obsoletes: firefox-ext-weave-sync
132 blino 20612
133     %description
134     The award-winning Web browser is now faster, more secure, and fully customizable
135 tv 45609 to your online life. With Firefox(R), we've added powerful new features that
136 blino 20612 make your online experience even better. It is an 'open source' product which is
137     freely available, and is acquiring a growing proportion of international web
138     browser usage.
139    
140     Firefox claims to offer a more secure web browsing experience than other products,
141     with better protection against spyware and other Internet-based security threats.
142     It includes all the standard features of a modern web browser, like Internet
143     searching, tracking recently visited sites, setting up shortcuts to favourite
144     sites, customising the software behaviour and so on. Firefox also includes
145     features like 'tabbed browsing' (opening several web sites as sections within the
146     same window) and methods for controlling pop-up windows, cookies and downloaded
147     files.
148    
149     %package devel
150     Summary: Development files for %{name}
151     Group: Development/Other
152    
153     %description devel
154     Files and macros mainly for building Firefox extensions.
155    
156     %prep
157 fwang 206843 %setup -qn mozilla-esr10
158 dmorgan 116916 %patch1 -p1 -b .lang
159 dmorgan 127856 %patch2 -p1 -b .vendor
160 lmenut 130942 #patch3 -p1 -b .systemproxy
161     %patch5 -p1 -b .appname
162 blino 20612 # It was disabled because firefox3 hangs when using soundwrapper
163 dmorgan 127856 #patch7 -p1
164     %patch8 -p1 -b .disable-software-update
165     %patch10 -p1 -b .default-mail-handler
166 blino 20612 ## KDE INTEGRATION
167 dmorgan 206634 # Disable kde integration , need refactoring
168     #%patch11 -p1 -b .kde
169     #%patch12 -p1 -b .kdemoz
170 blino 20612 # install kde.js
171 fwang 203621 #install -m 644 %{SOURCE9} browser/app/profile/kde.js
172 blino 20612
173 rtp 79029 %ifarch %arm
174     %if "%{_target_cpu}" != "armv7l"
175     %patch34 -p1
176     %endif
177     %endif
178 fwang 128523 %patch35 -p1
179 rtp 79029 pushd js/src
180     autoconf-2.13
181     popd
182     autoconf-2.13
183    
184 dmorgan 127856 # needed to regenerate certdata.c
185     pushd security/nss/lib/ckfw/builtins
186     perl ./certdata.perl < /etc/pki/tls/mozilla/certdata.txt
187     popd
188    
189 blino 20612 %build
190 fwang 149200 export MOZCONFIG=`pwd`/mozconfig
191 dmorgan 127856 cat << EOF > $MOZCONFIG
192     mk_add_options MOZILLA_OFFICIAL=1
193     mk_add_options BUILD_OFFICIAL=1
194     mk_add_options MOZ_MAKE_FLAGS="%{_smp_mflags}"
195     mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
196 fwang 132978 ac_add_options --host=%{_host}
197     ac_add_options --target=%{_target_platform}
198 fwang 205048 ac_add_options --enable-optimize="%{optflags}"
199 dmorgan 127856 ac_add_options --prefix="%{_prefix}"
200     ac_add_options --libdir="%{_libdir}"
201     ac_add_options --sysconfdir="%{_sysconfdir}"
202     ac_add_options --mandir="%{_mandir}"
203     ac_add_options --includedir="%{_includedir}"
204     ac_add_options --datadir="%{_datadir}"
205     ac_add_options --with-system-nspr
206     ac_add_options --with-system-nss
207     ac_add_options --with-system-zlib
208 fwang 133280 ac_add_options --with-system-libvpx
209     ac_add_options --enable-webm
210 lmenut 130942 ac_add_options --enable-gio
211     ac_add_options --disable-gnomevfs
212 dmorgan 127856 ac_add_options --disable-installer
213     ac_add_options --disable-updater
214     ac_add_options --disable-tests
215     ac_add_options --disable-debug
216     #ac_add_options --enable-chrome-format=jar
217     #ac_add_options --enable-update-channel=beta
218     ac_add_options --enable-official-branding
219     ac_add_options --enable-libproxy
220 fwang 142362 ac_add_options --with-system-png
221 dmorgan 127856 ac_add_options --with-system-jpeg
222     ac_add_options --enable-system-cairo
223     ac_add_options --enable-system-sqlite
224 lmenut 130942 ac_add_options --enable-startup-notification
225 fwang 133282 ac_add_options --enable-xinerama
226 dmorgan 127856 ac_add_options --with-distribution-id=org.mageia
227     ac_add_options --disable-crashreporter
228 rtp 79029 %ifarch %arm
229     %if "%{_target_cpu}" != "armv7l"
230 dmorgan 127856 ac_add_options --disable-methodjit
231     ac_add_options --disable-tracejit
232 rtp 79029 %endif
233 dmorgan 127856 ac_add_options --enable-system-ffi
234 rtp 79029 %endif
235     %ifnarch %arm %mips
236 dmorgan 127856 ac_add_options --with-valgrind
237     ac_add_options --with-java-include-path=%{java_home}/include
238     ac_add_options --with-java-bin-path=%{java_home}/bin
239 rtp 79029 %endif
240 blino 20612
241 dmorgan 127856 EOF
242    
243 blino 20612 %__perl -p -i -e 's|\-0|\-9|g' config/make-jars.pl
244    
245 fwang 133345 export LDFLAGS="%ldflags"
246 dmorgan 127856 make -f client.mk build
247 blino 20612
248     %install
249 ahmad 75100 rm -rf %{buildroot}
250 blino 20612
251 dmorgan 127856 make -C %{_builddir}/obj/browser/installer STRIP=/bin/true
252 blino 20612
253 dmorgan 127856 # Copy files to buildroot
254     %{__mkdir_p} %{buildroot}%{mozillalibdir}
255     cp -rf %{_builddir}/obj/dist/firefox/* %{buildroot}%{mozillalibdir}
256 blino 20612
257 dmorgan 127856 %{__mkdir_p} %{buildroot}%{_bindir}
258     ln -sf %{mozillalibdir}/firefox %{buildroot}%{_bindir}/firefox
259     pushd %{buildroot}%{_bindir}
260     ln -sf firefox mozilla-firefox
261     popd
262 tv 110649
263 lmenut 130942 # Create and own %_libdir/mozilla/plugins & firefox extensions directories
264     %{__mkdir_p} %{buildroot}%{pluginsdir}
265     %{__mkdir_p} %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
266     %{__mkdir_p} %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
267 blino 20612
268     # (tpg) desktop entry
269     %{__mkdir_p} %{buildroot}%{_datadir}/applications
270     install -m 644 %{SOURCE4} %{buildroot}%{_datadir}/applications/%{name}.desktop
271    
272     # (tpg) icons
273 dmorgan 127856 %{__cp} %{buildroot}%{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}/%{mozillalibdir}/icons/
274 colin 130660 for i in 16 22 24 32 48 256; do
275     # (cg) Not all icon sizes are installed with make install, so just redo it here.
276 tv 133105 %{__install} -m 644 browser/branding/official/default$i.png %{buildroot}%{mozillalibdir}/chrome/icons/default/default$i.png
277 blino 20612 %{__mkdir_p} %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps
278 colin 130660 ln -sf %{mozillalibdir}/chrome/icons/default/default$i.png %{buildroot}%{_iconsdir}/hicolor/"$i"x"$i"/apps/%{name}.png ;
279 blino 20612 done
280 colin 130660 %{__mkdir_p} %{buildroot}{%{_liconsdir},%{_iconsdir},%{_miconsdir}}
281     ln -sf %{mozillalibdir}/chrome/icons/default/default48.png %{buildroot}%{_liconsdir}/%{name}.png
282     ln -sf %{mozillalibdir}/chrome/icons/default/default32.png %{buildroot}%{_iconsdir}/%{name}.png
283 dmorgan 130666 ln -sf %{mozillalibdir}/chrome/icons/default/default16.png %{buildroot}%{_miconsdir}/%{name}.png
284 blino 20612
285 dmorgan 127856 # exclusions
286     rm -f %{buildroot}%{mozillalibdir}/README.txt
287     rm -f %{buildroot}%{mozillalibdir}/removed-files
288     rm -f %{buildroot}%{mozillalibdir}/precomplete
289    
290 doktor5000 170221 # this file is only used when creating a new user profile
291 blino 20612 install -D -m644 browser/app/profile/prefs.js %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
292     cat << EOF >> %{buildroot}%{mozillalibdir}/defaults/profile/prefs.js
293     user_pref("browser.EULA.override", true);
294     user_pref("browser.shell.checkDefaultBrowser", false);
295 rda 76933 user_pref("browser.startup.homepage", "file:///usr/share/indexhtml/index.html");
296 blino 20612 user_pref("app.update.auto", false);
297     user_pref("app.update.enabled", false);
298     user_pref("app.update.autoInstallEnabled", false);
299 lmenut 130942 user_pref("browser.showQuitWarning", true);
300 blino 20612 EOF
301    
302 doktor5000 170221 # files in this directory are read on every startup, and can change/add
303     # preferences for existing profiles
304     # extensions.autoDisableScopes is a new preference added in firefox 8
305     # it defines "scopes" where newly installed addons are disabled by default
306     # this is an additive bit field, and the value defaults to 15 (1+2+4+8)
307     # we need to remove system scope (8) from it so language packs and other addons
308     # which are installed systemwide won't get marked as 3rd party and disabled
309     # documentation: http://kb.mozillazine.org/About:config_entries#Extensions.
310     # or in toolkit/mozapps/extensions/AddonManager.jsm
311     # we also need to disable the "disable addon selection dialog"
312     cat << EOF > %{buildroot}%{mozillalibdir}/defaults/pref/mga.js
313     pref("extensions.autoDisableScopes", 0);
314     pref("extensions.shownSelectionUI", true);
315     EOF
316    
317 ahmad 75106 # (ahmad) these ones belonged in prefs.js (see above), remove them until it's
318     # decided what search engines to ship by default
319     #user_pref("browser.search.selectedEngine","Ask.com");
320     #user_pref("browser.search.order.1","Ask.com");
321     #user_pref("browser.search.order.2","Exalead");
322     #user_pref("browser.search.order.3","Google");
323     #user_pref("browser.search.order.4","Yahoo");
324    
325     # (ahmad) don't install these until it's decided what search engines to ship by
326     # default
327 blino 20612 # search engines
328 ahmad 75106 #cp -f %{SOURCE5} %{buildroot}%{mozillalibdir}/searchplugins/jamendo.xml
329     #cp -f %{SOURCE6} %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
330     #cp -f %{SOURCE8} %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
331 blino 20612
332 ahmad 75106 #sed -i 's/@DISTRO_VALUE@/ffx/' %{buildroot}%{mozillalibdir}/searchplugins/askcom.xml
333     #sed -i 's/@DISTRO_VALUE@//' %{buildroot}%{mozillalibdir}/searchplugins/exalead.xml
334 blino 20612
335 ahmad 130766 # use the system myspell dictionaries
336     rm -fr %{buildroot}%{mozillalibdir}/dictionaries
337     ln -s %{_datadir}/dict/mozilla %{buildroot}%{mozillalibdir}/dictionaries
338    
339 lmenut 130942 # (lm) touch and %ghost bookmarks.html to a proper uninstall
340     touch %{buildroot}%{mozillalibdir}/defaults/profile/bookmarks.html
341    
342 blino 20612 %find_lang %{name}
343    
344     mkdir -p %{buildroot}%{_sys_macros_dir}
345     cat <<FIN >%{buildroot}%{_sys_macros_dir}/%{name}.macros
346     # Macros from %{name} package
347     %%firefox_major %{major}
348     %%firefox_epoch %{ff_epoch}
349     %%firefox_version %{realver}%{?prel:-0.%prel}
350     %%firefox_mozillapath %{mozillalibdir}
351     %%firefox_pluginsdir %{pluginsdir}
352 tv 45614 %%firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
353     %%firefox_extdir %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
354 blino 20612 FIN
355    
356 ahmad 130766 %pre
357     if [ -d %{mozillalibdir}/dictionaries ]; then
358     rm -fr %{mozillalibdir}/dictionaries
359     fi
360 dmorgan 127856
361 blino 20612 %post
362     if [ ! -r /etc/sysconfig/oem ]; then
363     case `grep META_CLASS /etc/sysconfig/system` in
364     *powerpack) bookmark="mozilla-powerpack.html" ;;
365     *desktop) bookmark="mozilla-one.html";;
366     *) bookmark="mozilla-download.html";;
367     esac
368 lmenut 130942 ln -s -f ../../../../share/mga/bookmarks/mozilla/$bookmark %{mozillalibdir}/defaults/profile/bookmarks.html
369 blino 20612 fi
370    
371     %files -f %{name}.lang
372     %{_bindir}/%{name}
373     %{_bindir}/mozilla-firefox
374     %{_iconsdir}/hicolor/*/apps/*.png
375 colin 130660 %{_miconsdir}/%{name}.png
376     %{_iconsdir}/%{name}.png
377     %{_liconsdir}/%{name}.png
378 blino 20612 %{_datadir}/applications/*.desktop
379 fwang 206849 %{_libdir}/%{name}-%{major}*
380 lmenut 130942 %ghost %{mozillalibdir}/defaults/profile/bookmarks.html
381 blino 20612 %dir %{_libdir}/mozilla
382     %dir %{pluginsdir}
383 lmenut 130942 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
384     %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
385 blino 20612
386     %files devel
387     %{_sys_macros_dir}/%{name}.macros

  ViewVC Help
Powered by ViewVC 1.1.30