1 |
# No debug package, it's actually noarch |
2 |
%define debug_package %{nil} |
3 |
|
4 |
# No compile of doc files named .py |
5 |
%global _python_bytecompile_extra 0 |
6 |
|
7 |
%define oname flightgear |
8 |
|
9 |
Summary: The data for FlightGear Flight Simulator |
10 |
Name: flightgear-data |
11 |
Version: 2020.3.7 |
12 |
Release: %mkrel 1 |
13 |
License: GPLv2 |
14 |
Group: Games/Simulation |
15 |
Source0: https://downloads.sf.net/flightgear/FlightGear-%{version}-data.tar.bz2 |
16 |
URL: http://www.flightgear.org |
17 |
|
18 |
####(eatdirt) back on all arch |
19 |
####ExclusiveArch: x86_64 |
20 |
BuildArch: noarch |
21 |
Provides: flightgear-base = %{version}-%{release} |
22 |
Obsoletes: flightgear-data < 2020.3 |
23 |
|
24 |
%description |
25 |
The Flight Gear project is working to create a sophisticated flight simulator |
26 |
framework for the development and pursuit of interesting flight simulator |
27 |
ideas. We are developing a solid basic sim that can be expanded and improved |
28 |
upon by anyone interested in contributing. |
29 |
|
30 |
This package contains the base data files. |
31 |
|
32 |
%prep |
33 |
%setup -q -n fgdata |
34 |
%autopatch -p1 |
35 |
|
36 |
%install |
37 |
install -d -m 0755 %{buildroot}%{_gamesdatadir}/%{oname}/ |
38 |
cp -a * %{buildroot}%{_gamesdatadir}/%{oname}/ |
39 |
|
40 |
# fix permissions |
41 |
find %{buildroot}%{_gamesdatadir}/%{oname} -type f -exec chmod 644 {} \; |
42 |
|
43 |
# fix file not in utf-8 |
44 |
iconv %{buildroot}%{_gamesdatadir}/%{oname}/Thanks -f iso-8859-1 \ |
45 |
-t utf-8 -o %{buildroot}%{_gamesdatadir}/%{oname}/Thanks |
46 |
|
47 |
%files |
48 |
%doc AUTHORS COPYING NEWS README Thanks Docs |
49 |
%{_gamesdatadir}/%{oname}/ |