/[packages]/cauldron/genders/current/SPECS/genders.spec
ViewVC logotype

Annotation of /cauldron/genders/current/SPECS/genders.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 138374 - (hide annotations) (download)
Sun Sep 4 12:17:33 2011 UTC (12 years, 7 months ago) by fwang
File size: 5481 byte(s)
sync with mandriva rpm
1 ennael 63293 %define major 0
2 fwang 138374 %define libname %mklibname genders %{major}
3     %define develname %mklibname -d genders
4 ennael 63293
5 fwang 138374 %define gendersplusplus_libname %mklibname gendersplusplus 1
6    
7 ennael 63293 Summary: Static cluster configuration database
8     Name: genders
9 fwang 138335 Version: 1.18
10     Release: %mkrel 1
11 ennael 63293 Group: System/Libraries
12     License: GPL
13     URL: https://computing.llnl.gov/linux/genders.html
14     Source0: http://mesh.dl.sourceforge.net/sourceforge/genders/%{name}-%{version}.tar.gz
15     BuildRequires: byacc
16     BuildRequires: flex
17     BuildRequires: libtool
18     BuildRequires: perl-devel
19 fwang 138361 BuildRequires: python-devel
20 ennael 63293
21     %description
22     Genders is a static cluster configuration database used for cluster
23     configuration management. It is used by a variety of tools and scripts for
24     management of large clusters. The genders database is typically replicated
25     on every node of the cluster. It describes the layout and configuration of
26     the cluster so that tools and scripts can sense the variations of cluster
27     nodes. By abstracting this information into a plain text file, it becomes
28     possible to change the configuration of a cluster by modifying only one file.
29    
30     %package -n %{libname}
31     Summary: Static cluster configuration database library
32     Group: System/Libraries
33    
34     %description -n %{libname}
35     Genders is a static cluster configuration database used for cluster
36     configuration management. It is used by a variety of tools and scripts for
37     management of large clusters. The genders database is typically replicated
38     on every node of the cluster. It describes the layout and configuration of
39     the cluster so that tools and scripts can sense the variations of cluster
40     nodes. By abstracting this information into a plain text file, it becomes
41     possible to change the configuration of a cluster by modifying only one file.
42    
43 fwang 138374 %package -n %{gendersplusplus_libname}
44     Summary: Static cluster configuration database C++ library
45     Group: System/Libraries
46    
47     %description -n %{gendersplusplus_libname}
48     Genders is a static cluster configuration database used for cluster
49     configuration management. It is used by a variety of tools and scripts for
50     management of large clusters. The genders database is typically replicated
51     on every node of the cluster. It describes the layout and configuration of
52     the cluster so that tools and scripts can sense the variations of cluster
53     nodes. By abstracting this information into a plain text file, it becomes
54     possible to change the configuration of a cluster by modifying only one file.
55    
56     This package contains the C++ bindings for genders.
57    
58    
59 ennael 63293 %package -n %{develname}
60     Summary: Static library and header files for the genders library
61     Group: Development/C
62     Provides: %{name}-devel = %{version}
63     Provides: lib%{name}-devel = %{version}
64     Requires: %{libname} = %{version}
65    
66     %description -n %{develname}
67     Genders is a static cluster configuration database used for cluster
68     configuration management. It is used by a variety of tools and scripts for
69     management of large clusters. The genders database is typically replicated
70     on every node of the cluster. It describes the layout and configuration of
71     the cluster so that tools and scripts can sense the variations of cluster
72     nodes. By abstracting this information into a plain text file, it becomes
73     possible to change the configuration of a cluster by modifying only one file.
74    
75     This package contains the static genders library and its header files.
76    
77     %package compat
78 fwang 138374 Summary: Compatability library
79 ennael 63293 Group: System/Libraries
80    
81     %description compat
82     genders API that is compatible with earlier releases of genders
83    
84 fwang 138374 %package -n perl-Libgenders
85 ennael 63293 Summary: Genders interface
86     Group: Development/Perl
87 fwang 138374 Provides: perl-Genders = %{version}
88     Obsoletes: perl-Genders
89 ennael 63293
90 fwang 138374 %description -n perl-Libgenders
91 ennael 63293 This package provides a perl interface for querying a genders file.
92    
93 fwang 138374 %package -n python-libgenders
94     Summary: Genders interface
95     Group: Development/Python
96    
97     %description -n python-libgenders
98     This package provides a python interface for querying a genders file.
99    
100 ennael 63293 %prep
101    
102     %setup -q -n %{name}-%{version}
103    
104     %build
105    
106     %configure2_5x \
107     --with-genders-file=%{_sysconfdir}/%{name} \
108 fwang 138366 --with-perl-site-arch \
109     --with-extension-destdir=%{buildroot}
110 ennael 63293
111 fwang 138374 make LD_RUN_PATH=""
112 ennael 63293
113     %install
114     rm -rf %{buildroot}
115    
116     install -d %{buildroot}%{_sysconfdir}
117    
118 fwang 138374 %makeinstall_std LD_RUN_PATH=""
119 ennael 63293
120     install -m0644 genders.sample %{buildroot}%{_sysconfdir}/%{name}
121    
122 fwang 138374 # bork
123     mv %{buildroot}/usr/local/share/man/man3/Libgenders.3pm %{buildroot}%{_mandir}/man3/Libgenders.3pm
124 ennael 63293
125     %clean
126     rm -rf %{buildroot}
127    
128     %files
129     %defattr(-,root,root)
130     %{_bindir}/*
131     %{_mandir}/man1/*
132    
133     %files -n %{libname}
134     %defattr(-,root,root)
135     %doc README NEWS ChangeLog DISCLAIMER DISCLAIMER.UC COPYING TUTORIAL
136     %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}
137     %{_libdir}/*.so.%{major}*
138    
139 fwang 138374 %files -n %{gendersplusplus_libname}
140     %defattr(-,root,root)
141     %{_libdir}/libgendersplusplus.so.1*
142    
143 ennael 63293 %files -n %{develname}
144     %defattr(-,root,root)
145     %{_includedir}/*
146     %{_libdir}/*.so
147 fwang 138374 %{_libdir}/*.*a
148 ennael 63293 %{_mandir}/man3/genders*
149 fwang 138374 %{_mandir}/man3/libgenders*
150 ennael 63293
151     %files compat
152     %defattr(-,root,root)
153     %{_mandir}/man3/gendlib*
154     %dir %{_prefix}/lib/genders
155     %{_prefix}/lib/genders/*
156    
157 fwang 138374 %files -n perl-Libgenders
158 ennael 63293 %defattr(-,root,root)
159     %{perl_sitearch}/Genders.pm
160     %{perl_sitearch}/Libgenders.pm
161     %dir %{perl_sitearch}/auto/Libgenders
162     %{perl_sitearch}/auto/Libgenders/Libgenders.so
163 fwang 138374 %{_mandir}/man3/Genders.3pm*
164     %{_mandir}/man3/Libgenders.3pm*
165 ennael 63293
166 fwang 138374 %files -n python-libgenders
167     %defattr(-,root,root)
168     %{python_sitearch}/genders.py
169     %{python_sitearch}/libgenders-*-py*.egg-info
170     %{python_sitearch}/libgenders.so

  ViewVC Help
Powered by ViewVC 1.1.30