/[packages]/cauldron/genders/current/SPECS/genders.spec
ViewVC logotype

Contents of /cauldron/genders/current/SPECS/genders.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 679488 - (show annotations) (download)
Tue Sep 16 15:56:49 2014 UTC (9 years, 7 months ago) by umeabot
File size: 5269 byte(s)
Mageia 5 Mass Rebuild
1 %define major 0
2 %define libname %mklibname genders %{major}
3 %define develname %mklibname -d genders
4
5 %define gendersplusplus_libname %mklibname gendersplusplus 1
6
7 Summary: Static cluster configuration database
8 Name: genders
9 Version: 1.20
10 Release: %mkrel 6
11 Group: System/Libraries
12 License: GPL
13 URL: https://computing.llnl.gov/linux/genders.html
14 Source0: http://downloads.sourceforge.net/genders/%{name}-%{version}.tar.gz
15 BuildRequires: byacc
16 BuildRequires: flex
17 BuildRequires: libtool
18 BuildRequires: perl-devel
19 BuildRequires: python-devel
20
21 %description
22 Genders is a static cluster configuration database used for cluster
23 configuration management. It is used by a variety of tools and scripts for
24 management of large clusters. The genders database is typically replicated
25 on every node of the cluster. It describes the layout and configuration of
26 the cluster so that tools and scripts can sense the variations of cluster
27 nodes. By abstracting this information into a plain text file, it becomes
28 possible to change the configuration of a cluster by modifying only one file.
29
30 %package -n %{libname}
31 Summary: Static cluster configuration database library
32 Group: System/Libraries
33
34 %description -n %{libname}
35 Genders is a static cluster configuration database used for cluster
36 configuration management. It is used by a variety of tools and scripts for
37 management of large clusters. The genders database is typically replicated
38 on every node of the cluster. It describes the layout and configuration of
39 the cluster so that tools and scripts can sense the variations of cluster
40 nodes. By abstracting this information into a plain text file, it becomes
41 possible to change the configuration of a cluster by modifying only one file.
42
43 %package -n %{gendersplusplus_libname}
44 Summary: Static cluster configuration database C++ library
45 Group: System/Libraries
46
47 %description -n %{gendersplusplus_libname}
48 Genders is a static cluster configuration database used for cluster
49 configuration management. It is used by a variety of tools and scripts for
50 management of large clusters. The genders database is typically replicated
51 on every node of the cluster. It describes the layout and configuration of
52 the cluster so that tools and scripts can sense the variations of cluster
53 nodes. By abstracting this information into a plain text file, it becomes
54 possible to change the configuration of a cluster by modifying only one file.
55
56 This package contains the C++ bindings for genders.
57
58
59 %package -n %{develname}
60 Summary: Static library and header files for the genders library
61 Group: Development/C
62 Provides: %{name}-devel = %{version}
63 Provides: lib%{name}-devel = %{version}
64 Requires: %{libname} = %{version}
65
66 %description -n %{develname}
67 Genders is a static cluster configuration database used for cluster
68 configuration management. It is used by a variety of tools and scripts for
69 management of large clusters. The genders database is typically replicated
70 on every node of the cluster. It describes the layout and configuration of
71 the cluster so that tools and scripts can sense the variations of cluster
72 nodes. By abstracting this information into a plain text file, it becomes
73 possible to change the configuration of a cluster by modifying only one file.
74
75 This package contains the static genders library and its header files.
76
77 %package compat
78 Summary: Compatability library
79 Group: System/Libraries
80
81 %description compat
82 genders API that is compatible with earlier releases of genders
83
84 %package -n perl-Libgenders
85 Summary: Genders interface
86 Group: Development/Perl
87 Provides: perl-Genders = %{version}
88 Obsoletes: perl-Genders
89
90 %description -n perl-Libgenders
91 This package provides a perl interface for querying a genders file.
92
93 %package -n python-libgenders
94 Summary: Genders interface
95 Group: Development/Python
96
97 %description -n python-libgenders
98 This package provides a python interface for querying a genders file.
99
100 %prep
101
102 %setup -q -n %{name}-%{version}
103
104 %build
105
106 %configure2_5x \
107 --with-genders-file=%{_sysconfdir}/%{name} \
108 --with-perl-site-arch \
109 --with-extension-destdir=%{buildroot}
110
111 make LD_RUN_PATH=""
112
113 %install
114 install -d %{buildroot}%{_sysconfdir}
115
116 %makeinstall_std LD_RUN_PATH=""
117
118 install -m0644 genders.sample %{buildroot}%{_sysconfdir}/%{name}
119
120 # bork
121 mv %{buildroot}/usr/local/share/man/man3/Libgenders.3pm %{buildroot}%{_mandir}/man3/Libgenders.3pm
122
123 %files
124 %{_bindir}/*
125 %{_mandir}/man1/*
126
127 %files -n %{libname}
128 %doc README NEWS ChangeLog DISCLAIMER DISCLAIMER.UC COPYING TUTORIAL
129 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}
130 %{_libdir}/*.so.%{major}*
131
132 %files -n %{gendersplusplus_libname}
133 %{_libdir}/libgendersplusplus.so.1*
134
135 %files -n %{develname}
136 %{_includedir}/*
137 %{_libdir}/*.so
138 %{_libdir}/*.*a
139 %{_mandir}/man3/genders*
140 %{_mandir}/man3/libgenders*
141
142 %files compat
143 %{_mandir}/man3/gendlib*
144 %dir %{_prefix}/lib/genders
145 %{_prefix}/lib/genders/*
146
147 %files -n perl-Libgenders
148 %{perl_sitearch}/Genders.pm
149 %{perl_sitearch}/Libgenders.pm
150 %dir %{perl_sitearch}/auto/Libgenders
151 %{perl_sitearch}/auto/Libgenders/Libgenders.so
152 %{_mandir}/man3/Genders.3pm*
153 %{_mandir}/man3/Libgenders.3pm*
154
155 %files -n python-libgenders
156 %{python_sitearch}/genders.py*
157 %{python_sitearch}/libgenders-*-py*.egg-info
158 %{python_sitearch}/libgenders.so

  ViewVC Help
Powered by ViewVC 1.1.30