1 |
%define api 0.10 |
2 |
%define major 10 |
3 |
%define libname %mklibname %name %{api} %major |
4 |
%define develname %mklibname -d %name %api |
5 |
|
6 |
%global __provides_exclude_from %_datadir/gtk-doc |
7 |
%global __requires_exclude_from %_datadir/gtk-doc |
8 |
|
9 |
%define url_ver %(echo %{version}|cut -d. -f1,2) |
10 |
|
11 |
Summary: Set of document centric objects and utilities for glib/gtk |
12 |
Name: goffice |
13 |
Version: 0.10.36 |
14 |
Release: %mkrel 1 |
15 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
16 |
License: GPLv2 |
17 |
Group: System/Libraries |
18 |
Url: http://www.gnome.org |
19 |
BuildRequires: pkgconfig(cairo) >= 1.10.0 |
20 |
BuildRequires: pkgconfig(cairo-pdf) >= 1.10.0 |
21 |
BuildRequires: pkgconfig(cairo-ps) >= 1.10.0 |
22 |
BuildRequires: pkgconfig(cairo-svg) >= 1.10.0 |
23 |
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.22.0 |
24 |
BuildRequires: pkgconfig(gio-2.0) >= 2.28.0 |
25 |
BuildRequires: pkgconfig(glib-2.0) >= 2.28.0 |
26 |
BuildRequires: pkgconfig(gmodule-2.0) >= 2.28.0 |
27 |
BuildRequires: pkgconfig(gobject-2.0) >= 2.28.0 |
28 |
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.0.0 |
29 |
BuildRequires: pkgconfig(gtk+-3.0) >= 3.2.0 |
30 |
BuildRequires: pkgconfig(libgsf-1) >= 1.14.9 |
31 |
BuildRequires: pkgconfig(librsvg-2.0) >= 2.22.0 |
32 |
BuildRequires: pkgconfig(libspectre) >= 0.2.6 |
33 |
BuildRequires: pkgconfig(libxml-2.0) >= 2.4.12 |
34 |
BuildRequires: pkgconfig(libxslt) |
35 |
BuildRequires: pkgconfig(pango) >= 1.24.0 |
36 |
BuildRequires: pkgconfig(pangocairo) >= 1.24.0 |
37 |
BuildRequires: gtk-doc |
38 |
BuildRequires: intltool |
39 |
|
40 |
%description |
41 |
There are common operations for document centric applications that are |
42 |
conceptually simple, but complex to implement fully. |
43 |
- plugins |
44 |
- load/save documents |
45 |
- undo/redo |
46 |
|
47 |
%package -n %libname |
48 |
Summary: %{summary} |
49 |
Group: %{group} |
50 |
Requires: %name >= %version |
51 |
|
52 |
%description -n %libname |
53 |
Shared library implementing document centric objects and utilities for glib/gtk |
54 |
|
55 |
%package -n %develname |
56 |
Summary: %{summary} |
57 |
Group: Development/C |
58 |
Requires: %libname = %{version} |
59 |
Provides: %{name}-devel = %{version}-%{release} |
60 |
Provides: lib%{name}-devel = %{version}-%{release} |
61 |
|
62 |
%description -n %develname |
63 |
Development files of the Goffice library. |
64 |
|
65 |
%prep |
66 |
%setup -q |
67 |
%autopatch -p1 |
68 |
|
69 |
%build |
70 |
%configure2_5x --disable-static |
71 |
%make |
72 |
|
73 |
%install |
74 |
%makeinstall_std |
75 |
%find_lang %{name}-%{version} |
76 |
|
77 |
find %buildroot -name '*.la' -delete |
78 |
|
79 |
%files -f %{name}-%{version}.lang |
80 |
%doc README NEWS AUTHORS BUGS MAINTAINERS |
81 |
%dir %{_libdir}/%{name} |
82 |
%dir %{_datadir}/%{name} |
83 |
%dir %{_datadir}/%{name}/%{version} |
84 |
%{_datadir}/%{name}/%{version}/mmlitex |
85 |
|
86 |
%files -n %libname |
87 |
%{_libdir}/libgoffice-%{api}.so.%{major}{,.*} |
88 |
%{_libdir}/%{name}/%{version} |
89 |
|
90 |
%files -n %develname |
91 |
%{_includedir}/libgoffice-%{api} |
92 |
%{_libdir}/lib*.so |
93 |
%{_libdir}/pkgconfig/*.pc |
94 |
%{_datadir}/gtk-doc/html/goffice-%{api} |