/[packages]/cauldron/golang-go-systemd/current/SPECS/golang-go-systemd.spec
ViewVC logotype

Annotation of /cauldron/golang-go-systemd/current/SPECS/golang-go-systemd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 641528 - (hide annotations) (download)
Sun Jun 29 23:35:46 2014 UTC (9 years, 8 months ago) by bcornec
File size: 1825 byte(s)
- Upload golang-go-systemd from Fedora for docker

1 bcornec 641528 %global debug_package %{nil}
2     %global import_path github.com/coreos/go-systemd
3     %global gopath %{_datadir}/gocode
4     %global vers 2
5    
6     Name: golang-go-systemd
7     Version: %mkrel %{vers}
8     Release: 1
9     Summary: Go bindings to systemd socket activation, journal and D-BUS APIs
10     License: ASL 2.0
11     URL: http://%{import_path}
12     Source0: https://%{import_path}/archive/v%{vers}.tar.gz
13     BuildArch: noarch
14    
15     %description
16     %{summary}
17    
18     %package devel
19     Requires: golang
20     Summary: Go bindings to systemd socket activation, journal and D-BUS APIs
21     Provides: golang(%{import_path}) = %{version}-%{release}
22     Provides: golang(%{import_path}/activation) = %{version}-%{release}
23     Provides: golang(%{import_path}/dbus) = %{version}-%{release}
24     Provides: golang(%{import_path}/journal) = %{version}-%{release}
25    
26     %description devel
27     %{summary}
28    
29     This package contains library source intended for building other packages
30     which use coreos/go-systemd.
31    
32     %prep
33     %setup -n go-systemd-%{vers}
34    
35     %build
36    
37     %install
38     install -d -p %{buildroot}/%{gopath}/src/%{import_path}/{activation,dbus,journal}
39     cp -av {activation,dbus,journal} %{buildroot}/%{gopath}/src/%{import_path}
40    
41     %files devel
42     %doc LICENSE README.md
43     %dir %attr(755,root,root) %{gopath}
44     %dir %attr(755,root,root) %{gopath}/src
45     %dir %attr(755,root,root) %{gopath}/src/github.com
46     %dir %attr(755,root,root) %{gopath}/src/github.com/coreos
47     %dir %attr(755,root,root) %{gopath}/src/%{import_path}
48     %dir %attr(755,root,root) %{gopath}/src/%{import_path}/activation
49     %dir %attr(755,root,root) %{gopath}/src/%{import_path}/dbus
50     %dir %attr(755,root,root) %{gopath}/src/%{import_path}/journal
51     %{gopath}/src/%{import_path}/activation/*.go
52     %{gopath}/src/%{import_path}/dbus/*.go
53     %{gopath}/src/%{import_path}/journal/*.go

  ViewVC Help
Powered by ViewVC 1.1.30