/[packages]/cauldron/golang-go-systemd/current/SPECS/golang-go-systemd.spec
ViewVC logotype

Annotation of /cauldron/golang-go-systemd/current/SPECS/golang-go-systemd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 641536 - (hide annotations) (download)
Mon Jun 30 00:03:48 2014 UTC (9 years, 8 months ago) by bcornec
File size: 1349 byte(s)
- Another path fix for golang FHS

1 bcornec 641528 %global debug_package %{nil}
2 bcornec 641530 %define import_path github.com/coreos/go-systemd
3     %define gopath %{_libdir}/golang
4 bcornec 641536 %define gosrc %{gopath}/src/pkg/%{import_path}
5 bcornec 641528
6     Name: golang-go-systemd
7 bcornec 641530 Version: 2
8 bcornec 641536 Release: %mkrel 2
9 bcornec 641528 Summary: Go bindings to systemd socket activation, journal and D-BUS APIs
10     License: ASL 2.0
11     URL: http://%{import_path}
12 bcornec 641530 Source0: https://%{import_path}/archive/v%{version}.tar.gz
13 bcornec 641528 BuildArch: noarch
14     Requires: golang
15     Provides: golang(%{import_path}) = %{version}-%{release}
16     Provides: golang(%{import_path}/activation) = %{version}-%{release}
17     Provides: golang(%{import_path}/dbus) = %{version}-%{release}
18     Provides: golang(%{import_path}/journal) = %{version}-%{release}
19    
20 bcornec 641530
21     %description
22 bcornec 641528 %{summary}
23    
24     This package contains library source intended for building other packages
25     which use coreos/go-systemd.
26    
27     %prep
28 bcornec 641530 %setup -n go-systemd-%{version}
29 bcornec 641528
30     %build
31    
32     %install
33 bcornec 641530 install -d -p %{buildroot}/%{gosrc}/{activation,dbus,journal}
34     cp -av {activation,dbus,journal} %{buildroot}/%{gosrc}
35 bcornec 641528
36 bcornec 641530 %files
37 bcornec 641528 %doc LICENSE README.md
38 bcornec 641530 %dir %attr(755,root,root) %{gosrc}
39     %dir %attr(755,root,root) %{gosrc}/activation
40     %dir %attr(755,root,root) %{gosrc}/dbus
41     %dir %attr(755,root,root) %{gosrc}/journal
42     %{gosrc}/activation/*.go
43     %{gosrc}/dbus/*.go
44     %{gosrc}/journal/*.go

  ViewVC Help
Powered by ViewVC 1.1.30