/[packages]/cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 143438 - (hide annotations) (download)
Wed Sep 14 09:52:56 2011 UTC (12 years, 6 months ago) by fwang
File size: 7157 byte(s)
drop .la files
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14     %define version 1.3.12
15     %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 fwang 143438 Release: %mkrel 5
21 spuhler 47947 License: GPLv2+
22     Group: Graphics
23     URL: http://www.graphicsmagick.org/
24     Source0: http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/%{Name}-%{version}.tar.lzma
25 sander85 104629 Patch0: graphicsmagick-linkage_fix.diff
26 spuhler 47947 BuildRequires: x11-proto-devel
27     BuildRequires: perl-devel
28     BuildRequires: freetype2-devel
29     Buildrequires: tiff-devel
30     BuildRequires: png-devel
31     BuildRequires: jpeg-devel
32     BuildRequires: jasper-devel
33     BuildRequires: libwmf-devel
34     BuildRequires: zlib-devel
35     BuildRequires: bzip2-devel
36     BuildRequires: libxml2-devel
37     BuildRequires: lcms-devel
38     BuildRequires: libgs-devel
39     BuildRequires: jbigkit-devel
40    
41     %description
42     GraphicsMagick is the swiss army knife of image processing. It
43     provides a robust collection of tools and libraries which support
44     reading, writing, and manipulating an image in over 88 major formats
45     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
46     SVG, and TIFF. GraphicsMagick supports huge images on systems that
47     support large files, and has been tested with gigapixel-size images.
48     GraphicsMagick can create new images on the fly, making it suitable
49     for building dynamic Web applications. GraphicsMagick may be used to
50     resize, rotate, sharpen, color reduce, or add special effects to an
51     image and save the result in the same or differing image format.
52     Image processing operations are available from the command line, as
53     well as through C, C++, Perl, or Windows COM programming interfaces.
54     Extensions are available from third-parties to support programming in
55     Python, Tcl, and Ruby. With some modification, language extensions for
56     ImageMagick may be used.
57    
58     %files
59     %defattr(-,root,root)
60     %doc ChangeLog *.txt
61     %{_bindir}/gm
62     %dir %{_libdir}/GraphicsMagick-%{version}/config
63     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
64     %dir %{_datadir}/GraphicsMagick-%{version}/config
65     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
66     %if %build_modules
67     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
68     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
69     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
70     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
71     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.la
72     %endif
73     %{_mandir}/man1/GraphicsMagick++-config.1.*
74     %{_mandir}/man1/GraphicsMagick-config.1.*
75     %{_mandir}/man1/GraphicsMagickWand-config.1.*
76     %{_mandir}/man1/gm.1.*
77     %{_mandir}/man4/miff.4.*
78     %{_mandir}/man5/quantize.5.*
79    
80     #--------------------------------------------------------------
81    
82     %package -n %{libname}
83     Summary: %Name libraries
84     Group: System/Libraries
85    
86     %description -n %{libname}
87     This package contains the libraries needed to run programs dynamically
88     linked with ImageMagick libraries.
89    
90    
91     %files -n %{libname}
92     %defattr(-,root,root,755)
93     %{_libdir}/libGraphicsMagick++.so.3*
94     %{_libdir}/libGraphicsMagick.so.3*
95    
96     #--------------------------------------------------------------
97    
98     %package -n %{libwandname}
99     Summary: %Name libraries
100     Group: System/Libraries
101    
102     %description -n %{libwandname}
103     This package contains the libraries needed to run programs dynamically
104     linked with ImageMagick libraries.
105    
106    
107     %files -n %{libwandname}
108     %defattr(-,root,root,755)
109     %{_libdir}/libGraphicsMagickWand.so.2*
110    
111     #--------------------------------------------------------------
112    
113     %package -n %{develname}
114     Summary: Static libraries and header files for %{Name} app development
115     Group: Development/C
116     Provides: %{name}-devel = %{version}-%{release}
117     Provides: %{Name}-devel = %{version}-%{release}
118     Obsoletes: %mklibname -d graphicsmagick 1.1.10
119     Requires: %{libname} = %{version}
120     Requires: %{libwandname} = %{version}
121     Requires: jbig-devel
122     %if %{enable_jasper}
123     Requires: jasper-devel
124     %endif
125     %if %{enable_graphwiz}
126     Requires: graphviz-devel
127     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
128     %endif
129    
130     %description -n %{develname}
131     If you want to create applications that will use ImageMagick code or
132     APIs, you'll need to install these packages as well as
133     ImageMagick. These additional packages aren't necessary if you simply
134     want to use ImageMagick, however.
135    
136     imagemagick-devel is an addition to ImageMagick which includes static
137     libraries and header files necessary to develop applications.
138    
139     %files -n %{develname}
140     %defattr(-,root,root)
141     %{_bindir}/GraphicsMagick++-config
142     %{_bindir}/GraphicsMagick-config
143     %{_bindir}/GraphicsMagickWand-config
144     %dir %{_includedir}/GraphicsMagick
145     %{_includedir}/GraphicsMagick/Magick++.h
146     %dir %{_includedir}/GraphicsMagick/magick
147     %{_includedir}/GraphicsMagick/magick/*.h
148     %dir %{_includedir}/GraphicsMagick/Magick++
149     %{_includedir}/GraphicsMagick/Magick++/*.h
150     %dir %{_includedir}/GraphicsMagick/wand
151     %{_includedir}/GraphicsMagick/wand/*.h
152     %{_libdir}/*.so
153     %{_libdir}/pkgconfig/*.pc
154    
155     #--------------------------------------------------------------
156    
157     %package -n perl-Graphics-Magick
158     Summary: Libraries and modules for access to %Name from perl
159     Group: Development/Perl
160     Requires: %{name} = %{version}
161     %if %{enable_graphwiz}
162     Requires: graphviz
163     %endif
164    
165     %description -n perl-Graphics-Magick
166     This is the %Name perl support package. It includes perl modules
167     and support files for access to ImageMagick library from perl.
168    
169     %files -n perl-Graphics-Magick
170     %defattr(-,root,root)
171     %{_mandir}/man3*/*::*.3pm*
172     %{perl_vendorarch}/Graphics
173     %{perl_vendorarch}/auto
174    
175     #--------------------------------------------------------------
176    
177     %package doc
178     Summary: %{name} Documentation
179     Group: Books/Other
180    
181     %description doc
182     This package contains HTML/PDF documentation of %{name}.
183    
184    
185     %files doc
186     %defattr(-,root,root)
187     %_datadir/doc/GraphicsMagick
188    
189     #--------------------------------------------------------------
190    
191     %prep
192     %setup -q -n %{Name}-%{version}
193     %patch0 -p0 -b .linkage_fix
194    
195     %build
196     %define Werror_cflags %nil
197     %configure2_5x \
198     --enable-fast-install \
199     --disable-ltdl-install \
200     --without-dps \
201     %if %build_modules
202     --with-modules \
203     %else
204     --without-modules \
205     %endif
206     --enable-shared \
207     --disable-static \
208     --with-pic \
209     %if %{enable_jasper}
210     --with-jp2 \
211     %else
212     --without-jp2 \
213     %endif
214     --with-perl-options="INSTALLDIRS=vendor" \
215     --with-perl
216    
217     %make
218     %make perl-build
219    
220     %install
221     rm -rf %{buildroot}
222    
223     %makeinstall_std
224     %makeinstall_std -C PerlMagick
225 fwang 143438
226     find %{buildroot} -name '*.la' | xargs rm
227 spuhler 47947 rm -f %buildroot%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
228    
229     %clean
230     rm -rf %{buildroot}
231    
232    

  ViewVC Help
Powered by ViewVC 1.1.30