/[packages]/cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 143444 - (hide annotations) (download)
Wed Sep 14 10:08:25 2011 UTC (12 years, 7 months ago) by fwang
File size: 7263 byte(s)
add gentoo patches to fix build with latest libpng
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14     %define version 1.3.12
15     %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 fwang 143438 Release: %mkrel 5
21 spuhler 47947 License: GPLv2+
22     Group: Graphics
23     URL: http://www.graphicsmagick.org/
24     Source0: http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/%{Name}-%{version}.tar.lzma
25 sander85 104629 Patch0: graphicsmagick-linkage_fix.diff
26 fwang 143444 Patch1: http://dev.gentoo.org/~ssuominen/graphicsmagick-1.3.12-libpng15.patch.bz2
27 spuhler 47947 BuildRequires: x11-proto-devel
28     BuildRequires: perl-devel
29     BuildRequires: freetype2-devel
30     Buildrequires: tiff-devel
31     BuildRequires: png-devel
32     BuildRequires: jpeg-devel
33     BuildRequires: jasper-devel
34     BuildRequires: libwmf-devel
35     BuildRequires: zlib-devel
36     BuildRequires: bzip2-devel
37     BuildRequires: libxml2-devel
38     BuildRequires: lcms-devel
39     BuildRequires: libgs-devel
40     BuildRequires: jbigkit-devel
41    
42     %description
43     GraphicsMagick is the swiss army knife of image processing. It
44     provides a robust collection of tools and libraries which support
45     reading, writing, and manipulating an image in over 88 major formats
46     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
47     SVG, and TIFF. GraphicsMagick supports huge images on systems that
48     support large files, and has been tested with gigapixel-size images.
49     GraphicsMagick can create new images on the fly, making it suitable
50     for building dynamic Web applications. GraphicsMagick may be used to
51     resize, rotate, sharpen, color reduce, or add special effects to an
52     image and save the result in the same or differing image format.
53     Image processing operations are available from the command line, as
54     well as through C, C++, Perl, or Windows COM programming interfaces.
55     Extensions are available from third-parties to support programming in
56     Python, Tcl, and Ruby. With some modification, language extensions for
57     ImageMagick may be used.
58    
59     %files
60     %defattr(-,root,root)
61     %doc ChangeLog *.txt
62     %{_bindir}/gm
63     %dir %{_libdir}/GraphicsMagick-%{version}/config
64     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
65     %dir %{_datadir}/GraphicsMagick-%{version}/config
66     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
67     %if %build_modules
68     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
69     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
70     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
71     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
72     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.la
73     %endif
74     %{_mandir}/man1/GraphicsMagick++-config.1.*
75     %{_mandir}/man1/GraphicsMagick-config.1.*
76     %{_mandir}/man1/GraphicsMagickWand-config.1.*
77     %{_mandir}/man1/gm.1.*
78     %{_mandir}/man4/miff.4.*
79     %{_mandir}/man5/quantize.5.*
80    
81     #--------------------------------------------------------------
82    
83     %package -n %{libname}
84     Summary: %Name libraries
85     Group: System/Libraries
86    
87     %description -n %{libname}
88     This package contains the libraries needed to run programs dynamically
89     linked with ImageMagick libraries.
90    
91    
92     %files -n %{libname}
93     %defattr(-,root,root,755)
94     %{_libdir}/libGraphicsMagick++.so.3*
95     %{_libdir}/libGraphicsMagick.so.3*
96    
97     #--------------------------------------------------------------
98    
99     %package -n %{libwandname}
100     Summary: %Name libraries
101     Group: System/Libraries
102    
103     %description -n %{libwandname}
104     This package contains the libraries needed to run programs dynamically
105     linked with ImageMagick libraries.
106    
107    
108     %files -n %{libwandname}
109     %defattr(-,root,root,755)
110     %{_libdir}/libGraphicsMagickWand.so.2*
111    
112     #--------------------------------------------------------------
113    
114     %package -n %{develname}
115     Summary: Static libraries and header files for %{Name} app development
116     Group: Development/C
117     Provides: %{name}-devel = %{version}-%{release}
118     Provides: %{Name}-devel = %{version}-%{release}
119     Obsoletes: %mklibname -d graphicsmagick 1.1.10
120     Requires: %{libname} = %{version}
121     Requires: %{libwandname} = %{version}
122     Requires: jbig-devel
123     %if %{enable_jasper}
124     Requires: jasper-devel
125     %endif
126     %if %{enable_graphwiz}
127     Requires: graphviz-devel
128     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
129     %endif
130    
131     %description -n %{develname}
132     If you want to create applications that will use ImageMagick code or
133     APIs, you'll need to install these packages as well as
134     ImageMagick. These additional packages aren't necessary if you simply
135     want to use ImageMagick, however.
136    
137     imagemagick-devel is an addition to ImageMagick which includes static
138     libraries and header files necessary to develop applications.
139    
140     %files -n %{develname}
141     %defattr(-,root,root)
142     %{_bindir}/GraphicsMagick++-config
143     %{_bindir}/GraphicsMagick-config
144     %{_bindir}/GraphicsMagickWand-config
145     %dir %{_includedir}/GraphicsMagick
146     %{_includedir}/GraphicsMagick/Magick++.h
147     %dir %{_includedir}/GraphicsMagick/magick
148     %{_includedir}/GraphicsMagick/magick/*.h
149     %dir %{_includedir}/GraphicsMagick/Magick++
150     %{_includedir}/GraphicsMagick/Magick++/*.h
151     %dir %{_includedir}/GraphicsMagick/wand
152     %{_includedir}/GraphicsMagick/wand/*.h
153     %{_libdir}/*.so
154     %{_libdir}/pkgconfig/*.pc
155    
156     #--------------------------------------------------------------
157    
158     %package -n perl-Graphics-Magick
159     Summary: Libraries and modules for access to %Name from perl
160     Group: Development/Perl
161     Requires: %{name} = %{version}
162     %if %{enable_graphwiz}
163     Requires: graphviz
164     %endif
165    
166     %description -n perl-Graphics-Magick
167     This is the %Name perl support package. It includes perl modules
168     and support files for access to ImageMagick library from perl.
169    
170     %files -n perl-Graphics-Magick
171     %defattr(-,root,root)
172     %{_mandir}/man3*/*::*.3pm*
173     %{perl_vendorarch}/Graphics
174     %{perl_vendorarch}/auto
175    
176     #--------------------------------------------------------------
177    
178     %package doc
179     Summary: %{name} Documentation
180     Group: Books/Other
181    
182     %description doc
183     This package contains HTML/PDF documentation of %{name}.
184    
185    
186     %files doc
187     %defattr(-,root,root)
188     %_datadir/doc/GraphicsMagick
189    
190     #--------------------------------------------------------------
191    
192     %prep
193     %setup -q -n %{Name}-%{version}
194     %patch0 -p0 -b .linkage_fix
195 fwang 143444 %patch1 -p1 -b .libpng
196 spuhler 47947
197     %build
198     %define Werror_cflags %nil
199     %configure2_5x \
200     --enable-fast-install \
201     --disable-ltdl-install \
202     --without-dps \
203     %if %build_modules
204     --with-modules \
205     %else
206     --without-modules \
207     %endif
208     --enable-shared \
209     --disable-static \
210     --with-pic \
211     %if %{enable_jasper}
212     --with-jp2 \
213     %else
214     --without-jp2 \
215     %endif
216     --with-perl-options="INSTALLDIRS=vendor" \
217     --with-perl
218    
219     %make
220     %make perl-build
221    
222     %install
223     rm -rf %{buildroot}
224    
225     %makeinstall_std
226     %makeinstall_std -C PerlMagick
227 fwang 143438
228     find %{buildroot} -name '*.la' | xargs rm
229 spuhler 47947 rm -f %buildroot%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
230    
231     %clean
232     rm -rf %{buildroot}
233    
234    

  ViewVC Help
Powered by ViewVC 1.1.30