/[packages]/cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 276909 - (hide annotations) (download)
Tue Jul 31 23:10:35 2012 UTC (11 years, 8 months ago) by blino
File size: 7103 byte(s)
really link perl module with library
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14 fwang 263388 %define version 1.3.16
15 spuhler 47947 %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 blino 276909 Release: %mkrel 3
21 spuhler 47947 License: GPLv2+
22     Group: Graphics
23     URL: http://www.graphicsmagick.org/
24 fwang 195719 Source0: http://downloads.sourceforge.net/%{name}/%{Name}-%{version}.tar.xz
25 fwang 260526 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
26 blino 276909 Patch1: GraphicsMagick-1.3.16-perl-link.patch
27 spuhler 47947 BuildRequires: x11-proto-devel
28     BuildRequires: perl-devel
29     BuildRequires: freetype2-devel
30     Buildrequires: tiff-devel
31     BuildRequires: png-devel
32     BuildRequires: jpeg-devel
33     BuildRequires: jasper-devel
34     BuildRequires: libwmf-devel
35     BuildRequires: zlib-devel
36     BuildRequires: bzip2-devel
37     BuildRequires: libxml2-devel
38     BuildRequires: lcms-devel
39 fwang 269011 BuildRequires: lcms2-devel
40 spuhler 47947 BuildRequires: libgs-devel
41     BuildRequires: jbigkit-devel
42    
43     %description
44     GraphicsMagick is the swiss army knife of image processing. It
45     provides a robust collection of tools and libraries which support
46     reading, writing, and manipulating an image in over 88 major formats
47     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
48     SVG, and TIFF. GraphicsMagick supports huge images on systems that
49     support large files, and has been tested with gigapixel-size images.
50     GraphicsMagick can create new images on the fly, making it suitable
51     for building dynamic Web applications. GraphicsMagick may be used to
52     resize, rotate, sharpen, color reduce, or add special effects to an
53     image and save the result in the same or differing image format.
54     Image processing operations are available from the command line, as
55     well as through C, C++, Perl, or Windows COM programming interfaces.
56     Extensions are available from third-parties to support programming in
57     Python, Tcl, and Ruby. With some modification, language extensions for
58     ImageMagick may be used.
59    
60     %files
61     %doc ChangeLog *.txt
62     %{_bindir}/gm
63     %dir %{_libdir}/GraphicsMagick-%{version}/config
64     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
65     %dir %{_datadir}/GraphicsMagick-%{version}/config
66     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
67     %if %build_modules
68     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
69     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
70     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
71     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
72     %endif
73     %{_mandir}/man1/GraphicsMagick++-config.1.*
74     %{_mandir}/man1/GraphicsMagick-config.1.*
75     %{_mandir}/man1/GraphicsMagickWand-config.1.*
76     %{_mandir}/man1/gm.1.*
77     %{_mandir}/man4/miff.4.*
78     %{_mandir}/man5/quantize.5.*
79    
80     #--------------------------------------------------------------
81    
82     %package -n %{libname}
83     Summary: %Name libraries
84     Group: System/Libraries
85    
86     %description -n %{libname}
87     This package contains the libraries needed to run programs dynamically
88     linked with ImageMagick libraries.
89    
90    
91     %files -n %{libname}
92     %defattr(-,root,root,755)
93     %{_libdir}/libGraphicsMagick++.so.3*
94     %{_libdir}/libGraphicsMagick.so.3*
95    
96     #--------------------------------------------------------------
97    
98     %package -n %{libwandname}
99     Summary: %Name libraries
100     Group: System/Libraries
101    
102     %description -n %{libwandname}
103     This package contains the libraries needed to run programs dynamically
104     linked with ImageMagick libraries.
105    
106    
107     %files -n %{libwandname}
108     %defattr(-,root,root,755)
109     %{_libdir}/libGraphicsMagickWand.so.2*
110    
111     #--------------------------------------------------------------
112    
113     %package -n %{develname}
114     Summary: Static libraries and header files for %{Name} app development
115     Group: Development/C
116     Provides: %{name}-devel = %{version}-%{release}
117     Provides: %{Name}-devel = %{version}-%{release}
118     Obsoletes: %mklibname -d graphicsmagick 1.1.10
119     Requires: %{libname} = %{version}
120     Requires: %{libwandname} = %{version}
121     Requires: jbig-devel
122     %if %{enable_jasper}
123     Requires: jasper-devel
124     %endif
125     %if %{enable_graphwiz}
126     Requires: graphviz-devel
127     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
128     %endif
129    
130     %description -n %{develname}
131     If you want to create applications that will use ImageMagick code or
132     APIs, you'll need to install these packages as well as
133     ImageMagick. These additional packages aren't necessary if you simply
134     want to use ImageMagick, however.
135    
136     imagemagick-devel is an addition to ImageMagick which includes static
137     libraries and header files necessary to develop applications.
138    
139     %files -n %{develname}
140     %{_bindir}/GraphicsMagick++-config
141     %{_bindir}/GraphicsMagick-config
142     %{_bindir}/GraphicsMagickWand-config
143     %dir %{_includedir}/GraphicsMagick
144     %{_includedir}/GraphicsMagick/Magick++.h
145     %dir %{_includedir}/GraphicsMagick/magick
146     %{_includedir}/GraphicsMagick/magick/*.h
147     %dir %{_includedir}/GraphicsMagick/Magick++
148     %{_includedir}/GraphicsMagick/Magick++/*.h
149     %dir %{_includedir}/GraphicsMagick/wand
150     %{_includedir}/GraphicsMagick/wand/*.h
151     %{_libdir}/*.so
152     %{_libdir}/pkgconfig/*.pc
153    
154     #--------------------------------------------------------------
155    
156     %package -n perl-Graphics-Magick
157     Summary: Libraries and modules for access to %Name from perl
158     Group: Development/Perl
159     Requires: %{name} = %{version}
160     %if %{enable_graphwiz}
161     Requires: graphviz
162     %endif
163    
164     %description -n perl-Graphics-Magick
165     This is the %Name perl support package. It includes perl modules
166     and support files for access to ImageMagick library from perl.
167    
168     %files -n perl-Graphics-Magick
169     %{_mandir}/man3*/*::*.3pm*
170     %{perl_vendorarch}/Graphics
171     %{perl_vendorarch}/auto
172    
173     #--------------------------------------------------------------
174    
175     %package doc
176     Summary: %{name} Documentation
177     Group: Books/Other
178 fwang 195762 BuildArch: noarch
179 spuhler 47947
180     %description doc
181     This package contains HTML/PDF documentation of %{name}.
182    
183    
184     %files doc
185 luigiwalser 274582 %{_datadir}/doc/GraphicsMagick
186 spuhler 47947
187     #--------------------------------------------------------------
188    
189     %prep
190     %setup -q -n %{Name}-%{version}
191 fwang 260526 %patch0 -p0
192 blino 276909 %patch1 -p1 -b .perl-link
193 spuhler 47947
194     %build
195     %define Werror_cflags %nil
196     %configure2_5x \
197     --enable-fast-install \
198     --disable-ltdl-install \
199     --without-dps \
200 luigiwalser 274581 %if %{build_modules}
201 spuhler 47947 --with-modules \
202     %else
203     --without-modules \
204     %endif
205     --enable-shared \
206     --disable-static \
207     --with-pic \
208     %if %{enable_jasper}
209     --with-jp2 \
210     %else
211     --without-jp2 \
212     %endif
213     --with-perl-options="INSTALLDIRS=vendor" \
214     --with-perl
215    
216     %make
217     %make perl-build
218    
219     %install
220     rm -rf %{buildroot}
221    
222     %makeinstall_std
223     %makeinstall_std -C PerlMagick
224 fwang 143438
225     find %{buildroot} -name '*.la' | xargs rm
226 luigiwalser 274581 rm -f %{buildroot}%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
227 spuhler 47947
228     %clean
229     rm -rf %{buildroot}

  ViewVC Help
Powered by ViewVC 1.1.30