/[packages]/cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
ViewVC logotype

Contents of /cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 630779 - (show annotations) (download)
Mon Jun 2 23:22:55 2014 UTC (9 years, 9 months ago) by pterjan
File size: 7255 byte(s)
Rebuild for perl 5.20
1 %define build_modules 1
2 %{?_with_modules: %global build_modules 1}
3
4 %define enable_jasper 1
5 %{?_with_jasper: %global enable_jasper 1}
6
7 %define enable_graphwiz 1
8 %{?_with_graphwiz: %global enable_graphwiz 1}
9
10 %define Name GraphicsMagick
11 %define libname %mklibname %name 3
12 %define libwandname %mklibname graphicsmagickwand 2
13 %define develname %mklibname %name -d
14 %define version 1.3.18
15 %define qlev Q8
16
17 Summary: An X application for displaying and manipulating images
18 Name: graphicsmagick
19 Version: %{version}
20 Release: %mkrel 4
21 License: GPLv2+
22 Group: Graphics/Editors and Converters
23 URL: http://www.graphicsmagick.org/
24 Source0: http://downloads.sourceforge.net/%{name}/%{Name}-%{version}.tar.xz
25 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
26 Patch1: GraphicsMagick-1.3.16-perl-link.patch
27 BuildRequires: x11-proto-devel
28 BuildRequires: perl-devel
29 BuildRequires: freetype2-devel
30 BuildRequires: tiff-devel
31 BuildRequires: png-devel
32 BuildRequires: jpeg-devel
33 BuildRequires: jasper-devel
34 BuildRequires: libwmf-devel
35 BuildRequires: zlib-devel
36 BuildRequires: bzip2-devel
37 BuildRequires: libxml2-devel
38 BuildRequires: lcms-devel
39 BuildRequires: lcms2-devel
40 BuildRequires: libgs-devel
41 BuildRequires: libtool-devel
42 BuildRequires: jbigkit-devel
43
44 %description
45 GraphicsMagick is the swiss army knife of image processing. It
46 provides a robust collection of tools and libraries which support
47 reading, writing, and manipulating an image in over 88 major formats
48 including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
49 SVG, and TIFF. GraphicsMagick supports huge images on systems that
50 support large files, and has been tested with gigapixel-size images.
51 GraphicsMagick can create new images on the fly, making it suitable
52 for building dynamic Web applications. GraphicsMagick may be used to
53 resize, rotate, sharpen, color reduce, or add special effects to an
54 image and save the result in the same or differing image format.
55 Image processing operations are available from the command line, as
56 well as through C, C++, Perl, or Windows COM programming interfaces.
57 Extensions are available from third-parties to support programming in
58 Python, Tcl, and Ruby. With some modification, language extensions for
59 ImageMagick may be used.
60
61 %files
62 %doc ChangeLog *.txt
63 %{_bindir}/gm
64 %dir %{_libdir}/GraphicsMagick-%{version}/config
65 %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
66 %dir %{_datadir}/GraphicsMagick-%{version}/config
67 %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
68 %if %build_modules
69 %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
70 %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
71 %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
72 %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
73 %endif
74 %{_mandir}/man1/GraphicsMagick++-config.1.*
75 %{_mandir}/man1/GraphicsMagick-config.1.*
76 %{_mandir}/man1/GraphicsMagickWand-config.1.*
77 %{_mandir}/man1/gm.1.*
78 %{_mandir}/man4/miff.4.*
79 %{_mandir}/man5/quantize.5.*
80
81 #--------------------------------------------------------------
82
83 %package -n %{libname}
84 Summary: %Name libraries
85 Group: System/Libraries
86
87 %description -n %{libname}
88 This package contains the libraries needed to run programs dynamically
89 linked with GraphicsMagick libraries.
90
91 %files -n %{libname}
92 %{_libdir}/libGraphicsMagick++.so.3*
93 %{_libdir}/libGraphicsMagick.so.3*
94
95 #--------------------------------------------------------------
96
97 %package -n %{libwandname}
98 Summary: %Name libraries
99 Group: System/Libraries
100
101 %description -n %{libwandname}
102 This package contains the libraries needed to run programs dynamically
103 linked with GraphicsMagick libraries.
104
105 %files -n %{libwandname}
106 %{_libdir}/libGraphicsMagickWand.so.2*
107
108 #--------------------------------------------------------------
109
110 %package -n %{develname}
111 Summary: Static libraries and header files for %{Name} app development
112 Group: Development/C
113 Provides: %{name}-devel = %{version}-%{release}
114 Provides: %{Name}-devel = %{version}-%{release}
115 Obsoletes: %mklibname -d graphicsmagick 1.1.10
116 Requires: %{libname} = %{version}
117 Requires: %{libwandname} = %{version}
118 Requires: jbig-devel
119 %if %{enable_jasper}
120 Requires: jasper-devel
121 %endif
122 %if %{enable_graphwiz}
123 Requires: graphviz-devel
124 %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
125 %endif
126
127 %description -n %{develname}
128 If you want to create applications that will use GraphicsMagick code or
129 APIs, you'll need to install these packages as well as
130 GraphicsMagick. These additional packages aren't necessary if you simply
131 want to use GraphicsMagick, however.
132
133 graphicsmagick-devel is an addition to GraphicsMagick which includes static
134 libraries and header files necessary to develop applications.
135
136 %files -n %{develname}
137 %{_bindir}/GraphicsMagick++-config
138 %{_bindir}/GraphicsMagick-config
139 %{_bindir}/GraphicsMagickWand-config
140 %dir %{_includedir}/GraphicsMagick
141 %{_includedir}/GraphicsMagick/Magick++.h
142 %dir %{_includedir}/GraphicsMagick/magick
143 %{_includedir}/GraphicsMagick/magick/*.h
144 %dir %{_includedir}/GraphicsMagick/Magick++
145 %{_includedir}/GraphicsMagick/Magick++/*.h
146 %dir %{_includedir}/GraphicsMagick/wand
147 %{_includedir}/GraphicsMagick/wand/*.h
148 %{_libdir}/*.so
149 %{_libdir}/pkgconfig/*.pc
150
151 #--------------------------------------------------------------
152
153 %package -n perl-Graphics-Magick
154 Summary: Libraries and modules for access to %Name from perl
155 Group: Development/Perl
156 Requires: %{name} = %{version}
157 %if %{enable_graphwiz}
158 Requires: graphviz
159 %endif
160
161 %description -n perl-Graphics-Magick
162 This is the %Name perl support package. It includes perl modules
163 and support files for access to GraphicsMagick library from perl.
164
165 %files -n perl-Graphics-Magick
166 %{_mandir}/man3*/*::*.3pm*
167 %{perl_vendorarch}/Graphics
168 %{perl_vendorarch}/auto
169
170 #--------------------------------------------------------------
171
172 %package doc
173 Summary: %{name} Documentation
174 Group: Documentation
175 BuildArch: noarch
176
177 %description doc
178 This package contains HTML/PDF documentation of %{name}.
179
180 %files doc
181 %{_datadir}/doc/GraphicsMagick
182
183 #--------------------------------------------------------------
184
185 %prep
186 %setup -q -n %{Name}-%{version}
187 %patch0 -p0
188 %patch1 -p1 -b .perl-link
189
190 %build
191 %define Werror_cflags %nil
192 %configure2_5x \
193 --enable-fast-install \
194 --disable-ltdl-install \
195 --without-dps \
196 %if %{build_modules}
197 --with-modules \
198 %else
199 --without-modules \
200 %endif
201 --enable-shared \
202 --disable-static \
203 --with-pic \
204 %if %{enable_jasper}
205 --with-jp2 \
206 %else
207 --without-jp2 \
208 %endif
209 --with-perl-options="INSTALLDIRS=vendor" \
210 --with-perl
211
212 %make
213 %make perl-build
214
215 %install
216 %makeinstall_std
217 %makeinstall_std -C PerlMagick
218
219 find %{buildroot} -name '*.la' | xargs rm
220 rm -f %{buildroot}%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}

  ViewVC Help
Powered by ViewVC 1.1.30