/[packages]/cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 260526 - (hide annotations) (download)
Thu Jun 14 06:45:33 2012 UTC (11 years, 10 months ago) by fwang
Original Path: cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
File size: 7302 byte(s)
fix bug#6411: graphicsmagick knows nothing about modules
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14 fwang 251948 %define version 1.3.15
15 spuhler 47947 %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 fwang 260526 Release: %mkrel 3
21 spuhler 47947 License: GPLv2+
22     Group: Graphics
23     URL: http://www.graphicsmagick.org/
24 fwang 195719 Source0: http://downloads.sourceforge.net/%{name}/%{Name}-%{version}.tar.xz
25 fwang 260526 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
26 spuhler 47947 BuildRequires: x11-proto-devel
27     BuildRequires: perl-devel
28     BuildRequires: freetype2-devel
29     Buildrequires: tiff-devel
30     BuildRequires: png-devel
31     BuildRequires: jpeg-devel
32     BuildRequires: jasper-devel
33     BuildRequires: libwmf-devel
34     BuildRequires: zlib-devel
35     BuildRequires: bzip2-devel
36     BuildRequires: libxml2-devel
37     BuildRequires: lcms-devel
38     BuildRequires: libgs-devel
39     BuildRequires: jbigkit-devel
40    
41     %description
42     GraphicsMagick is the swiss army knife of image processing. It
43     provides a robust collection of tools and libraries which support
44     reading, writing, and manipulating an image in over 88 major formats
45     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
46     SVG, and TIFF. GraphicsMagick supports huge images on systems that
47     support large files, and has been tested with gigapixel-size images.
48     GraphicsMagick can create new images on the fly, making it suitable
49     for building dynamic Web applications. GraphicsMagick may be used to
50     resize, rotate, sharpen, color reduce, or add special effects to an
51     image and save the result in the same or differing image format.
52     Image processing operations are available from the command line, as
53     well as through C, C++, Perl, or Windows COM programming interfaces.
54     Extensions are available from third-parties to support programming in
55     Python, Tcl, and Ruby. With some modification, language extensions for
56     ImageMagick may be used.
57    
58     %files
59     %defattr(-,root,root)
60     %doc ChangeLog *.txt
61     %{_bindir}/gm
62     %dir %{_libdir}/GraphicsMagick-%{version}/config
63     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
64     %dir %{_datadir}/GraphicsMagick-%{version}/config
65     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
66     %if %build_modules
67     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
68     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
69     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
70     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
71     %endif
72     %{_mandir}/man1/GraphicsMagick++-config.1.*
73     %{_mandir}/man1/GraphicsMagick-config.1.*
74     %{_mandir}/man1/GraphicsMagickWand-config.1.*
75     %{_mandir}/man1/gm.1.*
76     %{_mandir}/man4/miff.4.*
77     %{_mandir}/man5/quantize.5.*
78    
79     #--------------------------------------------------------------
80    
81     %package -n %{libname}
82     Summary: %Name libraries
83     Group: System/Libraries
84    
85     %description -n %{libname}
86     This package contains the libraries needed to run programs dynamically
87     linked with ImageMagick libraries.
88    
89    
90     %files -n %{libname}
91     %defattr(-,root,root,755)
92     %{_libdir}/libGraphicsMagick++.so.3*
93     %{_libdir}/libGraphicsMagick.so.3*
94    
95     #--------------------------------------------------------------
96    
97     %package -n %{libwandname}
98     Summary: %Name libraries
99     Group: System/Libraries
100    
101     %description -n %{libwandname}
102     This package contains the libraries needed to run programs dynamically
103     linked with ImageMagick libraries.
104    
105    
106     %files -n %{libwandname}
107     %defattr(-,root,root,755)
108     %{_libdir}/libGraphicsMagickWand.so.2*
109    
110     #--------------------------------------------------------------
111    
112     %package -n %{develname}
113     Summary: Static libraries and header files for %{Name} app development
114     Group: Development/C
115     Provides: %{name}-devel = %{version}-%{release}
116     Provides: %{Name}-devel = %{version}-%{release}
117     Obsoletes: %mklibname -d graphicsmagick 1.1.10
118     Requires: %{libname} = %{version}
119     Requires: %{libwandname} = %{version}
120     Requires: jbig-devel
121     %if %{enable_jasper}
122     Requires: jasper-devel
123     %endif
124     %if %{enable_graphwiz}
125     Requires: graphviz-devel
126     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
127     %endif
128    
129     %description -n %{develname}
130     If you want to create applications that will use ImageMagick code or
131     APIs, you'll need to install these packages as well as
132     ImageMagick. These additional packages aren't necessary if you simply
133     want to use ImageMagick, however.
134    
135     imagemagick-devel is an addition to ImageMagick which includes static
136     libraries and header files necessary to develop applications.
137    
138     %files -n %{develname}
139     %defattr(-,root,root)
140     %{_bindir}/GraphicsMagick++-config
141     %{_bindir}/GraphicsMagick-config
142     %{_bindir}/GraphicsMagickWand-config
143     %dir %{_includedir}/GraphicsMagick
144     %{_includedir}/GraphicsMagick/Magick++.h
145     %dir %{_includedir}/GraphicsMagick/magick
146     %{_includedir}/GraphicsMagick/magick/*.h
147     %dir %{_includedir}/GraphicsMagick/Magick++
148     %{_includedir}/GraphicsMagick/Magick++/*.h
149     %dir %{_includedir}/GraphicsMagick/wand
150     %{_includedir}/GraphicsMagick/wand/*.h
151     %{_libdir}/*.so
152     %{_libdir}/pkgconfig/*.pc
153    
154     #--------------------------------------------------------------
155    
156     %package -n perl-Graphics-Magick
157     Summary: Libraries and modules for access to %Name from perl
158     Group: Development/Perl
159     Requires: %{name} = %{version}
160     %if %{enable_graphwiz}
161     Requires: graphviz
162     %endif
163    
164     %description -n perl-Graphics-Magick
165     This is the %Name perl support package. It includes perl modules
166     and support files for access to ImageMagick library from perl.
167    
168     %files -n perl-Graphics-Magick
169     %defattr(-,root,root)
170     %{_mandir}/man3*/*::*.3pm*
171     %{perl_vendorarch}/Graphics
172     %{perl_vendorarch}/auto
173    
174     #--------------------------------------------------------------
175    
176     %package doc
177     Summary: %{name} Documentation
178     Group: Books/Other
179 fwang 195762 BuildArch: noarch
180 spuhler 47947
181     %description doc
182     This package contains HTML/PDF documentation of %{name}.
183    
184    
185     %files doc
186     %defattr(-,root,root)
187     %_datadir/doc/GraphicsMagick
188    
189     #--------------------------------------------------------------
190    
191     %prep
192     %setup -q -n %{Name}-%{version}
193 fwang 260526 %patch0 -p0
194 blino 253364 # ImageMagick r4950, rt #70150, gentoo #378197
195 blino 253383 if [ -r PerlMagick/typemap ]; then
196     echo "typemap already exists, remove this code from spec file"
197     exit 1
198     fi
199 blino 253364 echo "Graphics::Magick T_PTROBJ" > PerlMagick/typemap
200 spuhler 47947
201     %build
202     %define Werror_cflags %nil
203     %configure2_5x \
204     --enable-fast-install \
205     --disable-ltdl-install \
206     --without-dps \
207     %if %build_modules
208     --with-modules \
209     %else
210     --without-modules \
211     %endif
212     --enable-shared \
213     --disable-static \
214     --with-pic \
215     %if %{enable_jasper}
216     --with-jp2 \
217     %else
218     --without-jp2 \
219     %endif
220     --with-perl-options="INSTALLDIRS=vendor" \
221     --with-perl
222    
223     %make
224     %make perl-build
225    
226     %install
227     rm -rf %{buildroot}
228    
229     %makeinstall_std
230     %makeinstall_std -C PerlMagick
231 fwang 143438
232     find %{buildroot} -name '*.la' | xargs rm
233 spuhler 47947 rm -f %buildroot%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
234    
235     %clean
236     rm -rf %{buildroot}
237    
238    

  ViewVC Help
Powered by ViewVC 1.1.30