/[packages]/cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 274582 - (hide annotations) (download)
Thu Jul 26 14:59:01 2012 UTC (11 years, 8 months ago) by luigiwalser
Original Path: cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
File size: 7030 byte(s)
SILENT: minor spec cleaning
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14 fwang 263388 %define version 1.3.16
15 spuhler 47947 %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 fwang 269011 Release: %mkrel 2
21 spuhler 47947 License: GPLv2+
22     Group: Graphics
23     URL: http://www.graphicsmagick.org/
24 fwang 195719 Source0: http://downloads.sourceforge.net/%{name}/%{Name}-%{version}.tar.xz
25 fwang 260526 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
26 spuhler 47947 BuildRequires: x11-proto-devel
27     BuildRequires: perl-devel
28     BuildRequires: freetype2-devel
29     Buildrequires: tiff-devel
30     BuildRequires: png-devel
31     BuildRequires: jpeg-devel
32     BuildRequires: jasper-devel
33     BuildRequires: libwmf-devel
34     BuildRequires: zlib-devel
35     BuildRequires: bzip2-devel
36     BuildRequires: libxml2-devel
37     BuildRequires: lcms-devel
38 fwang 269011 BuildRequires: lcms2-devel
39 spuhler 47947 BuildRequires: libgs-devel
40     BuildRequires: jbigkit-devel
41    
42     %description
43     GraphicsMagick is the swiss army knife of image processing. It
44     provides a robust collection of tools and libraries which support
45     reading, writing, and manipulating an image in over 88 major formats
46     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
47     SVG, and TIFF. GraphicsMagick supports huge images on systems that
48     support large files, and has been tested with gigapixel-size images.
49     GraphicsMagick can create new images on the fly, making it suitable
50     for building dynamic Web applications. GraphicsMagick may be used to
51     resize, rotate, sharpen, color reduce, or add special effects to an
52     image and save the result in the same or differing image format.
53     Image processing operations are available from the command line, as
54     well as through C, C++, Perl, or Windows COM programming interfaces.
55     Extensions are available from third-parties to support programming in
56     Python, Tcl, and Ruby. With some modification, language extensions for
57     ImageMagick may be used.
58    
59     %files
60     %doc ChangeLog *.txt
61     %{_bindir}/gm
62     %dir %{_libdir}/GraphicsMagick-%{version}/config
63     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
64     %dir %{_datadir}/GraphicsMagick-%{version}/config
65     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
66     %if %build_modules
67     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
68     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
69     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
70     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
71     %endif
72     %{_mandir}/man1/GraphicsMagick++-config.1.*
73     %{_mandir}/man1/GraphicsMagick-config.1.*
74     %{_mandir}/man1/GraphicsMagickWand-config.1.*
75     %{_mandir}/man1/gm.1.*
76     %{_mandir}/man4/miff.4.*
77     %{_mandir}/man5/quantize.5.*
78    
79     #--------------------------------------------------------------
80    
81     %package -n %{libname}
82     Summary: %Name libraries
83     Group: System/Libraries
84    
85     %description -n %{libname}
86     This package contains the libraries needed to run programs dynamically
87     linked with ImageMagick libraries.
88    
89    
90     %files -n %{libname}
91     %defattr(-,root,root,755)
92     %{_libdir}/libGraphicsMagick++.so.3*
93     %{_libdir}/libGraphicsMagick.so.3*
94    
95     #--------------------------------------------------------------
96    
97     %package -n %{libwandname}
98     Summary: %Name libraries
99     Group: System/Libraries
100    
101     %description -n %{libwandname}
102     This package contains the libraries needed to run programs dynamically
103     linked with ImageMagick libraries.
104    
105    
106     %files -n %{libwandname}
107     %defattr(-,root,root,755)
108     %{_libdir}/libGraphicsMagickWand.so.2*
109    
110     #--------------------------------------------------------------
111    
112     %package -n %{develname}
113     Summary: Static libraries and header files for %{Name} app development
114     Group: Development/C
115     Provides: %{name}-devel = %{version}-%{release}
116     Provides: %{Name}-devel = %{version}-%{release}
117     Obsoletes: %mklibname -d graphicsmagick 1.1.10
118     Requires: %{libname} = %{version}
119     Requires: %{libwandname} = %{version}
120     Requires: jbig-devel
121     %if %{enable_jasper}
122     Requires: jasper-devel
123     %endif
124     %if %{enable_graphwiz}
125     Requires: graphviz-devel
126     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
127     %endif
128    
129     %description -n %{develname}
130     If you want to create applications that will use ImageMagick code or
131     APIs, you'll need to install these packages as well as
132     ImageMagick. These additional packages aren't necessary if you simply
133     want to use ImageMagick, however.
134    
135     imagemagick-devel is an addition to ImageMagick which includes static
136     libraries and header files necessary to develop applications.
137    
138     %files -n %{develname}
139     %{_bindir}/GraphicsMagick++-config
140     %{_bindir}/GraphicsMagick-config
141     %{_bindir}/GraphicsMagickWand-config
142     %dir %{_includedir}/GraphicsMagick
143     %{_includedir}/GraphicsMagick/Magick++.h
144     %dir %{_includedir}/GraphicsMagick/magick
145     %{_includedir}/GraphicsMagick/magick/*.h
146     %dir %{_includedir}/GraphicsMagick/Magick++
147     %{_includedir}/GraphicsMagick/Magick++/*.h
148     %dir %{_includedir}/GraphicsMagick/wand
149     %{_includedir}/GraphicsMagick/wand/*.h
150     %{_libdir}/*.so
151     %{_libdir}/pkgconfig/*.pc
152    
153     #--------------------------------------------------------------
154    
155     %package -n perl-Graphics-Magick
156     Summary: Libraries and modules for access to %Name from perl
157     Group: Development/Perl
158     Requires: %{name} = %{version}
159     %if %{enable_graphwiz}
160     Requires: graphviz
161     %endif
162    
163     %description -n perl-Graphics-Magick
164     This is the %Name perl support package. It includes perl modules
165     and support files for access to ImageMagick library from perl.
166    
167     %files -n perl-Graphics-Magick
168     %{_mandir}/man3*/*::*.3pm*
169     %{perl_vendorarch}/Graphics
170     %{perl_vendorarch}/auto
171    
172     #--------------------------------------------------------------
173    
174     %package doc
175     Summary: %{name} Documentation
176     Group: Books/Other
177 fwang 195762 BuildArch: noarch
178 spuhler 47947
179     %description doc
180     This package contains HTML/PDF documentation of %{name}.
181    
182    
183     %files doc
184 luigiwalser 274582 %{_datadir}/doc/GraphicsMagick
185 spuhler 47947
186     #--------------------------------------------------------------
187    
188     %prep
189     %setup -q -n %{Name}-%{version}
190 fwang 260526 %patch0 -p0
191 spuhler 47947
192     %build
193     %define Werror_cflags %nil
194     %configure2_5x \
195     --enable-fast-install \
196     --disable-ltdl-install \
197     --without-dps \
198 luigiwalser 274581 %if %{build_modules}
199 spuhler 47947 --with-modules \
200     %else
201     --without-modules \
202     %endif
203     --enable-shared \
204     --disable-static \
205     --with-pic \
206     %if %{enable_jasper}
207     --with-jp2 \
208     %else
209     --without-jp2 \
210     %endif
211     --with-perl-options="INSTALLDIRS=vendor" \
212     --with-perl
213    
214     %make
215     %make perl-build
216    
217     %install
218     rm -rf %{buildroot}
219    
220     %makeinstall_std
221     %makeinstall_std -C PerlMagick
222 fwang 143438
223     find %{buildroot} -name '*.la' | xargs rm
224 luigiwalser 274581 rm -f %{buildroot}%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
225 spuhler 47947
226     %clean
227     rm -rf %{buildroot}

  ViewVC Help
Powered by ViewVC 1.1.30