/[packages]/cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec
ViewVC logotype

Annotation of /cauldron/graphicsmagick/pristine/SPECS/graphicsmagick.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 344941 - (hide annotations) (download)
Fri Jan 11 00:51:19 2013 UTC (11 years, 2 months ago) by boklm
Original Path: cauldron/graphicsmagick/current/SPECS/graphicsmagick.spec
File size: 7157 byte(s)
Update group: Graphics/Editors -> Graphics/Editors and Converters
1 spuhler 47947 %define build_modules 1
2     %{?_with_modules: %global build_modules 1}
3    
4     %define enable_jasper 1
5     %{?_with_jasper: %global enable_jasper 1}
6    
7     %define enable_graphwiz 1
8     %{?_with_graphwiz: %global enable_graphwiz 1}
9    
10     %define Name GraphicsMagick
11     %define libname %mklibname %name 3
12     %define libwandname %mklibname graphicsmagickwand 2
13     %define develname %mklibname %name -d
14 fwang 307082 %define version 1.3.17
15 spuhler 47947 %define qlev Q8
16    
17     Summary: An X application for displaying and manipulating images
18     Name: graphicsmagick
19     Version: %{version}
20 fwang 307082 Release: %mkrel 1
21 spuhler 47947 License: GPLv2+
22 boklm 344941 Group: Graphics/Editors and Converters
23 spuhler 47947 URL: http://www.graphicsmagick.org/
24 fwang 195719 Source0: http://downloads.sourceforge.net/%{name}/%{Name}-%{version}.tar.xz
25 fwang 260526 Patch0: GraphicsMagick-1.3.15-use-so-for-modules.patch
26 blino 276909 Patch1: GraphicsMagick-1.3.16-perl-link.patch
27 spuhler 47947 BuildRequires: x11-proto-devel
28     BuildRequires: perl-devel
29     BuildRequires: freetype2-devel
30     Buildrequires: tiff-devel
31     BuildRequires: png-devel
32     BuildRequires: jpeg-devel
33     BuildRequires: jasper-devel
34     BuildRequires: libwmf-devel
35     BuildRequires: zlib-devel
36     BuildRequires: bzip2-devel
37     BuildRequires: libxml2-devel
38     BuildRequires: lcms-devel
39 fwang 269011 BuildRequires: lcms2-devel
40 spuhler 47947 BuildRequires: libgs-devel
41 fwang 307089 BuildRequires: libtool-devel
42 spuhler 47947 BuildRequires: jbigkit-devel
43    
44     %description
45     GraphicsMagick is the swiss army knife of image processing. It
46     provides a robust collection of tools and libraries which support
47     reading, writing, and manipulating an image in over 88 major formats
48     including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
49     SVG, and TIFF. GraphicsMagick supports huge images on systems that
50     support large files, and has been tested with gigapixel-size images.
51     GraphicsMagick can create new images on the fly, making it suitable
52     for building dynamic Web applications. GraphicsMagick may be used to
53     resize, rotate, sharpen, color reduce, or add special effects to an
54     image and save the result in the same or differing image format.
55     Image processing operations are available from the command line, as
56     well as through C, C++, Perl, or Windows COM programming interfaces.
57     Extensions are available from third-parties to support programming in
58     Python, Tcl, and Ruby. With some modification, language extensions for
59     ImageMagick may be used.
60    
61     %files
62     %doc ChangeLog *.txt
63     %{_bindir}/gm
64     %dir %{_libdir}/GraphicsMagick-%{version}/config
65     %{_libdir}/GraphicsMagick-%{version}/config/*.mgk
66     %dir %{_datadir}/GraphicsMagick-%{version}/config
67     %{_datadir}/GraphicsMagick-%{version}/config/*.mgk
68     %if %build_modules
69     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}
70     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/filters
71     %dir %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders
72     %{_libdir}/%{Name}-%{version}/modules-%{qlev}/coders/*.so
73     %endif
74     %{_mandir}/man1/GraphicsMagick++-config.1.*
75     %{_mandir}/man1/GraphicsMagick-config.1.*
76     %{_mandir}/man1/GraphicsMagickWand-config.1.*
77     %{_mandir}/man1/gm.1.*
78     %{_mandir}/man4/miff.4.*
79     %{_mandir}/man5/quantize.5.*
80    
81     #--------------------------------------------------------------
82    
83     %package -n %{libname}
84     Summary: %Name libraries
85     Group: System/Libraries
86    
87     %description -n %{libname}
88     This package contains the libraries needed to run programs dynamically
89     linked with ImageMagick libraries.
90    
91    
92     %files -n %{libname}
93     %defattr(-,root,root,755)
94     %{_libdir}/libGraphicsMagick++.so.3*
95     %{_libdir}/libGraphicsMagick.so.3*
96    
97     #--------------------------------------------------------------
98    
99     %package -n %{libwandname}
100     Summary: %Name libraries
101     Group: System/Libraries
102    
103     %description -n %{libwandname}
104     This package contains the libraries needed to run programs dynamically
105     linked with ImageMagick libraries.
106    
107    
108     %files -n %{libwandname}
109     %defattr(-,root,root,755)
110     %{_libdir}/libGraphicsMagickWand.so.2*
111    
112     #--------------------------------------------------------------
113    
114     %package -n %{develname}
115     Summary: Static libraries and header files for %{Name} app development
116     Group: Development/C
117     Provides: %{name}-devel = %{version}-%{release}
118     Provides: %{Name}-devel = %{version}-%{release}
119     Obsoletes: %mklibname -d graphicsmagick 1.1.10
120     Requires: %{libname} = %{version}
121     Requires: %{libwandname} = %{version}
122     Requires: jbig-devel
123     %if %{enable_jasper}
124     Requires: jasper-devel
125     %endif
126     %if %{enable_graphwiz}
127     Requires: graphviz-devel
128     %define _requires_exceptions devel(libcdt)\\|devel(libcircogen)\\|devel(libcommon)\\|devel(libdotgen)\\|devel(libdotneato)\\|devel(libfdpgen)\\|devel(libgraph)\\|devel(libgvrender)\\|devel(libneatogen)\\|devel(libpack)\\|devel(libpathplan)\\|devel(libtwopigen)\\|devel(libgvc)\\|devel(libgvgd)
129     %endif
130    
131     %description -n %{develname}
132     If you want to create applications that will use ImageMagick code or
133     APIs, you'll need to install these packages as well as
134     ImageMagick. These additional packages aren't necessary if you simply
135     want to use ImageMagick, however.
136    
137     imagemagick-devel is an addition to ImageMagick which includes static
138     libraries and header files necessary to develop applications.
139    
140     %files -n %{develname}
141     %{_bindir}/GraphicsMagick++-config
142     %{_bindir}/GraphicsMagick-config
143     %{_bindir}/GraphicsMagickWand-config
144     %dir %{_includedir}/GraphicsMagick
145     %{_includedir}/GraphicsMagick/Magick++.h
146     %dir %{_includedir}/GraphicsMagick/magick
147     %{_includedir}/GraphicsMagick/magick/*.h
148     %dir %{_includedir}/GraphicsMagick/Magick++
149     %{_includedir}/GraphicsMagick/Magick++/*.h
150     %dir %{_includedir}/GraphicsMagick/wand
151     %{_includedir}/GraphicsMagick/wand/*.h
152     %{_libdir}/*.so
153     %{_libdir}/pkgconfig/*.pc
154    
155     #--------------------------------------------------------------
156    
157     %package -n perl-Graphics-Magick
158     Summary: Libraries and modules for access to %Name from perl
159     Group: Development/Perl
160     Requires: %{name} = %{version}
161     %if %{enable_graphwiz}
162     Requires: graphviz
163     %endif
164    
165     %description -n perl-Graphics-Magick
166     This is the %Name perl support package. It includes perl modules
167     and support files for access to ImageMagick library from perl.
168    
169     %files -n perl-Graphics-Magick
170     %{_mandir}/man3*/*::*.3pm*
171     %{perl_vendorarch}/Graphics
172     %{perl_vendorarch}/auto
173    
174     #--------------------------------------------------------------
175    
176     %package doc
177     Summary: %{name} Documentation
178 fwang 307083 Group: Documentation
179 fwang 195762 BuildArch: noarch
180 spuhler 47947
181     %description doc
182     This package contains HTML/PDF documentation of %{name}.
183    
184    
185     %files doc
186 luigiwalser 274582 %{_datadir}/doc/GraphicsMagick
187 spuhler 47947
188     #--------------------------------------------------------------
189    
190     %prep
191     %setup -q -n %{Name}-%{version}
192 fwang 260526 %patch0 -p0
193 blino 276909 %patch1 -p1 -b .perl-link
194 spuhler 47947
195     %build
196     %define Werror_cflags %nil
197     %configure2_5x \
198     --enable-fast-install \
199     --disable-ltdl-install \
200     --without-dps \
201 luigiwalser 274581 %if %{build_modules}
202 spuhler 47947 --with-modules \
203     %else
204     --without-modules \
205     %endif
206     --enable-shared \
207     --disable-static \
208     --with-pic \
209     %if %{enable_jasper}
210     --with-jp2 \
211     %else
212     --without-jp2 \
213     %endif
214     --with-perl-options="INSTALLDIRS=vendor" \
215     --with-perl
216    
217     %make
218     %make perl-build
219    
220     %install
221     rm -rf %{buildroot}
222    
223     %makeinstall_std
224     %makeinstall_std -C PerlMagick
225 fwang 143438
226     find %{buildroot} -name '*.la' | xargs rm
227 luigiwalser 274581 rm -f %{buildroot}%{_datadir}/GraphicsMagick-%{version}/{ChangeLog,NEWS.txt}
228 spuhler 47947
229     %clean
230     rm -rf %{buildroot}

  ViewVC Help
Powered by ViewVC 1.1.30