/[packages]/cauldron/gsl/current/SPECS/gsl.spec
ViewVC logotype

Contents of /cauldron/gsl/current/SPECS/gsl.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 405371 - (show annotations) (download)
Tue Mar 26 19:45:37 2013 UTC (11 years ago) by tv
File size: 5652 byte(s)
make doc subpackage noarch
1 %define major 0
2 %define libname %mklibname %{name} %major
3 %define develname %mklibname %{name} -d
4
5 Summary: The GNU Scientific Library for numerical analysis
6 Name: gsl
7 Version: 1.15
8 Release: %mkrel 3
9 License: GPLv2+
10 Group: Sciences/Mathematics
11 URL: http://www.gnu.org/software/gsl/
12 Source0: ftp://ftp.gnu.org/gnu/gsl/%{name}-%{version}.tar.gz
13 Source1: %{SOURCE0}.sig
14 Patch0: %{name}-1.14-undefined-symbols.patch
15
16 %description
17 The GNU Scientific Library (GSL) is a numerical library for C and
18 C++ programmers. It contains over 1000 mathematical routines written
19 in ANSI C. The library follows modern coding conventions, and lends
20 itself to being used in very high level languages (VHLLs).
21
22 The library covers the following subject areas:
23
24 Complex Numbers Roots of Polynomials Special Functions
25 Vectors and Matrices Permutations Sorting
26 BLAS Support Linear Algebra Eigensystems
27 Fast Fourier Transforms Quadrature Random Numbers
28 Quasi-Random Sequences Random Distributions Statistics
29 Histograms N-Tuples Monte Carlo Integration
30 Simulated Annealing Differential Equations Interpolation
31 Numerical Differentiation Chebyshev Approximation Series Acceleration
32 Discrete Hankel Transforms Root-Finding Minimization
33 Least-Squares Fitting Physical Constants IEEE Floating-Point
34
35 Further information can be found in the GSL Reference Manual.
36
37 Install the gsl package if you need a library for high-level
38 scientific numerical analysis.
39
40 %package progs
41 Summary: Programs of the Scientific Library
42 Group: Sciences/Mathematics
43 Requires: %{libname} = %{version}-%{release}
44
45 %description progs
46 Here're the GNU Scientific Library (GSL) programs:
47 - gsl-histogram: computes a histogram of the data on stdin
48 using n bins from xmin to xmax.
49 - gsl-randist: generates n samples from a given distribution DIST
50 with given parameters
51
52 %package doc
53 Summary: Documentation of the Scientific Library
54 Group: Documentation
55 BuildArch: noarch
56
57 %description doc
58 This is the documentation in info format of the GNU Scientific Library (GSL).
59 This doc can be viewed through info, pinfo, konqueror, gnome yelp, ...
60
61 %package -n %{libname}
62 Summary: Shared libraries for Scientific Library
63 Group: System/Libraries
64
65 %description -n %{libname}
66 The GNU Scientific Library (GSL) is a numerical library for C and
67 C++ programmers. It contains over 1000 mathematical routines written
68 in ANSI C. The library follows modern coding conventions, and lends
69 itself to being used in very high level languages (VHLLs).
70
71 The library covers the following subject areas:
72
73 Complex Numbers Roots of Polynomials Special Functions
74 Vectors and Matrices Permutations Sorting
75 BLAS Support Linear Algebra Eigensystems
76 Fast Fourier Transforms Quadrature Random Numbers
77 Quasi-Random Sequences Random Distributions Statistics
78 Histograms N-Tuples Monte Carlo Integration
79 Simulated Annealing Differential Equations Interpolation
80 Numerical Differentiation Chebyshev Approximation Series Acceleration
81 Discrete Hankel Transforms Root-Finding Minimization
82 Least-Squares Fitting Physical Constants IEEE Floating-Point
83
84 Further information can be found in the GSL Reference Manual.
85
86
87 %package -n %{develname}
88 Summary: Development files for Scientific Library
89 Group: Development/C
90 Requires: %{libname} = %{version}-%{release}
91 Provides: %{name}-devel = %{version}-%{release}
92 Provides: lib%{name}-devel = %{version}-%{release}
93 Obsoletes: %mklibname %{name} 0 -d
94 Provides: %mklibname %{name} 0 -d
95
96 %description -n %{develname}
97 The gsl package includes the GNU Scientific Library (GSL). The GSL is a
98 collection of routines for numerical analysis, written in C.
99 It now includes a random number suite, an FFT package, simulated annealing
100 and root finding. In the future, it will include numerical and Monte Carlo
101 integration and special functions.
102 Linking against the GSL allows programs to access functions which can
103 handle many of the problems encountered in scientific computing.
104
105 These are the static libs and include headers for developers.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 # (tpg) gcc-4.3.2 bug http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38051
113 export CFLAGS="%{optflags} -fno-strict-aliasing -fPIC"
114 export CXXFLAGS=$CFLAGS
115 export CPPCLAGS=$CFLAGS
116 %configure2_5x
117
118 %make
119
120 %check
121 %ifarch %arm %mips
122 # check is failing on arm probably due to double stuff
123 # I wouldn't be surprised that mips is affected too.
124 make check || /bin/true
125 %else
126 make check
127 %endif
128
129 %install
130 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
131
132 %makeinstall_std
133
134 #multiarch
135 %multiarch_binaries %{buildroot}%{_bindir}/gsl-config
136
137 %post doc
138 %_install_info gsl-ref.info
139
140 %postun doc
141 %_remove_install_info gsl-ref.info
142
143 %clean
144 rm -rf %{buildroot}
145
146 %files progs
147 %defattr(-,root,root)
148 %doc AUTHORS NEWS README THANKS
149 %{_bindir}/gsl-histogram
150 %{_bindir}/gsl-randist
151 %{_mandir}/man1/gsl-histogram*
152 %{_mandir}/man1/gsl-randist*
153
154 %files doc
155 %defattr(-,root,root)
156 %{_infodir}/*info*
157
158 %files -n %{libname}
159 %defattr(-,root,root)
160 %{_libdir}/*.so.%{major}*
161
162 %files -n %{develname}
163 %defattr(-,root,root)
164 %doc BUGS ChangeLog TODO doc/examples/
165 %{_bindir}/gsl-config
166 %multiarch %{multiarch_bindir}/gsl-config
167 %{_datadir}/aclocal/*.m4
168 %{_includedir}/*
169 %{_libdir}/pkgconfig/*.pc
170 %{_libdir}/*.a
171 %{_libdir}/*.la
172 %{_libdir}/*.so
173 %{_mandir}/man3/*
174 %{_mandir}/man1/gsl-config.*

  ViewVC Help
Powered by ViewVC 1.1.30