/[packages]/cauldron/gstreamer0.10-plugins-ugly/current/SPECS/gstreamer0.10-plugins-ugly.spec
ViewVC logotype

Contents of /cauldron/gstreamer0.10-plugins-ugly/current/SPECS/gstreamer0.10-plugins-ugly.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 610547 - (show annotations) (download)
Sun Mar 30 15:27:43 2014 UTC (10 years ago) by daviddavid
File size: 7507 byte(s)
rebuild for new x264

1 %define version 0.10.19
2 %define release 12
3
4 %define _glib2 2.2
5 %define major 0.10
6 %define majorminor 0.10
7 %define bname gstreamer0.10
8 %define name %{bname}-plugins-ugly
9
10 %define build_plf 0
11
12 %if "%{?distro_section}" == "tainted"
13 %define build_plf 1
14 %endif
15
16 %define build_experimental 0
17 %{?_with_experimental: %{expand: %%global build_experimental 1}}
18 %define build_lame 0
19 %define build_amrnb 0
20 %define build_amrwbdec 0
21 %define build_x264 0
22
23 %if %build_plf
24 %define build_lame 1
25 %define build_x264 1
26 %define build_amrnb 1
27 %define build_amrwbdec 1
28 %endif
29
30 Summary: GStreamer Streaming-media framework plug-ins
31 Name: %{name}
32 Version: %{version}
33 Release: %mkrel %{release}
34 License: LGPLv2+
35 Group: Video/Utilities
36 Source: http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
37 Patch0: gstreamer-plugins-ugly-0.10.17-amr-linking.patch
38 Patch1: gstreamer-plugins-ugly-0.10.19-cdio-0.90.patch
39 URL: http://gstreamer.freedesktop.org/
40 #gw for the pixbuf plugin
41 BuildRequires: gtk+2-devel
42 BuildRequires: glib2-devel >= %_glib2
43 BuildRequires: liborc-devel >= 0.4.5
44 BuildRequires: libgstreamer-plugins-base-devel >= 0.10.36
45 BuildRequires: libmesaglu-devel
46 BuildRequires: libmad-devel
47 BuildRequires: libid3tag-devel
48 BuildRequires: libdvdread-devel
49
50 %ifnarch %mips %arm
51 BuildRequires: valgrind-devel
52 %endif
53
54 BuildRequires: libcheck-devel
55 Provides: %{bname}-audiosrc
56 Provides: %{bname}-audiosink
57
58 %description
59 GStreamer is a streaming-media framework, based on graphs of filters which
60 operate on media data. Applications using this library can do anything
61 from real-time sound processing to playing videos, and just about anything
62 else media-related. Its plugin-based architecture means that new data
63 types or processing capabilities can be added simply by installing new
64 plug-ins.
65
66 This package contains a set of plug-ins that have good quality and
67 correct functionality, but distributing them might pose problems. The
68 license on either the plug-ins or the supporting libraries might not
69 be how the GStreamer authors like. The code might be widely known to
70 present patent problems.
71
72 %if %build_plf
73 This package is in the 'tainted' section as it violates some patents.
74 %endif
75
76 %prep
77 %setup -q -n gst-plugins-ugly-%{version}
78 %apply_patches
79 autoconf
80
81 %build
82 %configure2_5x --disable-dependency-tracking \
83 --with-package-name='%{distribution} %name package' \
84 --with-package-origin='http://www.mageia.org/' \
85 %if ! %build_lame
86 --disable-lame \
87 %endif
88 %if %build_experimental
89 --enable-experimental
90 %endif
91
92 %make
93
94 %check
95 cd tests/check
96 make check
97
98 %install
99 rm -rf %{buildroot}
100 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
101
102 %find_lang gst-plugins-ugly-%{majorminor}
103 # Clean out files that should not be part of the rpm.
104 # This is the recommended way of dealing with it for RH8
105 rm -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
106 rm -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.a
107 rm -f %{buildroot}%{_libdir}/*.a
108 rm -f %{buildroot}%{_libdir}/*.la
109
110 %clean
111 rm -rf %{buildroot}
112
113 %files -f gst-plugins-ugly-%{majorminor}.lang
114 %defattr(-, root, root)
115 %doc AUTHORS COPYING README NEWS
116 %{_libdir}/gstreamer-%{majorminor}/libgstasf.so
117 %{_libdir}/gstreamer-%{majorminor}/libgstdvdlpcmdec.so
118 %{_libdir}/gstreamer-%{majorminor}/libgstdvdread.so
119 %{_libdir}/gstreamer-%{majorminor}/libgstdvdsub.so
120 %{_libdir}/gstreamer-%{majorminor}/libgstiec958.so
121 %{_libdir}/gstreamer-%{majorminor}/libgstmad.so
122 %{_libdir}/gstreamer-%{majorminor}/libgstmpegaudioparse.so
123 %{_libdir}/gstreamer-%{majorminor}/libgstmpegstream.so
124 %{_libdir}/gstreamer-%{majorminor}/libgstrmdemux.so
125 %if %build_experimental
126 %{_libdir}/gstreamer-%{majorminor}/libgstsynaesthesia.so
127 %endif
128
129 %if %build_lame
130 ### LAME ###
131 %package -n %{bname}-lame
132 Summary: GStreamer plug-in for encoding mp3 songs using lame
133 Group: Sound/Utilities
134 Requires: %{bname}-plugins >= %{version}-%{release}
135 BuildRequires: liblame-devel >= 3.89
136
137 %description -n %{bname}-lame
138 Plug-in for encoding mp3 with lame under GStreamer.
139
140 This package is in the 'tainted' section as it violates some patents.
141
142 %files -n %{bname}-lame
143 %defattr(-, root, root)
144 %{_libdir}/gstreamer-%{majorminor}/libgstlame.so
145 %endif
146
147 %if %build_x264
148 %package -n %{bname}-x264
149 Summary: GStreamer plug-in for H264/AVC video encoding
150 Group: Video/Utilities
151 BuildRequires: libx264-devel
152
153 %description -n %{bname}-x264
154 Plug-in for encoding H264/AVC video.
155
156 This package is in the 'tainted' section as it violates some patents.
157 %files -n %{bname}-x264
158 %defattr(-, root, root)
159 %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
160 %{_datadir}/gstreamer-%{majorminor}/presets/GstX264Enc.prs
161 %endif
162
163 %if %build_amrnb
164 %package -n %{bname}-amrnb
165 Summary: GStreamer plug-in for AMR-NB support
166 Group: Video/Utilities
167 Requires: %{bname}-plugins >= %{version}-%{release}
168 BuildRequires: opencore-amr-devel
169
170 %description -n %{bname}-amrnb
171 Plug-in for decoding AMR-NB under GStreamer.
172
173 This package is in the 'tainted' section as it violates some patents.
174
175 %files -n %{bname}-amrnb
176 %defattr(-, root, root)
177 %{_libdir}/gstreamer-%{majorminor}/libgstamrnb.so
178 %{_datadir}/gstreamer-%{majorminor}/presets/GstAmrnbEnc.prs
179 %endif
180
181 %if %build_amrwbdec
182 %package -n %{bname}-amrwbdec
183 Summary: GStreamer plug-in for AMR-WB decoding support
184 Group: Video/Utilities
185 Requires: %{bname}-plugins >= %{version}-%{release}
186 BuildRequires: opencore-amr-devel
187
188 %description -n %{bname}-amrwbdec
189 Plug-in for decoding AMR-Wb under GStreamer.
190
191 This package is in the 'tainted' section as it violates some patents.
192
193 %files -n %{bname}-amrwbdec
194 %defattr(-, root, root)
195 %{_libdir}/gstreamer-%{majorminor}/libgstamrwbdec.so
196 %endif
197
198 ### SIDPLAY ###
199 %package -n %{bname}-sid
200 Summary: GStreamer Sid C64 music plugin
201 Group: Video/Utilities
202 Requires: %{bname}-plugins >= %{version}-%{release}
203 BuildRequires: sidplay-devel => 1.36.0
204
205 %description -n %{bname}-sid
206 Plugin for playback of C64 SID format music files
207
208 %files -n %{bname}-sid
209 %defattr(-, root, root)
210 %{_libdir}/gstreamer-%{majorminor}/libgstsid.so
211
212 ### A52DEC ###
213 %package -n %{bname}-a52dec
214 Summary: GStreamer VOB decoder plugin
215 Group: Video/Utilities
216 Requires: %{bname}-plugins >= %{version}-%{release}
217 BuildRequires: a52dec-devel >= 0.7.3
218
219 %description -n %{bname}-a52dec
220 Plugin for decoding of VOB files.
221
222 %files -n %{bname}-a52dec
223 %defattr(-, root, root)
224 %{_libdir}/gstreamer-%{majorminor}/libgsta52dec.so
225
226 %package -n %{bname}-mpeg
227 Summary: GStreamer plug-ins for MPEG video playback and encoding
228 Group: Video/Utilities
229 Requires: %{bname}-plugins >= %{version}-%{release}
230 BuildRequires: libmpeg2dec-devel => 0.3.1
231
232 %description -n %{bname}-mpeg
233 Plug-ins for playing and encoding MPEG video.
234
235 %files -n %{bname}-mpeg
236 %defattr(-, root, root)
237 %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2dec.so
238
239 %package -n %{bname}-cdio
240 Summary: GStreamer plug-in for audio CD playback
241 Group: Sound/Utilities
242 Requires: %{bname}-plugins >= %{version}-%{release}
243 BuildRequires: libcdio-devel
244 Conflicts: %{bname}-plugins-good < 0.10.10
245
246 %description -n %{bname}-cdio
247 Plug-in for audio CD playback.
248
249 %files -n %{bname}-cdio
250 %defattr(-, root, root)
251 %{_libdir}/gstreamer-%{majorminor}/libgstcdio.so
252
253 %package -n %{bname}-twolame
254 Summary: GStreamer plug-in for MP2 encoding support
255 Group: Sound/Utilities
256 Requires: %{bname}-plugins >= %{version}-%{release}
257 BuildRequires: libtwolame-devel
258
259 %description -n %{bname}-twolame
260 Plug-in for encoding MP2 under GStreamer.
261
262 %files -n %{bname}-twolame
263 %defattr(-, root, root)
264 %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so

  ViewVC Help
Powered by ViewVC 1.1.30