/[packages]/cauldron/gtkmm3.0/current/SPECS/gtkmm3.0.spec
ViewVC logotype

Contents of /cauldron/gtkmm3.0/current/SPECS/gtkmm3.0.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1379257 - (show annotations) (download)
Wed Mar 20 16:24:30 2019 UTC (5 years ago) by ovitters
File size: 3864 byte(s)
new version 3.24.1
1 %define url_ver %(echo %{version} | cut -d "." -f -2)
2
3 %define pkgname gtkmm
4 %define api_version 3.0
5 %define major 1
6 %define libname_orig %mklibname %{pkgname} %{api_version}
7 %define libname %mklibname %{pkgname} %{api_version} %{major}
8 %define libnamedev %mklibname -d %{pkgname} %{api_version}
9 %define libnamestaticdev %mklibname -d -s %{pkgname} %{api_version}
10
11 Name: %{pkgname}%{api_version}
12 Summary: C++ interface for popular GUI library gtk+
13 Version: 3.24.1
14 Release: %mkrel 1
15 #gw lib is LGPL, tool is GPL
16 License: LGPLv2+ and GPLv2+
17 Group: System/Libraries
18 URL: http://gtkmm.sourceforge.net/
19 Source: https://download.gnome.org/sources/%{pkgname}/%{url_ver}/%{pkgname}-%{version}.tar.xz
20 BuildRequires: graphviz
21 BuildRequires: xsltproc
22 BuildRequires: doxygen
23 BuildRequires: pkgconfig(giomm-2.4) >= 2.46.1
24 BuildRequires: pkgconfig(pangomm-1.4) >= 2.38.1
25 BuildRequires: pkgconfig(gtk+-3.0) >= 3.18.0
26 BuildRequires: pkgconfig(cairomm-1.0) >= 1.12.0
27 BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.26.0
28 BuildRequires: pkgconfig(gtk+-unix-print-3.0)
29 BuildRequires: pkgconfig(atkmm-1.6)
30
31 %description
32 Gtkmm provides a C++ interface to the GTK+ GUI library. Gtkmm2 wraps GTK+ 2.
33 Highlights include typesafe callbacks, widgets extensible via inheritance
34 and a comprehensive set of widget classes that can be freely combined to
35 quickly create complex user interfaces.
36
37 %package -n %{libname}
38 Summary: C++ interface for popular GUI library gtk+
39 Group: System/Libraries
40 Provides: %{libname_orig} = %{version}-%{release}
41 Provides: %{pkgname}%{api_version} = %{version}-%{release}
42
43 %description -n %{libname}
44 Gtkmm provides a C++ interface to the GTK+ GUI library. Gtkmm2 wraps GTK+ 2.
45 Highlights include typesafe callbacks, widgets extensible via inheritance
46 and a comprehensive set of widget classes that can be freely combined to
47 quickly create complex user interfaces.
48
49 This package contains the library needed to run programs dynamically
50 linked with %{pkgname}.
51
52 %package -n %{libnamedev}
53 Summary: Headers and development files of %{pkgname}
54 Group: Development/GNOME and GTK+
55 Requires: %{libname} = %{version}-%{release}
56 Provides: %{pkgname}%{api_version}-devel = %{version}-%{release}
57 Provides: %{libname_orig}-devel = %{version}-%{release}
58
59 %description -n %{libnamedev}
60 This package contains the headers and development files that are needed,
61 when trying to develop or compile applications which need %{pkgname}.
62
63 %package -n %{libnamestaticdev}
64 Summary: Static libraries of %{pkgname}
65 Group: Development/GNOME and GTK+
66 Requires: %{libnamedev} = %{version}
67 Provides: %{libname_orig}-static-devel = %{version}-%{release}
68
69 %description -n %{libnamestaticdev}
70 This package contains the static libraries of %{pkgname}.
71
72 %package doc
73 Summary: GTKmm documentation
74 Group: Documentation
75 BuildArch: noarch
76
77 %description doc
78 Gtkmm provides a C++ interface to the GTK+ GUI library. Gtkmm2 wraps GTK+ 2.
79 Highlights include typesafe callbacks, widgets extensible via inheritance
80 and a comprehensive set of widget classes that can be freely combined to
81 quickly create complex user interfaces.
82
83 This package contains all API documentation for gtkmm. You can readily read
84 this documentation with devhelp, a documentation reader.
85
86 %prep
87 %setup -q -n %{pkgname}-%{version}
88
89 %build
90 %configure2_5x \
91 --enable-static \
92 --enable-shared
93 %make
94
95 %install
96 %makeinstall_std
97
98 rm -f %buildroot%_libdir/*.la
99
100 %files -n %{libname}
101 %doc AUTHORS COPYING NEWS README
102 %{_libdir}/libgdkmm-%{api_version}.so.%{major}{,.*}
103 %{_libdir}/libgtkmm-%{api_version}.so.%{major}{,.*}
104
105 %files -n %{libnamedev}
106 %doc PORTING ChangeLog
107 %{_includedir}/*
108 %{_libdir}/*.so
109 %{_libdir}/gtkmm-%{api_version}
110 %{_libdir}/gdkmm-%{api_version}
111 %{_libdir}/pkgconfig/*.pc
112
113 %files -n %{libnamestaticdev}
114 %doc COPYING
115 %{_libdir}/*.a
116
117 %files doc
118 %doc %{_datadir}/doc/gtkmm-%{api_version}
119 %doc %{_datadir}/devhelp/books/*

  ViewVC Help
Powered by ViewVC 1.1.30