1 |
%define api 1.0 |
2 |
%define major 4 |
3 |
%define gir_major 1.0 |
4 |
%define libname %mklibname %{name} %{api} %{major} |
5 |
%define develname %mklibname -d %{name} |
6 |
%define girname %mklibname %{name}-gir %{gir_major} |
7 |
|
8 |
%define url_ver %(echo %{version}|cut -d. -f1,2) |
9 |
|
10 |
Name: gupnp-igd |
11 |
Version: 0.2.5 |
12 |
Release: %mkrel 1 |
13 |
Summary: Handle Internet Gateway Device port mappings |
14 |
Group: System/Libraries |
15 |
License: LGPLv2+ |
16 |
URL: http://www.gupnp.org/ |
17 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
18 |
BuildRequires: pkgconfig(gupnp-1.0) |
19 |
BuildRequires: libgirepository-devel |
20 |
|
21 |
%description |
22 |
GUPnP is an object-oriented open source framework for creating UPnP |
23 |
devices and control points, written in C using GObject and libsoup. |
24 |
The GUPnP API is intended to be easy to use, efficient and flexible. |
25 |
|
26 |
GUPnP-Igd is a library that handle Internet Gateway Device port mappings. |
27 |
|
28 |
%package -n %{libname} |
29 |
Summary: Handle Internet Gateway Device port mappings |
30 |
Group: System/Libraries |
31 |
|
32 |
%description -n %{libname} |
33 |
GUPnP is an object-oriented open source framework for creating UPnP |
34 |
devices and control points, written in C using GObject and libsoup. |
35 |
The GUPnP API is intended to be easy to use, efficient and flexible. |
36 |
|
37 |
GUPnP-Igd is a library that handle Internet Gateway Device port mappings. |
38 |
|
39 |
%package -n %{develname} |
40 |
Summary: Development package for %{name} |
41 |
Group: Development/C |
42 |
Requires: %{libname} = %{version}-%{release} |
43 |
Requires: %{girname} = %{version}-%{release} |
44 |
Provides: %{name}-devel = %{version}-%{release} |
45 |
Provides: lib%{name}-devel = %{version}-%{release} |
46 |
|
47 |
%description -n %develname |
48 |
Files for development with %{name}. |
49 |
|
50 |
%package -n %{girname} |
51 |
Summary: GObject Introspection interface description for %{name} |
52 |
Group: System/Libraries |
53 |
Requires: %{libname} = %{version}-%{release} |
54 |
|
55 |
%description -n %{girname} |
56 |
GObject Introspection interface description for %{name}. |
57 |
|
58 |
%prep |
59 |
%setup -q |
60 |
%autopatch -p1 |
61 |
|
62 |
%build |
63 |
%configure2_5x --disable-static |
64 |
%make |
65 |
|
66 |
%install |
67 |
%makeinstall_std |
68 |
|
69 |
#we don't want these |
70 |
rm -rf %{buildroot}%{_libdir}/libgupnp-igd-%{api}.la |
71 |
|
72 |
%files -n %{libname} |
73 |
%doc AUTHORS COPYING README |
74 |
%{_libdir}/lib%{name}-%{api}.so.%{major}{,.*} |
75 |
|
76 |
%files -n %{girname} |
77 |
%{_libdir}/girepository-1.0/GUPnPIgd-%{gir_major}.typelib |
78 |
|
79 |
%files -n %{develname} |
80 |
%doc %{_datadir}/gtk-doc/html/gupnp-igd/ |
81 |
%{_includedir}/%{name}-%{api}/ |
82 |
%{_libdir}/pkgconfig/%{name}-%{api}.pc |
83 |
%{_libdir}/lib%{name}-%{api}.so |
84 |
%{_datadir}/gir-1.0/GUPnPIgd-1.0.gir |