/[packages]/cauldron/hexchat/current/SPECS/hexchat.spec
ViewVC logotype

Contents of /cauldron/hexchat/current/SPECS/hexchat.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 799429 - (show annotations) (download)
Wed Nov 26 20:28:23 2014 UTC (9 years, 4 months ago) by sander85
File size: 4634 byte(s)
New version: 2.10.2
1 %define perl_version %(rpm -q --qf '%%{epoch}:%%{VERSION}' perl)
2
3 Summary: An IRC chat program
4 Name: hexchat
5 Version: 2.10.2
6 Release: %mkrel 1
7 Group: Networking/IRC
8 License: GPLv2
9 Url: http://hexchat.github.io
10 Source0: http://dl.hexchat.net/%{name}/%{name}-%{version}.tar.xz
11 Patch0: hexchat-servlist.patch
12 Patch1: hexchat-pci.ids-path.patch
13
14 BuildRequires: bison
15 BuildRequires: pkgconfig(gtk+-2.0)
16 BuildRequires: pkgconfig(openssl)
17 BuildRequires: pkgconfig(libsexy)
18 BuildRequires: gettext-devel
19 BuildRequires: perl-devel
20 BuildRequires: pkgconfig(python)
21 BuildRequires: pkgconfig(dbus-glib-1)
22 BuildRequires: pkgconfig(libnotify)
23 BuildRequires: pkgconfig(libpci)
24 BuildRequires: pkgconfig(libcanberra)
25 BuildRequires: pkgconfig(libproxy-1.0)
26 BuildRequires: gnome-common
27
28 # To get the balloon alerts working
29 Requires: libnotify
30
31 Obsoletes: xchat < 2.8.8-22
32 Obsoletes: xchat-gnome < 0.26.1-23
33 Obsoletes: xchat-gnome-autoaway < 0.26.1-23
34 Obsoletes: xchat-gnome-notification < 0.26.1-23
35 Obsoletes: xchat-gnome-notifyosd < 0.26.1-23
36 Obsoletes: xchat-gnome-soundnotification < 0.26.1-23
37 Obsoletes: xchat-gnome-tcl < 0.26.1-23
38 Obsoletes: xchat-gnome-urlscraper < 0.26.1-23
39 Obsoletes: xchat-tcl < 2.8.8-22
40
41 Provides: xchat
42 Provides: xchat-gnome
43
44 %description
45 HexChat is an IRC chat program. It allows you to join multiple IRC
46 channels (chat rooms) at the same time, talk publicly, private
47 one-on-one conversations etc.
48
49 HexChat is based on XChat, but unlike XChat it's completely free
50 for both Windows and Unix-like systems.
51
52 %package devel
53 Summary: HexChat header for plugin development
54 Group: Development/C
55
56 Obsoletes: xchat-devel < 2.8.8-22
57 Obsoletes: xchat-gnome-devel < 0.26.1-23
58
59 %description devel
60 This package contains xchat-plugin.h needed to build external plugins.
61
62 %package perl
63 Summary: HexChat Perl plugin
64 Group: Networking/IRC
65 Requires: %{name} = %{version}-%{release}
66 Requires: perl-base = %{perl_version}
67
68 Obsoletes: xchat-gnome-perl < 0.26.1-23
69 Obsoletes: xchat-perl < 2.8.8-22
70 Provides: xchat-gnome-perl
71 Provides: xchat-perl
72
73 %description perl
74 Provides Perl scripting capability to HexChat.
75
76 %package python
77 Summary: HexChat Python plugin
78 Group: Networking/IRC
79 Requires: %{name} = %{version}-%{release}
80
81 Obsoletes: xchat-gnome-python < 0.26.1-23
82 Obsoletes: xchat-python < 2.8.8-22
83 Provides: xchat-gnome-python
84 Provides: xchat-python
85
86 %description python
87 Provides Python scripting capability to HexChat.
88
89 %package checksum
90 Summary: HexChat Checksum plugin
91 Group: Networking/IRC
92 Requires: %{name} = %{version}-%{release}
93
94 %description checksum
95 Calculates checksum for DCC file transfers.
96
97 %package doat
98 Summary: HexChat Do At plugin
99 Group: Networking/IRC
100 Requires: %{name} = %{version}-%{release}
101
102 %description doat
103 Performs an arbitrary command on multiple channels.
104
105 %package fishlim
106 Summary: HexChat FiSHLiM plugin
107 Group: Networking/IRC
108 Requires: %{name} = %{version}-%{release}
109
110 %description fishlim
111 FiSHLiM is an HexChat plugin for FiSH IRC encryption.
112
113 %package sysinfo
114 Summary: SysInfo plugin
115 Group: Networking/IRC
116 Requires: %{name} = %{version}-%{release}
117
118 %description sysinfo
119 Display info about your hardware and OS.
120
121
122 %prep
123 %setup -q
124 %patch0 -p1 -b .servlist
125 %patch1 -p1 -b .pciids
126
127 %build
128 ./autogen.sh
129
130 %configure2_5x \
131 --enable-openssl \
132 --enable-shm
133
134 %make
135
136
137 %install
138 # Remove COPYING
139 rm -f share/doc/COPYING
140
141 %makeinstall_std
142
143 %find_lang %{name}
144
145 # Add SVG for hicolor
146 %{__install} -D -m644 data/icons/hexchat.svg %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/hexchat.svg
147
148 desktop-file-install \
149 --add-category="GTK" \
150 --add-category="IRCClient" \
151 --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/*
152
153 mkdir -p %{buildroot}%{_includedir}
154 cp src/common/hexchat-plugin.h %{buildroot}%{_includedir}/
155
156 rm -rf %{buildroot}%{_libdir}/%{name}/plugins/*.la
157
158
159 %preun
160 %preun_uninstall_gconf_schemas apps_hexchat_url_handler
161
162
163 %files -f %{name}.lang
164 %{_bindir}/%{name}
165 %{_datadir}/applications/%{name}.desktop
166 %{_datadir}/dbus-1/services/org.%{name}.service.service
167 %{_datadir}/appdata/%{name}.appdata.xml
168 %{_iconsdir}/hicolor/*/apps/*.png
169 %{_iconsdir}/hicolor/scalable/apps/%{name}.svg
170 %dir %{_libdir}/%{name}/plugins
171 %dir %{_libdir}/%{name}
172 %{_mandir}/man1/%{name}.1.*
173
174 %files devel
175 %{_includedir}/%{name}-plugin.h
176 %{_libdir}/pkgconfig/%{name}-plugin.pc
177
178 %files perl
179 %{_libdir}/%{name}/plugins/perl.so
180
181 %files python
182 %{_libdir}/%{name}/plugins/python.so
183
184 %files checksum
185 %{_libdir}/%{name}/plugins/checksum.so
186
187 %files doat
188 %{_libdir}/%{name}/plugins/doat.so
189
190 %files fishlim
191 %{_libdir}/%{name}/plugins/fishlim.so
192
193 %files sysinfo
194 %{_libdir}/%{name}/plugins/sysinfo.so

  ViewVC Help
Powered by ViewVC 1.1.30