/[packages]/cauldron/icu/current/SPECS/icu.spec
ViewVC logotype

Annotation of /cauldron/icu/current/SPECS/icu.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 72827 - (hide annotations) (download)
Wed Mar 16 21:14:53 2011 UTC (13 years ago) by rtp
File size: 4888 byte(s)
- backport fix from upstream ticket 7664 (bad asm syntax)

1 blino 1497 %define major 44
2     %define libname %mklibname icu %{major}
3     %define develname %mklibname icu -d
4     %define realversion 4.4.2
5     %define tarballver %(echo %realversion|sed -e 's|\\.|_|g')
6    
7     Summary: International Components for Unicode
8     Name: icu
9     Version: 4.4.2
10 blino 1505 Release: %mkrel 2
11 blino 1497 Epoch: 1
12     License: MIT
13     Group: System/Libraries
14     URL: http://www.icu-project.org/index.html
15     Source0: http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{tarballver}-src.tgz
16     Source1: http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{tarballver}-docs.zip
17     Source2: http://cvs.fedora.redhat.com/viewcvs/*checkout*/devel/icu/icu-config
18     Patch0: %{name}4c-3_8-setBreakType.patch
19     Patch2: icu4c-4_2-multiarch.patch
20     Patch3: icu4c-4_0-format_not_a_string_literal_and_no_format_arguments.diff
21     Patch4: icu-4.4-configure.patch
22     Patch5: icu-4.4.1-pkgdata.patch
23 rtp 72827 Patch6: icu-4.4-arm_asm.patch
24 blino 1497 BuildRequires: doxygen
25     Requires: %{libname} = %{epoch}:%{version}-%{release}
26     BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
27    
28     %description
29     The International Components for Unicode (ICU) libraries provide robust and
30     full-featured Unicode services on a wide variety of platforms. ICU supports
31     the most current version of the Unicode standard, and they provide support
32     for supplementary Unicode characters (needed for GB 18030 repertoire support).
33    
34     As computing environments become more heterogeneous, software portability
35     becomes more important. ICU lets you produce the same results across all the
36     various platforms you support, without sacrificing performance. It offers
37     great flexibility to extend and customize the supplied services, which
38     include:
39    
40     * Text: Unicode text handling, full character properties and character set
41     conversions (500+ codepages)
42     * Analysis: Unicode regular expressions; full Unicode sets; character, word
43     and line boundaries
44     * Comparison: Language sensitive collation and searching
45     * Transformations: normalization, upper/lowercase, script transliterations
46     (50+ pairs)
47     * Locales: Comprehensive locale data (230+) and resource bundle architecture
48     * Complex Text Layout: Arabic, Hebrew, Indic and Thai
49     * Time: Multi-calendar and time zone
50     * Formatting and Parsing: dates, times, numbers, currencies, messages and
51     rule based
52    
53     %package doc
54     Summary: Documentation for the International Components for Unicode
55     Group: System/Libraries
56     Requires: %{name} = %{epoch}:%{version}-%{release}
57    
58     %description doc
59     Documentation for the International Components for Unicode.
60    
61     %package -n %{libname}
62     Summary: Libraries for the International Components for Unicode
63     Group: System/Libraries
64    
65     %description -n %{libname}
66     Libraries for the International Components for Unicode.
67    
68     %package -n %{develname}
69     Summary: Development files for the International Components for Unicode
70     Group: Development/Other
71     Requires: %{libname} = %{epoch}:%{version}-%{release}
72     Provides: %{name}%{major}-devel = %{epoch}:%{version}-%{release}
73     Provides: %{name}-devel = %{epoch}:%{version}-%{release}
74     Provides: lib%{name}-devel = %{epoch}:%{version}-%{release}
75     Obsoletes: %mklibname -d icu 36
76     Obsoletes: %mklibname -d icu 34
77     #define _requires_exceptions statically\\|linked
78    
79     %description -n %{develname}
80     Development files and headers for the International Components for Unicode.
81    
82     %prep
83     %setup -q -n %{name}
84     %patch0 -p1 -b .setBreakType
85     %patch2 -p1 -b .multiarch
86     %patch3 -p0 -b .format_not_a_string_literal_and_no_format_arguments
87     %patch4 -p1
88     %patch5 -p0 -b .bufferoverflow
89 rtp 72827 %patch6 -p1 -b .asm_arm
90 blino 1497
91     mkdir -p docs
92     cd docs
93     unzip -q %{SOURCE1}
94     cd -
95    
96     %build
97     pushd source
98     # (tpg) needed for patch 2
99     autoconf
100     export CFLAGS='%optflags -fno-strict-aliasing'
101     export CXXFLAGS='%optflags -fno-strict-aliasing'
102     %configure2_5x \
103     --with-library-bits=64else32 \
104     --disable-rpath \
105     --with-data-packaging=library \
106     --disable-samples
107     %make
108     %make doc
109     popd
110    
111     #%%check
112     #pushd source
113     #make check
114     #popd
115    
116     %install
117     rm -rf %{buildroot}
118     pushd source
119     %makeinstall_std
120     popd
121    
122     cp -pR ./source/tools/ctestfw/libicutest.so* %buildroot/%{_libdir}
123    
124     # fix attribs
125     chmod 755 %{buildroot}%{_libdir}/*.so*
126    
127     install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/icu-config
128     sed -i s/\\\$\(THREADSCXXFLAGS\)// %{buildroot}/%{_libdir}/pkgconfig/icu.pc
129     sed -i s/\\\$\(THREADSCPPFLAGS\)/-D_REENTRANT/ %{buildroot}/%{_libdir}/pkgconfig/icu.pc
130    
131     %clean
132     rm -rf %{buildroot}
133    
134     %files
135     %defattr(-,root,root)
136     %{_bindir}/*
137     %exclude %{_bindir}/icu-config
138     %{_sbindir}/*
139    
140     %files doc
141     %defattr(-,root,root)
142     %doc readme.html docs/*
143     %{_mandir}/man1/*
144     %{_mandir}/man8/*
145    
146     %files -n %{libname}
147     %defattr(-,root,root)
148     %{_libdir}/*.so.%{major}*
149    
150     %files -n %{develname}
151     %defattr(-,root,root)
152     %{_bindir}/icu-config
153     %{_libdir}/*.so
154     %{_libdir}/pkgconfig/icu.pc
155     %dir %{_includedir}/layout
156     %dir %{_includedir}/unicode
157     %{_includedir}/layout/*
158     %{_includedir}/unicode/*
159     %dir %{_libdir}/%{name}
160     %{_libdir}/%{name}/*
161     %dir %{_datadir}/%{name}
162     %{_datadir}/%{name}/*
163    
164    

  ViewVC Help
Powered by ViewVC 1.1.30